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About This Guide 

This section provides information about this Administration Guide, and the other 
ways in which aPriori supports the aPriori application. 

Key topics include: 
 Overview 
 Related documents 
 Typographic conventions 
 Feedback and customer support 
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Overview 
This Administration Guide contains detailed information about using the tools in the 
virtual production environment (VPE) toolset to maintain the VPEs in your aPriori 
deployment.  

Related documents 
In addition to this guide, you can find more information about the aPriori application in 
the following documents: 

 aPriori User Guide – This guide contains detailed information about the aPriori 
solution. It is designed as a reference for your everyday work.  

 aPriori Cost Model Guide – This guide contains detailed information about 
process groups and includes a chapter on direct and indirect overhead.  

 aPriori Cost Model Workbench User Guide – This guide explains how to use 
aPriori’s Cost Model Work Bench (CMWB) to customize cost models. 

 aPriori System Administration Guide – This guide contains detailed information 
about administering the aPriori solution using the System Admin toolset. It is 
designed as a reference for aPriori system administrators. 

 Release Notes – This document highlights the changes made in aPriori since the 
previous release. It also contains last minute information about the release.  

 Installation Guide – This guide contains detailed information about installing 
aPriori. 

 System Requirements – This document provides information on the minimum 
and recommended client and server requirements to run aPriori, as well as the 
CAD file formats supported by aPriori. 

Typographic conventions 
The following conventions are used in this guide to convey additional information.  
 

Style  Description Example 
Code Code style is used for text that is used 

literally, appearing exactly as shown. This 
includes command names, path and file 
names, and system information. 

E:\setup.exe 

Italic 
code 

Italic code style is used for names of 
variables that you must provide. For 
example, you need to supply a value for 
your_file in the path name example to 
the right. 

C:\aPriori\your_file 

GUI GUI style is used to indicate objects in the 
aPriori interface. 

the Document field 
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GUI 
Action 

GUI Action style is used to indicate objects 
in the aPriori interface that you click, 
select, or otherwise act upon. 

Click OK. 

Note: Notes highlight information, provide supplementary information, offer time-saving 
or easier ways to perform the same task, or explain how to prevent errors or data 
loss. Be sure to read this information carefully. 

Feedback and customer support 
We appreciate your comments about this guide. Please contact us with your comments, 
questions, and requests for technical support. 
 

Website: http://www.apriori.com/support 
Email: support@apriori.com 
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1 VPE Administration 
Overview 

This chapter provides a brief introduction to aPriori's Virtual Production 
Environment (VPE) and the role of a VPE Administrator. 

This chapter includes the following topics: 
 Introduction 
 The VPE Toolset 
 Using the Search CSL utility 



VPE Administration Overview  aPriori VPE Administration Guide 

aPriori Version 2019 R2 aPriori Confidential 2 

Introduction to VPEs and administration 
A Virtual Production Environment (VPE) represents a manufacturing facility by defining a 
set of virtual machines, workcenters, processes, process routings, and process groups. 
This representation includes definitions of the physical aspects of the environment 
(speeds, feeds, manufacturing times) as well as cost structure (labor rates, overheads, 
and so forth). Often, all of the elements of a VPE would be in one physical location, 
analogous to a factory. However, this may vary from customer to customer. 
aPriori provides a set of Starting Point ("baseline") VPEs representing average costs of 
manufacturing in various geographic regions. You (or aPriori Professional Services) may 
also configure a VPE to represent your in-house manufacturing environment and cost 
structure, or a supplier’s manufacturing environment and cost structure. 
Updating and maintaining your company's VPEs requires at least one individual to serve 
as a VPE Administrator: this role has more privileges than a typical aPriori user, but not 
as many as a System Administrator. This document addresses those tasks that a VPE 
Administrator might be expected to perform. This document also includes a chapter 
devoted to administration of the separately-licensed Wire Harness module, since it is 
implemented as a special VPE (see Chapter 7, Wire Harness and PCBA VPE). 

The VPE Toolset 
VPE-related features are accessed through the VPE Toolset, which is accessed from the 
Tools menu at the top of the main aPriori client. 

To access the VPE Toolset 

1 In the aPriori client, click Tools>VPE Toolset. 
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This displays the aPriori VPE Toolset window. 

 

2 Use the VPE Toolset to access: 
• VPE Manager – Use this tool to update VPE data, such as materials, machines, 

rates, defaults, and variables. This is covered primarily in the next chapter, 
VPE Manager. 

• Cost Model Workbench – Use this tool to build or edit cost models, modify VPE 
logic, and configure custom inputs and outputs. This module is licensed 
separately and is documented in the aPriori Cost Model Workbench Guide. 

• Process Group Site Variables – Use this tool to modify site variables for process 
groups, which impact how GCDs are analyzed by aPriori when it generates 
cost estimates for all the VPEs in the deployment. This is covered in Chapter 
4, Process Group Site Variables. 

• Deployment Data Administration – Use this tool to manage active currencies and 
exchange rates, set the default VPE for each process group, and configure 
display names for cost outputs. This is covered in Chapter 5, Deployment 
Data Administration.  

• BOM Loader – Use this tool to import bills of materials and populate your 
aPriori database with components and cost data. This module is licensed 
separately. This is covered in Chapter 6, BOM Loader. 
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3 The File and Tools menus provide access to specific actions that are appropriate to 
your current location. Items on these menus are added and removed (or enabled and 
disabled) depending on where you are within the VPE Toolset options. For example,  
here are the options available on the Files > Export menu at the top level of the VPE 
Toolset window and the VPE Manager:  

 

Using the Search CSL utility 
When working with VPEs and cost models, it can be useful to search the through the 
cost model source files to find where things are defined. The VPE Toolset and Cost Model 
Workbench provide a Search CSL mechanism to find specific strings of code or text 
within a cost model.   

4 From the toolbar of any VPE Toolset utility click Tools > Search CSL. 
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5 In the resulting Search dialog: 

 
Provide values for: 

• The name of the VPE or Cost Model to search 
• The process group within the VPE or cost model to search 
• The string to search for. The search is case sensitive. 

As you enter text in the Search String field, aPriori instantly searches throughout the 
entire cost model, and returns in the right pane a list of all CSL files that include the 
specified string. Clicking on one of the entries displays the entire file in the lower-right 
pane. 
This is particularly useful for tracing where certain formulas or settings are used in the 
cost model and can also be used to track down the specific code that creates a message 
seen in the application. 

Note: This search does not include lookup tables, plant variables, or any VPE data 
(machine, material, tool shop, etc.). 
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2 VPE Manager 

The aPriori VPE Manager allows you to update VPE data, such as machines, 
materials, rates, defaults, and variables. You can use it to create, open, import, 
export, and delete VPEs, as well as view a VPE’s change log. You can also use 
it to add and delete machine and material data as well as edit that and other data 
contained within the VPE. 

This chapter includes the following topics: 
 Overview 
 Managing VPEs 
 Editing VPEs 
 Managing VPE cut code 
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Overview of the VPE Manager 
The aPriori VPE Manager allows you to manage VPEs and edit the data contained in 
each VPE. For more information, see Managing VPEs on page 8 and Editing VPEs on 
page 48. 

To start the VPE Manager 

6 Select Tools > VPE Toolset from the aPriori menu bar to display the aPriori VPE 
Toolset window. 

 

7 Click VPE Manager to display the Select VPE window. 
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8 Select a VPE and click Open to display the VPE in the aPriori VPE Manager window. 
Use the left pane to navigate through the process groups display their elements in 
the right pane. 

 

Managing VPEs 
The VPE Manager allows you to view, create, copy, import, export, and delete VPEs, or 
portions of VPEs. The features described below can be found on different VPE Toolset 
File menus depending on context, but all are available from the VPE Manager File menu . 
You must purchase a separate license to create and copy VPEs. 
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Opening a VPE 
You can open a VPE from the File menu on the VPE Toolset or the VPE Manager. You 
can have multiple VPEs open at the same time.  

To open a VPE  

1 To display the Select VPE window, either Select File > Open VPE from any VPE 
Toolset or VPE Manager tool bar, or just start the VPE Manager, which automatically 
prompts you to select a VPE: 

 

2 Select the VPE you want to edit and click Open to display that VPE in the aPriori 
VPE Manager. 

 



 

aPriori Version 2019 R2 aPriori Confidential 10 

Changing a VPE currency and exchange rate version 
You can specify a default currency and a saved exchange rate version for this VPE. 

1 Open the VPE as described in Opening a VPE above. 

2 Click Tools > VPEs > Change Currency. 

3 In the Change VPE Currency dialog, select the desired currency and (optionally) the 
desired saved exchange rate table from the drop-down menus. 

For more information about saving exchange rate versions, see Saving an exchange 
rate version. 

Creating a new VPE 
The VPE Manager allows you to create a new VPE by copying an existing VPE, or by 
creating a new VPE from scratch and then adding process groups manually, or by 
creating an overlay VPE... 

Note: aPriori strongly recommends that you create overlays when you need to create a 
new VPE. Since overlay VPEs can inherit values from their parents, they are 
much easier to maintain. This approach is also much preferable with recent 
developments in aPriori Cost Models and the introduction of Regional Data 
Libraries. The older methods of creating standalone VPEs from scratch or 
copying them from existing VPEs are covered below, but the preferred method of 
creating overlay VPEs is covered in detail in the following section: Working with 
Overlay (“Inherited”) VPEs. 

Note: When creating VPEs, do NOT use hyphens, slashes, or ampersands (-, /, &) in 
the file names. 

To create a new VPE 

1 If the VPE Toolset is not already open, click Tools > VPE Toolset. 

2 Select File > New VPE from the VPE Manager menu bar to display the New VPE 
window. 

3 Enter a unique name for the new VPE and click OK to create the VPE and open it 
the aPriori VPE Manager. 

4 Optionally click the top entry in the navigation pane (the new VPE name) and scroll 
to the bottom of the screen. Enter a unique type name for this VPE. Although 
optional, this may be useful for creating Access Control statements to determine who 
has or does not have access to this VPE. For example, you may want to ensure that 
only European users have access to this new VPE. By creating a type called 
“VPE_EU_ONLY”, a System Administrator could use the Permissions tab to create a 
rule that prohibits North American users from accessing this VPE. (The default VPE 
Type for basic aPriori-provided VPEs is “Regional Data Libraries”.) 
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5 Optionally edit any of the other fields on this page to reflect the requirements of this 
new VPE.  

6 Right-click the VPE, select Add ProcessGroup from the context menu, and select 
the process group you want to add to display the Select baseline version window. 

7 Select the version of the cost model to use for the process group and click OK to add 
the process group to the VPE. 
We recommend that you select the most recent version (that is, the one with the 
highest number), unless you know that you want to use an older version. 

8 Repeat steps 4 and 5 for each process group you want to add. 

9 When done, click the Publish icon ( ) to save your changes. 

To make a standalone copy of a VPE 

1 If the VPE Toolset is not already open, click Tools > VPE Toolset. 

2 Select File > Copy VPE > Disassociate from Source VPE (copy-only)... 

3 From the Select VPE window, select the VPE to copy and click Copy. 

4 Enter a unique name for the new VPE and click OK. 

5 In the Select Process Groups window, select each process group you want to include 
(or use the Select/Deselect All checkbox) and click OK. 

 

6 When done, click the Publish icon ( ) to save your changes. 

Working with Overlay (“Inherited”) VPEs 
An overlay VPE (also referred to as an inherited VPE) is created from one or more VPEs 
and maintains a link to the original(s) so that updates to the parent(s) get passed on to 
the child. 
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You can make customizations to the overlay VPE, and these customizations get re-
applied after the overlay is updated from a parent VPE. Individual data points in all VPE 
tables can be overridden, along with individual files in the cost model. 
An overlay VPE can inherit values from up to four different parent VPEs, one each for 
the following: 

 Cost Model information 
 Material Catalog 
 Machines 
 Tool Shops 

Note: Plant Variables in an overlay VPE are inherited from the Machine VPE. In 
previous releases, these values were inherited from Cost Model VPE. 

When you save an overlay VPE, only the customizations are stored. When you open an 
overlay VPE, aPriori first loads the data from the parent VPE(s), and then applies all the 
local customizations. 
You can create an overlay VPE from a starting point VPE, a custom VPE, or from 
another overlay VPE. 

Note:  Implementing overlay VPEs in a logical fashion requires some advance 
planning and set-up. For example, if you are just beginning to set up your 
overlay VPEs, it does not make much sense to assign different starting point 
VPES to the different areas of your overlay VPE (such as aPriori USA to the 
Cost Model VPE field, aPriori Mexico to the Material Catalog field, and aPriori 
China to the Machines field, etc.) Rather, you might create a master overlay 
VPE for your company from one of the starting points, and customize it with 
company-specific overrides, and then create regional overlay VPEs from that 
master with their own customizations for machines and materials, and so on 
down to finer levels of resolution. 

Why use overlay VPEs? 
aPriori starting point VPEs provide a starting point for you to set up your production 
VPEs.  You are likely to create one or more custom VPEs to adjust or add some data 
and logic that reflect your manufacturing practices and buying power.  You need to 
maintain your configurations and customizations, but you also want to continue to 
update data and logic from aPriori’s semi-annual starting point updates. 
Overlay VPEs can be useful in this environment because they inherit from their parents, 
and then re-apply customizations. This means that VPEs that are derived from an aPriori 
starting point VPE automatically inherit semi-annual starting point updates, without 
overwriting your customizations. When you use overlay VPEs, you minimize the number 
of places you need to update data and logic.   
Here are some examples of how you might use overlay VPEs: 

 Use an overlay VPE to create a customized cost model based on aPriori starting 
point data, allowing you to  keep it updated with semi-annual starting point VPE 
updates. 
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 Create a master custom cost model, but then create regional overlay VPEs from 
it which inherit the majority of the model but which  include small regional 
customizations  (for example,  the overlay VPEs all share the same underlying 
cost model for common processes, but each have their own routing structures). 

 Same as above, except that the only difference between the child VPEs and the 
parent  are the machine data,  material rates,  and  logistics logic. 

 Create a European overlay VPE in Euros that is based on the USA starting point 
VPE in US dollars. 

 Create a European overlay VPE in Euros that is based on a custom European 
VPE in Euros. 

The following illustrations provide additional visual examples of overlay VPE usage. 
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Note: Updates to a parent VPE are guaranteed to be propagated to child VPEs only 
after a restart of aPriori. 

It is important to realize that the cost model defines metadata such as columns and 
column types for machine, material, and tool shop tables. Therefore, if overlay VPE 
“Company_XYZ_Germany” inherits its cost model from starting point VPE “aPriori 
Germany”, the only allowable columns for “Company_XYZ_Germany”  machines and 
materials are those defined in the cost model versions for the various process groups in  
“aPriori Germany”. 
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If you wanted “Company_XYZ_Germany” to have different columns for machines, 
materials or tool shops, you would want to create another overlay which inherits from 
“apriori Germany” and modify the metadata there.  You could then have 
“Company_XYZ_Germany” use that VPE for its cost model base.   

Note: Currently, when you override a material or a machine, there is no direct way to 
determine if a value is inherited or overridden. 

To create an overlay VPE 

1 If the VPE Toolset is not already open, click Tools > VPE Toolset. 

2 Select File > Copy VPE > Maintain inheritance with Source VPE (copy and 
link)... 
This displays the Select Base VPEs dialog. 

3 Select the VPEs that you want to use as parents for this overlay VPE. Note that if 
you populate the Cost Model VPE: field, any of the other three VPE fields that are 
empty will be auto populated by this selection.   
In the screenshot below,  a number of custom  VPEs (probably overlays themselves) 
have already been created for the company, and these custom VPEs are used as 
parent for this new overlay VPE. 
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4 Enter a descriptive name for the new overlay VPE in the New VPE Name: field. 

5 Click OK. 

6 When done, click the Publish icon ( ) to save your changes. 

To determine if a VPE is an overlay 
Unless you use a special naming convention, it may not be immediately obvious whether 
or not a VPE is an overlay. Use this procedure to check, and to identify what VPEs it 
inherits from. 

1 If the VPE is not already open, click File > Open VPE from the aPriori VPE Toolset and 
then select the VPE from the Select VPE window. Click Open. 

2 In the resulting aPriori VPE Manager window, click the top-level entry in the left pane, 
and then examine the entries in the right pane. 
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If the VPE is an overlay, you will see an inheritance path for the following lines: 

• VPE Inheritance 
• VPE Material Inheritance 
• VPE Machine Inheritance 
• VPE Tool Shop Inheritance 

Notes: 
1. Regional Data Libraries (RDLs) will display “**Unavailable** in the VPE 
Inheritance fields.  
2. Standalone VPEs will display “N/A” in the VPE Inheritance fields. 

To use the Update to Latest buttons 
The inheritance lines in the display for an overlay VPE will be appended with Update to 
Latest buttons in the following circumstances: 

 If you or another admin have loaded a newer Regional Data Library or have 
installed a baseline update for your VPEs. 

 If you export this overlay VPE and import it into a newer environment. 
Update to Latest for Material, Machine, and Toolshop inheritance tells aPriori to use the 
latest VPE Data available in the database for the given VPE. 
Update to Latest for “VPE Inheritance” applies to the CSL/Base VPE and tells aPriori to 
use the Cost Model Versions (CMVs) that are shipping with the latest RDL. It does NOT 
change the actual CMV being used. For example, if in 16,2, you were using CMV 5 and 
in 17.1 aPriori provides CMV 10, Update to Latest will still result in CMV 5 being used, 
but now from the 17.1 version. 
Update to Latest intentionally does not move you to the latest CMV on the latest RDL 
because aPriori wants this to be an explicit action on your part, since it is not known 
what additional migration upgrade work might be required. If your site has performed 
customizations, simply bumping the CMV could result in a VPE that doesn’t work 
correctly. This mechanism does allow you to implement bug fixes for older CMVs.  
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To push plant variables to descendants 
You can propagate updates to top level VPE plant variables to all overlay VPEs that 
inherit machine data from a specific VPE. This is useful for VPE managers who utilize 
Overlay VPEs within their deployment.  For example, if your tool crib labor rate has 
increased, and your deployment has many VPEs which inherit their machine data from a 
single “template” VPE, that update can be made in the “template” VPE and this feature 
can be used to push the updated value down to all of the VPEs that inherit machine data 
from the “template” VPE.. 

1 From the VPE Toolset toolbar, click Tools > Push Plant Variables to Dependents 

2 From the pull-down menu, select the parent VPE from which you wish to push plant 
variables.  

3 Click OK. 

To rename or rebase overlay VPEs 
Renaming or rebasing (i.e., changing which VPEs an overlay inherits from) overlay 
VPEs can be done with out-of-the-box aPriori Professional, but the procedure is manual, 
complex, and subject to errors due to typos. 
If you need to rename or rebase your overlay VPEs, please contact aPriori Customer 
Support and request the optional “Overlay VPE Rename Script”. 

VPE Export operations 
The VPE Manager provides the ability to export an entire VPE, or just certain portions 
such as processes, site variables, lookup tables, materials, machine  data, etc.   
Export a complete VPE when you want to: 

 Perform periodic data maintenance or updates in your staging environment, and 
then copy the updated VPE back to your production environment. 

 Copy a VPE to another  server. 
 Provide a copy of the VPE to aPriori Customer Support regarding an issue. 
 Make a backup of the VPE before making changes to it. 

You can export VPEs either one at a time, or several all at once. 
Export just certain portions of a VPE (such as processes, lookup tables. data, etc.) for 
development or maintenance of a VPE. For example, you might develop or modify a 
process in one VPE (or in one process group) that would be useful in another VPE (or 
within the same VPE but in a different process group). Or you might regularly export, 
update, and re-import some of your data on a quarterly, semi-annual, or annual basis. 
aPriori also provides additional options for editing smaller amounts of VPE data. See 
Editing VPE data for more information. 
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To export a single VPE 

1 From the VPE Toolset window or the VPE Manager window, click File > Export > 
Export VPE to Zip. 

Note:  The Export to Excel option is deprecated as of aPriori Release 2014R1. Use 
Export to Zip for all VPE exports. 

If you are in the VPE Manager window, you will only be able to export the currently 
open VPE. (For more information, see Opening a VPE on page 9.) 
If you are in the VPE Toolset window, you will be presented with a list of VPEs. Select 
the one you wish to export. 

Note: When you export an overlay VPE to a compressed file, you are given the 
option of exporting just the overlay VPE itself, or the entire “bundle”  -- the 
overlay VPE plus all the VPEs from which it inherits. In general, you should 
always select the entire bundle. 

2 Navigate to the folder where you want to save the exported VPE file, enter a name 
for the file, and click Save to display the VPE Change Log Entry window. 
Although you are specifying a name for the exported file, the name of the VPE 
contained in the exported files does not change. When imported, any existing VPE 
with the same VPE name will be overwritten. If you want to maintain a backup of the 
original VPE, make sure to export it prior to importing. For more information, see 
Creating a new VPE on page 10. 

3 Enter a description of the changes made to the exported VPE and click OK. 
For example, if you are exporting a staging environment VPE to import it into a 
production environment, enter the changes made from the previous production 
version to make users aware of your updates. 
You can also click Skip Log to export the VPE without describing the changes. 
A single .vpe.zip file is created. 

To export multiple VPEs 
This is particularly useful when creating local backups of configuration work done in 
aPriori. 

1 From the VPE Toolset window or the VPE Manager window, click File > Export > 
Multiple VPEs 

2 Follow the prompts and the usage notes in the resulting Export Multiple VPEs window 
to: 

• Specify a folder to which the export files will be written. 
• Select the VPEs to export (CTRL-click or SHIFT-click to expand your 

selection(s). 
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• Specify how to handle overlay VPEs: just the overlay VPE itself, or the entire 
“bundle”  -- the overlay VPE plus all the VPEs from which it inherits. In 
general, you should always select the entire bundle. 

• Specify a prefix for the file names. 

3 Click OK.  

4 To export site variables 
See To export site variables from a deployment on page 97. 

To export processes 
See Exporting, modifying, and importing processes on page 59 for information about 
when and how to use aPriori's process import/export capabilities. 

1 Open the VPE from which you want to export the process(es). In this example we will 
export from the aPriori USA VPE. 

2 Click File > Export > Processes... from the VPE Manager tool bar.  

3 In the Export Processes dialog, select the process group from which you want to 
export the process(es). In this example we will be exporting from the Sheet Metal 
process group. 
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4 Once you have selected the process group, expand and select the process-related 
elements that you want to export. In this example we just want to select the "3D 
Laser" so that we can copy it into a different process group. Then click OK. 
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5 When prompted, navigate to a folder and save the .zip file. Give it a more descriptive 
name if desired but be sure to leave the ".process.zip" extension intact. 

6 Once the .zip file is saved, aPriori prompts you to also save a .txt file with a summary 
of the exported process info.  
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aPriori saves this in the same folder as (and with the same name as) the .zip file.  
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To export VPE Data to Excel 
The VPE Toolset provides the ability to export VPE data such as machines, materials, 
tool shops, and plant variables to Excel spreadsheets. You can optionally edit the 
exported data in these Excel spreadsheets, and then import the data into either the 
original VPE or a different VPE where the imported data will be visible and used in 
subsequent costings in that VPE. This provides an efficient way to export/import just 
data of interest without including all the other elements of the VPE. 

Note: If you have updated to 16.1 from an earlier release, make sure to read the 
"IMPORTANT NOTE ABOUT PRE-16.1 VPES" in the section "To Import VPE 
Data from Excel". 

To add materials or machines, add a new row in the spreadsheet and populate it with 
the necessary details.   
To remove a machine or a material, change the value in the Edit Operation column to 
“delete” by selecting from the dropdown menu.  

Note: The Name column cannot be changed. Any changes to that column will be 
interpreted as a new material, machine, etc. 

You should refer to the VPE Manager display whenever you change the values of fixed 
value fields (such as Cut Code) to ensure that the value you enter in Excel corresponds to 
an acceptable value in the VPE Manager. 
The export process creates an index spreadsheet for the VPE, and separate 
spreadsheets for each of the process groups within the VPE. The index spreadsheet 
contains a cross-reference to all of the related process group spreadsheets and a sheet 
named "VPE_data" containing all of the plant information for the VPE. 

1 Open the VPE in the aPriori VPE Manager window, then click File > Export > VPE 
Data to Excel.  
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Note: Alternatively, you can open a specific VPE from within the VPE Manager and 
then right-click the top entry in the left-hand navigation pane, and select 
Export > All VPE Data to Excel… from the context menu: 

 

2 Navigate to the folder where you want to create the export Excel files. If you wish, 
modify the default name to something more specific. (The default name for the index 
spreadsheet  is simply the VPE name. The spreadsheets for process groups have 



 

aPriori Version 2019 R2 aPriori Confidential 26 

the process group name appended to the default name. For example, "aPriori USA-
Casting.xls"). Click Okay.  
This creates an Excel file for every process group in the VPE, as well as an "index" 
spreadsheet: 

 
The index spreadsheet (the only one that does not have a process group appended to 
its name) contains the top-level information about the VPE, as well as a cross-reference 
to all of the other process group-related spreadsheets created by the export. The "top-
level" info is what you see in the VPE Manager when you click the VPE name at the top of 
the navigation page.  
The screenshots below show how the info in the spreadsheets map to the displays in the 
VPE manager. Note that the Import Behavior column in the index spreadsheet simply flags 
those fields which cannot be edited and then re-imported. Also, the strings in the 
Description column are populated from the "tooltip" text when you hover over and item in 
the VPE Manager. These strings also cannot be edited and then re-imported. 
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Index sheet mapping: 
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The spreadsheet for each process group contains sheets for materials, each machine, 
and (if applicable) tool shops. You can see the mapping between the VPE Manager 
display and the exported spreadsheet below, using the Casting process group as an 
example: 
Materials (process groups without material stock) 
The first tab in the export spreadsheet maps to the Materials table in the VPE Manager. 
Most process groups simply consider the basic properties of the materials and each row 
lists a different material:  
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Materials (process groups WITH material stock): 
A few process groups -- Forging, Bar & Tube, Sheet Metal, and Sheet Metal -- Transfer 
Die -- must use material in the form of pre-formed stock: round tubes, solid bars, I-
beams, etc. Each of these can come in different lengths, made of different materials, and 
these factors must be taken into account during the costing of the part that uses them. 
For these process groups, the Materials tab is much larger and is populated with all the 
additional stock information found  in the VPE Manager. 
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When working with these stock-based process groups, it may also be helpful to refer to 
the Material Selection window in the main aPriori UI: 
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Machines: 
The next several tabs contain the machine information. 
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Tool Shops: 
Any tool shops defined under the VPE processes will be allocated to the far-right tabs in 
the export spreadsheets, with a "_tshops" extension. 

Note: Only one tool shop is supported per process, so you cannot add additional tool 
shops via Excel. 
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To export VPE Lookup Tables to Excel 
VPE lookup tables provide tabular data, either for a cost model in general, or for a 
specific process or operation. (Lookup tables are described in detail in the section 
"Working with Lookup Tables" in the Cost Model Workbench User Guide.) The VPE 
Manager provides the ability to export all lookup tables in a VPE to an Excel 
spreadsheet where the information can be imported into a different VPE or modified and 
then re-imported into the original VPE.  
For a practical example of how this can work, you can review aPriori's separately 
licensed Wire Harness VPE, which uses this functionality to load and maintain a 
"Component Library" lookup table of approved parts. See "Updating the Component 
Library" starting on page 139 for more information. 

1 Open the VPE in the aPriori VPE Manager window, then click File > Export > VPE 
Lookup tables to Excel.  

 

3 Navigate to the folder where you want to create the export Excel files. If you wish, 
modify the default name to something more specific. (The default name is simply the 
VPE name. such as "aPriori USA.xls). Click Okay.  
This creates an Excel file for every process group in the VPE, as well as an "index" 
spreadsheet for all of the other sheets created by the export.  
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You can now modify the Excel files with updated lookup table info and then re-import 
into the current VPE, or just import the exported Excel files into another VPE.  
If you are modifying a sheet with data from a .csv file or another spreadsheet, it is critical 
that you ensure that the columns in the import file match the columns in the lookup table 
spreadsheet exactly.  
Then you must copy the cells from the import spreadsheet and paste them into the 
corresponding cells in the Assembly componentLibrary sheet. If you are replacing all the 
information in your Component Library, make sure that no old data remains in the target 
spreadsheet after the Paste. If you are adding new information, make sure that you do 
not overwrite data that you wish to keep. Save the modified spreadsheet when done. 
The screenshots below show how the data in the lookup table spreadsheets map to the 
displays in the VPE Manager. (The index spreadsheet is the same as described in the 
previous section for exporting VPE data.) 
The spreadsheet for each process group has a tab for each lookup table in that process 
group: 
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To export from the command line 
aPriori provides the ability to export VPE data (and optionally. lookup tables) to Excel 
spreadsheets from the command line. This requires some configuration as explained 
below. 

1 Open the following file in a text editor: 
<apriori_install_dir>\bin\exportVpeDataToExcel.properties 
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4 Edit the lines highlighted below as  necessary: 
templateFile=ext/project-management-plugin/macro/ide/exportMultipleVPEsData.xml 
inputs.vpeFolder=<Enter destination folder here> 
inputs.exportVPEs=CSL(asList(asMap('plantName', '<Enter VPE name here>'))) 
inputs.exportVPELevelData=true 
inputs.exportMaterials=true 
inputs.exportMachines=true 
inputs.exportToolShops=true 
inputs.exportLookupTables=false 
inputs.useXls=false 

Basic example -- The edited file below will export data from the "aPriori USA" VPE to Excel 
spreadsheets located in D:/aaa_tmp/000_vpe_export_folder: 
templateFile=ext/project-management-plugin/macro/ide/exportMultipleVPEsData.xml 
inputs.vpeFolder= D:/aaa_tmp/000_vpe_export_folder 
inputs.exportVPEs=CSL(asList(asMap('plantName', ' aPriori USA'))) 
inputs.exportVPELevelData=true 
inputs.exportMaterials=true 
inputs.exportMachines=true 
inputs.exportToolShops=true 
inputs.exportLookupTables= false 
inputs.useXls=false 

Note: The vpeFolder path MUST use forward slashes ("/"), not Windows back slashes ("\"). 

Advanced example -- The edited file below additionally includes lookup tables, and exports from 
multiple VPES ("aPriori USA" and "aPriori Mexico") to older-style .xls (not .xlsx) files: 
templateFile=ext/project-management-plugin/macro/ide/exportMultipleVPEsData.xml 
inputs.vpeFolder= D:/aaa_tmp/000_vpe_export_folder 
inputs.exportVPEs=CSL(asList(asMap('plantName', 'aPriori USA'), asMap('plantName', 

'aPriori Mexico'))) 
inputs.exportVPELevelData=true 
inputs.exportMaterials=true 
inputs.exportMachines=true 
inputs.exportToolShops=true 
inputs.exportLookupTables= true 
inputs.useXls=true 

5 Open a command console and change to the aPriori installation bin directory. In this example, aPriori 
is installed at the root of the D: drive. Adjust as necessary for your installation. 

 

6 Execute the following command line, substituting your actual values for the aPriori installation 
directory and your login credentials: 
runMacro <apriori_install_dir>\bin\exportVpeDataToExcel.properties 

<your_apriori_login> <your_apriori_password> 
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Note: You MUST specify the complete aPriori installation path. If you specify a relative path (such 
as ".\exportVpeDataToExcel.properties", the command will fail. 

As the export command runs it displays status on the console. Watch for error messages -- most 
common errors are due to back slashes in the properties file and relative pathnames in the command 
line. The export can take several minutes to complete, so if it looks like it is hanging, give it plenty of 
time before you decide to cancel. 

 
When done, your export folder should contain Excel files for the process groups plus an index file for 
each VPE you specified. 
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VPE Import operations 
You can import exported VPEs into the VPE Manager, either one at a time, or several all 
at once. You may want to do this when installing a regional data library update, or when 
moving a modified VPE from a testing environment into production.  
You can also import just certain portions of a VPE that reside in spreadsheets created by 
various export commands, such as data, site variables, processes, or lookup tables. This 
can be useful if you want to take advantage of information in one VPE (or another 
process group) and add it to a different VPE (or process group). 

To import a single VPE 

1 Select File > Import > VPE... from the aPriori VPE Manager menu bar to display 
the Import VPE Files window. 

7 Navigate to the folder that contains the VPE you want to import and select it. 
You can select any VPEs that has been exported as a Microsoft Excel (.xls) or 
compressed (.vpe.zip) file. 

If a compressed file was created in a different version of aPriori, you will not be able 
to import it. 

8 Click Open to import the selected VPE and display the imported files in the Loaded 
VPE window.  
If the imported VPE has the same name as an existing VPE, the existing VPE will be 
overwritten.  

9 Click OK.  

To import multiple VPEs 
This option is particularly useful when importing updated Regional Data Libraries, or 
when importing backup VPE files. 

1 Select File > Import > Import Multiple VPEs... from the aPriori VPE Manager menu 
bar to display the Import Multiple VPEs window. 

2 Navigate to the folder that contains the VPEs that you want to import. 

3 Read the Usage Notes in the window to aid you in your selection. Note that you can 
import only files with .vpe.zip extensions. 

4 Click OK. 

To import site variables 
See To import site variables into a deployment on page98 . 
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To import processes 
Use this option to import spreadsheets that were created with the export processes 
command. See Exporting, modifying, and importing processes on page 59 for 
information about when and how to use aPriori's process import/export capabilities. 
Note: If a branch node has nothing defined in it (for example, no node attributes, CSL , 
lookup tables, process setup options, etc.), then it is skipped/ignored on import. 

1 Open the VPE which contains the process group into which you wish to import the 
exported process(es). (See To export processes on page 20.) 

2 From the VPE Manager tool bar click File > Import > Process... Then in the Import 
Processes dialog, navigate to the .process.zip containing the exported process(es) 
that you wish to import, then click OK. 

 

3 In the resulting Import Processes dialog, select the process group into which you want 
to import the process. Then select the elements of the process which you wish to 
import, and leave unchecked anything that you do not want to import. (In this 
example, we are importing all elements into the Sheet Plastic process group.) Click 
OK when done. 
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4 Once the process has been imported into the process group, you can modify it as 
necessary (see the Cost Model Workbench User Guide). 

To Import VPE Data from Excel 
The VPE Manager provides the ability to import VPE data such as materials, machines, 
plant variables, and tool shops from Excel spreadsheets. Typically, these spreadsheets 
would have been previously exported and perhaps modified with updated information 
before being imported into a VPE (either a different VPE, or the same VPE form which it 
was originally exported). This mechanism is very useful for doing VPE maintenance 
such as updating labor rates, material rates, and other data elements that must be 
revised in the VPE on a regular basis. 
For more information about the format of these spreadsheets and how to create them, 
see To export VPE Data to Excel on page 24. 

1 Open the VPE Manager on the VPE to which you want to import the data, and from 
the tool bar click File > Import > VPE Data from Excel.   

Note: Alternatively, you can open a specific VPE from within the VPE Manager and 
then right-click the top entry in the left-hand navigation pane and select 
Import > All VPE Data to Excel… from the context menu.  

2 Navigate to and click the index Excel file.  (This is the one without a process group 
embedded in its name. For example, if you had previously exported the data from the 
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aPriori USA VPE and kept the default name, the index file would be "aPriori 
USA.xls".) 

3 Click Open. 

Note: If aPriori displays an error message when you try to import, double-check that 
you have not selected one of the process group files or another incorrect 
spreadsheet. You MUST select the index spreadsheet.  

The import can take several minutes if it consists of many process groups. Asterisks 
appear next to process groups in the Navigation pane if they have been modified by 
the import. 

4 (Optional.) When prompted, either enter a description of your changes and click OK 
or click Skip Log. 

5 (Optional.) When prompted to publish the VPE, click yes.  

Note: Imported data will not be available to other VPE users unless you Publish. 

IMPORTANT NOTE ABOUT PRE-16.1 VPES: If you have upgraded to 16.1 from a 
previous release and use the Export VPE Data to Excel feature, you will 
encounter an error when re-importing these spreadsheets unless you perform the 
manual fix described below.  

The error is "Default tool material does not exist: Mold Base". 

 
To avoid this error, perform the following steps before using Import VPE Data from 
Excel. This procedure is necessary ONLY if you upgraded to 16.1 from an earlier 
release. 

1 Open the Plastic Molding spreadsheet in Excel. (This spreadsheet should have 
name similar to "<vpeName>-Plastic Molding.xls".) 

2 Go to the "Injection_Molding_tShops" tab. (The "_tShops" tabs are to the far right in 
the workbook.) 

3 Under the "Default Tool Material Name" column, change "Mold Base" to "Steel". (If the 
value in this cell is already "Steel", your VPE is already up-to-date and you do NOT 
need to perform this fix.) 
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4 Repeat Step 3 for the "Reaction_Injection_Molding_tShops" tab and the 
"Structural_Foam_Molding_tShops tab. 

5 Save the Excel spreadsheet. You should now be able to execute Import VPE Data 
from Excel without error. 

To Import VPE Lookup Tables from Excel 
The VPE Manager provides the ability to import lookup tables from Excel spreadsheets. 
Typically, these spreadsheets would have been previously exported and perhaps 
modified with updated information before being imported into a VPE (either a different 
VPE, or the same VPE form which it was originally exported). 
For information about lookup tables, see the section "Working with Lookup Tables" in the 
Cost Model Workbench User Guide. For information about exporting lookup tables, see 
To export VPE Lookup Tables to Excel on page 33. For an example of how the 
separately-priced aPriori Wire Harness VPE makes use of lookup table import/export to 
maintain a Component Library of approved parts, see Updating the Component Library 
starting on page 139. 

Note: When you need to remove rows when editing a lookup table spreadsheet, it is 
critical that you do not leave empty rows. If you select one or more rows and 
press the Delete key, you remove the contents of the cells but leave the 
empty rows in place. This will cause problems when you import the 
spreadsheet into aPriori. Therefore, use the right-mouse-click Delete option, 
and ensure that the rows are removed as well as their content. 

1 Open the VPE Manager on the VPE to which you want to import the lookup tables, 
and from the tool bar click File > Import > VPE Lookup tables from Excel.   

2 Navigate to and click the index Excel file.  (This is the one without a process group 
embedded in its name. For example, if you had previously exported the lookup tables 
from the aPriori USA VPE and kept the default name, the index file would be "aPriori 
USA.xls".) 

3 Click Open. 
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Note: If aPriori displays an error message when you try to import, double-check that 
you have not selected one of the process group files or another incorrect 
spreadsheet. You MUST select the index spreadsheet.  

4 Refer to the usage notes in the Import VPE Lookup Tables from Excel dialog, and select 
either Replace or Add as appropriate. The import can take several minutes if it 
consists of many process groups. Asterisks appear next to process groups in the 
Navigation pane if they have been modified by the import. 

5 (Optional.) When prompted, either enter a description of your changes for the log 
and click OK or click Skip Log. 

6 (Optional.) When prompted to publish the VPE, click yes. 

To import from the command line 
aPriori provides the ability to import VPE data (and optionally lookup tables) from Excel 
spreadsheets from the command line. (For information about creating these 
spreadsheets, see To export from the command line.)This requires some configuration 
as explained below. 

1 Open the following file in a text editor: 
<apriori_install_dir>\bin\importVpeDataFromExcel.properties 

Edit the lines highlighted below as  necessary: 
templateFile=ext/project-management-plugin/macro/ide/importMultipleVPEsData.xml 
inputs.vpeFolder=<Enter source folder here> 
inputs.availableVPEs=CSL (asList(asMap('name', '<Enter xls or xlsx file name for the 

imported VPE here>'))) 
inputs.importVPELevelData=true 
inputs.importMaterials=true 
inputs.importMachines=true 
inputs.importToolShops=true 
inputs.importLookupTables=false 
inputs.replaceRows=false 

Basic example -- The edited file below will import "aPriori USA" VPE data from the 
Excel spreadsheets located in D:/aaa_tmp/000_vpe_export_folder. The spreadsheet 
filename you specify in the third line must be that of the index file -- the one that 
includes only the VPE name, not a process group name. 
templateFile=ext/project-management-plugin/macro/ide/importMultipleVPEsData.xml 
inputs.vpeFolder=D:/aaa_tmp/000_vpe_export_folder 
inputs.availableVPEs=CSL (asList(asMap('name', 'aPriori USA.xls'))) 
inputs.importVPELevelData=true 
inputs.importMaterials=true 
inputs.importMachines=true 
inputs.importToolShops=true 
inputs.importLookupTables=false 
inputs.replaceRows=false 

Note: The vpeFolder path MUST use forward slashes ("/"), not Windows back 
slashes ("\"). 

Advanced example -- The edited file below additionally includes lookup tables, and 
also imports multiple VPES ("aPriori USA" and "aPriori Mexico"). It also specifies that 
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data from the spreadsheet should overwrite any data in the VPE with the same 
name: 
templateFile=ext/project-management-plugin/macro/ide/importMultipleVPEsData.xml 
inputs.vpeFolder=D:/aaa_tmp/000_vpe_export_folder 
inputs.availableVPEs=CSL (asList(asMap('name', 'aPriori Mexico.xls'),asMap('name', 

'aPriori USA.xls'))) 
inputs.importVPELevelData=true 
inputs.importMaterials=true 
inputs.importMachines=true 
inputs.importToolShops=true 
inputs.importLookupTables=true 
inputs.replaceRows=true 

2 To import lookup tables: Set inputs.importLookupTables=true in the properties file. This 
allows lookup table data to be imported. 

• If you exported from the command line, by using the 
exportVpeDataFromExcel.properties file with inputs.importLookupTables=true, the 
lookup tables will be exported as part of the Excel sheets containing the data. 
They can then be imported alongside the rest of the VPE data, as part of 
those spreadsheets that were previously exported.  

• If you exported from the VPE Manager UI, by using File > Export > VPE 
Lookup Tables to Excel, the lookup tables will be exported independently of 
the data. The Excel spreadsheets will only contain lookup tables and will 
have the same names as those containing VPE data, so they cannot both be 
imported at the same time. 

3 Open a command console and change to the aPriori installation bin directory. In this 
example, aPriori is installed at the root of the D: drive. Adjust as necessary for your 
installation. 

 
Execute the following command line, substituting your actual values for the aPriori 
installation directory and your login credentials: 
runMacro <apriori_install_dir>\bin\importVpeDataFromExcel.properties 

<your_apriori_login> <your_apriori_password> 

Note: You MUST specify the complete aPriori installation path. If you specify a 
relative path (such as ".\importVpeDataFromExcel.properties", the command will fail. 

As the import command runs it displays status on the console. Watch for error 
messages -- most common errors are due to back slashes in the properties file and 
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relative pathnames in the command line. The import can take several minutes to 
complete, so if it looks like it is hanging, give it plenty of time before you decide to 
cancel. 

 
When done, your VPE(s) should contain the data from all the Excel files. 
Note: To see the new VPE data after importing using the command line, it is 
important to close the VPE and then click File > Refresh Database Connection 
from the main window toolbar. 
 

Importing a starting point VPE update 
You may want to import a starting point VPE that has been updated by aPriori. aPriori 
starting point VPEs  are updated and delivered semi-annually. Updated information 
typically includes Regional Data Libraries and/or cost model updates   such as 
machining tables for specific processes or cost model logic for specific processes or 
operations. Each update includes release notes that explain the changes that have been 
made and the trends in the Regional Data Libraries. 
aPriori Customer Support will provide you with a URL link to the specific update files that 
are appropriate for your version of aPriori software. 
Updates must be loaded from a computer which has aPriori installed and is on the same 
local area network (LAN) as the database server. The amount of time the update will 
take is dependent on the connection to the database and the number of regions to be 
updated.  

Note: If you try to load updates from a machine which is not on the same LAN as the 
database server, the update may take many hours to complete.  

Your aPriori user ID must have administrator privileges to import VPE updates.  aPriori 
recommends notifying the end users when the update will take place. Users may remain 
connected to the system during the update. The updates are effective immediately and 
the end users may notice cost differences as the updates happen. 
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Note Starting point VPE updates are sometimes compatible only with certain versions 
of aPriori. Please consult the relevant Release Notes for the aPriori starting point 
VPE update and work with aPriori Customer Support to determine if a specific 
update is appropriate for your needs and environment. 

To import a starting point VPE update 
The most up-to-date procedure for installing an update will be in the Release Notes that 
accompany the update. These steps typically include the following. 
Downloading the files and importing the baseline update file: 

1 Download the package provided by aPriori Customer Support to a local folder. This 
folder should contain the following content: 

• A license file: <filename>.apz  

• A baseline update file: baseLineUpdate-<version_numbers>.apx 

• Regional Data Library region files: <region_name>.vpe.zip 

2 Import the new license file (the user who completes this step must be configured as 
a System Administrator in the aPriori environment) 

3 Import the baseline update file (the user who completes this step must be configured 
as a VPE Manager in the aPriori environment) 

4 From the aPriori client, click Tools > VPE Toolset 

5 In the VPE Toolset, click File > Import > aPriori Baseline Update… 

6 Navigate to the baseline update file, select it, and  click Open. 

Note: If you downloaded the file using Internet Explorer, the original file extension 
(.apx) may have been changed to .zip. By default, the file browser only 
displays files with .apx extensions, so you will need to either select All files 
in the Files of type: field or change the file extension of the update back to 
.apx.  

7 Click OK. 
While the update is being loaded, you will see the progress in the lower right corner 
of the VPE Manager Toolset.  

8 When the update completes, a message pops up confirming that the update was 
successful.  
Click OK. 

Importing the Regional Data Libraries 

The previous steps must be completed before starting the steps below. To complete 
these steps, you must be a VPE Administrator. 
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Note: . The process below assumes that you have configured your  installation with an 
aPriori Macro that enables you to import multiple VPEs at one time. You must 
contact your aPriori account representative to discuss installing this macro. It is 
possible to install the Regional Data Library files one by one without this macro 
(using the standard VPE Toolset menu File > Import > VPE…), but the 
procedure will take much longer and requires much more interaction.  

1 From the VPE Toolset click File > Import > Multiple VPEs… 

Note: This option is available only if you have installed the aPriori Macro mentioned 
above. 

Follow the steps in the resulting window to locate and import the VPE files: 

2 Select a local directory that contains all of the regional data libraries (.vpe.zip files). 

3 Select the VPE files you wish to import 

4 Click OK. 

Note: While the update is being loaded, you will only see a progress bar in the 
bottom right corner of the aPriori client, not the VPE Toolset window. 

5 When the import completes, a message pops up confirming that the update was 
successful.  
Click OK. 

Deleting a VPE 
You can delete a VPE if it has become outdated or to remove a VPE created for training. 

Note: You cannot delete a VPE which: 
• is the default VPE for a process group. 
• has overlay VPEs that inherit from it. 

To delete a VPE 

1 Open the VPE you want to delete. 
For more information, see Opening a VPE on page 9. 

2 Select File > Delete VPE from the aPriori VPE Manager menu bar to display the 
Delete VPE window. 

3 Click OK to delete the VPE. 
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Viewing a VPE change log 
When a VPE is exported, information can be entered into the VPE change log. You can 
view this log when the VPE is imported. For more information, see VPE on page 18 and 
VPE on page 38. 

To view a VPE’s change log 

1 Open the VPE for which you want to view the change log. 
For more information, see, see Opening a VPE on page 9. 

2 Select File > View VPE Change Log from the aPriori VPE Manager menu bar to 
display the VPE Change Log window. 

 

3 Click OK to close the change log. 

Editing VPEs 
You can use the aPriori VPE Manager to edit virtual production environment (VPE) data. 
This data includes facility data, such as variables, lookup tables, processes, operations, 
machines, and materials.  
When you open a VPE, the data for the VPE is organized in the navigation list on the 
left. Select a folder or file to display its data on the right. 
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All VPEs have a consistent file structure. You can: 

 Click the top-level VPE folder to display general facility data and usage 
information, such as a description, objective, and usage guidelines and 
limitations. 

 Click each process group folder to display the cost model version and default 
material name. The Notes field contains information displayed to aPriori users on 
the VPE Details window.  

 Click  or double-click a process group to expand it: 
Variables display the plant variables for the processes used in the selected VPE’s cost 
model.  
Lookup tables display lookup tables, such as handling times or cut rates. 
Processes display the default tool shop and default machine for each process. The 
Notes cell contains information displayed to aPriori users in the VPE Details window. 
Operations display the operations associated with each process. 
Machines display machine descriptions, rates, speeds, and feeds. 
Materials display the material list and composition, sheet size, and rate data. 
All the VPEs provided with your installation of aPriori have been created and tested to 
reflect specific costing behavior. Changes to these VPEs will impact cost estimates for 
all components using the VPE. We recommend that you use the following best practices 
to ensure that VPE changes are applied in a controlled and consistent manner: 
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 Make any VPE modifications in a staging environment before moving them to 
production. 

 Create a data maintenance plan for each VPE to ensure that VPE data is kept 
current. 

 Ensure that anyone editing VPE data attends aPriori Administrator training or 
engages with aPriori Professional Services for support. 

To edit a VPE 

1 Open the VPE you want to edit. 
The VPE is displayed in the aPriori VPE Manager. You cannot edit aPriori starting 
point VPEs. For more information, see , see Opening a VPE on page 9. 

 

2 Save a copy of the VPE as a backup. 
For more information, see VPE on page 18. 

3 Edit the VPE data. 
You can use the aPriori VPE Manager to add or delete the machines and materials 
in each process group. You also can edit machine, material, and other VPE data. For 
more information, see Adding machine and material data on page 51, Editing VPE 
data on page 59, and Deleting machine and material data from a VPE on page 64. 

4 Select File > Publish VPE from the aPriori VPE Manager menu bar or click  in the 
toolbar to save your changes. 
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5 Select File > Close, press Ctrl+W, or click  on the title bar to close the VPE 
Manager and return to the aPriori VPE Toolset window. 

Adding machine and material data  
Add machine, material type, and stock data to a VPE when the VPE does not contain 
the machines or materials used by your facility. 
If you want to add a large number of machines or materials to the VPE, we recommend 
that you export the VPE data and add the new machines or materials in Excel, then 
import it. For more information, see To export VPE Data to Excel on page 24 and To 
Import VPE Data from Excel on page 40 . 
A note about material hardness 
By default, most material hardness values are set to “0.00” in the VPE Manager 
“Materials” UI. In this case, aPriori cost models will derive a reasonable hardness value 
from internal tables at costing time, if you have a specific hardness value that you want 
to be used for costing, you can provide an override value. 
 

 

To add a machine 

1 Open the VPE to which you want to add a machine. 
The VPE is displayed in the aPriori VPE Manager. For more information, see 
Opening a VPE on page 9. Expand the process group to which you want to add a 
machine. 

2 Expand the Machines folder. 

3 Expand the machine type folder for the type of machine you want to add. 
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4 Right-click the machine type folder and select Create new machine from the context 
menu to display the New Machine window. 

 

5 Enter the machine’s name and select the work center. Check Apply Default Values 
if you want to use the values from the default machine to populate the new 
machine’s data.  

6 Click OK to add the new machine as a new file in the Navigation pane and as a new 
row in the machine type table in the Data pane. 

 

7 Click the machine in the Navigation pane to edit the machine’s properties. 
If you are editing directly in the table, you can click  in the column header to expand 
the column and display its sub-columns. Click  to collapse the sub-columns.  
As you edit, an asterisk (*) appears next to the file in the Navigation pane and next to 
the row to indicate that there are unsaved changes. 
For example, in the figure above, a new bend brake SPH-90C (Amada) machine was 
added. It appears as the last file in the Bend Brake list in the Navigation pane and as 
the last row in the table. Because the labor rate was edited, an asterisk appears next 
to the machine. 
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To add or update a machine field 
You can add or update a column in the machine table across all processes in a process 
group at once, rather than making the same change to each distinct process machine 
table.  This feature is useful if your company wishes to add a column to all machine 
tables in a VPE, such as “Factory Location.”  

1 In the VPE Toolset (or the Cost Model Workbench), open a VPE and select the 
process group you wish to change. 

2 From the menu bar, click Tools > Add/Update machine field. 

3 Enter values in the fields in the resulting dialog box and click OK. 

4 The column is added to the table, but it will not actually be populated with data.  

5 Select File > Publish VPE from the aPriori VPE Manager menu bar or click  in the 
toolbar to save your changes. 

6 Input values into the field through the VPE Manager. 

To add a material 

1 Open the VPE to which you want to add a material.  
The VPE is displayed in the VPE Manager. For more information, see Opening a 
VPE on page 9. 

2 Expand the process group to which you want to add a material. 

3 Expand the Materials folder. 

4 Right-click the Materials folder and select Add material from the context menu to 
display the New Material window. 

 

5 Enter a name for the material and click OK to display a list of material types. 
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6 Select a material type and click OK to display a list of material cut codes. 

 
A material’s cut code characterizes the machinability of a material and is adapted 
from the Sandvik Cormorant cutability classification (CMC code) scheme for metals. 
Different materials that machine similarly are assigned the same cut code. For 
example, both Inconel and Hastelloy are assigned a cut code of 20.21 as they are 
both nickel-based, heat resistant super-alloys.  
For more information on assigning material cut codes, see Assigning material cut 
codes on page 76. 

7 Select a material cut code and click OK to add the new material as a new item in the 
Navigation pane and as a new row in the Materials table in the Data pane. 

8 Click the material in the Navigation pane to edit the material’s properties. 
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Material properties vary by process group. Review the cost model to understand the 
role that material properties play in calculating cost. Typically, once a material is 
added, the only value that changes over time is the Unit Cost. 
Common material properties include: 

 Density – The density of the material 
 USA Name, DIN Name, and EN Name – These properties reflect the name 

or standard by which the material is known in the US, Germany, and UK, 
respectively. They are optional fields that may be populated in addition to the 
primary Name field. 

 Cost Units – Material cost data can be entered in multiple units systems. 
Select one of the following unit types from the drop-down list: 
 Cost per KG – Available for all process groups 
 Cost per LB – Available for all process groups 
 Cost per Square Foot – Available for the Sheet Metal process group 
 Cost per Square Meter – Available for the Sheet Metal process group  
 Cost per Linear Foot – Available for the Bar & Tube Fabrication and 

Forging groups 
 Cost per Linear Meter – Available for the Bar & Tube Fabrication and 

Forging groups 
 Cost per Item (Each) – Cost for an individual stock item of the specified 

size. Available for some process groups  
Regardless of the cost units chosen, costs are converted as appropriate and 
displayed in cost per mass units in the aPriori interface. That is, in the aPriori 
interface, material unit costs are displayed as Cost per Kg or Cost per Lb, 
depending on whether the user has chosen Metric or English units for 
display.  

 Cost per Unit – Material unit cost based on the selected Cost Units  
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Note: When you add a material with cut code 4.0 or 4.1, please specify Rockwell C as 
the Hardness System field value. When you add a material with cut code 
23.1, 23.21, or 23.22, please specify Tensile Strength as the Hardness 
System field value. See A note about material hardness for more information. 

9 Add material stocks to the material type folder following the instructions in To add a 
material stock below. 
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To add or update a material field 
You can add or update a column in the material table across multiple process groups in 
a VPE at once, rather than making the same change to each process group individually.  
This feature is useful if your company needs to add a column to all material tables in a 
VPE, such as “Company Description.” 

1 In the VPE Toolset (or the Cost Model Workbench), open a VPE. 

2 From the menu bar, click Tools > Add/Update material field. 

3 Enter the fields in the resulting dialog box. Use CTRL-left-click and SHIFT-left-click 
to extend your selection of process groups from the Select Process Group(s) field. 

4 When you click OK, a window will open for each process group you selected as it is 
updated. You can dismiss these windows when done. 

5 The column is added to the table, but it will not actually be populated with data.  

6 Input values into the field through the VPE Manager. 

7 Select File > Publish VPE from the aPriori VPE Manager menu bar or click  in the 
toolbar to save your changes. 

To add a material stock 

1 Open the VPE to which you want to add a material stock.  
The VPE is displayed in the aPriori VPE Manager. For more information, , see 
Opening a VPE on page 9. 

2 Expand the process group to which you want to add a material stock. 
Material stocks are available for the Bar & Tube Fabrication, Forging, Sheet Metal, 
and Stock Machining process groups. 

3 Expand the Materials folder. 

4 Expand the material type folder for the type of material stock you want to add. 

5 Right-click the material type folder and select Add material stock from the context 
menu to display the New Material Stock window. 

6 Enter a name for the material stock and click OK to add the new material stock as a 
new file in the Navigation pane and as a new row in the Materials table in the Data 
pane. 

7 Enter data directly in the Material Stocks table cells or click the material stock in the 
Navigation pane to enter the values in fields. 
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If you are editing directly in the table, you can click  to expand a column and display 
its sub-columns. Click  to collapse the sub-columns.  
As you edit, an asterisk (*) appears next to the file in the Navigation pane and next to 
the row to indicate that there are unsaved changes. 

To add a tool shop 
A tool shop is a set of variables to calculate tooling related costs. A tool shop is 
something like a miniature VPE but is tooling specific. They have no CSL but store data 
such as relative costs for different die materials, and can be used by a process that 
makes use of tooling such as molds, cores, etc. To create a tool shop, you (or an 
administrator who has permission to use the Cost Model WorkBench) must first create a 
tool shop type, and then associate it with the relevant process. For these initial steps, 
please refer to the aPriori Cost Model Workbench Guide, “Working with Tool Shop 
Metadata”.  
Once the initial set-up work is done, you can use the VPE Manager to add tool shops 
and view and modify their variables. 

1 Open the VPE to which you want to add a tool shop. 
The VPE is displayed in the aPriori VPE Manager. For more information, , see 
Opening a VPE on page 9. 

2 Expand the process group to which you want to add the tool shop.  

3 Expand the Processes folder. 

4 Expand the process folder to which you want to add the tool shop. (If your target 
process cannot be expanded or does not include a Tool Shops subfolder, review the 
preliminary work that was done on the CMWB as described above.) 

5 Right-click Tool Shops and click Create Tool Shop. 

6 Enter a name for the tool shop and click OK. 
The tool shop should now appear under the Tool Shops subfolder. 

7 Click the new tool shop and enter values as needed in the fields that are displayed. 

Creating a new process 
You can define a new process for a specific process group within a VPE: 

1 From the VPE Toolset, click Tools > Create New Process. 

2 In the resulting dialog, specify the VPE and the Process Group to which the process 
should be added. (This feature currently works for VPE Cost Models and not 
baseline cost models. For example, you can create a new process for an overlay 
VPE based on the aPriori USA baseline VPE, but you cannot add it directly to the 
aPriori USA baseline VPE.) 
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3 Enter a name for the process. 

4 Optionally, you can specify if you wish to copy the machine table definition from 
another process to this new process. 

Note: This copies only the table definition, not the actual table data.   

5 Click OK. 
For more details about using this feature, see the section "Adding a New Process to a 
Process Group" in the Cost Model Workbench Guide.  

Exporting, modifying, and importing processes 
aPriori provides the ability to export and import processes, allowing you to develop and 
modify processes and then share them across different process groups or VPEs. The 
export and import procedures themselves are relatively straightforward and are covered 
in the following two sections: 

 To export processes on page 20 
 To import processes on page 39 

However, there are a number of constraints and details that you should consider when 
exporting and importing processes. Import behavior may vary depending on a number of 
factors, such as the Cost Model Version (CMV) of the donor and recipient process 
groups, whether the donor or recipient have been overridden, whether or not you are 
working with overlays, etc. 
Constraints: 

 This table shows the behavior of an import based on whether or not the "donor" 
and "recipient" objects  (CSL files, field definitions, etc.)  have been overridden: 

 

Donor Recipient Result 

Baseline Baseline Ignore 

Baseline Overridden Ignore 

Overridden Baseline Import 

Overridden Overridden Import 

 
 The CMV of the Process Group from which the process was exported must exist 

in the recipient VPE. 
 Choosing to import over an existing item will replace anything existing in that 

item, so it is your responsibility to ensure that nothing is broken as a result. 
 VPE data is not transferred to or from overlay VPEs.  
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However, you can work around this using the Export/Import VPE data tools (see To 
export VPE Data to Excel and To Import VPE Data from Excel ): 

1 Export processes from the donor process group, 

2 Export all VPE data from the donor VPE. 

3 Trim all data other than the relevant processes. 

4 Import the process(es) to the recipient process group. 

5 Import the trimmed VPE data to the recipient VPE. 
• When exporting from an Overlay, a process must live entirely in that level of 

the overlay. I.e., you cannot build an Investment Casting process in Level A, 
override just a single operation in Level B, and export from Level B. 

• Process export/import is a manual feature that does not provide a lot of 
automation or error checking. You must take responsibility to ensure that your 
work is complete and valid. Note that you must: 

• Manually perform any template creation, modification, or reconciliation 
operations. (Templates are not included in the export/import operations.) 

• Explicitly specify any associated branch nodes. 
• Ensure that the process will work with the CMV of the recipient VPE. For 

example, inherited items may be different if the exported process was built on 
CMV50 and is imported into CMV100: the import will simply respect 
inheritance, it will not verify that the inherited item has not changed from CMV 
to CMV. 

• You may occasionally encounter a situation with an older process where the 
export does not include all of the data required by the process. When you 
import the process to another process group, this missing data can lead to a 
costing error message. For example, the Sheet Metal "Std Press" process 
references a "Die Base Cost" value which was not included in the Std Press 
tool shop when the process was written. It was stored in a separate lookup 
table using a mechanism that has not been used for the more recently 
developed processes. When you import this process to another process 
group, you may get an error similar to "Standard Press Tool Shop:Diemaker1 
plant:TestVPEStdPress is invalid. Die Base Cost Table is empty in CSL module 
processes/Std Press/Component/csl/ptaxStdPress.csl at line 221 in CSL module 

processes" While this is very rare, you must be prepared to perform some 
manual CSL and lookup table editing to work around the issue (or be willing 
to have aPriori Professional Services assist you). 

Editing VPE data 
The aPriori VPE Manager supports several ways to edit VPE data. You can: 

 Edit individual data fields. We recommend this approach if you need to make 
changes to a single item. 
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 Edit data within the cells of a table. We recommend this approach for batch 
changes because you can view all the machines or materials requiring a change 
in one table. 

 Export the data within a single VPE machine or material folder to a .csv file, edit 
the data in Excel, then import the data back into the VPE. This approach is 
efficient if you are editing a single machine or material table. 

 Export all the data in a VPE to a set of Excel spreadsheets, where you can edit 
the data and then re-import it. This is useful if you need to edit a large amount of 
data across multiple process groups. 

Note: Do NOT edit the Cost Model Version without the support of aPriori Professional 
Services or aPriori Support. Editing the version changes the VPE’s process and 
cost logic and may change the behavior of your specific VPE (that is, changing 
the cost model version can modify the VPE configurations and cost model 
extensions made by your organization). 

To edit individual data fields 

1 Navigate to the display of a single page of information. 

 

2 Edit values as necessary within the data fields shown in the Data pane.  
As you edit, an asterisk (*) appears next to the file in the Navigation pane and next to 
the row to indicate that there are unsaved changes. 

3 Select File > Publish VPE from the VPE Manager menu bar or click  in the 
toolbar to save your changes. 

To edit data in tables 

1 Navigate to the display of a table of information. 
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2 Double-click non-gray cells in the table displayed in the Data pane to edit the values 
in those cells. 
As you edit, an asterisk (*) appears next to the file in the Navigation pane and next to 
the row to indicate that there are unsaved changes. 
When editing data in a table, you can: 

• Hover in the upper left corner of the table to display icons  that allow 
you to expand, collapse, and resize columns. 

• Click  in the column header to expand the column and display its sub-
columns. Click  to collapse the sub-columns. 

• Click a column header to sort the table by that column. Click again to reverse 
the sort. 

3 Select File > Publish VPE from the VPE Manager menu bar or click  in the 
toolbar to save your changes. 



 

aPriori Version 2019 R2 aPriori Confidential 63 

To edit by exporting individual tables to .csv files 

1 Navigate to a machine or materials table. 

 

2 Right-click the folder in the Navigation pane and select Export > <table_name> 
from the context menu. 

3 In the resulting Select a File to Export window, navigate to the folder where you want to 
save the .csv file, specify a name, and click Save.  

4 Open the exported .csv file in Microsoft Excel. 

5 Edit the values in Excel. 
The Name field in material and machine tables cannot be changed because it is the 
primary ID for the table. If you do edit this field, it will create a new machine, material 
type, or material stock and leave the original one as is when you import the data into 
the aPriori VPE Manager. 
You must delete items from within the VPE Manager. They cannot be deleted in 
Excel. For more information, see Deleting machine and material data from a VPE on 
page 64. 

6 Save the edited file as a .csv file in Excel. 

7 Right-click the folder you selected in step 1 and select Import from the context menu 
to display the Select File to Import window. 

8 Select the edited .csv file and click Open to update all the data within the folder with 
the edited data and display the details of the import in the Import Summary window. 
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9 Click OK to close the Import Summary window. 

10 Select File > Publish VPE from the VPE Manager menu bar or click  in the 
toolbar to save your changes. 

To edit by exporting data to Excel 
aPriori's powerful Excel export/import capabilities are covered in the following sections: 

 To export VPE Data to Excel 

 To export VPE Lookup Tables to Excel 

 To Import VPE Data from Excel 

 To Import VPE Lookup Tables from Excel 

Deleting machine and material data from a VPE 
Delete machine and material data from a VPE when your facility does not have that 
machine or use that material. You can delete machine and material data from the 
Navigation pane or from the Data pane. If you need to delete multiple items, use the 
Data pane. 

To delete a machine, material type, or material stock from the Navigation pane 

1 Right-click the machine, material type, or material stock you want to delete and 
select one of the following from the context menu to display the Delete Material 
window: 

• Delete machine  
• Delete Material  
• Delete Material Stock  

2 Click OK to delete the machine, material type, or material stock. 

3 Select File > Publish VPE from the VPE Manager menu bar or click  in the 
toolbar to save your changes. 

To delete a machine, material type, or material stock from the Data pane 

1 Select one of the following in the Navigation pane: 
• Machine type folder 
• Materials folder 
• Material type folder 

2 Right-click a row in the table in the Data pane and select Delete Rows from the 
context menu to delete the machine, material type, or material stock. 
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To delete multiple machines, material types, or material stocks, Ctrl+click each row 
that you want to delete, then right-click one of the selected rows and select Delete 
Rows from the context menu. 
If you attempt to delete the machine currently specified as the default machine for a 
process, you must select a new default machine. If you do not select a default 
machine, no rows will be deleted. 

Removing tool shops from a VPE 

1 From the VPE Manager, click Tools > Remove Tool Shops. 

2 Follow the embedded “Key Usage Notes” to navigate through the VPE, process 
group, and available processes to find and select the tool shop you wish to remove.  

3 Select OK when done. 

4 Publish the modified VPE. 

Working with wage grades 
Wage grades help you manage the labor rates associated with the various machines in 
a process group. If you assign the same wage grade to multiple machines, you can 
change the labor rate associated with those machines all at once, by changing the labor 
rate associated with the assigned wage grade. This means that instead of making a 
change to the Labor Rate field for every machine, you can make one change to the Labor 
Rate field of the assigned wage grade. 
Working with wage grades involves working with the following types of tables: 

 Skill Levels: each VPE has one Skill Levels table, which contains definitions of skill 
levels. Each wage grade associates a skill level and a process type (such as 
Metals or Plastics) with a labor rate. Each skill level is identified by a positive 
integer, and optionally has a name and description. 
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Starting point VPEs include some predefined skill levels. You can use the Skill 
Levels table to edit, add, and delete skill levels. See Managing skill levels. 

 Wage Grades: each VPE has one Wage Grades table, which contains definitions of 
wage grades. Each wage grade is identified by a skill level and a process type 
(no two wage grades can have both the same skill level and the same process 
type). Each wage grade also has an associated labor rate, which you can change 
as needed. 

 
Starting point VPEs include some predefined wage grades. You can use the 
Wage Grades table to modify, add, and delete wage grades. See Managing 
wage grades. 

 Wage Grade Associations: each process group has one Wage Grade Associations 
table, which associates machines with wage grades.  
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Starting point VPEs have predefined wage grade associations that vary by 
process, but for machines within a process are always the same. You can use 
the Wage Grade Association table to modify these associations. You can also 
manage wage grade associations with the machine table for a process, or with 
the machine property Wage Grade Name for a specific machine. See Managing 
wage grade associations. 

You can generate a Wage Grades report by selecting File > Export > Wage Grades. This 
report is an Excel file with one row for each machine in the VPE, grouped by process 
group and process; it displays Labor Rate, Skill Level, and Wage Grade field values for each 
machine. When you are ready to update your VPEs to use wage grades rather than 
labor rates for individual machines, you can use this report to review the spectrum of 
labor rates assigned to different processes and machines within a given process. You 
can even convert the report to a pivot table using standard functionality in Microsoft 
Excel, to help analyze the data. This can help you to determine how many wage grades 
should be established, and which wage grade should be associated with each process 
or machine. 
You also can use this report to determine if a machine has a labor rate or wage grade 
specified in its machine field or if it is inheriting a labor wage grade association specified 
at the process level. If the labor rate or wage grade is specified for an individual 
machine, the Labor Rate, Skill Level, and/or Wage Grade columns will be populated in 
the row for that machine. If the machine is inheriting its values from the wage grade 
association at the process level, those fields will be blank. 

Managing skill levels 
You manage skill levels for a VPE with the Skill Levels table. 

To view the Skill Levels table 
Click Skill Levels in the navigation pane of the VPE Manager. 
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The Skill Levels table appears: 

 
Each row of the table defines a skill level. 

To edit a skill level 

1 For each cell of the Skill Levels table that you want to edit, double click inside the 
cell, and modify the text. 

2 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar.  

To add a skill level 

1 Right click a row of the Skill Levels table, and select Add new Skill Level… 
The New Skill Level dialog appears: 

 

2 Enter a positive integer in the Skill Level field. Do not enter a number that already 
appears in the Skill Level column of the table. Optionally, add text to the Skill Name and 
Skill Description fields. 

3 Click OK. The new row appears in the table. 



 

aPriori Version 2019 R2 aPriori Confidential 69 

4 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

To delete a skill level 

1 Right click a row of the Skill Levels table and select Delete Rows.  

2 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

To delete multiple skill levels 

1 Select multiple rows by clicking a row and ctrl-clicking additional rows. Alternatively, 
select a range of rows by clicking the row at the beginning of the range and shift-
clicking the row at the end of the range. 

2 Right click one of the selected rows and select Delete Rows. 

3 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

Managing wage grades 
You manage wage grades for a VPE with the Wage Grades table. 

To view the Wage Grades table 
Click Wage Grades in the navigation pane of the VPE Manager. 
The Wage Grades table appears: 
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Each row of the table represents a wage grade. 

To edit a wage grade 

1 For each cell of the Wage Grades table that you want to edit, double click inside the 
cell, and modify the text.  
You can edit the Labor Rate and Process Type fields. You cannot edit the Skill Level and 
Wage Grade fields. 

2 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar.  

To add a wage grade 

1 Right click a row of the Wage Grade table, and select Add new Wage Grade… 
The New Wage Garde dialog appears: 
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2 Enter a non-negative integer in the Labor Rate field. 

3 Click the Skill Level field and select a skill level. 

4 Optionally, enter a process type in the Process Type field.  

5 Ensure that no other wage grade has the same values matches the contents of both 
the Skill Level field and Process Type field.  

6 Click OK. The new row appears in the table. 

7 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

To delete a wage grade 

1 Right click a row of the Wage Grades table and select Delete Rows.  

2 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

To delete multiple wage grades 

1 Select multiple rows by clicking a row and ctrl-clicking additional rows. Alternatively, 
select a range of rows by clicking the row at the beginning of the range and shift-
clicking the row at the end of the range. 

2 Right click one of the selected rows and select Delete Rows. 

3 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

Managing wage grade associations 
You manage wage grade associations for a process group with the Wage Grade 
Associations table. The table allows you to assign a wage grade to a process (and 
thereby assign that wage grade to all the machines for the process) or assign a wage 
grade to an individual machine. 
Alternatively, you manage wage grade associations with the machine table for a process 
or with the Wage Grade Name machine property for an individual machine. 
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To view the Wage Grade Associations table 
In the navigation pane of the VPE Manager, expand the process group whose table you 
want to view, and click Wage Grade Associations. 
The process group’s Wage Grade Associations table appears: 

 

To assign a wage grade to a process 

1 In the Wage Grade Associations table, select the process to which you want to 
assign a wage grade. Assigning a wage grade to a process effectively assigns  

2 Double click the cell in the Wage Grade Name column for the selected row and select 
the desired wage grade from the dropdown menu. 
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3 In the machine table for the selected process, right click anywhere in the Labor Rate 
column, and select Clear Labor Rate Overrides. 

 

4 Click OK in the Clear Labor Rates Overrides dialog. aPriori updates the Labor Rate 
field for every machine of the selected process. 

5 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

To assign a wage grade to a machine 
Note that this is only necessary if you want a machine to have a different wage grade 
from the one established for the Process. 

1 In the Process Name column of the Wage Grade Associations table, expand the 
process for the machine to which you want to assign a wage grade. 
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2 Select the machine to which you want to assign a wage grade. 

3 Double click the cell in the Wage Grade Name column for the selected row and select 
the desired wage grade from the dropdown menu. 

 

4 When you are done assigning wage grades to machines of the process, right click 
anywhere in the Labor Rate column of the process’s machine table, select Clear Labor 
Rate Overrides. 

 

5 Click OK in the Clear Labor Rates Overrides dialog. aPriori updates the Labor Rate 
field for every machine to which you assigned a wage grade. 
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6 When you are done editing the table, select Publish VPE from the File menu or click 
the Publish icon in the toolbar. 

Note that you can also assign a wage grade to a machine by selecting the machine in 
the navigation pane and editing the machine’s Wage Grade Name field. 

 
You can also assign a wage grade to a machine by editing the machine’s Wage Grade 
Name field in the machine table for the machine’s process group.  

 
In either case, aPriori updates the Labor Rate field once you have cleared Labor Rate 
overrides. (Note that is only necessary to Clear Labor Rate Overrides once per machine 
table.) 

Managing VPE cut code data 
This section describes how to assign cut codes or add user-defined cut codes and 
provides several tables of reference data. 
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Assigning material cut codes 
aPriori requires that each material be assigned a cut code when it is added to a VPE. A 
material's cut code characterizes the machinability of a material and is adapted from the 
Sandvik Cormorant cutability classification (CMC code) scheme for metals. Different 
materials that machine similarly are assigned the same cut code. For example, both 
Inconel and Hastelloy are assigned a cut code of 20.21, as they are both nickel-based, 
heat resistant super-alloys.  
aPriori uses the cut code to determine the appropriate cutting speed and feed rates for 
various machining operations, which affects the resulting machining process cycle time, 
and therefore, the cost of the part.  
In some cases, you may want to assign a user-defined cut code instead of a CMC code. 
Consider, for example, two materials that are assigned the same CMC code, and 
suppose that you want aPriori to use different cutting speeds or feed rates for each one. 
In this case, you can assign one of the materials a user-defined cut code and enter 
custom speed and feed data for that cut code into the appropriate lookup table. See 
Adding a user-defined cut code on page 77. 
If you are not familiar with the Sandvik Cormorant CMC code scheme, you can use this 
section to help you determine the appropriate cut code for a given material. This section 
contains the following tables: 

 Cut codes reference listing for metals – Defined by Sandvik Coromant for metals  
 Cut codes reference listing for plastics – Because Sandvik Coromant does not 

define cut codes for plastics, aPriori assigns unique cut code values using a 
similar numbering system  

 Cut code by metallurgical category –If you know the metallurgical category, 
match it to a range of cut codes, and then further refine the cut code by using the 
Cut codes by example material and Brinell Hardness values table 

 Cut codes by example metal material and Brinell Hardness value – If you know 
the material type and hardness, you can find a similar example material in this 
table to determine the cut code. Examples listed are for U.S. standards 
(AISI/SAE). You can find similar tables in other guides for Great Britain, Sweden, 
Germany, France, Italy, Spain, and Japan. 

 Cut codes by example plastic material – If you know the plastic material type, you 
can find a similar example material in this table to determine the cut code. 

 Cut codes by material trade name – If you know the trade name of the material, 
you may find it in this table, although it contains only a small fraction of existing 
trade names. 

 Cut codes with recommended feeds and speeds – Recommended speed and 
feed data for both carbide and high-speed steel tools (for drilling with a 1.0” 
diameter tool). If you know the speed and feed for a material, you can find the 
corresponding cut code in this table. (aPriori allows you to override the feed and 
speed for most machining operations if only speed or feed matches the known 
value.) 
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 Cut codes with recommended feeds and speeds, relative to mild steel – 
Recommended speed and feed ratios relative to unalloyed low carbon steel (cut 
code 1.1). If you know the feed and speed for the material relative to mild steel, 
you can find the corresponding cut code in this table.  

The data in the tables comes from the following sources: 
 Machining Data Handbook, Vol. 1, 3rd Edition 
 Machining Data Handbook, Vol. 2, 3rd Edition 
 Sandvik Coromant (Metric) Rotating Tools, 2002 
 Sandvik Coromant (Metric) Turning Tools, 2002 

Adding a user-defined cut code 
Follow these steps to add a new, user-defined cut code and assign it to a material type: 

1 Create a new material type and its stocks (see Adding machine and material data on 
page 51). If the material type already exists in aPriori (but with a CMC code instead 
of a user-defined cut code), delete it (see Deleting machine and material data from a 
VPE on page 64) and create a new material type with a user-defined cut code.  
When you create the material type, specify a cut code that is between 90.01 and 
90.99 (inclusive). 

2 Use Excel to create rows of cutting data for the new cut code. The cutting data for 
milling (in the lookup table tblMilling), for example, includes a row for each unique 
combination of cut code, tool series, and tool diameter; and each such row includes 
data for cutting speed, number of tool teeth, feed per tooth, tool life, and tool cost, 
among others. 

3 Add the rows to the appropriate lookup table (for example, to tblMilling). See Editing 
VPE data on page 60. 

4 If you subsequently add a new material type with the same associated cutting 
practices, you can assign it the same user-defined cut code. You do not need to re-
enter the cutting data. 

Cut code reference listing for metals 
Cut code Description 
1.0 Steel: Unalloyed, C = 0.05 - 0.10% 
1.1 Steel: Unalloyed, C = 0.10 - 0.25% 
1.2 Steel: Unalloyed, C = 0.25 - 0.55% 
1.3 Steel: Unalloyed, C = 0.55 - 0.80% 
1.4 Steel: Unalloyed, high carbon & carbon tool steel 
1.5 Steel: Unalloyed, hardened and tempered 
2.1 Steel: Low-alloyed, non-hardened 
2.12 Steel: Low-alloyed, ball bearing steel 
2.2 Steel: Low-alloyed, hardened and tempered 
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Cut code Description 
3.1 Steel: High-alloyed, annealed 
3.11 Steel: High-alloyed, annealed 
3.13 Steel: High-alloyed, hardened tool steel 
3.2 Steel: High-alloyed, hardened 
3.21 Steel: High-alloyed, hardened tool steel 
3.22 Steel: High alloyed, hardened steel; others 
4.0 Hard Steel: Hardened steel 
4.1 Extra Hard Steel, hardened and tempered 
5.1 Stainless Steel - bars/forged: Ferritic/martensitic 
5.11 Stainless Steel - bars/forged: Ferritic/martensitic, non-hardened 
5.12 Stainless Steel - bars/forged: Ferritic/martensitic, PH-hardened 
5.13 Stainless Steel - bars/forged: Ferritic/martensitic, hardened 
5.2 Stainless Steel - bars/forged: Austenitic 
5.21 Stainless Steel - bars/forged: Austenitic, non-hardened 
5.22 Stainless Steel - bars/forged: Austenitic, PH-hardened 
5.23 Stainless Steel - bars/forged: Austenitic, super austenitic 

5.51 Stainless Steel - bars/forged: Austenitic-ferritic (Duplex), non-weldable > 
0.05%C 

5.52 Stainless Steel - bars/forged: Austenitic-ferritic (Duplex), weldable < 
0.05%C 

6.1 Steel Castings: Unalloyed 
6.2 Steel Castings: Low alloy (alloying elements < 5%) 
6.3 Steel Castings: High alloy (alloying elements > 5%) 
6.32 Castings: Stainless austenitic 
6.33 Castings: Manganese steel, 12-14% 
7.1 Malleable Cast Iron: Ferritic (short chipping) 
7.2 Malleable Cast Iron: Pearlitic (long chipping) 
7.3 Malleable Cast Iron: Martensitic 
8.1 Grey Cast Iron: Low tensile strength 
8.2 Grey Cast Iron: High tensile strength 
8.3 Grey Cast Iron: Austenitic 
9.1 Nodular SG Iron: Ferritic 
9.2 Nodular SG Iron: Pearlitic 
9.3 Nodular SG Iron: Martensitic 
10.0 Chilled Cast Iron 
10.1 Chilled Cast Iron: Cast or cast and aged 
15.11 Stainless Steel - cast: Ferritic/martensitic, non-hardened 
15.12 Stainless Steel - cast: Ferritic/martensitic, PH-hardened 
15.13 Stainless Steel - cast: Ferritic/martensitic, hardened 
15.21 Stainless Steel - cast: Austenitic 
15.22 Stainless Steel - cast: Austenitic, PH-hardened 
15.23 Stainless Steel - cast: Austenitic, super austenitic 

15.51 Stainless Steel - cast: Austenitic-ferritic (Duplex), non-weldable > 
0.05%C 

15.52 Stainless Steel - cast: Austenitic-ferritic (Duplex), weldable < 0.05%C 
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Cut code Description 
20.11 Heat Resistant Super Alloys: Iron base, annealed or solution treated 

20.12 Heat Resistant Super Alloys: Iron base, aged or solution treated and 
aged 

20.2 Obsolete 
20.21 Heat Resistant Super Alloys: Nickel base, annealed or solution treated 

20.22 Heat Resistant Super Alloys: Nickel base, aged or solution treated and 
aged 

20.23 Heat Resistant Super Alloys: Nickel base, cold drawn 
20.24 Heat Resistant Super Alloys: Nickel base, cast or cast and aged 
20.25 Obsolete 
20.26 Obsolete 
20.27 Obsolete 
20.28 Obsolete 
20.3 Obsolete 
20.31 Heat Resistant Super Alloys: Cobalt base, annealed or solution treated 

20.32 Heat Resistant Super Alloys: Cobalt base, aged or solution treated and 
aged 

20.33 Heat Resistant Super Alloys: Cobalt base, cast or cast and aged 

23.1 Heat Resistant Super Alloys: Titanium alloys, commercial pure (99.5% 
Ti) 

23.21 Heat Resistant Super Alloys: Titanium alloys, a, near a and a + b alloys, 
annealed 

23.22 Heat Resistant Super Alloys: Titanium alloys, a + b alloys in aged 
condition, b alloys, annealed 

30.11 Aluminum Alloys: Wrought or wrought and coldworked, non-aging 
30.12 Aluminum Alloys: Wrought or wrought and aged 
30.21 Aluminum Alloys: Cast, non-aging 
30.22 Aluminum Alloys: Cast or cast and aged 
30.3 Aluminum Alloys: Al > 99% 
30.41 Aluminum Alloys: Cast, 13 - 15% Si 
30.42 Aluminum Alloys: Cast, 16 - 22% Si 
33.1 Copper and Copper Alloys: Free cutting alloys, > 1% Pb 
33.2 Copper and Copper Alloys: Brass, leaded bronzes, < 1% Pb 

33.3 Copper and Copper Alloys: Bronze and non-leaded copper including 
electrolytic copper 

Cut code reference listing for plastics 
Cut code Description 
41.11 Glass Filled Thermoplastic, Low Speed 
41.21 Glass Filled Thermoplastic, Medium Speed 
42.11 Glass Filled Thermoset, Low Speed 
42.12 Glass Filled Thermoset, Low Speed 
42.13 Glass Filled Thermoset, Low Speed 
51.21 Unfilled Thermoplastic, Medium Speed 
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51.22 Unfilled Thermoplastic, Medium Speed 
51.31 Unfilled Thermoplastic, High Speed 
51.32 Unfilled Thermoplastic, High Speed 
52.11 Unfilled Thermoset, Low Speed 
52.12 Unfilled Thermoset, Low Speed 
52.13 Unfilled Thermoset, Low Speed 
52.14 Unfilled Thermoset, Low Speed 
52.15 Unfilled Thermoset, Low Speed 
52.21 Unfilled Thermoset, Medium Speed 
52.31 Unfilled Thermoset, High Speed 
52.32 Unfilled Thermoset, High Speed 

Cut codes by metallurgical category 
Metallurgical category Cut code 
Carbon Steels, Wrought - Low Carbon 1.0 
Carbon Steels, Wrought - Low Carbon 1.1 
Carbon Steels, Wrought - Medium Carbon 1.2 
Carbon Steels, Wrought - Medium Carbon 1.3 
Carbon Steels, Wrought - High Carbon 1.4 
Carbon Steels, Wrought - Medium Carbon 1.5 
Free Machining Alloy Steels, Wrought - Medium and High Carbon 
Leaded 2.1 

Free Machining Alloy Steels, Wrought - Medium and High Carbon 
Leaded 2.12 

Free Machining Alloy Steels, Wrought - Medium and High Carbon 
Leaded 2.2 

Tool Steels, Wrought - Hot Work 3.1 
Tool Steels, Wrought - Hot Work 3.11 
Tool Steels, Wrought - High Speed 3.13 
Tool Steels, Wrought - Hot Work 3.2 
Tool Steels, Wrought - Hot Work 3.21 
Tool Steels, Wrought - Hot Work 3.22 
Stainless Steels, Wrought - Martensitic 4.0 
Stainless Steels, Wrought - Martensitic 4.1 
Stainless Steels, Wrought - Martensitic 5.1 
Stainless Steels, Wrought - Martensitic 5.11 
Precipitation Hardening Stainless Steels, Wrought 5.12 
Stainless Steels, Wrought - Martensitic 5.13 
Stainless Steels, Wrought - Austenitic 5.2 
Stainless Steels, Wrought - Austenitic 5.21 
Precipitation Hardening Stainless Steels, Wrought 5.22 
Stainless Steels, Wrought - Austenitic 5.23 
Stainless Steels, Wrought - Ferritic 5.51 
Stainless Steels, Wrought - Ferritic 5.52 
Carbon Steels, Cast - Low Carbon 6.1 
Alloy Steels, Cast - Low Carbon 6.2 
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Metallurgical category Cut code 
Alloy Steels, Cast - Low Carbon 6.3 
Stainless Steels, Cast - Austenitic 6.32 
Manganese, Wrought 6.33 
Malleable Cast Irons 7.1 
Malleable Cast Irons 7.2 
Malleable Cast Irons 7.3 
Gray Cast Irons - Pearlitic - Ferritic 8.1 
Gray Cast Irons - Pearlitic + Free Carbide 8.2 
Gray Cast Irons - Austenitic (Ni - Resist) 8.3 
Ductile Cast Irons - Ferritic 9.1 
Ductile Cast Irons - Pearlitic-Martensitic 9.2 
Ductile Cast Irons - Martensitic 9.3 
White Cast Irons (Abrasion Resistant) - Annealed 10.0 
White Cast Irons (Abrasion Resistant) - Annealed 10.1 
Stainless Steels, Cast - Martensitic 15.11 
Precipitation Hardening Stainless Steels, Cast 15.12 
Precipitation Hardening Stainless Steels, Cast 15.13 
Stainless Steels, Cast - Austenitic 15.21 
Precipitation Hardening Stainless Steels, Cast 15.22 
Stainless Steels, Cast - Austenitic 15.23 
Stainless Steels, Cast - Ferritic 15.51 
Stainless Steels, Cast - Ferritic 15.52 
High Temperature Alloys, Wrought and Cast - Iron Base, Wrought 20.11 
High Temperature Alloys, Wrought and Cast - Iron Base, Wrought 20.12 
High Temperature Alloys, Wrought and Cast - Nickel Base, Wrought 20.21 
High Temperature Alloys, Wrought and Cast - Nickel Base, Wrought 20.22 
High Temperature Alloys, Wrought and Cast - Nickel Base, Wrought 20.23 
High Temperature Alloys, Wrought and Cast - Nickel Base, Cast 20.24 
High Temperature Alloys, Wrought and Cast - Cobalt Base, Wrought 20.31 
High Temperature Alloys, Wrought and Cast - Cobalt Base, Wrought 20.32 
High Temperature Alloys, Wrought and Cast - Cobalt Base, Cast 20.33 
Titanium Alloys, Wrought - Commercially Pure 23.1 
Titanium Alloys, Wrought - Alpha and Alpha-Beta Alloys 23.21 
Titanium Alloys, Wrought - Alpha and Alpha-Beta Alloys 23.22 
Aluminum Alloys, Wrought 30.11 
Aluminum Alloys, Wrought 30.12 
Aluminum Alloys, Cast - Die Castings 30.21 
Aluminum Alloys, Cast - Die Castings 30.22 
Aluminum Alloys, Cast - Die Castings 30.3 
Aluminum Alloys, Cast - Sand and Permanent Mold 30.41 
Aluminum Alloys, Cast - Die Castings 30.42 
Copper Alloys, Cast 33.1 
Copper Alloys, Cast 33.2 
Copper Alloys, Cast 33.3 
Plastics, Thermoplastics - Filled and Molded 41.11 
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Metallurgical category Cut code 
Plastics, Thermoplastics - Filled and Molded 41.21 
Plastics, Thermosetting Plastics - Filled and Molded 42.11 
Plastics, Thermosetting Plastics - Filled and Molded 42.12 
Plastics, Thermosetting Plastics - Filled and Molded 42.13 
Plastics, Thermoplastics - Cast, Molded, or Extruded 51.21 
Plastics, Thermoplastics - Molded or Extruded 51.22 
Plastics, Thermoplastics - Cast, Molded, or Extruded 51.31 
Plastics, Thermoplastics - Molded or Extruded 51.32 
Plastics, Thermosetting Plastics - Cast or Molded 52.11 
Plastics, Thermosetting Plastics - Cast 52.12 
Plastics, Thermosetting Plastics – Cast 52.13 
Plastics, Thermosetting Plastics - Filled and Molded 52.14 
Plastics, Thermosetting Plastics - Cast 52.15 
Plastics, Thermosetting Plastics - Cast 52.21 
Plastics, Thermosetting Plastics - Cast or Molded 52.31 
Plastics, Thermosetting Plastics - Molded or Extruded 52.32 

Cut codes by example metal material and Brinell Hardness 
values 

Example metal materials Hardness Cut 
code 

U.S. - 1005, 1006, 1008, 1009, 1010, 1012, 1015, 1017, 
1020, 1023, 1025 125 HB 1.0 

U.S - 1005, 1006, 1008, 1009, 1010, 1012, 1015, 1017, 
1020, 1023, 1025, A570.36, 1115, A573-81 65, 1015, 1020, 
1213, 12L13, 1215, 12L14, 1025, A572-60 
DIN - 17100, 1.0144 CR, 1.0144 HR, 1.0402 CR, 1.0402 HR, 
1.1121 CR, 1.1121 HR, 10025-5 CR, 10142 HR, 10273 HR, 
1626 HR, 1652-3 CR, 1652-3 HR, 17100 HR, 17103 CR, 
59231 HR 
EN - 10210-1, 10025-2 CR, 10025-2 HR, 10083-2 CR, 
10083-2 HR, 10132-2 CR, 10132-2 HR, 10017 CR, 10277-2 
HR, 10060 HR, 10210 HR, 10084 CR, 10278 HR, 10210-1 
HR, 10250-2 CR, 10025/2-2004 HR 

125 HB 1.1 

U.S - 1005, 1006, 1008, 1009, 1010, 1012, 1015, 1017, 
1020, 1023, 1025, A570.36, 1115, A573-81 65, 1015, 1020, 
1213, 12L13, 1215, 12L14, 1025, A572-60, 59231 HR, 
10142 HR, 1626 HR, 1652-3 CR, 10025-5 CR, 1652-4 CR, 
1652-3 HR, 10273 HR, 1652-4 HR, 17100 HR, 10025/2-2004 
HR, 10277-2 HR, 10210 HR, 10278 CR, 10017 CR, 10025-2 
CR, 10278 HR, 10060 HR, 10083-2 HR, 10210-1 HR, 1652-3 
CR, 17103 CR, 1652-4 CR, 10084 CR, 10250-2 CR, 10025-2 
CR, 59231 HR, 10142 HR, 1626 HR, 1.1121 CR, 1.0144 CR, 
1.0402 CR, 1.1121 HR, 1.0144 HR, 1.0402 HR, 10025/2-

150 HB 1.2 
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Example metal materials Hardness Cut 
code 

2004 HR, 10277-2 HR, 10210 HR, 10132-2 CR, 10025-2 CR, 
10083-2 CR, 10132-2 HR, 10025-2 HR, 10083-2 HR 
U.S. - 1030, 1033, 1035, 1037, 1038, 1039, 1040, 1042, 
1043, 1044, 1045, 1046, 1049, 1050, 1053, 1055, 1525, 
1526, 1527, 1060 

170 HB 1.3 

U.S - 1060, 1064, 1065, 1069, 1070, 1074, 1075, 1078, 
1080, 1084, 1085, 1086, 1090, 1095, 1561, 1566, 1572, 
1095, W1, W210 

210 HB 1.4 

U.S. - 1524, 1536, 1541, 1547, 1548, 1551, 1552 300 HB 1.5 
U.S. - 41L30, 41L40, 41L45, 41L47, 41L50, 43L40, 51L32, 
52L100, 86L20, 86L40, A573-81, 5120, 9255, 9262, 52100, 
ASTM A204Gr.A, 4520, ASTM A350LF5, 8620, 8740, 5015, 
5140, 5155, ASTM A182, F11, F12, F22, L1, 8620, L6 

180 HB 2.1 

U.S. - 41L30, 41L40, 41L45, 41L47, 41L50, 43L40, 51L32, 
52L100, 86L20, 86L40 210 HB 2.12 

U.S. - 41L30, 41L40, 41L45, 41L47, 41L50, 43L40, 51L32, 
52L100, 86L20, 86L40, 3135, 3415, 3310, 9255, 4130 330 HB 2.2 

U.S. - H10, H11, H12, H13, H14, H19 200 HB 3.1 
U.S. - H10, H11, H12, H13, H14, H19, ASTM A353, 2515, 
D3, H13, A2, S1, H21, HW3 200 HB 3.11 

U.S. - M1, M2, M6, M10, T1, T2, T6, M 2, M 35, M 7 200 HB 3.13 
U.S. - H10, H11, H12, H13, H14, H19 225 HB 3.2 
U.S. - H10, H11, H12, H13, H14, H19, HNV3 300 HB 3.21 
U.S. - H10, H11, H12, H13, H14, H19 380 HB 3.22 
U.S. - 440A, 440B, 440C 55 HRc 4.0 
U.S. - 440A, 440B, 440C, 610, 0-2 59 HRc 4.1 
U.S. - 403, 410, 420, 422, 501, 502 200 HB 5.1 
U.S. - 403, 410, 420, 422, 501, 502, 403, 416, 430, 410, 405, 
420, 431, 431F, 434, CA6-NM, 405, HNV6, 446, EV8, 
S44400 

200 HB 5.11 

U.S. - 15-5 PH, 16-6 PH, 17-4 PH, 17-7 PH, 17-14 Cu Mo, 
AF-71, AFC-77, Almar 362 (AM-362), AM-350, AM-355, AM-
363, Custom 450, Custom 455, HNM, PH 13-8 Mo, PH 14-8 
Mo, PH 15-7 Mo, Stainless W, 630, 17-4 PH 

330 HB 5.12 

U.S. - 403, 410, 420, 422, 501, 502 330 HB 5.13 
U.S. - 201, 202, 301, 302, 304, 304L, 305, 308, 321, 347, 
348, 384, 385, 302B, 309, 309S, 310, 310S, 314, 316, 316L, 
317, 330 
 

175 HB 5.2 

U.S. - 201, 202, 301, 302, 304, 304L, 305, 308, 321, 347, 
348, 384, 385, 302B, 309, 309S, 310, 310S, 314, 316, 316L, 
317, 330, 304L, 304, 303, 301, 304LN 316, 316LN, 316L, 
317L, UNS V 0890A, 321, 347, 316 Ti, 318, 309, 310S, 308, 
4133, 2528, 17456, 10272, 10088-3, 10216-5, 17440, 
1.4305, 1.4305, 1.4301, 1.4401, 1.4436, 58M, 10088-1, 

200 HB 5.21 
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Example metal materials Hardness Cut 
code 

10222-5, 10269, 1.4301, 17441, 1.4404, 10028-7, 10088-7, 
10088-2, 1.4301, 17441, 1.4404, 10028-7, 10088-7, 10088-2 
DIN - 1.4301, 1.4305, 1.4401, 1.4404, 1.4436, 2528, 4133, 
17440, 17441, 17456 
EN - 10028-7, 58M, 10222-5, 10088-2, 10269, 10088-3, 
10272, 1.4305, 10088-7, 10216-5 
U.S. - 15-5 PH, 16-6 PH, 17-4 PH, 17-7 PH, 17-14 Cu Mo, 
AF-71, AFC-77, Almar 362 (AM-362), AM-350, AM-355, AM-
363, Custom 450, Custom 455, HNM, PH 13-8 Mo, PH 14-8 
Mo, PH 15-7 Mo, Stainless W 

330 HB 5.22 

U.S. - Nitronic 32, Nitronic 33, Nitronic 40, Nitronic 50, 
Nitronic 60, NO8028, S31254 200 HB 5.23 

U.S. - 405, 409, 429, 430, 434, 436, 442, 446, S31500, 
S32900 230 HB 5.51 

U.S. - 405, 409, 429, 430, 434, 436, 442, 446, S32304, 
S31803 260 HB 5.52 

U.S. - ASTM A426: Grade CP1; 1010, 1020 
DIN - 1681 GS52 
EN - 10293 

150 HB 6.1 

U.S. - ASTM A217: Grade WC9; ASTM A352: Grades LC3, 
LC4; ASTM A426: Grades CP2, CP5, CP5b, CP11, CP12, 
CP15, CP21, CP22; 1320, 2315, 2320, 4110, 4120, 4320, 
8020, 8620 

200 HB 6.2 

U.S. - ASTM A217: Grade WC9; ASTM A352: Grades LC3, 
LC4; ASTM A426: Grades CP2, CP5, CP5b, CP11, CP12, 
CP15, CP21, CP22; 1320, 2315, 2320, 4110, 4120, 4320, 
8020, 8620 
DIN - 17155 
EN - 10213 

200 HB 6.3 

U.S. - ASTM A297: Grades HD, HE, HF, HH, HI, HK, HL, 
HN, HP, HT, HU; ASTM A608: Grades HD50, HE35, HF30, 
HH30, HH33, HI35, HK30, HK40, HL30, HL40, HN40, HT50, 
HU50 

200 HB 6.32 

- 250 HB 6.33 
U.S. - ASTM A47:Grades 32510, 35018; ASTM A602: Grade 
M3210; SAE J158: Grade M3210, L3 130 HB 7.1 

U.S. - ASTM A220: Grades 40010, 45006, 45008, 50005; 
ASTM A602: Grade M4504, M5003; SAE J158: Grades 
M4504, M5003, 32510 
DIN - 1693 GGG-40 
EN - GJS-400 

230 HB 7.2 

U.S. - ASTM A220: Grade 80002; ASTM A602: Grade 
M8501; SAE J158: Grade M8501, 40010, 50005, 70003, 
A220-70003 

250 HB 7.3 
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Example metal materials Hardness Cut 
code 

U.S. - ASTM A48: Class 25; SAE J431c: Grade G2500, 
A220-80002 
DIN - 1691 GG, 1561 GG-10 
EN - GJL-100, 1561 

180 HB 8.1 

U.S. - ASTM A48: Classes 45, 50; SAE J431c: Grades 
G3500, G4000, No 20 B, No 25 B, No 30 B 220 HB 8.2 

U.S. - ASTM A436: Types 2, 3, 6; ASTM A436: Types 2b, 4, 
No 35 B, No 40 B, No 45 B, No 50 B, No 55 B 
 

175 HB 8.3 

U.S. - ASTM A536: Grades 60-40-18, 65-45-12; SAE J434c: 
Grades D4018, D4512, A436 Type 2 160 HB 9.1 

U.S. - ASTM A536: Grade 100-70-03; SAE J434c: Grade 
D7003, 60-4018, 80-55-06, A43D2 250 HB 9.2 

U.S. - ASTM A536: Grade 120-90-02; SAE J434c: Grade 
DQ&T, 100-70-03 330 HB 9.3 

U.S. - ASTM A532: Class I, Type D; Class II, Types A, B, C, 
D, E; Class III, Type A 400 HB 10.0 

U.S. - ASTM A532: Class I, Type D; Class II, Types A, B, C, 
D, E; Class III, Type A 400 HB 10.1 

U.S. - ASTM A217: Grade CA-15; ASTM A296: Grades CA-
15, CA-15M, CA-40; ASTM A426: Grades CP7, CP9, 
CPCA15; ASTM A487: Classes CA15a, CA-15M 

200 HB 15.11 

U.S. - ASTM A351: Grade CD-4MCu; ACI Grade CB-7Cu; 
ACI Grade CD-4MCu; 17-4 PH; AM-355, 403, 416, 430, 410, 
405, 420, 431, 431F, 434, CA6-NM, 405, HNV6, 446, EV8, 
S44400 

330 HB 15.12 

U.S. - ASTM A351: Grade CD-4MCu; ACI Grade CB-7Cu; 
ACI Grade CD-4MCu; 17-4 PH; AM-355, 630, 17-4 PH 330 HB 15.13 

U.S. - ASTM A297: Grades HD, HE, HF, HH, HI, HK, HL, 
HN, HP, HT, HU; ASTM A608: Grades HD50, HE35, HF30, 
HH30, HH33, HI35, HK30, HK40, HL30, HL40, HN40, HT50, 
HU50 

200 HB 15.21 

U.S. - ASTM A351: Grade CD-4MCu; ACI Grade CB-7Cu; 
ACI Grade CD-4MCu; 17-4 PH; AM-355, 304L, 304, 303, 
301, 304LN 316, 316LN, 316L, 317L, UNS V 0890A, 321, 
347, 316 Ti, 318, 309, 310S, 308 

330 HB 15.22 

U.S. - ASTM A297: Grades HD, HE, HF, HH, HI, HK, HL, 
HN, HP, HT, HU; ASTM A608: Grades HD50, HE35, HF30, 
HH30, HH33, HI35, HK30, HK40, HL30, HL40, HN40, HT50, 
HU50, 17-7 PH 

330 HB 15.23 

U.S. - ASTM A217: Grades C5, C12; ASTM A296: Grades 
CB-30, CC-50, CE-30, CA6N, CA-6NM, CD4MCu; ASTM 
A297: Grade HC; ASTM A497: Class CA6NM; ASTM A608: 
Grade HC30, NO8028, S31254 

230 HB 15.51 
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Example metal materials Hardness Cut 
code 

U.S. - ASTM A217: Grades C5, C12; ASTM A296: Grades 
CB-30, CC-50, CE-30, CA6N, CA-6NM, CD4MCu; ASTM 
A297: Grade HC; ASTM A497: Class CA6NM; ASTM A608: 
Grade HC30, S31500, S32900 

260 HB 15.52 

U.S. - A-286, Discaloy, Incoloy Alloy 800, Incoloy 800H, 
Incoloy Alloy 801, Incoloy Alloy 802, N-155, V-57, W-545, 15-
25-6, 19-9DL, S32304, S31803 

200 HB 20.11 

U.S. - A-286, Discaloy, Incoloy Alloy 800, Incoloy 800H, 
Incoloy Alloy 801, Incoloy Alloy 802, N-155, V-57, W-545, 15-
25-6, 19-9DL, 330 

280 HB 20.12 

U.S. - Hayne Alloy 263, Incoloy Alloy 901, Incoloy Alloy 903, 
Inconel Alloy 617, Inconel Alloy 625, Inconel Alloy 702, 
Inconel Alloy 706, Inconel Alloy 718, Inconel Alloy 721, 
Inconel Alloy 722, Inconel Alloy X-750, Inconel Alloy 751, 
M252, Nimonic 75, Nimonic 80, Waspaloy 
DIN - 2.4665, 2.4668, 2.4819, 2.4856 
EN - 17750, 10204, 17744, 10095 

250 HB 20.21 

U.S. - Hayne Alloy 263, Incoloy Alloy 901, Incoloy Alloy 903, 
Inconel Alloy 617, Inconel Alloy 625, Inconel Alloy 702, 
Inconel Alloy 706, Inconel Alloy 718, Inconel Alloy 721, 
Inconel Alloy 722, Inconel Alloy X-750, Inconel Alloy 751, 
M252, Nimonic 75, Nimonic 80, Waspaloy, 5390A, 5666 

350 HB 20.22 

U.S. - Hastelloy Alloy B, Hastelloy Alloy B-2, Hastelloy C, 
Hatelloy Allow C-276, Hastelloy Alloy G, Hastelloy Alloy S, 
Hastelloy Alloy X, Incoloy Alloy 804, Incoloy Alloy 825, 
Incoloy Allow 825, Inconel Alloy 600, Inconel Alloy 601, 
Refractaloy 26, Udimet 630 

275 HB 20.23 

U.S. - Hastelloy Alloy B, Hastelloy Alloy, C, ASTM A296: 
Grades CW-12M, N-12M, CY-40; ASTM A297: Grades HW, 
HX; ASTM A494: Grades N-12M-1, N-12M-2, CY-40, CW-
12M-1, CW-12M-2; ASTM A08: Grades HW50, HX50, 5660, 
5391, 5383, 4676, AMS 5399, AMS 5544 

320 HB 20.24 

U.S. - AiResist 213, Haynes Alloy 25 (L605), Haynes Alloy 
188, J-1570, MAR-M905, MAR-M918, S-816, V-36 200 HB 20.31 

U.S. - AiResist 213, Haynes Alloy 25 (L605), Haynes Alloy 
188, J-1570, MAR-M905, MAR-M918, S-816, V-36 300 HB 20.32 

U.S. - AiResist 13, AiResist 215, FSX-414, HS-6, HS-21, HS-
31 (X-40), HOWMET #3, MAR-M302, MAR-M322, MAR-
M509, NASA Co-W-Re, WI-52, X-45, 5537C, AMS 5772 

320 HB 20.33 

U.S. - 99.5 
350 
Tensile 
Strength 

23.1 

U.S. - Ti-5Al-2Sn-2Zr-4Mo-4Cr (ti-17), Ti-6Al-6V-2Sn, Ti-7Al-
4Mo, Ti-8Al-1Mo-1V 
DIN - 3.7114, 3.7165 
EN - 17851 (90), 17850 

320 
Tensile 
Strength 

23.21 
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Example metal materials Hardness Cut 
code 

U.S. - Ti-6Al-4V, Ti-6Al-4V ELI, Ti-6Al-2Sn-4Zr-2Mo, Ti-6Al-
2Sn-4Zr-2Mo-.25Si, Ti-6Al-2Sn-4Zr-6Mo 

1050 
Tensile 
Strength 

23.22 

U.S. - EC, 1060, 1100, 1145, 1175, 1235, 2011, 2014, 2017, 
2018, 2021, 2024, 2025, 2117, 2218, 2219,2618, 3003, 
3004, 3005, 4032, 5005, 5050, 5052, 5056, 5083, 5086, 
5154, 5252, 5254, 5454, 5456, 5457, 5652, 5657, 6053, 
6061, 6063, 6066, 6070, 6101, 6151, 6253, 6262, 6453, 
6951, 7001, 7004, 7005, 7039, 7049, 7050, 7075, 7079, 
7175, 7178, AMS R54520, AMS R56400, AMS R56401 
DIN - 3.0517, 3.3211, 3.3523 
EN - 4004, 485-2, AW5052 

60 HB 30.11 

U.S. - EC, 1060, 1100, 1145, 1175, 1235, 2011, 2014, 2017, 
2018, 2021, 2024, 2025, 2117, 2218, 2219,2618, 3003, 
3004, 3005, 4032, 5005, 5050, 5052, 5056, 5083, 5086, 
5154, 5252, 5254, 5454, 5456, 5457, 5652, 5657, 6053, 
6061, 6063, 6066, 6070, 6101, 6151, 6253, 6262, 6453, 
6951, 7001, 7004, 7005, 7039, 7049, 7050, 7075, 7079, 
7175, 7178 
DIN - 1743-2 Z110, 1743-2 Z2720, 1743-2 Z810 
EN - CEN EN12844(98) ZP12, CEN EN12844(98) ZP27, 
CEN EN12844(98) ZP8 
 

100 HB 30.12 

U.S. - 360.0, A360.0, 380.0, A380.0, C443.0, 518.0 
DIN - 3.3215, 3.3547, 3.5662, 3.5912, 9.5912 
EN - AW-6082, AW-5083, 1753(97) MC21230, 1753 (97) 
MC21120, 1753(97) MC21121 

75 HB 30.21 

U.S. - 383.0,A384.0, 413.0, A413.0, SC64D, GD-AISI12, 
356.1, A413.0, A380.1, A413.1, A413.2, A360.2 
DIN - 3.2151, 3.2341, 3.2371, 1743-2 Z410, 1743-2 Z430, 
226A 
EN - 1706(98) AC-45500, 1706(98) AC-42200, 1706(98) AC-
42100, CEN EN 12844(98) ZP5, CEN EN 12844(98) ZP2, 
1706(98) AC-46200 

90 HB 30.22 

U.S. - 383.0,A384.0, 413.0, A413.0, 356.1, A413.0, A380.1, 
A413.1, A413.2, A360.2 30 HB 30.3 

U.S. - A140, 201.0, 208.0, 213.0, 222.0, 224.0, 242.0, 295.0, 
B295.0, 308.0, 319.0, 328.0, A332.0, F332.0, 333.0, 354.0, 
355.0, C355.0, 356.0, A356.0, 357.0, 359.0, B443.0, 514.0, 
A514.0, B514.0, 520.0, 535.0, 705.0, 707.0, A712.0, D712.0, 
713.0, 771.0, 850.0, A850.0, B850.0, Hiduminim RR-350 

130 HB 30.41 

U.S. - 383.0,A384.0, 413.0, A413.0 130 HB 30.42 
U.S. - 834, 836, 838, 842, 844, 848, 852, 852, 854, 855, 857, 
858, 864, 867, 879, 928, 932, 934, 935, 937, 938, 939, 943, 
944, 945, 953, 954, 956, 973, 974, 976, 978 
DIN - 2.0291 

110 HB 33.1 
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code 

EN - CEN 12167 CW603N 
U.S. - 801, 803, 805, 807, 809, 811, 813, 814, 815, 818, 820, 
822, 824, 825, 826, 827, 828, 863, 902, 907, 909, 910, 911, 
913, 916, 917, 962, 963, 964, 966, 993 
DIN - 2.0335, 2.0383, 1719, 20380 
EN - CEN EN 1652(98) CW507L, 14640, 12659, 12164 

90 HB 33.2 

U.S. - 801, 803, 805, 807, 809, 811, 813, 814, 815, 818, 820, 
822, 824, 825, 826, 827, 828, 863, 902, 907, 909, 910, 911, 
913, 916, 917, 962, 963, 964, 966, 993 
DIN - 2.0531, 2.0598, 2.0976, 1787, 12165, 17655 
EN - 1982-CC765S-GS, 1982(98) CC762S, CEN EN 12451 
CW300G, Cu-ETP, 12165, 1982(98) CC498K 

100 HB 33.3 

Cut codes by example plastic material 
Example plastic material Cut code 
Polyamides (Nylons): 35% Glass Reinforced - Types 6/10, 6/12 41.11 
Polyamides (Nylons): 35% Glass Reinforced - Types 6, 6/6 41.21 
Silicone-Glass Filled 42.11 
Allyl - Glass Filled 42.12 
Polyimide - Glass Filled 42.13 
Acrylic, Acetal, Polycarbonate, Polysulfone, Polystyrene 51.21 
Fluorocarbons: (TFE) Tetrafluoroethylene, (CTFE) 
Chlorotrifluoroethylene 51.22 

(ABS) Acrylonitrile-Butadiene-Styrene, Polyarylether, Polypropylene, 
Polyethylene, Cellulose Acetate 51.31 

Polyamides (Nylons): Unfilled - Types 6, 6/6, 6/12, 11, 12 51.32 
Silicone 52.11 
Furan, Polybutadiene 52.12 
Polyurethane 52.13 
Allyl - Fiber Filled 52.14 
Polyurethane 52.15 
Allyl (DAP) 52.21 
Epoxy, Melamine, Phenolic 52.31 
Polyimide 52.32 
Allyl - Glass Filled 42.12 

Cut codes by material trade name 
Trade name Material 

type 
Descriptio
n 

Cut 
code 

OVAKO 520M (Ovako Steel), FORMAX 
(Uddeholm Tooling), IMACRO NIT (Imatra 
Steel) 

Steel 
Low-alloy, 
non-
hardened 

2.1 
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INEXA 482 (XM) (Inexa Profil), S355J2G3, C45 
(XM), 16MnCrS5 (XM), INEXA280 (XM), 
070M20(XM), HARDOX 500 (SSAB - Swedish 
Steel Corp.), WELDOX 700 (SSAB - Swedish 
Steel Corp.) 

Steel 
Low-alloy, 
non-
hardened 

2.2 

SANMAC 304 (Sandvik Steel), SANMAC 304L, 
SANMAC 316, SANMAC 316L 

Stainless 
Steel 

Austenitic 
material 

5.21 / 
15.21 

2554 SMO, 654 SMO, SANMAC SANICRO 
(Sandvik Steel) 
 
 

Stainless 
Steel 

Austenitic 
material 

5.23 / 
15.23 

SANMAC SAF 2205 (Sandvik Steel), SANMAC 
SAF 2507 

Stainless 
Steel 

Austenitic/f
erritic 
material 

5.52 / 
15.52 

Incoloy 800 
Heat 
Resistant 
Super Alloy 

Iron base 20.11 

Haynes 600, Nimocast PD16, Nimonic PE 13, 
Rene 95 

Heat 
Resistant 
Super Alloy 

Nickel base 20.2 

Hastelloy C, Incoloy 825, Inconel 600, Monet 
400 

Heat 
Resistant 
Super Alloy 

Nickel base 20.21 

Inconel 700, Inconel 718, Mar - M 432, Nimonic 
901, Waspaloy 

Heat 
Resistant 
Super Alloy 

Nickel base 20.22 

Jessop G 64 
Heat 
Resistant 
Super Alloy 

Nickel base 20.24 

Air Resist 213, Jetalloy 209 
Heat 
Resistant 
Super Alloy 

Cobalt 
base 20.3 

Cut codes by recommended speed and feed 
Carbide 
speed 
(m/min) 

Carbide 
feed 
(mm/r) 

HSS 
speed 
(m/min) 

HSS 
feed 
(mm/r) 

 
Cut 
code 

5.00 0.10 4.00 0.10 20.33 
9.50 0.10 5.00 0.10 20.32 
32.50 0.09 8.00 0.25 20.11 
32.50 0.09 6.00 0.20 20.12 
32.50 0.09 6.00 0.10 20.31 
40.00 0.15 18.00 0.04 4.1 
50.00 0.08 6.00 0.10 20.21 
50.00 0.08 5.00 0.10 20.22 
50.00 0.08 5.00 0.10 20.23 
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Carbide 
speed 
(m/min) 

Carbide 
feed 
(mm/r) 

HSS 
speed 
(m/min) 

HSS 
feed 
(mm/r) 

 
Cut 
code 

50.00 0.08 2.00 0.10 20.24 
60.00 0.11 17.00 0.30 6.33 
60.00 0.14 8.00 0.20 23.21 
60.00 0.14 9.00 0.18 23.22 
75.00 0.11 14.00 0.23 6.32 
82.50 0.20 12.00 0.20 3.22 
87.00 0.14 29.00 0.30 23.1 
87.00 0.30 20.00 0.36 5.22 
90.00 0.10 21.00 0.30 8.3 
95.00 0.11 14.00 0.23 3.13 
100.00 0.12 9.00 0.23 15.22 
100.00 0.12 14.00 0.23 15.23 
104.40 0.13 5.00 0.13 10.1 
107.50 0.09 74.00 0.50 30.11 
110.00 0.10 23.00 0.20 7.3 
110.00 0.12 20.00 0.30 5.51 
110.00 0.12 20.00 0.30 5.52 
110.00 0.12 14.00 0.23 15.21 
116.00 0.14 11.00 0.23 5.12 
116.00 0.14 11.00 0.23 5.12 
116.00 0.40 9.00 0.30 5.23 
120.83 0.10 9.00 0.15 9.3 
120.83 0.13 5.00 0.13 10.0 
120.83 0.15 21.00 0.04 4.0 
121.80 0.11 19.50 0.40 6.3 
130.00 0.12 12.00 0.20 3.21 
140.00 0.14 26.00 0.30 7.2 
142.10 0.14 9.00 0.23 15.12 
145.00 0.14 17.00 0.30 5.13 
145.00 0.14 17.00 0.30 5.13 
147.90 0.14 9.00 0.23 15.13 
150.00 0.12 15.00 0.30 5.21 
150.00 0.14 14.00 0.25 9.2 
150.00 0.16 36.50 0.50 30.21 
160.00 0.05 18.00 0.30 15.51 
160.00 0.05 18.00 0.30 15.52 
160.00 0.12 18.00 0.30 6.2 
170.00 0.14 15.00 0.30 1.5 
170.00 0.14 14.00 0.30 2.2 
170.00 0.14 20.00 0.40 5.11 
170.00 0.14 39.50 0.40 8.2 
170.00 0.18 40.00 0.40 7.1 
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Carbide 
speed 
(m/min) 

Carbide 
feed 
(mm/r) 

HSS 
speed 
(m/min) 

HSS 
feed 
(mm/r) 

 
Cut 
code 

170.00 0.18 30.50 0.40 9.1 
180.00 0.14 15.00 0.25 3.11 
197.20 0.14 18.00 0.40 15.11 
200.00 0.08 23.50 0.36 6.1 
203.00 0.40 32.00 0.50 30.42 
204.71 0.12 15.00 0.25 3.2 
210.00 0.12 23.50 0.40 2.12 
210.00 0.14 23.50 0.45 1.3 
210.00 0.14 17.00 0.45 1.4 
220.00 0.12 25.50 0.45 2.1 
230.00 0.14 23.50 0.45 1.2 
230.00 0.16 18.00 0.40 33.2 
234.90 0.16 18.00 0.40 33.3 
250.00 0.18 60.00 0.55 8.1 
270.00 0.08 26.50 0.50 1.1 
272.60 0.40 63.50 0.40 30.41 
283.50 0.18 n/a n/a 42.11 
290.00 0.08 26.50 0.50 1.0 
300.00 0.16 32.00 0.50 30.22 
300.00 0.16 51.50 0.40 33.1 
307.06 0.14 15.00 0.25 3.1 
324.00 0.12 n/a n/a 41.11 
350.00 0.16 63.50 0.50 30.12 
364.50 0.12 n/a n/a 41.21 
364.50 0.12 n/a n/a 42.12 
364.50 0.12 n/a n/a 42.13 
364.50 0.18 35.11 1.47 52.11 
409.41 0.14 20.00 0.40 5.1 
443.53 0.14 18.00 0.30 5.2 
459.00 0.12 30.48 0.98 52.14 
459.00 0.18 50.35 1.47 52.12 
459.00 0.18 50.35 1.47 52.13 
621.00 0.18 50.35 1.47 52.15 
621.00 0.18 50.35 1.47 52.21 
661.50 0.18 79.50 1.47 51.21 
661.50 0.18 79.50 1.47 51.22 
678.60 0.50 63.50 0.50 30.3 
823.50 0.18 59.63 1.47 51.31 
823.50 0.18 59.63 1.47 51.32 
823.50 0.18 59.63 1.47 52.31 
823.50 0.18 59.63 1.47 52.32 
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Cut codes by recommended speed and feed, relative to mild 
steel 

Carbide speed ratio Carbide feed 
ratio 

HSS speed 
ratio 

HSS feed 
ratio 

Cut 
code 

0.02 1.28 0.15 0.20 20.33 
0.04 1.25 0.19 0.20 20.32 
0.06 1.00 0.19 0.20 20.23 
0.12 1.13 0.30 0.50 20.11 
0.12 1.13 0.23 0.20 20.31 
0.14 1.13 0.23 0.40 20.12 
0.15 1.88 0.68 0.08 4.1 
0.19 1.00 0.23 0.20 20.21 
0.19 1.00 0.19 0.20 20.22 
0.19 1.00 0.08 0.20 20.24 
0.22 1.38 0.64 0.60 6.33 
0.22 1.75 0.30 0.40 23.21 
0.22 1.75 0.34 0.36 23.22 
0.28 1.38 0.53 0.46 6.32 
0.30 1.50 0.75 0.72 5.22 
0.30 1.75 1.09 0.60 23.1 
0.31 2.50 0.45 0.40 3.22 
0.35 1.38 0.53 0.46 3.13 
0.36 1.63 0.19 0.26 10.1 
0.37 1.50 0.34 0.46 15.22 
0.37 1.50 0.53 0.46 15.23 
0.40 1.13 2.79 1.00 30.11 
0.40 1.50 0.34 0.60 5.23 
0.40 1.75 0.42 0.46 5.12 
0.41 1.50 0.75 0.60 5.51 
0.41 1.50 0.75 0.60 5.52 
0.41 1.50 0.53 0.46 15.21 
0.42 1.25 0.34 0.30 9.3 
0.42 1.38 0.74 0.80 6.3 
0.42 1.63 0.19 0.26 10.0 
0.42 1.88 0.79 0.08 4.0 
0.48 1.50 0.45 0.40 3.21 
0.49 1.75 0.34 0.46 15.12 
0.50 1.25 0.87 0.40 7.3 
0.50 1.75 0.64 0.60 5.13 
0.51 1.75 0.34 0.46 15.13 
0.52 1.75 0.98 0.60 7.2 
0.56 1.50 0.57 0.60 5.21 
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Carbide speed ratio Carbide feed 
ratio 

HSS speed 
ratio 

HSS feed 
ratio 

Cut 
code 

0.56 1.75 0.53 0.50 9.2 
0.56 2.00 1.38 1.00 30.21 
0.59 0.63 0.68 0.60 15.51 
0.59 0.63 0.68 0.60 15.52 
0.59 1.50 0.68 0.60 6.2 
0.63 1.75 0.57 0.60 1.5 
0.63 1.75 0.53 0.60 2.2 
0.63 1.75 0.75 0.80 5.11 
0.63 1.75 1.49 0.80 8.2 
0.63 2.25 1.51 0.80 7.1 
0.63 2.25 1.15 0.80 9.1 
0.67 1.75 0.57 0.50 3.11 
0.68 1.75 0.68 0.80 15.11 
0.70 5.00 1.21 1.00 30.42 
0.71 1.50 0.57 0.50 3.2 
0.72 1.25 0.79 0.60 8.3 
0.74 1.00 0.89 0.72 6.1 
0.78 1.50 0.89 0.80 2.12 
0.78 1.75 0.89 0.90 1.3 
0.78 1.75 0.64 0.90 1.4 
0.81 1.50 0.96 0.90 2.1 
0.81 2.00 0.68 0.80 33.3 
0.85 1.75 0.89 0.90 1.2 
0.85 2.00 0.68 0.80 33.2 
0.93 2.25 2.26 1.10 8.1 
0.94 5.00 2.40 0.80 30.41 
1.00 1.00 1.00 1.00 1.1 
1.06 1.75 0.57 0.50 3.1 
1.07 1.00 1.00 1.00 1.0 
1.11 2.00 1.21 1.00 30.22 
1.11 2.00 1.94 0.80 33.1 
1.30 2.00 2.40 1.00 30.12 
1.41 1.75 0.75 0.80 5.1 
1.53 1.75 0.68 0.60 5.2 
2.34 6.25 2.40 1.00 30.3 
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3 Process Group Site 
Variables 

The aPriori Process Group Site Variables tool allows you to adjust the process 
group site variables that apply to all your VPEs. 

This chapter includes the following topics: 
 Overview of Process Group Site Variables 
 Site Variable best practices 
 Site Variable procedures 
 Scenario-specific site variable overrides
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Overview of Process Group Site 
Variables 

aPriori uses global variables that impact all the VPEs for a process group at your 
site. These global variables influence how aPriori analyzes geometric cost drivers 
(GCDs).  

Note We recommend that you attend VPE Manager Training and contact 
aPriori Support if you have questions before using the aPriori Process 
Group Site Variables tool to edit these global variables. 

All the VPEs provided with your installation of aPriori have been created and 
tested to reflect specific costing behavior. Changes to these site variables will 
impact cost estimates for all components using the VPEs in your deployment.  

Site Variable best practices 
We recommend that you use the following best practices to ensure that VPE 
changes are applied in a controlled and consistent manner: 
 Make any VPE modifications in a staging environment before moving them to 

production. 
 Create a data maintenance plan for each VPE to ensure that VPE data is 

kept current. 
 Ensure that anyone editing VPE data attends aPriori Administrator training or 

engages with aPriori Professional Services for support. 

Site Variable procedures 
The aPriori Process Group Site Variables tool allows you to edit the global 
variables for the aPriori application deployed at your site. It also allows you to 
export and import a deployment’s site variables; for example, it allows you to 
export variables from a staging environment and import them into a production 
environment. 
Note that aPriori provides the ability to define and set scenario-specific site 
variable overrides, as described later in this chapter. 

To start the Process Group Site Variables tool 

1 Select Tools > VPE Toolset from the aPriori menu bar to display the aPriori VPE 
Toolset window. 
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5 Click Process Group Site Variables to display the aPriori Process Group Site 
Variables tool, then select a process group from the left column. 

 

To edit site variables 

1 Review the deployment site shown in the aPriori Process Group Site Variables 
toolbar to verify that you are editing the global variables for the correct deployment. 
For example, in the figure above, the tool will edit global variables at the Default – 
Default Scenarios site.  
If the deployment site is incorrect, change the selection. For more information, see 
To select a different deployment site, below. 

2 Select the process group that contains the global variables you want to edit form the 
Process Group pane to display those variables in a tab in the Data pane. 
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3 Double-click a field to edit its value. 

4 Select File > Publish VPE from the VPE Manager menu bar or click  in the 
toolbar to save your changes. 

To export site variables from a deployment 

1 Select File > Export > Site Variables… from the Process Group Site Variables 
menu bar to display the Select Process Groups window. 

2 Select the desired process groups and click OK. The Export Site Variables dialog 
appears. 

3 Specify a filename and folder for the exported variables and click Save. 
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To import site variables into a deployment 

1 Select File > Import > Site Variables… from the Process Group Site Variables 
menu bar to display the Import Site Variables dialog. 

2 Specify the sitevars.zip file to import and click Open. 

To select a different deployment site 

1 Select File > Switch Component Schema from the Process Group Site Variables 
menu bar to display the Select Component Schema window. 

2 Select the deployment site you want to edit and click OK. 

Scenario-specific site variable overrides 
It is possible to override a site variable when you cost a scenario. If your company has 
different roles for VPE and System Administration, you will need to collaborate with an 
aPriori System Administrator to configure this functionality.  In general, the System 
Administrator needs to create a new User Defined Attribute (UDA) with exactly the same 
name as the target site variable. This UDA must be configured to appear on the Cost 
Guide with a Display Name that makes clear which Process Group it applies to. You 
users must be educated as to what this field does, and when to use it and when to leave 
it blank. 
Note that this UDA can be further mapped to a CAD Property so that a value in the 
original CAD file can control the override value of the site variable. 

1 Determine which site variable you want your users to be able to override when 
costing. Use the Process Group Site Variables tool as described earlier in this 
chapter to view the variables available in each Process Group. 

2 Arrange to have an aPriori System Administrator create a User Defined Attribute 
(UDA) with exactly the same name as the site variable. This procedure is described 
in the aPriori System Administration Guide. Also ensure that the administrator 
creating the UDA understands exactly which Process Group this override applies to. 
They will need to build this into the Display Name that appears in the Cost Guide. 

3 Ensure that the UDA appears in the Company-Defined Attributes section of the Cost 
Guide.  

4 If the user doing the costing enters a value in this field, it will override the default 
value of the site variable. Ensure that your users understand when they should use 
this override, and that they should not specify a value for Process Group(s) not 
relevant for this site variable. 

 
 



 

aPriori Version 2019 R2 aPriori Confidential 99 

4 Deployment Data 
Administration 

The Deployment Data Administration tool allows you to manage which currencies 
are active and the exchange rates, set the default VPE for each process group, 
and configure the names used for cost outputs throughout the aPriori application. 

This chapter includes the following topics: 
 Overview 
 Selecting your deployment site 
 Managing currency 
 Managing process groups 
 Managing cost taxonomy display names 
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Overview of the Deployment Data admin 
tool 
The aPriori Deployment Data Administration tool allows you to manage which currencies 
are active and the exchange rates, set the default VPE for each process group, and 
configure the names used for cost outputs throughout the aPriori application. 

To start the Deployment Data Administration tool 

1 Select Tools > VPE Toolset from the aPriori menu bar to display the aPriori VPE 
Toolset window. 

 

2 Click Deployment Data to display the Deployment Data Administration tool. 
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Selecting your deployment site 
Before making any changes, review the deployment site shown in the aPriori Process 
Group Site Variables toolbar to verify that you are editing the global variables for the 
correct deployment. 
For example, in the figure above, the tool will edit global variables at the Default – Default 
Scenarios deployment.  
If the deployment site is incorrect, change the selection. For more information, see To 
select a different deployment site, below. 

To select a different deployment site 

1 Select File > Switch Component Schema from the Deployment Data 
Administration menu bar to display the Select Component Schema window. 

2 Select the deployment site you want to edit and click OK. 

Managing currency 
aPriori supports multiple currencies and user-defined historical exchange rate versions. 
This allows the user to select the currency used to display costs. It also provides the 
ability to save and then use different versions of historical exchange rates cost 
components. It can also aggregate component costs that are specified in multiple 
currencies and display them in a single currency. 
The Deployment Data Administration tool allows you to select which currencies are 
active in the aPriori application, edit the currency code, description, and rate, as well as 
create a new currency and delete a currency. You can save this information with a user-
defined version label.  
You can then select a currency and (optionally) a saved exchange rate version in the 
main aPriori Professional UI (see the aPriori Professional User Guide),  or set the 
currency and exhange rate version for a specific VPE (see Editing VPE data on page 
59). 
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To display currency data 

1 Display the Deployment Data Administration window as described in To start the 
Deployment Data Administration tool. 

2 Click Currency in the Navigation pane to display a Currency tab in the Data pane. 

 

Selecting the currencies to display 
aPriori provides an initial set of currencies that include countries with significant 
manufacturing capabilities. Active currencies are available in the aPriori application for 
display and computation. US Dollars (USD) is the only currency active by default. 
Note USD is not listed in the currency table, though it is always active in the system. 
The system assumes the exchange rate for US Dollars is 1. All other currency rates 
must be entered into aPriori as a percent of US Dollars. 

To activate or deactivate a currency 

1 Check the Active box next to the currency you want to activate in the aPriori 
application. Uncheck the box to deactivate the currency. 

2 Select File > Publish VPE from the Deployment Data Administration menu bar or 
click  in the toolbar to save your changes. 

Editing currency data 
The aPriori application uses the facility currency to calculate the cost of all components. 
If the user selects a different currency, aPriori converts the cost using the currency 
exchange rate specified in the Deployment Data Administration tool. These converted 
costs are displayed in italics and provide a tooltip that displays the exchange rate. 
You can use the Deployment Data Administration tool to add, edit, and delete the 
currencies available to the aPriori application. 
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To create a new currency 

1 Double-click the empty cell at the end of the table and enter a currency code for the 
new currency. 

2 Enter a description of the new currency and the rate, as a percentage of US Dollars. 

3 Check the Active box if you want to activate the currency in the aPriori application. 

4 Select File > Publish VPE from the VPE Manager menu bar or click  in the 
toolbar to save your changes. 
An aPriori System Administrator can set this currency as a user’s preferred currency 
using the System Admin toolkit (The preferred currency is the currency used to 
display cost data in aPriori.) For more information, see the aPriori System 
Administration Guide. 
You can also construct VPEs that use this currency as the source currency. 

To edit currency data 

1 Double-click in a white table cell to edit the currency data. 
You can also right-click the table and select Copy Entire Table from the context 
menu to paste the table into Microsoft Excel for editing. When you are finished 
editing the table in Excel, right-click the table and select Paste from the context 
menu to include your edited data. 

Note The Conversion cells provide a standard conversion rate for display and 
computation in aPriori. While currency exchange rates fluctuate on a daily 
basis, this daily fluctuation is not necessarily desirable in the aPriori cost 
assessment because it could obscure the effect of design and manufacturing 
decisions. We recommend that you carefully consider the frequency with 
which you update Rates. 

2 Select File > Publish VPE from the VPE Manager menu bar or click  in the 
toolbar to save your changes. 

To delete a currency 

1 Right-click the currency you want to delete and select Remove from the context 
menu to delete the currency. 
DO NOT delete the default currency for any VPE in your deployment because it will 
prevent the VPE from operating correctly. 

2 Select File > Publish VPE from the Deployment Data Administration menu bar or 
click  in the toolbar to save your changes. 

Saving an exchange rate version 
From 2019 R1 SP1 on, you can save historical exchange rates for later use. The 
recommended workflow is to update the Default currency table so that it is always up to 
date. Whenever you update the Default currency table, make a copy of it and give the 
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copy a descriptive version name so that it can be identified and used at a later time. For 
example, to add a new currency code, modify an exchange rate, and save these 
changes in a new version table: 

1 Display the Deployment Data Administration window as described in To start the 
Deployment Data Administration tool. 

2 Click Currency in the left column, and make sure that Default is displayed in the 
pull-down menu. 

3 To add a new currency code, double-click the first open Currency Code field at the 
bottom of the existing table. 

 
In this example, we will add “MYR” for the Malaysian Ringgit, which as of this writing 
has an exchange rate of 4.18. We will also update the Turkish Lira from 6.0 to 5.74. 
When done, Publish the table so that the Default table now has the most up-to-date 
information. 
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4 When the Publish action completes, click in the Default field and edit the name to 
something that indicates what version the new copy will represent, such as a date 
like “2019_JUNE_05_a”. To enable the Publish button again, you must make an 
innocuous change to the table, such as toggling a currency off and then back on 
again. Click Publish. When done, “Default” and “2019_JUNE_05_a” will be identical, 
until the next time you update the Default table and create a new version copy.  

Note: Saved exchange rate versions are currently accessible only to the aPriori 
Professional client and Cost Insight Report. They are not yet available to 
Manually Costed process groups, Bulk Costing, or Cost Insight Design.  

Managing process groups 
A process group is a set of processes that are of the same manufacturing type. For 
example, the Sheet Metal process group includes processes such as Laser Cut, Bend Brake, 
and Shear processes, while the Casting process group includes Die Cast and Sand Cast 
processes. Components may often be completely manufactured using processes in a 
single process group. Other times, a part or assembly requires multiple process groups, 
such as Casting, Machining, and Finishing. 
The Deployment Data Administration tool allows you to select the default VPE for each 
process group. 

To display process group data 
Click Process Groups in the Navigation pane to display a Process Groups tab in the Data 
pane. 
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To set the default facility for a process group 

1 Click Process Groups in the Navigation pane to display a Process Groups tab in the 
Data pane. 

2 Double-click the Default VPE cell to display the drop-down list and select the default 
facility. 

3 Select File > Publish VPE from the Deployment Data Administration menu bar or 
click  in the toolbar to save your changes. 

Managing cost taxonomy display names 
aPriori provides a set of standard names for fields and their categories in the Cost 
Taxonomy. For example, the name Piece Part Cost applies to the field which is the sum 
of the fields named Total Variable Costs, Period Overhead Allocations, and Margin. 
These field names are displayed throughout the aPriori application, such as on cost 
table tabs and in reports.  
You can customize these names to: 

 Reflect the terminology in use at your company. For example, you may want to 
rename the Margin field to Profit.  Or the category of Variable Costs may be referred 
to as Fluctuating Costs in local jargon. 

 Better represent the use of the field at your company. For example, your 
company may use the Extra Costs field to represent rush fees, so you can rename 
this field to Rush Fees.  

To display cost taxonomy display names 
Click Cost Taxonomy Display Names in the Navigation pane of the Deployment Data 
Administration window to display the system display names and their custom display 
names in the Data pane. 
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To change a cost taxonomy display name 

1 Double-click the Custom Display Name field for the system display name you want to 
change and enter the name you want aPriori to display. 
If no custom display name is provided, aPriori uses the system display name. 

2 Select File > Publish VPE from the Deployment Data Administration menu bar or 
click  in the toolbar to save your changes. 
aPriori users will see the new display names the next time they start aPriori. 
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5 BOM Loader 

The BOM Loader maps aPriori fields to column headings read in from a comma-
separated values (CSV) file, so you can generate and populate aPriori 
components and rollups with multiple types of cost data, including quoted costs, 
actual costs, user defined costs, and even cost estimates constructed outside of 
aPriori, such as from a spreadsheet model. You can also use the BOM loader to 
import lists of purchased parts and their cost data, providing the ability to load a 
complete parts catalog. This module is licensed separately.  

This chapter includes the following topics: 
 Working with BOMs and Catalog Parts 
 Loading a BOM 
 Using the BOM Loader from the Command Line 
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Working with BOMs and Catalog Parts 
You can import bills of materials into aPriori using the BOM Loader in the VPE Toolset. 
The BOM Loader is a separately licensed module which lets engineers and managers 
quickly:  

 Generate and organize new aPriori part and assembly components 
 Update and organize existing components 
 Add hierarchical structure to rollups  
 Import lists of purchased parts and their cost data, providing the ability to load a 

complete parts catalog 
The BOM Loader is an efficient way to populate your aPriori database with components 
and cost data that can be rolled up and analyzed further using the BOM Comparison 
Report. For more information, see the BOM Reports" section of the aPriori User Guide. 

Note: In versions previous to 2015 R1, aPriori supported a separate Catalog Part Loader. 
This feature has now been deprecated and its functionality is now covered by the 
BOM Loader. To use the BOM Loader to load Catalog Parts, you must make the 
following explicit settings: 

1 In the input file, set level and quantity to 1 for all components, and map accordingly. 

2 In the input file, set official to true, and map accordingly) 

3 Ensure that the Calculate Values... checkbox is checked. 

4 Open the scenarios after importing and bulk lock them (there is no ability for the 
BOM loader to import scenarios as locked). -As an alternative, your System 
Administrator could implement an Access Control scheme that maps UDAs that only 
allow certain people to edit those scenarios. 

To start the BOM Loader 

1 Select Tools > VPE Toolset from the aPriori menu bar to display the aPriori VPE 
Toolset window. 
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2 Click BOM Loader to display the aPriori BOM Loader tool. 

 
This dialog and its fields are described in the next section. 

Loading a BOM 
The BOM Loader imports a comma-separated values (CSV) file that defines 
components and attributes and maps its column headings to aPriori fields. CSV files are 
typically viewed and edited in Microsoft Excel. 
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This allows you to populate aPriori components and rollups with multiple types of cost 
data, including quoted costs, actual costs, user defined costs, and even estimated costs 
generated outside of aPriori, such as from a spreadsheet model. The flexibility to load in 
different scenarios allows you to easily create two variants of the same product in order 
to estimate the cost impact of different feature sets or manufacturing approaches. You 
can structure the roll-up created by this BOM import with a functional group template 
(see the aPriori User Guide for information about functional group templates.) In the 
CSV file, each line represents a component (that is, either a part or an assembly). 
As aPriori reads the file line by line, it either creates new component scenarios or skips 
or updates existing component scenarios, based on the settings of the BOM Loader field 
labeled Processing Rule if Scenario Exists.  

 

Note: When you load a BOM, aPriori does not do any summing of costs horizontally 
(that is, it will not recalculate a value in a row based on other values in that row at 
load time), but it will sum vertical costs (that is, a field at the assembly level will 
be summed from its sub-component values). 
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To load a BOM 

1 Click  next to the Import button to display the Open window. (The Open window 
typically opens automatically when you first bring up the BOM Loader.)  

2 Select the CSV file that contains the BOM you want to import, then click Open. 

The CSV file must be formatted correctly. For more information, see Formatting a 
BOM on page 113. 

Once you select the .csv file, the window updates to display the Column Mapping 
pane , which is described below.   

3 Enter a new roll-up name in the Rollup Name field.  
You can also click the “...” buttom to search for an existing roll-up. Select the roll-up 
and click OK. 
If you do not specify a roll-up, aPriori loads components directly to the aPriori 
database. 

4 Click  next to the Functional Template field and open your functional group template. 
(See "Using Functional Groups" in the aPriori User Guide for information about 
defining functional group templates.) 
In the Default Scenario Name field, enter a descriptive string. This name gets appended 
to the name of any parts and also to any roll-up (if specified).

 

Note: If a specific scenario name field is NOT present in the BOM file for a particular 
row, then this default name is used instead. If a specific scenario name IS 
specified in the BOM, then it will be used. aPriori resolves any conflicts with 
existing names by appending (2), (3), etc.  

5 From the Processing Rule if Scenario Exists pull-down menu, select one of the 
following options: 

• Update – Update the existing scenario with the values imported from the 
BOM. 

• Skip – Do not update the existing scenario. 
• Create New Scenario – Make a copy of the existing scenario, then update 

the copy with values that are in the BOM load CSV file. 
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6 In the Column Mapping pane, map the Input File Column values from the CSV file to the 
aPriori Field values. 
You must map the Part Number, Quantity, and Level fields to load the BOM.  

You must also map any required User Defined Attribute (UDA) fields if present. 
In addition to the minimum required, fields you must also set the field Type if you are 
loading in components with non-integer quantities or loading in component 
placeholders for assemblies (e.g. single components that will be assemblies when 
the product is designed). Valid fields for type include Part, Assembly, or Bulk 
Item. 

Single components can be designated as assemblies in a BOM load. Additionally, 
BulkItem is used to designate non-integer components like fluids. The quantity field 
in aPriori does not accept non integers. When a component is specified as a 
BulkItem, the quantity from the BOM file is appended to the description field and 
the quantity in aPriori is set to 1. 
To map a field, click the aPriori Field cell and select the field you want to map to from 
the drop-down list. 
By default, manually costed parts are not totaled. If you wish to have these values 
aggregated, click the checkbox labeled Calculate aggregate costs for Manually Costed 
components? When enabled, the following fields are computed during load unless 
they are mapped from a value in the CSV file: other direct costs, variable costs, amortized 
investment, fully burdened cost, aggregate fully burdened cost, capital investment. 

7 If you wish to specify a different currency for manually costed components only, use 
the drop-down menu labeled Manually Costed Currency. aPriori-costed 
components will use the currency from the VPE. 

8 When done, click Import to import the information from the CSV file into aPriori and 
create new or update existing components and rollups. 
For more information, see BOM Loader assumptions on page 125 and BOM loader 
results on page 126. 

Formatting a BOM 
The aPriori BOM Loader can import components, component specific information, and 
the structure of engineering BOMs. Each line of a BOM you want to import must contain 
data specific to a single component and data for an instance of a component must be 
represented on a single line.  
For example, labor and material costs should not be itemized on unique rows under a 
particular component. Instead, labor and material costs must be loaded as columns and 
mapped directly to the relevant aPriori fields.  
The BOM Loader imports only CSV file formats, so you must first convert Microsoft 
Excel or other formats to CSV files. The files must use a North American locale, so that 
decimals are represented by periods (.) and not by commas (,) as in EU locales. 
Column headings must contain the names of the attributes you intend to map to aPriori 
fields in the first row of the CSV file. The BOM Loader requires that the following aPriori 
fields be mapped to columns in your CSV file: 
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 Part Number – Unique identifier for the component 

 Quantity – Number of components represented in a particular row 

 Level – Indicates depth within a BOM structure, with 1 or 0 being the top level 

Required user defined attributes for component must also be mapped. For more 
information about user defined attributes, see the aPriori System Administration Guide. 
aPriori will create assembly components as inferred by the BOM Loader’s assumptions. 
For more information, see BOM Loader assumptions below.  

Mapping BOM Loader Headings to the UI and Spreadsheet 
Reports 
The table below (see Mapping BOM Loader Headings to the UI and Spreadsheet 
Reports  

) lists all of the aPriori column headings that can be mapped to the columns in your BOM 
input file. These appear on the aPriori Field drop-down menu. 

 
If your site has implemented any User Defined Attributes (UDAs), they also will appear 
on the drop-down menu.  
The three required fields (Level, Part Number, and Quantity) are highlighted with red 
asterisks (*) in the table, the same as they appear in the menus (see the screenshot 
above). If your site has implemented any required UDAs, they also will appear with red 
asterisks. 
Some of the following fields accept "true" or "false" values, as indicated by (True/False) 
in the description. It is best practice to use the syntax "true" and "false".  If needed, there 
is additional acceptable syntax.  True can be specified as a case-insensitive string true, 
yes, or 1.  .False can be specified as a case-insensitive string false, 0, or a blank field. 
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Note: Some of the names on the drop-down menu (the entries in the Name on "aPriori 
Field" menu: column) may have been redefined in your deployment. The 
following table lists the default names as shipped with aPriori. (To modify display 
names, use the VPE Administrator feature at Tools > VPE Toolset> 
Deployment Data> Cost Taxonomy Display Names.) 

Unless otherwise specified, the UI name is identical to the name on the "aPriori Field" 
menu. 
Mapping BOM Loader Headings to the UI and Spreadsheet Reports  

Name on 
"aPriori 
Field" 
menu: 

Found in the 
UI: 

Spreadsheet Report 
Variable Name used in 
XML definition: 

Description: 

Active Detail View: 
Cost 
Descriptors 

active (True/False). Applies to 
CAD-connected 
components. An Active 
scenario automatically 
updates whenever the CAD 
part changes. Setting a part 
to Inactive means that GCDs 
remain static even if the CAD 
part is updated and must be 
updated manually before 
changes to the CAD files will 
be reflected in the Bulk Cost 
operation. 

Additional 
Amortized 
Investmen
ts 

Detail View: 
Fixed Costs 

additonalAmortizedInvestm
ent 

Fixed Investment Costs 
incurred to make a part that 
are not accounted for in Hard 
Tooling Programming or 
Fixture Costs amortized over 
the estimated lifetime 
production volume.  aPriori 
starting point cost models do 
not calculate Additional 
Amortized Investments. 

Additional 
Direct 
Costs 

Detail View: 
Variable 
Costs, Other 

additionalDirectCosts Other costs that can be 
specifically associated with 
the manufacture of a given 
design. Expendable Tooling 
Cost per part, Additional 
Direct Costs, and Extra 
Costs are accounted for in 
Other Direct Costs (see 
below). Default value is zero. 

Amortized 
Batch 
Setup 

Detail View: 
Variable 
Costs 

setupCostPerPart The cost of configuring a 
machine to run a batch of a 
given design, accounting for 
machine downtime and labor 
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incurred. The cost is 
amortized to individual parts 
or assemblies by dividing by 
the number of components in 
a batch. For example: 
(Setup Time * (Labor Rate + 
Direct Overhead Rate)) / 
Batch Size 

Annual 
Volume 

Detail View: 
Manufacturin
g Info 

annualVolume Number of parts to be 
produced in one year. 

Compone
nt Height 

Geometric 
Cost Drivers 

part.height The shortest dimension of 
the component. 
Note: A general way to 
export GCDs for 
Spreadsheet Reports is to 
use the following syntax: 
<Formula>gcd.parameter</F
ormula> 
where parameter is the 
information related to a GCD 
you want to export. 
Note: You may encounter 
aliases for this variable 
named part.boxHeight or 
part.envelopeHeight. 

Compone
nt Length 

Geometric 
Cost Drivers 

part.length The longest dimension of the 
component. 
Note: You may encounter 
aliases for this variable 
named part.boxLength or 
part.envelopeLength. 

Compone
nt Surface 
Area 

Geometric 
Cost Drivers 

part.surfaceArea The total surface area of the 
component. 

Compone
nt Volume 

Geometric 
Cost Drivers 

part.volume The total finished volume of 
material in the component. 

Compone
nt Width 

Geometric 
Cost Drivers 

part.width The second longest 
dimension of the component. 
Note: You may encounter 
aliases for this variable 
named part.boxWidth or 
part.envelopeWidth. 



BOM Loader  aPriori VPE Administration Guide 

aPriori Version 2019 R2 aPriori Confidential 117 

Copy 
From 

Cost Guide: 
Recently 
Used 
Settings 

N/A The costed component from 
which to copy the cost 
settings, in the format: 
PartName.Scenario 

Cost Type Detail View: 
Cost 
Descriptors 
Cost Guide: 
Company-
Defined 
Attributes 

costType The source that provided the 
cost information for the 
component. Choice of 
Design Engineering, 
Manufacturing, Procurement, 
Accounting/Finance, 
Program Management, 
Supplier, Other  

Currency Detail View: 
Applies to all 
monetary 
fields 
EXCEPT in 
the "Quoted 
Info" section. 
Cost Guide: 
Currency 
pull-down 
menu 
"View" menu 
> Change 
Currency? 
Tools > VPE 
Toolset> 
Deployment 
Data> 
Currency 

currencyCode Select the currency used for 
the costs in this row. These 
values will be converted to 
the default display currency 
in aPriori and will be shown 
in italic. Fields in the "Quoted 
Info" section can be set 
separately with "Quoted 
Currency" (see below).  
See the "Managing 
Currencies" section of the 
"Deployment Data" chapter 
of the aPriori VPE 
Administration Guide for 
more information. 

Date 
Costed  

Detail View: 
Cost 
Descriptors 

calculationDate The date and time in the 
format: 
MM/DD/YYYY  hh:mm:ss  

Descriptio
n 

Detail View: 
Cost 
Descriptors 
Cost Guide: 
Company-
Defined 
Attributes 

description Information that will help you 
identify the component. 
"Description" can be mapped 
to a CAD "description" 
property. See the "Using 
CAD Properties" chapter of 
the aPriori System 
Administration Guide. 

Direct 
Overhead 

Detail View: 
Variable 
Costs 

directOverheadCost Direct overhead accounts for 
machine depreciation, 
machine maintenance, and 
energy to power machines. 
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In addition, you have the 
option of including facilities 
cost (rent, insurance, and 
utilities) in direct overhead, 
which by default is included 
in indirect overhead (see 
below). 

Expendab
le Tooling 

Detail View: 
Variable 
Costs, Other 

expendableToolingCostPer
Part 

The cost of tooling, such as a 
drill bit or turret press punch, 
consumed during 
manufacturing. 

Extra 
Costs 

Detail View: 
Variable 
Costs, Other 

extraCosts Total of additional 
miscellaneous costs. By 
default, this value is zero in 
aPriori starting point cost 
models. Your VPE may be 
customized to use this field 
to capture specific types of 
costs and relabeled as 
needed (see the aPriori 
Administration Guide, 
Managing Cost Taxonomy 
Display Labels).  

Finish 
Mass 

Detail View: 
Component 
Mass 

finishMass The total finished mass of 
material in the component 
based on the final 
manufactured “Component 
Volume” and selected 
Material.  

Fixture 
Cost 

Detail View: 
Capital Costs 

fixtureCost The cost of devices that hold 
a specific part or assembly in 
the correct orientation on a 
machine during manufacture 
or assembly. These devices 
are not supposed to be re-
used for a part or an 
assembly of a different 
design. The capital cost is 
the price to buy one set of 
the tooling. 

Fixture 
Cost 
(amortize
d) 

Detail View: 
Fixed Costs 

fixtureCostPerPart The cost per part of devices 
that hold a specific part or 
assembly in the correct 
orientation on a machine 
during manufacture or 
assembly. These devices are 
not supposed to be re-used 
for a part or an assembly of a 
different design.  
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Fully 
Burdened 
Cost 

Detail View: 
Fully 
burdened 

fullyBurdenedCost For parts, the sum of Piece 
Part Cost and Fixed Costs.  
For assemblies, the sum of 
Fully Burdened Cost of 
Assembly Processes and 
Fully Burdened Cost of 
Subcomponents. 
For Roll-ups, the sum of 
Piece Part Cost and Fixed 
Costs for all first level 
children (parts, assemblies, 
roll-ups). 

Functiona
l Group 

See 
"Description". 

See "Description". "Functional Group" is used to 
map components to an 
alternative hierarchy or 
grouping from the BOM 
structure.  Components 
being loaded via the BOM 
Loader can be mapped to 
specific functional groups.  
Functional groups must be 
defined in aPriori using the 
Functional Group Generator.  
See the "Using Functional 
Groups" section of the 
aPriori User Guide. 

Hard 
Tooling 

Detail View: 
Capital Costs 

hardToolingCost Hard tools are purchased for 
creating one specific design 
and cannot be used to create 
others. The Capital Cost is 
the price to buy one set of 
the tooling. 

Hard 
Tooling 
Amortized 

Detail View: 
Fixed Costs 

toolingCostPerPart The cost of hard tooling per 
part. 

Image File 
Path 

Component 
View 

N/A -- There is no "image 
file path" to extract once 
the image is in the 
database. However, you 
can incorporate the image 
into your report by 
specifying: 
generateThumbnails="true
" 
The image file will be 
generated in the same 
directory as the report. 

The location of an image file 
that you wish to associate 
with a CAD-less (virtual) part 
or assembly. Supported 
image formats are: BMP, 
WBMP, JPG, JPEG, PNG, 
GIF. This image will appear 
where a CAD-related 
component typically displays 
a representation of the CAD 
model, such as the 
Component Viewer or 
Search dialog in the main 
aPriori GUI. 
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Indirect 
Overhead 

Detail View: 
Period Costs 

periodOverhead Indirect overhead accounts 
for support services for 
quality, maintenance, 
planning & purchasing, 
manufacturing engineering 
(CNC programming and 
process planning), and tool 
crib. By default, indirect 
overhead also includes 
facility costs (rent, insurance, 
and utilities), but you have 
the option of moving facilities 
cost to direct overhead. 

Labor Detail View: 
Variable 
Costs 

laborCost The cost of labor needed to 
manufacture the part or 
assembly. Usually includes 
hourly wages and benefits. 

Level* Detail View: 
Cost Object 

bomDepth *Required. Indicates depth 
within a BOM structure, with 
1 or 0 being the top level. 
Note: If you specify "0" as 
the top level, the 
Spreadsheet "bomDepth" 
top-level will be "1", and all 
other bomDepth values will 
be incremented by 1. Also, 
there is a Spreadsheet 
Report "Level" which is 
different than the BOM and 
UI "Level".  

Logistics Detail View: 
Variable 
Costs 

logisticsCost The cost of transportation 
between supply chain 
facilities. 

Manually 
Costed 

Cost Guide: 
Basic Options 
(Process 
Group) 

manuallyCosted (True/false) Indicates that 
costs are specified manually 
and are not affected by 
changes to the component's 
GCDs, non-geometric cost 
drivers, or VPE data. 

Margin Detail View: 
Period Costs 

margin Profit built into the 
component cost estimate. By 
default, this is zero in aPriori 
starting point cost models. 

Material 
Cost 

Detail View: 
Variable 
Costs 

materialCost The cost of the material used 
to manufacture the part. 
Includes allocation of scrap 
material wasted during 
manufacturing. Does not 
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include consumable material, 
such as weld wire or 
adhesives, only primary 
material. 

Material 
Overhead 

Detail View: 
Variable 
Costs, Other 

materialOverheadCost Additional cost attributed to 
purchasing, receiving, 
handling, storing, and 
delivering materials used in 
production. 

Model 
Number 

Detail View: 
Cost 
Descriptors 
Cost 
Guide:Compa
ny-Defined 
Attributes 

modelNumber Unique identifying name or 
number for the component. 

Official Detail View: 
Cost 
Descriptors 

official (True/false)  Specifies that 
this is the "Official" scenario, 
which in over-simplified 
terms is the scenario that will 
roll-up into an assembly or 
roll-up by default. See the 
section "Working with official 
scenarios" in the aPriori User 
Guide for more detailed 
information. 
Note that if a component has 
not been initialized, the first 
scenario specified in the 
BOM Loader is made official 
even if this field is False.   
If a subsequent scenario in 
the BOM Loader is marked 
“Official” for the component, 
it will supersede the official 
status of the first scenario. 
The BOM load is processed 
by the order of the rows, top 
to bottom 

Other 
Direct 
Costs 

Detail View: 
Variable 
Costs, Other 

otherDirectCosts The subtotal of Expendable 
Tooling, Additional Direct 
Costs, and Extra Costs. 

Part 
Number* 

"Name": 
Detail View: 
Cost Object  
"Part 
Number": 

partNumber (*Required.) Unique identifier 
for the component; the 
component identifier as 
specified in the CAD model. 
Maps to "Name", "Part 
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Create a 
Virtual Part 
dialog 
"Name/Part 
#": 
Search 
dialog. 

Number", or "Name/Part #" 
in different areas of the UI. 

Piece Part 
Cost 

Detail View: 
Period Costs 

pieceCost The sum of all costs of 
making a part, including 
margin if applied, but 
excluding Fixed (tooling-
related) Costs. 

Product 
Line 
Name 

Detail View: 
Cost 
Descriptors 
Cost Guide: 
Company-
Defined 
Attributes 

productLineName The product line on which 
the component is used. 

Programm
ing Cost 

Detail View: 
Capital Costs 

programmingCost Cost of creating a computer 
program that Computer 
Numerical Control (CNC) 
machines will follow to make 
or assemble parts of a 
specific design. 

Programm
ing Cost 
(amortize
d) 

Detail View: 
Fixed Costs 

programmingCostPerPart Programming Cost per part. 

Project 
Name 

Detail View: 
Cost 
Descriptors 
Cost Guide: 
Company-
Defined 
Attributes 

projectName The name of the project 
associated with this 
component. 

Purchase
d 

Detail View: 
Manufacturin
g Info 
Cost Guide: 
Company-
Defined 
Attributes 

purchased  (True/False) Set to TRUE if 
you are purchasing this 
component from a supplier. 
FALSE indicates that you are 
making the component at 
one of your company’s 
factories. 

Quantity* Detail View: 
Cost Object 

countInParent (*Required.) Quantity of the 
component identified in the 
Part Number field.  Typically 
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has a value of ‘1’ unless the 
Part Number is a component 
within an Assembly and 
appears multiple times in the 
assembly. 

Quoted 
Annual 
Volume 

Detail View: 
Quote Info 

quotedAnnualVolume The quoted number of 
components to be produced 
per year. 

Quoted 
Currency 

Detail View: 
Applies to 
monetary 
fields ONLY 
in the "Quote 
Info" section 
Cost Object 
Info window, 
Quoted Cost 
tab: Currency 
pull-down 
menu 
"View" menu 
> Change 
Currency 
Tools > VPE 
Toolset> 
Deployment 
Data> 
Currency 

quotedCurrencyCode The currency used for the 
quoted costs. All other 
monetary fields are 
controlled by "Currency" (see 
above). 
See the "Managing 
Currencies" section of the 
"Deployment Data" chapter 
of the aPriori VPE 
Administration Guide for 
more information. 

Quoted 
Date 

Detail View: 
Quote Info 

quotedDate The date of the quote. 

Quoted 
Factory 
(Source) 

Detail View: 
Quote Info 

quotedFacilityName The factory or source for the 
quoted cost information. 

Quoted 
Material 
Compositi
on 

Detail View: 
Quote Info 

quotedMaterialCompositio
n 

The material used to create 
the quoted cost. 

Quoted 
Routing 

Detail View: 
Quote Info 

quotedProcessRouting The process used to create 
the quoted cost. 

Quoted 
Total 
Capital 
Investmen
t 

Detail View: 
Quote Info 

quotedCapitalInvestment The total quoted capital 
investment cost to 
manufacture the component. 

Quoted 
Total Cost 

Detail View: 
Quote Info 

quotedFullyBurdenedCost The total quoted cost to 
manufacture the component. 
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Revision Detail View: 
Cost 
Descriptor 
Cost Guide: 
Company-
Defined 
Attributes 

revision The revision number for the 
component. "Revision" can 
be mapped to a CAD 
"revision" property. See the 
"Using CAD Properties" 
chapter of the aPriori System 
Administration Guide. 

Scenario Detail View: 
Cost Object 

scenarioName The name of the scenario 
which this row defines. You 
can specify multiple 
scenarios for a single part or 
assembly; each scenario 
requires a different row. 

SG&A Detail View: 
Period Costs 

sgaCost Sales, general, and 
administrative expenses per 
part. 

Target 
Cost 

Detail View: 
Cost Targets 
Cost Guide: 
Targets 

targetCost How much you want or 
expect the fully burdened 
cost of the part to be, for 
comparison against costing 
results. 

Target 
Mass 

"Target Finish 
Mass" 
Detail View: 
Mass Targets 
Cost Guide: 
Targets 

targetFinishMass How much you want or 
expect your finished 
component to weigh, for 
comparison against costing 
results. 

Total 
Amortized 
Investmen
t 

Detail View: 
Fixed Costs 

amortizedInvestment The sum of all fixed costs. 
Fixed costs must be incurred 
before the start of 
manufacturing. In aPriori, all 
fixed costs are amortized to 
the individual part or 
assembly by dividing the 
total, up-front cost for the 
fixed cost (the capital cost) 
by the total product volume. 

Total 
Capital 
Investmen
ts 

Detail View: 
Capital Costs 

totalCapitalInvestment The total capital investment 
cost to manufacture the 
component.  

Total 
Variable 
Costs 

Detail View: 
Variable 
Costs 

totalCost The sum of all cost items for 
a part, Total Variable Costs 
is the marginal cost 
associated with making “one 
more” part of a give design. 
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This includes all variable 
costs associated with the 
creation of a part but does 
not include depreciation of 
capital tooling.  

Type "Cost Object 
Type" 
Detail View: 
Cost 
Descriptors  
 

scenarioType Valid entries are Assembly, 
Part, or BulkItem. 
Note: "BulkItem" is provided 
for backward compatibility 
and maps to "Part" when you 
import the BOM. 

BOM Loader assumptions 
The BOM Loader uses the following rules to generate components. 

 The loader infers the parent child relationship between components based on 
whether the depth increased/decreases or stays the same as the prior line. If the 
depth increases, the next line is a child, if it remains constant, the next line is a 
peer. If it decreases, the next line belongs to the current line’s parent, or if the 
depth decreases to the top level, the next line becomes a new top-level item. 
Note that you can explicitly set what component type (assembly or part) is to be 
loaded, regardless of Level values, by mapping the Type field.  

 Depth is inferred by the values mapped to the Level aPriori field. Top-level depth 
may either be 0 or 1 – if both are present, 0 is the top level. 

 Quantity describes the quantity for a component described per line item. 
Quantities for like components sharing the same parent are combined. 

 Functional group assignments may not conflict over an assembly’s structure. 
That is, a parent assembly may not be assigned to Functional Group 1 with sub-
assemblies assigned to Functional Group 2. If a parent assembly is assigned to 
Functional Group 1, all its subcomponents will also be found in Functional Group 
1 by association. 

 By default, the currency of the costs for manually costed components  being 
loaded are imported per the setting of the Manually Costed Currency drop-
down menu. aPriori-costed components use the currency from the VPE  
However,  you can specify a Currency column in the CSV file which overrides the 
default setting, only for that row. If the specified currency is not supported, the 
BOM Loader displays an error message and the import does not succeed.  

 The units of the values, such as volume, surface area, dimensions, and mass are 
imported per the Units selection in the BOM Loader. 

 If the CSV file has an “Official” column, any row that is set to TRUE (by a case-
insensitive value of , “true”, “yes”, or “1”) will become the official scenario for that 
part. If more than one scenario for a part has the official column set to TRUE, 
then only the first one will become official; subsequent rows will be ignored. 

 The CSV file accepts an optional “Scenario” column. If the value for a row is 
specified and the scenario exists, then aPriori creates or overwrites a copy from 
the specified scenario based on the selected Processing Rule for existing 
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scenarios . If the specified scenario name does not already exist, then aPriori 
creates a new copy from the official scenario. If no scenario name is specified, 
then the scenario name specified in the Default Scenario Name field is used.  The 
same rules as described above are applied to this default scenario name whether 
or not the component already has such a scenario.  If more than one row exists 
for the same part name and neither have a scenario name specified (or they all 
have the SAME scenario name specified) then only the first row results in a new 
scenario being created -- the subsequent rows will all reference the scenario that 
was created from the first row. If the row indicates that the scenario is a child or 
an assembly or rollup, then the assembly ( or rollup ) only points to the official 
scenario if "TRUE" is in the official column AND the scenario name specified 
ALSO happens to be the official scenario. 

 When a BOM load creates a new scenario for an existing part, it does so by 
copying from the existing part. If your site has implemented Access Control, in 
some situations this can cause the BOM load to fail due to an Access Control 
error -- READ privileges are checked against the existing component, to which 
you may not have access. For more information about Access Control, see the 
aPriori System Administration Guide.  

 When using the BOM Loader to load cost values, the input spreadsheet column 
which indicates whether it is manually costed must NOT be located last in the 
spreadsheet (to the right of other columns/fields that you will map to aPriori 
fields).  If the “manually costed” field is in the right-most position and is mapped 
after the other fields, then the actual (manual) cost values from the spreadsheet 
are not correctly loaded into aPriori. Therefore, organize your input spreadsheet 
so that the column indicating whether a part is to be interpreted as manually 
costed is located in any position other than the last column that gets mapped to 
an aPriori field. 

 Top-level components from the CSV file are added to the output roll-up only if 
there are NO functional groups specified anywhere in CSV file, or if they 
themselves have a functional group specified. 

BOM loader results: The following table provides a high-level summary of what happens 
when you import a BOM: 

Before Import  After Import 

CAD based, manually costed or virtual 
component already exists in database 

The result of this depends on the 
processing rule for existing scenarios: 

•         Update – existing scenario would be 
updated with the specified inputs. 
o   Added cost overrides and other 
mapped inputs 

•         Create a New Scenario – new 
manually costed scenario with “ <scenario 
name> (2)” name would be created.  It 
would be manually costed and use “User 
Guided” process group.  And have all 
specified inputs applied as usual. 

•         Skip – a component scenario from 
CSV file will be skipped to BOM load. 
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No component exists in database  A new component with scenario name 
(specified in “Default Scenario Name” 
field or mapped to “Scenario” aPriori field 
from CSV file) is initialized. This scenario 
became official, since no other scenarios 
present in DB.  It uses the “User Defined” 
process group and the part is manually 
costed. 

When you load a BOM, aPriori does all of the following: 
 Creates new components in the aPriori database for new part numbers. 
 Creates assembly components for new components with child components on 

the following lines.  
 Creates part components for new components without child components on the 

following lines, unless you map a field in the CSV file to aPriori’s Type field, and 
the value of the field is assembly. (Valid values for the Type field are Part, 
Assembly, and BulkItem.) 

 Creates a new Purchased scenario if purchased components are mapped to the 
Purchased aPriori field and the value of the field is Yes. This scenario combines 
component costs for the purchased component into the material cost field and 
ignores the child component costs if the component is an assembly. 

If a component is of type “BulkItem” and has a non-integer quantity, aPriori creates a 
single new component in the assembly or roll-up with an aPriori part number comprised 
of the original part number value followed by the non-integer quantity. 

 Creates a single new component in the assembly or roll-up for the Part 
Number listed with a non-integer quantity. The new component has an aPriori 
part number comprised of the original part number value followed by the non-
integer quantity. 

 Creates a single new component in the assembly or roll-up for the Part 
Number specified as Type:BulkItem. The new component has an aPriori part 
number comprised of the original part number value followed by the non-integer 
quantity. 

Note: New BOM loaded components are created as manually costed with user guided 
GCDs. CAD file association works for new BOM loaded components as specified 
in the section "Changing the file associated with a component" section of the 
aPriori User Guide. Once a file is associated to a new BOM loaded component, 
you must uncheck the Manually Costed box to generate an aPriori process-
based estimate. 

Using the BOM Loader from the 
Command Line 
The BOM Loader provides a command line option which enables you to automate your 
BOM import into aPriori using a task scheduler. This is implemented in a batch file 
command named bomLoad that takes as an argument a configuration file specifying 
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what the BOM load run will do. This behaves exactly as if you had provided the same 
inputs to the BOM loader UI and clicked "Import". 
The template properties file and bomload.cmd file are stored in: 

<aPriori_Install_dir>\bin\bomLoad.cmd 

<aPriori_Install_dir>\ext\bom-cost-loader-plugin\command-
line\bomLoadTemplate.properties 

The bomLoad command has the following syntax: 
bomLoad <propertiesFile> [<username> <password>] 

NOTE: If <username> and <password> are not specified on the command line, they 
are searched for in the properties file. If not found there, and if your aPriori 
administrator has implemented Single Sign On (SSO), the BOM loader attempts 
to use the currently logged-in user’s Windows credentials.  

The following properties can be specified in <propertiesFile>: 
bomLoad.username=<username> 

bomLoad.password=<password> 

bomLoad.deployment =<deployment> 

bomLoad.schemaname=<schemaname> 

bomLoad.bomCsvFile=<pathToBOMCsvFile> 

bomLoad.mapping=<mapping> Note: The specified mapping must exist in the database. 
bomLoad.defaultScenarioName=<defaultScenarioName> 

bomLoad.defaultScenarioProcessingRule=<create|update|skip> 

bomLoad.rollupName=<rollupName> Note: Optional 

bomLoad.functionalGroupTemplate=<functionalGroupTemplate> Note: Optional 

You can configure the bomLoad.cmd script to set custom values for max heap size 
and max perm size by following commented instructions in the script. 

To use the default settings, leave the script as is. It should look like this: 
 

@call "%~dp0runAnt.cmd" -f "%ANT_SCRIPTS%/bomLoad.xml"  
"-Dapriori.propertiesFile=%PROPERTIES_FILE%" "-
Dapriori.user=%USER%"  
"-Dapriori.password=%PASSWORD%" bomLoad 

:: comment line above and uncomment lines below to override max 
heap/perm size. 1020m and 150m are example values, change 
these to the desired memory sizes 

::@set MAX_HEAP_SIZE=1020m 
::@set MAX_PERM_SIZE=150m 
::@call "%~dp0runAnt.cmd" -f "%ANT_SCRIPTS%/bomLoad.xml"  

"-Dapriori.maxMemory=%MAX_HEAP_SIZE%"  
"-Dapriori.maxPermSize=%MAX_PERM_SIZE%"  
"-Dapriori.propertiesFile=%PROPERTIES_FILE%"  
"-Dapriori.user=%USER%" "-Dapriori.password=%PASSWORD%" 
bomLoad 
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To use custom values, comment out the first @call line and uncomment 
the remaining lines under the instructions comment. It should look like 
this: 

::@call "%~dp0runAnt.cmd" -f "%ANT_SCRIPTS%/bomLoad.xml"  
"-Dapriori.propertiesFile=%PROPERTIES_FILE%" "-
Dapriori.user=%USER%"  
"-Dapriori.password=%PASSWORD%" bomLoad 

:: comment line above and uncomment lines below to override max 
heap/perm size. 
1020m and 150m are example values, change these to the 
desired  
memory sizes 

@set MAX_HEAP_SIZE=1020m 
@set MAX_PERM_SIZE=150m 
@call "%~dp0runAnt.cmd" -f "%ANT_SCRIPTS%/bomLoad.xml"  

"-Dapriori.maxMemory=%MAX_HEAP_SIZE%"  
"-Dapriori.maxPermSize=%MAX_PERM_SIZE%"  
"-Dapriori.propertiesFile=%PROPERTIES_FILE%" "-
Dapriori.user=%USER%"  
"-Dapriori.password=%PASSWORD%" bomLoad 

Note: “1020m” and “150m” are example values, these should be set to the desired 
sizes. 

All errors, status indications, and results of the import will be output to the console and to 
log files. 
Log files are saved in <user home>\aPriori\minorVersion\bomLoad-logs 

Java exceptions are output to the log file only. 

To use the bomLoad command 

1 Open a Windows command window. 

2 cd to  <aPriori Install folder>\bin 

3 Enter: 
bomLoad <full path to the bomLoad.properties file> 

The above example assumes that you are providing <username> and <password>  
through the properties file. The bomLoad.properties file must have all the required 
properties specified. Assuming that all supplied properties are valid, all data from the 
BOM csv file will be pushed to the aPriori database and the corresponding scenario files 
will be created or updated. The following info will appear in the console: 
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Between the lines BEGIN BOM LOAD and END BOM LOAD lines are four sections: 

 Inputs -- Contains some of the specified properties in the bomLoad.properties file 
(follows the same order as the BOM Load UI). 

 Mapping – Lists the fields for the specified mapping. 

 Validating – Records the progress of each data row import. 

 Import results – Displays totals (similar in appearance to the BOM load UI). 
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If any of the required properties are not specified, an error message with the missing 
property name(s) is displayed in the console. An example of output for a missing 
defaultScenarioName property is shown below: 

 
Other messages are displayed for errors such as specifying non-existing mappings or 
failing to supply a rollupName property for a functional group template. 

The following screenshot shows an example of the error log file: 
 <user home>\aPriori\minorVersion\bomLoad-logs\apriori.log 
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6 Wire Harness and 
PCBA VPEs 

The separately licensed Wire Harness and PCBA Process Groups are 
implemented as special VPEs. This chapter covers the administration tasks 
associated with Wire Harness and/or PCBA VPE installation, configuration, and 
maintenance.  

This chapter includes the following topics: 
  Managing Wire Harness and PCBA VPEs 
  Adding or Importing User Defined Attributes 
  Importing the Wire Harness and/or PCBA VPE 
 Compiling Component Library Data 
 Maintaining the Component Library 
 Mapping BOM Loader headings 
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Managing Wire Harness and PCBA VPEs 
The separately licensed Wire Harness and PCBA Process Groups are implemented as 
special VPEs that must be imported and configured for your users. The components 
necessary to cost Wire Harnesses and PCBAs (such as VPE, UDAs, Batch File scripts, 
etc.) are typically not shipped with the general aPriori release. Please contact Customer 
Support to acquire these components. 

Note: It is likely that aPriori Customer Support or Services will initially perform these 
tasks for you. Before attempting any of the procedures in this section, make sure 
to communicate with aPriori to check if these steps have already been performed 
for you. 

Some configuration procedures are performed by an aPriori System Administrator, while 
most are handled by an aPriori VPE Administrator. Procedures for System 
Administrators are documented in the System Administration Guide.  Procedures for 
VPE Administrators are documented below.  (For end user information about Wire 
Harness and PCBA Costing, see the "Wire Harness Process Group" and “PCBA 
Process Group” chapters of the aPriori Professional Cost Model Guide.) 
Note: Depending on the size of your site, the roles of System Administrator and VPE 
Administrator might be filled by the same person or by different individuals. Also, as 
mentioned above, some or all of these configuration steps may be performed by aPriori 
Professional Services when you purchase Wire Harness and/or PCBA Process Group 
functionality. If you have any questions as to what steps need to be performed, or who 
should perform them, please contact aPriori Customer Support. 
The basic steps for configuring Wire Harness and/or PCBA Costing include: 

 System Admin: Import or Add User Defined Attributes (see the System 
Administration Guide). 

 VPE Admin: Import the Wire Harness and/or PCBA VPE. 
 System Admin or VPE Admin: Define the Wire Harness and/or PCBA BOM 

Loader Mappings/ 
 aPriori Professional Services: WIRE HARNESS ONLY: Create XML tables for 

the Transformation Utility. 
 System Admin: Install the Wire Harness and/or PCBA Costing Macro files (see 

the System Administration Guide). 
 aPriori Professional Services and/or designated employee(s) at your 

company: Compile Component Library information. 
 VPE Admin: Update the Wire Harness and/or PCBA VPE with the Component 

Library. 
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Adding or Importing User Defined 
Attributes 
Adding/importing User Defined Attributes (UDAs) is a task performed by the aPriori 
System Administrator. See the "Configuring the Wire Harness and PCBA Process 
Groups" chapter of the aPriori System Administration Guide for more information. 
We recommend that your System Administrator add the UDAs at the same time that you 
perform the steps in this chapter. The UDAs must be added before you or your users 
define and map BOM Loader columns for wire harness and/or PCBA. 

Importing the Wire Harness and/or PCBA 
VPE 
You must import the Wire Harness and/or PCBA VPE before you can begin costing. 

1 Acquire the VPE distribution .zip file(s) and place them in an accessible folder. 

2 Log into the aPriori client and click Tools > VPE Toolset. 

3 In the aPriori VPE Toolset window, click File > Import > VPE. 

4 Navigate to the directory containing your VPE distribution file, select the file, and 
click Open. 

Mapping BOM Loader headings 
Before allowing your users to cost wire harnesses or PCBAs, you must configure the 
BOM Loader by mapping BOM column headings to aPriori fields: 

1 Open the aPriori client and select Tools > VPE Toolset. 

2 Click the BOM Loader icon. The BOM Loader opens and prompts you to select the 
file to import.  

3 Select a wire harness or PCBA .csv data import file (NOT the component library file). 
For a new installation, this might be a demo file created for you by aPriori 
Professional Services with a name like “WIRE-HARNESS-001 - formatted.csv”, 
delivered in a folder with a name like “Wire Harness Demo Data”. 

4 Assuming that this is the first import done on your installation, the aPriori BOM 
Loader prompts you to enter a mapping name. Provide a descriptive name such as 
"Wire_Harness" (or “PCBA”). 

5 Ensure that this checkbox is checked in the upper-right corner. 
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6 One by one, click the aPriori Field cell for each Input File Column header and select the 
appropriate plain-English display name as shown in the screenshots below. 
(Different BOM versions may use different naming conventions, such as underscores 
vs spaces and initial caps.) 
Wire Harness mappings:  

 
PCBA mappings: 
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7 Click the Save Changes icon in the upper-left corner when done. 
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Creating Wire Harness XML tables 
This is a step that is performed by aPriori Professional Services, and which is used only 
for Wire Harness, not PCBA. Because different Wire Harness tools generate data in 
different forms, aPriori Professional Services may provide you with customized XML files 
that the Transformation Utility uses to convert your data properly. This section is 
included only so that you are aware of work that occurs behind the scenes for your Wire 
Harness installation. 

Compiling Component Library Data 
The aPriori Wire Harness and PCBA VPEs come with an empty Component Library that 
needs to be populated with current data applicable to your installation. This Component 
Library serves as a cross-reference between your company's approved parts list for wire 
harness or PCBA design (typically using internal part numbers) and manufacturer and 
supplier part numbers along with information such as current cost, life cycle status, etc.  
There are at least a couple of ways that this data can be compiled: 

 Your company may already maintain this information. If so, you can format it and 
import it into aPriori. 

 Your company may maintain only an approved parts list but have a preferred 
method of acquiring corresponding manufacturer and supplier data, and pricing 
information for individual components. In this case, you need to compile the data 
using your company's preferred process, then format it and import it into aPriori. 

 Your company may maintain only an approved parts list but does not have any 
preferred or established process for acquiring corresponding manufacturer and 
supplier data, and pricing information for individual components. In this case, you 
can work with third-party aPriori partner such as Ciiva to acquire real-time pricing 
and availability information from a wide range of different suppliers. As above, 
you then format the output from the third-party and import it into aPriori. 

Note: This initial set-up procedure needs to be done only once. You can periodically 
revisit this procedure to update your information as needed. If you are not sure 
whether or not you need to go through this procedure, contact your Professional 
Services representative. 

If your company provides or compiles the Component Library 
data 
If your company already has (or will compile) data that cross-references its approved 
parts list to manufacturer or supplier part numbers and other information like costs and 
availability, you need to format that data in a table format that can be imported into 
Microsoft Excel (which aPriori uses to import and export Component Library data). Use 
the same general formatting rules that are used to update aPriori Component Library 
data, as described in To update the Component Library lookup tables . 
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If you use a third-party to compile the Component Library data 
Third parties such as Ciiva provide real-time pricing and availability information from a 
wide range of different suppliers. You then upload your wire harness or PCBA data 
(consisting of your approved parts list and their corresponding manufacturer and 
manufacturer part numbers) so that the third-party can return costing information that 
you then use to populate or update your aPriori Component Library.  

Note: In general, you should use the documentation provided by the third-party and/or 
aPriori Professional Services.  However, the general example below based on 
one third-party gives you an idea of what to expect. Further note that you will 
need to map third-party and aPriori terminology to each other. For example, in 
Ciiva a "Product" will typically map to an aPriori "part number".  

1 Whenever your company adds new part numbers, log into the third-party application 
and create/add new components. This typically involves entering the name of your 
wire harness or PCBA and a version number. 

2 Upload your company data. You need to prepare a ".csv" file which is based on your 
company-approved parts list and which at a minimum contains columns for: 
 Base Component Part Number Attribute (internal part number) 
 Manufacturer Component Name Attribute 
 Manufacturer Component Part Number Attribute 
Depending on the third party, you may be able to do things like create a Bill of 
Materials on import, by adding an additional copy of the Base Component Part 
Number Attribute for use as the Designator Attribute. You may also specify the 
Quantity Attribute for each part number. You may also add an extra column to 
designate the Class for new component parts in the third party. aPriori uses this 
attribute to define the name of the customer for which the particular database is set 
up. If no column is added, you have the option to allow for empty class attributes and 
designate a default value. 
Once the .csv file is prepared, upload it to the third party. 

3 Map the fields from the spreadsheet to the third-party fields.  

Note: aPriori terms may not be the same as third party terms. For example, in Ciiva, 
the "Class" attribute should be the customer name, but in aPriori wire harness 
terms, "Class" refers to the high-level designation of what the part is (i.e., 
wire, terminal, connector, etc.)  

4 Complete the import. 

5 Search, add, and confirm supplier parts. 

Note: You will need to repeat this periodically to update costing data. 
Depending on the third party and your requirements, you may need to perform other 
steps such as updating lifecycle status, syncing components, etc. 

6 Obtain pricing Information. 
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7 Export and format component data for import into aPriori, typically through an Export 
to CSV operation. Give it a descriptive name like “aPriori Component Library 
WH.csv” 

Updating the Component Library 
The basic steps for updating your wire harness or PCBA Component Library include:  

 Make a backup copy of your wire harness and/or PCBA VPE. 
 Export the Component Library lookup tables from your VPE to Excel. 
 Update the componentLibrary table in both of your process groups (Assembly 

and User Guided) with current data. 
 Re-import the updated Component Library lookup tables 

To back up your wire harness or PCBA VPE 
Use the VPE Export feature to make a copy of your VPE before performing the 
procedures in this section. See VPE Export operations for details. 

To export the Component Library lookup tables 
This procedure assumes that you are updating your Component Library with output from 
a third party like Ciiva. Adjust the procedure as necessary to reflect your actual situation. 

1 In the aPriori client, click Tools > VPE Toolset. 

2 In the resulting aPriori VPE Toolset window, click the VPE Manager icon ( ), then 
select the wire harness or PCBA VPE from the Select VPE window. For this example, 
the VPE is named Wire Harness; yours may have a custom name, or you may be 
exporting the PCBA VPE. Click Open. 

 

3 In the resulting aPriori VPE Manager window, click File > Export > VPE Lookup tables 
to Excel.  
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4 Specify a name (for this example, "wire_harness_LUT" or “PCBA_LUT”) and click 
Okay.  
This creates an Excel file for every process group in the VPE, as well as an "index" 
spreadsheet for all of the other sheets created by the export. In the case of the Wire 
Harness and PCBA VPEs, there are only two process groups that generate Excel 
files: Assembly and User Guided. TAKE NOTE OF THE FOLDER WHERE THE 
SPREADSHEET IS BEING SAVED. 

 

To update the Component Library lookup tables 
Note: It is important that you update both the Assembly and User Guided process 
groups. 

1 in Excel, open the source file that contains the data you wish to import into your 
component library. (In the example in the previous section, this was the output file 
from a third party and was named "aPriori Component Library WH.csv".) 

2 Open the exported lookup table file for the Assembly process group. (In the example 
in the previous step, this was named "wire_harness_LUT-Assembly.xls".) 
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3 Click on the componentLibrary sheet. 

 

4 Ensure that the columns in the import file spreadsheet match the columns in the 
lookup table spreadsheet exactly. If not,. Modify (or regenerate) the import file so that 
they do. 

 

Note: When you need to remove rows when editing a lookup table spreadsheet, it is 
critical that you do not leave empty rows. If you select one or more rows and 
press the Delete key, you remove the contents of the cells but leave the 
empty rows in place. This will cause problems when you import the 
spreadsheet into aPriori. Therefore, use the right-mouse-click Delete option, 
and ensure that the rows are removed as well as their content. 

5 Carefully copy the cells from the import spreadsheet and paste them into the 
corresponding cells in the Assembly componentLibrary sheet. If you are replacing all 
the information in your Component Library, make sure that no old data remains in the 
target spreadsheet after the Paste. If you are adding new information, make sure 
that you do not overwrite data that you wish to keep. 

6 You must update the User Guided exported file with the same information. You could 
simply repeat the previous three steps, but a more efficient method would be to use 
the Excel Copy command: open the User Guided workbook, delete the 
componentLibrary tab, then copy the updated tab from the Assembly workbook into 
User Guided. 
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Note: It is important that you update the componentLibrary for both Assembly and 
User Guided. 

7 Save and close both files when they have been successfully updated with the data 
from the import file. 

To reimport the Component Library tables 
To re-import the Component Library tables: 

1 Return to the VPE Manager and click File > Import > VPE Lookup tables from 
Excel.   

2 Navigate to and click only the index Excel file.  (This is the one without a process 
group embedded in its name; in this example, "wire_harness_LUT.xls".) 

3 Click Open. 

Note: If aPriori displays an error message when you try to import, double-check that 
you have not selected one of the process group files or another incorrect 
spreadsheet. You MUST select the index spreadsheet.  

4 If replacing existing data with updated data, specify Replace. If you are adding data 
about new components, specify Add to existing data. 

5 Optional: Enter a comment for a log entry describing the update. 

6 Click the Publish VPE icon (  ) when done. 
If you are updating the component library for both Wire Harness and PCBA, you must 
repeat this entire process for the other VPE. 

Maintaining the Component Library 
You should plan to update your Component Library on a regular schedule to keep your 
data current.  
On a frequent basis (perhaps weekly, or on-demand) you will need to add new 
components as they are added to your company's approved parts list. 
On a less frequent basis (perhaps quarterly or annually), update all components with 
current information. 
Consult aPriori Professional Services about a schedule and process that makes sense 
for your installation. 

  
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