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About This Guide 

This section provides information about this User Guide, and the other ways in which aPriori supports 
the aPriori application. 

Key topics include: 
 Overview 
 Related documents 
 Typographic conventions 
 Feedback and customer support 
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Overview 
This User Guide contains detailed information about using aPriori to generate costs for 
parts and assemblies.  

Related documents 
In addition to this guide, you can find more information about the aPriori application in 
the following documents: 
 aPriori Cost Model Guide – This guide contains detailed information about process 

groups and includes a chapter on direct and indirect overhead. Note: This document 
contains chapters that formerly appeared in the aPriori User Guide. 

 aPriori Cost Model Workbench User Guide – This guide explains how to use aPriori’s 
Cost Model Work Bench (CMWB) to customize cost models 

 aPriori System Administration Guide – This guide contains detailed information about 
administering the aPriori solution using the System Admin toolset. It is designed as a 
reference for aPriori system administrators.  

 aPriori VPE Administration Guide – This guide contains detailed information about 
using the tools in the virtual production environment (VPE) toolset to maintain the 
VPEs in your aPriori deployment. It is designed as a reference for VPE 
administrators.  

 Release Notes – This document highlights the changes made in aPriori since the 
previous release. It also contains last minute information about the release.  

 Installation Guide – This guide contains detailed information about installing aPriori. 
 System Requirements – This document provides information on the minimum and 

recommended client and server requirements to run aPriori, as well as the CAD file 
formats supported by aPriori. 

Typographic conventions 
The following conventions are used in this guide to convey additional information. 
 

Style  Description Example 
Code Code style is used for text that is used 

literally, appearing exactly as shown. This 
includes command names, path and file 
names, and system information. 

E:\setup.exe 

Italic 
code 

Italic code style is used for names of 
variables that you must provide. For 
example, you need to supply a value for 
your_file in the path name example to 
the right. 

C:\aPriori\your_file 
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GUI GUI style is used to indicate objects in the 
aPriori interface. 

the Document field 
 

GUI 
Action 

GUI Action style is used to indicate objects 
in the aPriori interface that you click, 
select, or otherwise act upon. 

Click OK. 

Note Notes highlight information, provide supplementary information, offer timesaving 
or easier ways to perform the same task, or explain how to prevent errors or data 
loss. Be sure to read this information carefully. 

Feedback and customer support 
We appreciate your comments about this guide. Please contact us with your comments, 
questions, and requests for technical support. 
 

Websit
e: 

http://www.apriori.com/support 

Email: support@apriori.com 
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1 Introduction 

aPriori is a real-time, accurate cost management solution that allows designers, 
manufacturing engineers, purchasing/sourcing professionals, and management 
to estimate and control product costs throughout the product’s entire lifecycle. 

Key topics include: 
 About aPriori  
 Getting help 
 aPriori interface 
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About aPriori  
aPriori provides real-time visibility to product cost that helps you get from concept to 
customer faster, with a better product. 

How We Do It 
aPriori’s product costing software generates detailed cost estimates and connects all 
members of your product team to relevant views of cost data – from sales to supplier, 
from concept to customer. 

 

Value Proposition 
Real-time transparency to the cost of tradeoffs helps you avoid late stage design churn, 
get to market faster, meet target costs, and achieve your strategic product goals more 
consistently. 
aPriori’s Product Cost Modeling (PCM) technology platform also helps you create a 
culture of profitability across your enterprise where people: 
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 Sell Smarter -- Knowing product cost before responding to customer RFQs lets 
you establish accurate quotes which eliminate surprises and yield more desirable 
margins. 

 Identify & Eliminate Cost Drivers Early -- Design, Sourcing & Manufacturing 
cost drivers can be identified and eliminated before products reach the market, 
resulting in reduced late stage churn and improved product profitability. 

 Negotiate More Effectively with Suppliers -- Awareness of “True 
Manufacturing Cost” enables sourcing teams to identify cost drivers and work 
more productively with suppliers and avoid overpaying for purchased parts. 

Democratization of Cost 
A Product Cost Management platform provides early visibility to cost, consistency of 
costing practices across all members of the product team and higher throughput of cost 
optimized parts, all leading to a more cost-conscious culture where everyone is 
considering profitability with each decision they make. 
Some of the key capabilities and benefits provided to core members of the product team 
include: 

Group/Activities Benefits/Outcome 

Design / Engineering 
 Generate cost estimates for individual 

components or complete BOMs 
representing logical functional groups 
and complete products. 

 Continuously monitor product designs 
against both cost and weight targets. 

 Identify and eliminate cost drivers early 
in the product development process 

 Compare alternative designs to identify 
optimal cost outcomes.(NPI and ECOs) 

 

 Launch new products at or below 
target cost/weight 

 Reduce the number of Value 
Engineering projects, and “get it right 
the first time” 

 Accelerate TTM by eliminating wait 
time for quotes on new product 
designs. 

 

 

Sourcing 
 Evaluate multiple 

sourcing/manufacturing scenarios 
before sending an RFQ to suppliers 

 Understand true manufacturing cost 
before negotiating with suppliers 

 Cost optimize a larger volume of 
components/products using batch 
costing capabilities 

 

 Avoid overpaying for outsourced 
parts 

 Achieve annual cost reduction goals 
 Negotiate more effectively with 

suppliers by concentrating on 
manufacturing data vs. commercial 
pricing. 

 

Cost Engineering 
 Conduct detailed cost analysis on 

complex components to identify and 
eliminate cost drivers 

 Cost optimize a larger volume of 
components/products using batch 
costing capabilities 

 Achieve or exceed annual cost 
reduction objectives, even with 
limited manpower 

 Increase value of individuals and the 
entire program by identifying greater 
savings for the company. 
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 Amplify your cost knowledge 
throughout the enterprise by partnering 
with aPriori to refine and maintain cost 
models/data leveraged by the entire 
product team 

 

 Effectively provide “at elbow” service 
to the product team by embedding 
your knowledge and experience in 
aPriori. 

Technical details 
To arrive at an accurate cost, aPriori models the physics of each machine used to 
manufacture a product. In a typical installation, aPriori requires the user to provide a 
limited number of inputs, including the high-level manufacturing process group (e.g., 
Sheet Metal fabrication or Casting), annual volume, and production life. Then aPriori 
automatically extracts most of the cost-driver data it requires from the CAD model of the 
part. Finally, aPriori uses a technique called Purpose Driven Geometric Assessment to 
determine manufacturing process, time, and cost. 
aPriori does not require a CAD model for all costing operations. In cases where a CAD 
model is not available (such as competitive tear-down and analysis of a product), aPriori 
provides User Guided Costing where you can provide as much information as is known 
or can be estimated about a part product, and then calculate costs based on that 
available information. 
aPriori can calculate costs by importing a CAD file from a wide variety of CAD systems 
into aPriori Desktop, or by running the Cost Ticker with the Pro/ENGINEER and Creo 
Parametric CAD applications.  
When you import a CAD file, aPriori extracts geometry data from the file and allows you 
to perform all costing operations without accessing the originating CAD application. The 
costing information is saved in the aPriori database. aPriori provides the entire range of 
aPriori capabilities in a desktop application. 
Running the aPriori Cost Ticker within a CAD application provides real-time response 
cost information for design changes to the current component. The aPriori Cost Ticker is 
displayed in a small window and provides a limited set of aPriori functions. 

Getting help 
aPriori provides several different types of training and ELearning courses. Please 
contact aPriori Support or Professional Services for more information. 
You can also get help from the aPriori Help menu. Select: 

 Help Contents to display the aPriori documentation set in a web browser (Google 
Chrome, Mozilla Firefox, or Internet Explorer 8 through 11). 

 View License to display the license expiration date as well as the processes, cost 
connectors, and features included in your license. 

 Explore Logs Directory to display the logs folder in your aPriori installation directory. 
If you report an issue to aPriori Support, they may request the information in 
these files to help diagnose the problem. 

Note: aPriori logs could contain unfiltered strings that have been entered by a user. 
To avoid the possibility of a cross-site scripting attack you should avoid using 
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a browser-based utility to review logs. Instead, use a basic text editor such as 
Notepad. 

 aPriori Support to log into the aPriori Support site. 
 About aPriori to display the version number and copyright information. 

The aPriori interface 
aPriori’s graphical user interface (GUI) was designed to generally reflect Microsoft 
standards and contains the usual tool bars, buttons, and windows associated with every 
Microsoft-compliant graphical application. 
As a result, only those features of the GUI that relate to performing aPriori-specific tasks 
are explained in this guide. We assume, for example, that you are familiar with standard 
Windows conventions, such as dragging a window’s title bar to move the window or 
clicking the close button to close the window. 

 
The aPriori Desktop is organized into the following areas: 
Cost Guide – Optionally displayed at the left side of the window. Assists you in providing 
information needed to make an accurate costing of the current component. 
Component scenario tab – Typically displayed in the middle of the window. Lets you 
manipulate the component in 3D in a component viewer; displays cost information on the 
Part Summary, Design to Cost, Cost Summary, Part (or Assembly) Details, and Investment tabs; 
and allows you to modify the cost inputs on the Manufacturing Process and Geometric Cost 
Drivers panes. 
Message pane – Displays information from aPriori as it evaluates the costs associated 
with alternative ways of manufacturing the component. 
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Navigation pane 
In addition to the default areas described above, you can also optionally display a 
floating Navigation pane, which provides two tabs: Component and Open Items. 

 
The Component tab displays information related to the component in the current 
component scenario tab. It contains the following folders: 

 Scenarios – Lists all scenarios associated with the current component. For more 
information, see Working with scenarios on page 66. 

 Where Used – Lists all other components in which the current component is used. 
For example, a part may be included in an assembly, an analysis, a comparison, 
and a roll-up. 

The Open Items tab lists all components currently open in aPriori Desktop, providing a 
quick mechanism for viewing and navigating across these components. The Open Items 
tab contains the following folders: 

 Assemblies – Lists all open assemblies.  
 Parts – Lists all open parts. 
 Roll-ups – Lists all open Roll-ups. 
 Comparisons – Lists all open Comparisons. 
 Analyses – Lists all open Analyses. 

Roll-ups and comparisons support drag and drop functionality. You can drag and drop 
components from the navigation pane to the active roll-up or comparison. 

To expand a folder in the navigation pane 
Click the  icon.  

To open a component within a folder 
Double-click the component or right-click the component and select Open. 
All components in the navigation pane provide right mouse button support. The options 
available on the right-mouse menu vary based on the type of the component. 
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Arranging the aPriori interface 
You can show or hide the navigation pane and the message pane, select one of several 
layouts, and set aPriori’s default layout. 

To show or hide the navigation pane 
Select View > Show Navigation to display the navigation pane. Deselect Show 
Navigation (or click the red “x” (  ) in the upper-right corner of the window) to hide it. 

To show or hide the message pane 
Select View > Show Messages to display the message pane. Deselect Show 
Messages to hide it. 

To select a layout 
Select View > Change Layout then select a layout to adjust the display of the aPriori 
panes. 

To set the current layout as the default 
Select View > Use as Part Default Layout to use the open layout as the default layout 
for parts. When you open a part, aPriori will use this layout. 

Selecting a language for the aPriori interface 
The aPriori interface can be displayed in English, German, or (in SP1 and later) French. 
English is used unless your Microsoft Windows locale is set to Germany or France. You 
can set the Windows locale for your machine, or just for aPriori. 

Note There are some minor limitations when using the foreign-language versions of 
aPriori. Certain items are not translated, including the names of specific VPE 
items, such as materials and machines, Excel report column headings, and 
certain costing error windows and messages. You can obtain a complete list of 
these items from aPriori Support. If your company is interested in making aPriori 
available in other languages, please contact aPriori Support. 

To set the Microsoft Windows locale for your machine 

1 Select Control Panel from the Windows Start menu. 

2 Click Clock, Language, and Region. 

3 Click Change location under Region and Language to display the Location tab of the 
Region and Language window. 

4 Select Germany or France (SP1 and later) from the Current location drop-down 
list and click OK. 
All applications on your machine will use the specified locale. 

To set the Microsoft Windows locale for aPriori only 

1 Open the apriori.properties file in your local aPriori installation directory. 
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2 Add one of the following lines to the file. 
To display aPriori in German, add  
apriori.display.locale=de_DE 

To display aPriori in French (SP1 and later), add  
apriori.display.locale=fr_FR 

To return the display of aPriori to English, remove the line above, or edit it to:  
apriori.display.locale=en_US 

3 Save the file. 

4 Restart aPriori. 
 

Special Characters 
In general, aPriori will accept the following characters when naming components or 
scenarios: 
!@#$%^&()_`~-_=+\|}{[]’;:/?., 
Note that the following characters are accepted but can cause problems later when 
exporting. 
><”* 
Likewise, \ is accepted, but will not show up later when you search for a component. 
Finally, there are a couple of restrictions for naming VPEs which are covered in the VPE 
Administration Guide. 
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2 Getting Started 

This section describes aPriori’s technical requirements, and how to install, start, 
exit, and uninstall the aPriori application. 

Key topics include: 
 Technical requirements 
 Installing aPriori 
 Starting aPriori 
 Exiting aPriori 
 Uninstalling aPriori 
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Technical requirements 
For detailed technical requirements, please see the System Requirements document. 
This document provides information on the minimum and recommended client and 
server requirements to run aPriori and the CAD file formats supported by aPriori. 

Installing aPriori 
For information about installing aPriori, refer to the aPriori Installation Guide. 

Starting aPriori  
You can start aPriori Professional Desktop in CAD-Independent or Direct Integration 
mode for Pro Engineer / Creo only. 

Note: When starting aPriori, you may or may not see a login window asking you to enter 
a username and password. This behavior can differ depending on how your 
aPriori system administrator has configured your system. You should be given 
this information when beginning to use aPriori.  

To start aPriori Desktop in CAD-Independent mode 

Click the aPriori icon  on your desktop. 

To start aPriori from NX, CATIA V5, or SolidWorks 
If you have the "Cost in aPriori" plugin installed in your CAD tool, click the aPriori icon: 

. (These plugins are installed separately from the core product. If you are interested 
in using one, please contact your aPriori administrator.  Note: The Catia and SW plugins 
are available for download from the aPriori Support Site. The NX Cost in aPriori plugin is 
delivered as a custom integration through aPriori Professional Services.) 
This starts aPriori and opens and costs your CAD tool's current part. Your CAD tool may 
require you to specify whether to open and cost a single part or a group of part 
variations. 

Note: If you initiated a component cost using "Cost in aPriori" via CAD, and you change 
the geometry of the component in your CAD application to recost the component, 

press the aPriori icon  again.  This step is required because if you try to 
update your cost directly in aPriori, the system will not be referencing the 
component’s most up-to-date geometry.  

You can also start aPriori and cost the current part by selecting a menu item: 
 NX: Select Cost in aPriori > Cost in aPriori. 
 CATIA V5: Select Tools > Cost in aPriori > Cost in aPriori. 
 SolidWorks: Select Cost in aPriori > Cost in aPriori. 
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If the aPriori icon or menu is not visible in your CAD tool, you can make it visible as 
follows: 

 NX: Select Tools > Customize, select the Toolbars tab, and check the Cost in aPriori 
checkbox. 

 CATIA V5: Select View > Toolbars > Cost in aPriori. 
 SolidWorks: Select View > Toolbars > Cost in aPriori. 

To modify the folder in which your CAD tool looks for aPriori, do the following: 
 NX: Select Cost in aPriori > Options. 
 CATIA V5: Select Tools > Cost in aPriori > Options. 
 SolidWorks: Select Cost in aPriori > Options. 

To start aPriori Desktop in Direct Integration mode for Pro Engineer / Creo Only 

1 Start your CAD application. By default, the aPriori Cost Ticker starts automatically. 

2 Click the  button in the aPriori Cost Ticker to switch to aPriori. 
If you changed aPriori User Preferences to not start aPriori automatically with  
the CAD system, click the aPriori menu in the CAD system and select Start aPriori to 
start the Cost Ticker. If you added aPriori icon to the CAD system toolbar, click the 
aPriori icon to start the Cost Ticker. 

Exiting aPriori 
Select File > Exit from the aPriori menu bar to exit aPriori. 

Uninstalling aPriori 
For details about uninstalling aPriori, refer to the aPriori Installation Guide. 
 



 

aPriori Professional 
2019 R2 aPriori Confidential 12 

3 aPriori Cost Ticker 
Basics 

This section provides basic information on how to use aPriori to calculate the 
cost of a part or an assembly using the Cost Ticker. In Direct Integration mode, 
aPriori starts as a Cost Ticker that can be expanded into aPriori Desktop. In 
CAD-Independent mode, aPriori starts as a Desktop that can be minimized into 
the Cost Ticker. 

This chapter includes the following topics: 
 Starting the aPriori Cost Ticker 
 Costing a component in the aPriori Cost Ticker 
 Expanding the aPriori Cost Ticker 
 Switching to aPriori Desktop 
 aPriori Cost Ticker icons and command buttons 
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Starting the aPriori Cost Ticker 
To start aPriori Cost Ticker in CAD-Independent mode 

1 Click  on your Windows desktop or use the Windows Start menu to start 
aPriori Desktop. 

2 Open a component in aPriori Desktop. See Opening a component in aPriori on 
page 19. 

3 Click the  button in the top right corner of the aPriori Desktop tool bar to run 
aPriori as the Cost Ticker.  

To start aPriori Cost Ticker in Direct Integration mode 
Start your CAD application. The Cost Ticker starts automatically.  

Note You can disable auto startup by changing User Preferences in aPriori Desktop, 
see Starting aPriori  on page 10 for more information. 

Costing a component in the aPriori Cost 
Ticker 
The Cost Ticker displays a summary of a component’s cost. When you open a 
component, the Cost Ticker’s behavior depends on whether this component has been 
costed before.  
By default, One Click Costing™ is enabled, which means that you must explicitly click 
the Cost button to cost the component. However, you can switch from One Click Costing 
to auto-costing, which means that aPriori will automatically cost a component whenever 
it is opened, activated, or changed in the CAD system.  (This was the default behavior in 
earlier releases of aPriori).  To enable auto costing in aPriori Desktop; see One Click 
Costing™ (enabling/disabling auto-costing in response to CAD changes) on page 56 for 
details. 

To cost a new component 

1 Open the component. 

2 By default, when you open a component that has never been costed before, aPriori 
displays a dialog directing you to open the aPriori desktop. Doing so causes the new 
part to be opened in the Cost Guide which helps you provide the necessary 
information to perform an initial costing. 

3 As of Release 2018 R1 SP1, the Cost button will be enabled in the Ticker even for 
new parts if your aPriori system administrator has configured your installation to 
automatically import CAD properties and all inputs needed to cost a part have been 
successfully mapped (Process Group, VPE, Material , and Annual Volume). This 
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enables Design Engineers to generate initial cost estimates while keeping their focus 
their CAD windows and design-related tasks. Note that Batch Size is not required to 
be set to enable the Ticker Cost button. If Batch Size is not available through CAD 
properties, the value is determined by the default aPriori mechanism of computing it 
as a fraction of Annual Volume. 
For more information about mapping CAD properties, see the chapter “Using CAD 
Properties in the 2018 R1 SP1 (or later) aPriori Professional System Administration 
Guide. 
For information about using the Cost Guide, see Initial costing: the Cost Guide on 
page 21. 

To cost a previously costed component 

1 Open the component. 

2 If the component has been costed before, the Cost Ticker displays the last saved 
cost values for the component. The stale clock icon  and gray background color 
indicate that the cost information is not current. 

3 Click Cost.  
aPriori displays progress messages during the costing process. 
When the costing is done, the cost values are displayed. 

 
The clock icon and the background color indicate that the cost information is current. 

Expanding the aPriori Cost Ticker 
To expand the aPriori Cost Ticker 
Click the  button.  
In addition to the current cost of the component, the expanded Cost Ticker shows the 
previous cost and the last saved cost. 
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A green arrow to the left of the cost component indicates the cost has gone down since 
the last update, and red arrow indicates that the cost has gone up. 

To contract the aPriori Cost Ticker 
Click the  button in the expanded Cost Ticker. 

Switching to aPriori Desktop 
To switch to aPriori Desktop 
Click the  button. 

aPriori Cost Ticker icons and command 
buttons 
The following table lists all the icons and command buttons available in aPriori Cost 
Ticker and explains how they are used. 
 

Icon  Usage 

 Click this button to display system messages. The color of the Message 
button indicates the system status: 
 Green – the part has been costed successfully without errors. 
 Yellow – a warning has been produced during costing 
 Red – an error has occurred during costing 
Close messages to return to the Cost Ticker.  

 The Cost Target icon is displayed only if the target cost for the component is 
set. You can set the target cost for a component by editing the component’s 
Production Info in aPriori Desktop, see Initial costing: the Cost Guide on 
page 21 for details. If the target cost is set and the current cost is: 
 Between 90% and 110% of the target cost, the indicator on the Cost 

Target icon points straight up 
 Less than 90% of the target cost, the indicator points to the left 
 More than 110% of the target cost, the indicator points to the right 
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Note You also can set the target mass (weight) for a component in the 
Production Info window, but the Cost Target icon only reflects actual vs. 
target cost status. 

 Click this button to expand the Cost Ticker. 

 In the expanded Cost Ticker, click this button to contract the Cost Ticker. 

 This button is available in Direct Integration mode only. Click this button to 
access the Geometric Cost Drivers (GCDs) options: 
  Select this option to refresh the GCDs from the CAD model and 

calculate new cost using the updated GCDs. Place the mouse pointer 
over this icon to see the date and time when the GCDs were last 
updated.  

Note In CAD-Independent mode, this option is available directly from the 
tool bar.  

  Select this option to view the GCDs for the component. When you 
select this option, the Cost Ticker closes and the aPriori GCDs window is 
displayed. For details about GCDs, see Geometric Cost Drivers on page 
198. To return to the Cost Ticker, close the GCDs window 

 Select this option to refresh the GCDs from the CAD model and calculate 
new cost using the updated GCDs.  
Note In CAD-Independent mode, this option is available from the tool bar. In 
Direct Integration mode, this option is available from the GCDs Options 
menu. 

 Click this button to save the cost object and the displayed cost. If the 
displayed cost is not current, the Save button is not available. 

 This icon indicates that the displayed cost is current, which means that the 
component has not changed since this cost was last calculated. Place the 
mouse pointer over this icon to see when the displayed cost was last saved. 

 This icon indicates that the displayed cost is not current; the component has 
been changed since this cost was calculated. Place the mouse pointer over 
this icon to see when the displayed cost was saved. When the cost is not 
current, the Cost Ticker window is dark grey and the Save button is disabled. 

 Click this button to cost a component. 

 Click this button to switch to aPriori Desktop. For more information, see 
aPriori Desktop Basics on page 17. 
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4 aPriori Desktop 
Basics 

This section provides basic information on how to use aPriori to calculate the 
cost of a part or an assembly using the aPriori Desktop. 

This chapter includes the following topics: 
 aPriori modes 
 Initial costing: The Cost Guide 
 Using the Search tool 
 Changing the file associated with a component 
 Copying cost settings from one component to another 
 Using the Cost Object Info window 
 Component scenario tabs 
 Status messages 
 Saving cost information 
 Refreshing the database connection 
 Changing user preferences 
 Connecting to and disconnecting from CAD 
 Closing a component in aPriori Desktop 
 Switching to aPriori Cost Ticker 
 aPriori Desktop icons and command buttons 
 Cost Status Icons 
 aPriori Desktop table controls 
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aPriori modes 
aPriori Desktop works in CAD-Independent mode or Direct Integration mode.  

CAD-Independent mode 
In CAD-Independent mode, aPriori retrieves the component’s geometry from the 
imported CAD file. Once a component’s geometry has been saved in the aPriori 
database, you can work with the component in file-connected or in file-disconnected 
mode. 
In file-connected mode, aPriori locates the CAD file that provides the component’s 
geometry and constantly monitors the state of this file. Any change in the CAD file is 
immediately reflected in aPriori, which allows you to refresh component’s GCDs as soon 
as component’s geometry changes. You can perform any aPriori operation that requires 
regenerating GCDs on a file-connected component. 
In file-disconnected mode, you work only with component’s data saved in aPriori 
database. In this mode you cannot refresh component’s GCDs, thus you are limited to 
those aPriori operations that do not require regenerating GCDs. 
Note that with 2-Model Machining (see the chapter 2-Model Machining Process Group in 
the aPriori Professional Cost Model Guide), you must be CAD-file connected to both the 
source and finished CAD models in order to extract GCDs. If you change the source 
scenario specified in the Production Scenario tab of the Cost Guide, both the new 
source scenario and the current finished scenario should be CAD-file connected; if either 
is not, aPriori disables Save for the current finished scenario, and any subsequent 
costing relies on GCDs extracted using the old source scenario.   

Direct Integration mode 
In Direct Integration mode, aPriori retrieves the component’s geometry directly from the 
CAD application and constantly monitors its status. This allows you to refresh the 
component’s GCDs as soon as the component’s geometry changes. In Direct Integration 
mode you can perform any aPriori operation that requires regenerating GCDs.  
You can open multiple components in aPriori Desktop in Direct Integration mode. 
However, the component that is active in the CAD application is treated differently in the 
following ways: 

 In the CAD application, the aPriori menu is only available for the active 
component. 

 In aPriori, you cannot close the component that is active in the CAD application.  

Active and inactive scenarios 
You have additional control over when CAD-connected (file-connected or direct-
integration) components get updated with CAD changes. You can specify that a scenario 
is either Active or Inactive. If you set a scenario to “Inactive”, it will not automatically 
update from CAD changes unless you explicitly tell aPriori to refresh its GCDs. This can 
make costing operations go faster, but you run the risk of not capturing recent updates to 
the CAD model.  
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When switching to an inactive sub-component scenario in an assembly (see Switching 
Scenarios in Assembly/Roll-up Details view on page 74), aPriori will warn you: 
“You have selected a scenario that is not active (connected to CAD) and may have different 
geometry than the component that is in this assembly. If you continue, then the component 
scenario's geometry may be different than the component's geometry in this assembly (which is 
connected to CAD). Do you wish to continue?” 

Note: In releases prior to 2014R1, the “official” scenario of a subcomponent in an 
assembly was always considered “active” while other scenarios were 
automatically considered “inactive. The concepts of “official” and “active” are now 
separate, and you can control them independently. 

Opening a component in aPriori 
When you open a component in aPriori Desktop, a new scenario tab opens for the 
component. The name of the component is shown on the tab label. The name of the 
scenario is shown in parenthesis next to the component name. 
The component also displays in the Navigation pane if displayed. 
You can open multiple components and multiple scenarios for the same component in 
multiple tabs. To switch from one component or scenario to another, click on the 
corresponding tab. In Direct Integration mode, you can also switch to a component by 
activating the component in the CAD tool. See also Component scenario tabs on page 
49 and Working with scenarios on page 66. 

Note: You cannot simultaneously open two parts with the same name, but which exist in 
different directories. One example of this situation is obvious: if you open a 
component in aPriori, and then try to open a same-named component from a 
different directory, aPriori displays an error message. A less obvious example of 
this situation can occur with assemblies: If you have a CAD assembly that has 
subcomponents with the same name but which reside in different directories, and 
you try to open this in aPriori, you will get an explanatory error message. To work 
around this situation, you must ensure that the CAD assembly does not specify 
same-named sub-components from different directories.  

Opening a component from a CAD file or CAD system 
You can open an MCAD component, a part or an assembly, from: 

 A CAD file, in CAD-Independent mode. 
 A CAD system, in Direct Integration mode. 

To open a part in CAD-Independent mode 

1 Select File > Open CAD file... The Open CAD file browser opens.  

2 Browse to the directory that contains the desired part CAD file.  
If the directory contains CAD files with the same name and same file type extension, 
but different numeric extensions that follow the file type extension, only the latest file 
will appear in the Open CAD file list box. For example, if the directory contains files 
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cadfile.prt.1, cadfile.prt.2, and cadfile.prt.3, numbered chronologically, only 
cadfile.prt.3 will appear in the Open CAD file list box.  

3 Select the part CAD file. 

4 If you want to open the default (typically “Initial”) scenario, proceed to the next step 
and open the file. If you want to open a different, existing scenario, first type its name 
in the “Scenario name:” field at the bottom of the Open CAD File dialog. If you want to 
create a new scenario for the component, enter it in the “Scenario name:” field. Note 
that the “Scenario name:” field cannot be blank. For more information about scenarios, 
see Working with scenarios on page 66.  

5 Click Open. The part opens in aPriori Desktop.  
When you open a component, the official scenario for the component opens by 
default. To open a different scenario, you must manually select it from the list of the 
component scenarios on the Component tab of the navigation pane. For more 
information, see Working with scenarios on page 66. 

To open an assembly in CAD-Independent mode 

1 Select File > Open CAD file... The Open CAD file window opens. 

2 Select an assembly file using the same procedure described above and click Open. 
aPriori locates all the part files that belong to the assembly. If all the part files are 
found, the assembly opens in aPriori Desktop. 
The assembly components are listed in the Assembly Costs Tab and you can 
navigate the full assembly structure there. To open a component from the list, 
double-click it or select an action from the right-click menu. If the component has 
never been costed before, the Cost Guide is displayed (see Initial costing: the Cost 
Guide on page 21.)   
A component opened from the list of components of a file-connected assembly, also 
becomes file-connected. 

If the CAD file is moved to a different location or deleted while you are working with a 
component opened from this file, the component becomes file-disconnected. The  
icon in the aPriori tool bar becomes greyed out. 

To open a component (part or assembly) in Direct Integration mode 

1 Open the component in your CAD application.  

Note: In Direct Integration mode, the scenario, the default scenario name specified 
in User Preferences is automatically used for newly opened and costed 
components. 

2 Cost the component in aPriori. For more information, see Initial costing: the Cost 
Guide on page 21. 

The  icon on the component scenario tab in aPriori Desktop indicates that this component 
is active in the CAD application. 
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Opening a component from the aPriori database 
Once you have saved the costing information for an MCAD component or created and 
saved a roll-up, a comparison, or an analysis in aPriori, you can open any of these 
components from aPriori database. 

To open a component from the aPriori database using the Search tool 

1 Click the Search button  or select File > Open. The Search window opens. 

2 Enter search criteria in the filter fields and click Find. The list of components and their 
scenarios that match the filter criteria is displayed. See Using the Search tool on 
page 37 for more information. 

3 Select the component scenario that you wish to open.  

4 Click OK. 

To open a recently saved component 

1 Select File > Open Recent. The list of recently saved components is displayed. 

2 Select a file from the list. 

To open a component from the navigation pane 
When an open component has other components associated with it, those components 
are displayed in the navigation pane. Click on a component in the navigation pane to 
open the component in a new tab. 

 In CAD-Independent mode, when you open a part or an assembly from aPriori 
database, aPriori attempts to locate the corresponding CAD file: 

 If the CAD file is found in the folder from which it was opened last time, the part 
or assembly becomes file-connected.  

If the CAD file is not found in the specified location, the part or assembly is file-
disconnected. 
In Direct Integration mode, the component that you open from aPriori database is not 
connected to the CAD system. Only the component that is active in the CAD system is 
connected. 

To open the most recent scenario (keyboard shortcut) 
To open the latest (“most recent”) scenario, use the shortcut keyboard sequence: 
Ctrl-Shift-L 

Initial costing: The Cost Guide 
When you open a component that has never been costed before, aPriori displays the 
Cost Guide at the left side of the desktop. The Guide is a wizard-like interface, divided into 
three tabs that guide you to enter the production, tolerance, and machine & process 
information needed to generate an accurate costing for the component. 
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The display of the Guide is controlled by the Cost Guide button and the Cost Guide 
toolbar.  

 
The Cost Guide is displayed when the button is set and is hidden when the button is not 
set, or when you click the “X” button ( ) in the toolbar. (You can also use the View > 
Show Cost Guide menu option.) 

Note: The Cost Guide is always displayed when costing a component for the first time, 
regardless of the setting of the Guidance button.   

The Cost Guide is useful not only for initially entering cost inputs but also for refining 
those inputs.  You may wish to leave it open most of the time. 
The Cost Guide incorporates and combines features and tools that are found throughout 
the aPriori GUI and presents them in order in one place so that your initial costing can 
be more complete and more accurate. Experienced aPriori users will find that many 
tasks that you formerly performed in different areas of the UI are now much more easily 
accessed through the Cost Guide. Some of these areas include: 

 Production information (otherwise entered on the Production Info tab of the Cost 
Object window). 

 Administration information (otherwise entered on the Administrative Info tab of the 
Cost Object window). 

 Routing choices, presented as a simplified version of the aPriori Routing Selection 
window (otherwise specified from the Manufacturing Process panel Edit > Routing 
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Selection menu). This simplified version emphasizes primary routing 
alternatives. 

 Secondary process choices such as Heat Treatment or Surface Treatment 
processes, presented in an easy-to-navigate check-box format (otherwise 
specified by including these secondary processes within the aPriori Routing 
Selection window (see Selecting a process routing on page 182). 

Note: The reason for this organization of primary routing choices and optional 
secondary process choices in the Cost Guide is so that you would not be 
required to go into the full routing editor to add secondary processes. 
However, this behavior can be customized by a process node attribute -- 
“displayInSPDialog” -- which administrators can modify in the Cost Model 
Workbench:  

Nodes with the “displayInSPDialog” node attribute set to TRUE will appear in the 
Secondary Process dialog and NOT be displayed in the Simplified Routing Editor 
Nodes with the “displayInSPDialog” node attribute set to FALSE (or not defined at all) 
WILL appear in the Simplified Routing Editor and not the Secondary Process dialog. 
Refer to the node attributes section of the Cost Model Workbench Guide for more 
information. 

 Tolerance policy and/or tolerances on individual GCDs (otherwise specified from 
the Manufacturing Process panel Edit > Tolerance menu, or from the context menu 
on individual GCDs in the Geometric Cost Drivers panel). 

 Process setup options (otherwise specified from the Manufacturing Process panel 
Edit > Process Setup Options menu). 

 Machine Selection (otherwise specified from the Manufacturing Process panel Edit 
> Machine Selection menu).   

You do not need to provide every possible value to the Cost Guide. In fact, you could 
perform an initial costing with little or no input to the Cost Guide at all – the Cost Guide will 
not force you to enter values, although it will prevent you from using the Process and 
Machine Options tab until the component has been costed at least once. Such a 
premature costing would not be accurate, but the point is that the Cost Guide is provided 
to make it obvious what cost factors you should consider, and make it easy for you to 
specify those inputs that you decide to provide, when you are ready to provide them. 
To navigate within the Cost Guide, you can use the Next and Back buttons at the bottom 
of the window to proceed to the next logical tab or to return to the previous one. You can 
also proceed directly to a specific tab by selecting the tab labels at the top of the 
window. 

Note: At any time, you can see the inputs you have provided to the Cost Guide by going 
to the Manufacturing Process panel in the aPriori desktop and clicking Edit > Cost 
Overrides Summary. You can also reverse all your overrides from here by 
clicking the Clear All Overrides button at the bottom of the window. For more 
information about the Cost Overrides Summary window, see Working with the 
Overrides Summary dialog on page 122. 

The following sections will step you through the various Cost Guide tabs and fields. 
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Production Scenario Tab, Basic options 
The first (“Production Scenario”) tab is divided into sections for gathering important, basic 
information about your component for costing.  

Note: Your aPriori System Administrator may have customized this tab so that the fields 
and groupings reflect your company’s standards and workflows. This section 
describes how this Cost Guide tab appears out of the box and may differ from 
what you see on your screen. For more information, see the “Managing Dialog 
Views” section of the aPriori Professional System Administration Guide. 

 
Recently used settings: If you have already costed other components and can use 
their values as  a starting point for the current model, use this pull-down menu to either 
select a specific component, or select Choose another... to bring up the Search tool to 
find it (see Using the Search tool on page 37). 

 
Selecting a previously-costed component populates the Cost Guide with the values used 
for that previous costing, and you can either use them as is, or modify them for your 
current component.  
In general terms, Recently Used Settings copies everything.  More specifically, it 
copies all inputs provided for the previous scenario and tries to apply them to the new 
scenario.  All routings and processes are copied, even if they do not apply to the new 
scenario. For example, if you copy from a scenario with 3-Axis Mill pinned, and 3-Axis 
Mill is not feasible for the new scenario, the routing will be copied, but it will fail costing.   
For operation/GCD-level settings, aPriori tries to do some geometry matching to find 
similar features in similar locations.  For example, if you have a hole that has a tolerance 
in your source model, and you copy those settings to a model where the hole has moved 
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a small amount, the match will probably succeed. However, if the hole has moved 
across the whole part, the match will probably fail. 

Note: This functionality applies only to parts, NOT assemblies. However, you can copy 
welds between assemblies as discussed at To copy virtual welds.    

Process Group: Perhaps the single most important setting you need to consider is the 
Process Group selection. When aPriori first encounters a new CAD file, it has no way of 
automatically determining what kind of component it is. So if, for example, you open a 
model of a roto-molded plastic milk jug, and do not change the Process Group setting 
from the default value of Sheet Metal to Roto & Blow Molding before costing the 
component, aPriori will do its best to route the milk bottle through a sheet metal process. 
Obviously the results will not be particularly useful. So, the first thing you should always 
do when preparing to cost a new component is to select the appropriate process group.   

Note: When you select Manually Costed from the Process Group drop-down menu, a 
Currency field also gets displayed, allowing you to change the displayed currency. 
Additional options may also be displayed in this section when you select the 
Casting, Forging, or 2-Model Machining process groups. See the aPriori Cost Model 
Guide f or an explanation of these additional options. 

VPE: The Virtual Production Environment (VPE) is a cornerstone of aPriori costing: this 
represents a virtual factory that typically defines production capabilities and related 
production cost factors such as available machines, process routings, speeds & feeds, 
labor rates, and so forth, at one physical location. aPriori provides a set of Starting Point 
VPEs (formerly called "Baseline VPEs"), which typically are modified at each user site as 
needed. If you need to change to a different VPE (for example, if the component is to be 
manufactured in Mexico instead of the USA), click the “...” button to display the Virtual 
Production Environment Selection window. 

 
If you specify a secondary process such as painting, you can control the selection of the 
VPE for that secondary process either automatically or by manually selecting it as 
follows: 

 If you want the secondary process to be completed in a specific, different area 
than the primary process, select that VPE for that secondary process the same 
way you do as for the primary process. 
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 If you want to automatically use the default VPE for that process, leave Use 
primary VPE as default for secondary processes unchecked. aPriori will use 
whatever default has been defined for that process. (These defaults can be set 
using Tools > VPE Toolset > Deployment Data > Process Groups.) 

 If you want secondary process to be costed using the same VPE as the primary 
process, check Use primary VPE as default for secondary processes. 

Administrators can find more information about VPEs and how to customize them in the 
VPE Administration Guide. 
Process Routing: Process routing is the sequence of manufacturing steps that a 
component must go through to be created. Typically, there are several primary 
alternative routings with differing costs that could be used to accomplish the same end-
result. For example, a cast component may be created by either sand-casting, die-
casting, or permanent-mold casting routings.  There are also secondary processes such 
as heat or surface treatments that can be added after the main work on the component 
has been completed. The default is to have aPriori analyze the various possible routing 
options for a component, determine which are feasible from a manufacturing 
perspective, and of these then choose the most cost-effective one. However, you may 
be aware of specific constraints that make a specific routing necessary.  
To specify the routing, click the “...” button next to aPriori-computed routing to display 
the compact Routing Selection window. (This is a smaller, simplified version of the 
complete Routing Selection window available from the Manufacturing Process panel Edit > 
Routing Selection menu. It shows only primary routing alternatives and not secondary 
processes such as Heat Treatment or Surface Treatment) 

 
You can also specify secondary processes from the Cost Guide by clicking the “...” button 
next to the second option under the Process Routing section (with the default No 
optional process overrides setting).  

 
This displays the Include or Exclude Secondary Treatments window. 
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Select the treatment that you wish to control and then click either Include or Exclude at 
the bottom of the window. Click OK when done. 
Material: Clicking the “...” button next this field brings up the Material Selection window 
that is also available from the Manufacturing Process panel Edit > Material Selection 
menu. Use this to override the default stock chosen by aPriori. See Selecting material on 
page 138 for information about using this window. 
Volume and Batch Size: The values for volume and years are generally self-
explanatory: how many units of this component do you expect to produce annually, and 
for how many years? The batch size value is typically the expected monthly rate, and so 
is usually calculated as volume/12. The batch value is used in many of the calculations 
shown in each of the process group chapters. You can either have aPriori automatically 
calculate the batch value or specify it yourself if the field is enabled via preferences. 
Default values for all these settings are made through Tools > Preferences (see 
Changing user preferences on page 55).   

Production Scenario Tab, Company-Defined Attributes 
The mid-section of the first tab of the Cost Guide contains additional attribute fields.   
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The specific attribute fields that are displayed are configurable and will vary from 
customer to customer. Your aPriori System Administrator may have created User 
Defined Attributes (UDAs – see the aPriori Professional System Administration Guide). 
By default, UDAs will appear in this section of the Cost Guide, but your System 
Administrator may have further configured the Cost Guide so such UDAs may appear 
anywhere. Attributes are used to describe the component and can be used when 
searching for a component, reporting on a component, and may even drive costing-logic 
for a component.  Fields with an asterisk (*) are required and must be provided before 
the component can be costed and saved. 

Note: Your system administrator may have configured these fields and may have set 
them up so that they automatically get populated by properties or parameters 
that are defined in the CAD files. For more information on defining attribute fields 
to be used by your company, and how they appear in the aPriori user interface, 
see the sections on “User Defined Attributes”, “Dialog Views”, and "Using CAD 
Properties" in the aPriori System Administration Guide.   

Here are some Company-Defined Attributes that are provided by default, and how they 
can be used: 

 Description – Enter information that will help you identify the component. 
 Product Line – Enter the product line on which the component is used. 
 Model Number – Enter a unique identifying name or number for the component. 
 Project – Enter the name of the project that includes the component. 
 Revision – Enter the revision number for the component. 
 Cost Type – Select the source that provided the cost information for the 

component. 
 CAD Version – Displays the CAD version aPriori extracted from the component 

file. 
 GCD Extraction Time – Displays the date and time the GCDs were last 

retrieved for the component. This information is provided by aPriori.  
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 Purchased – Check this box if you are purchasing this component from a 
supplier. Uncheck the box if you are making the component at one of your 
company’s factories.  

When you have completed entering information on this tab, you can either: 
 Perform an initial costing by clicking the Cost Now button at the bottom of the 

Cost Guide (or the Cost button on the toolbar), or 
 Proceed directly to the GCD Tolerances tab by clicking the Next button at the 

bottom of the Cost Guide, or by clicking the GCD Tolerances tab at the top of the 
Cost Guide.  

Until you perform an initial costing, you will not be able to use the Process and Machine 
Options tab. 

Production Scenario Tab, Targets 
The bottom section of the Cost Guide Production Scenario tab contains two important 
fields if you have specific goals regarding how much your finished part should cost or 
how much it should weigh. 

 
Target Cost: Specify a value in this field if you know how much you want or expect the 
fully burdened cost of the part to be and wish to compare it to the results of costing 
operations. aPriori provides two ways to easily compare this value against the value 
from a cost run: 

 Cost columns in the Part Details tab 

 
Note: To display the Target Cost column, you may need to select Part Details > 
Table View > Select Table View and either Cost Details or All Data. 

 Cost Target icon 
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Hovering over the Cost Target icon displays a tool tip containing the variance of 
the Fully Burdened Cost from the Target Cost. The color and position of the 
meter in the icon will vary depending on the size of that variance, as described in 
aPriori Desktop icons and command buttons on page 61.  

Target Finish Mass: Specify a value in this field if you have a weight goal for your 
finished component. This is a common element of design, where you want your 
component to be as light as possible, and to use the least amount of material, while 
meeting performance and safety requirements. aPriori calculates the actual weight of the 
component, based on the volume of the CAD model and the density of the chosen 
material, and displays it alongside the Target Finish Mass value in the Part Details tab. 

 
Note: To display the Target Finish Mass column, you may need to select Part 
Details > Table View > Select Table View > All Data. 
 

 

GCD Tolerances tab 
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Use the GCD Tolerances tab to set either an overall tolerance policy for the component, 
or specific tolerance overrides for particular GCDs.  

• To set a tolerance policy for the component overall, click the Tolerance 
Policy… button.  (See Using the Tolerance Policy Editor for more information 
about the tolerance policy) 

• To specify tolerance and roughness requirements for a GCD, first select the 
GCD and then click the Edit Tolerances button.  See Specifying or importing 
tolerance and roughness on page 143 for more information. 

When using this Cost Guide tab, note that: 
• The Tolerance Policy button is always enabled. The Edit Tolerances button 

is enabled when you have selected a GCD that can accept a tolerance 
setting.  

• There is some interaction between the Cost Guide tab and the Geometric Cost 
Drivers panel. Depending on the object, selecting or acting upon something in 
one panel will be reflected in the other.  

• For more GCD details, you can switch to the Geometric Cost Drivers panel and 
display the GCD Properties table to its right.  

• When you edit the tolerance values for a GCD, each override is listed at the 
bottom of the Cost Guide, along with a Revise button. 

 
When done with the GCD Tolerances tab, you may click the Cost Now button or move to 
another Cost Guide tab by clicking the Next button at the bottom of the Cost Guide, or by 
clicking the Process and Machine Options tab at the top of the Cost Guide. 
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Process and Machine Options Tab 

 
The Process and Machine Options tab lets you provide routing-specific inputs, such as 
selecting a specific machine or process setup options for processes included in the 
routing.   
The top portion of this tab displays the selected routing in tree form, similar to the display 
in the Manufacturing Process pane.  The tree displays processes chosen for the routing, 
and under each process specific operations that are used to manufacture specific GCDs. 
If you have not yet costed the current component, this tab will display the message “An 
initial cost must exist before you can override process-specific options.”  Ensure that your 
costing inputs are correct on the other two tabs, and then click the Cost Now button and 
return to this tab. 
Depending on what you select in the process tree, the Set Process Options or 
Machine... button will display a window allowing you to specify a particular machine, or 
(if available) optional settings that can be modified for that machine, or both. If nothing 
can be user-modified for the selection, the Set Process Options or Machine... button 
remains disabled. 
Here is the window that comes up when you select the Punching process for a Bar & 
Tube component: 
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The Process Setup Options tab displays any optional features that the currently selected 
machine allows you to configure.  By default, aPriori checks feasibility rules to determine 
whether the current process should be costed with the current settings. If you wish to 
override this setting and ignore feasibility rules, unselect Check process feasibility 
rules. 
You can select a different machine than the one that aPriori automatically selects by 
selecting the Machine Selection tab. 

 
Selecting Advanced Options displays choices regarding whether or not to check the 
feasibility of that machine, and how to continue if aPriori determines that the machine 
cannot successfully handle the component. (The machine feasibility rules apply to the 
selected machine, while the feasibility checkbox at the bottom of the window applies to 
process feasibility rules.)  
It is important to note that the Machine Selection and Process Setup Options tabs will 
differ significantly between different process groups and different VPEs.  
See Selecting a machine for an operation on page 175, and Editing process setup 
options on page 177, for more detailed information about how to specify machine and 
process overrides. 

Note: In some cases, aPriori will display a Process Setting Option window that contains 
informational messages about values that aPriori has calculated for the selected 
GCD. These windows are read-only, so they are not actually PSOs that you can 
override.  

As with the GCD Tolerances tab, any overrides that you specify will be listed at the bottom 
of the Cost Guide with Revise buttons to allow further modification. 
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Note: Although you typically do not specify Process Setting Options (PSOs) until after 
you have costed the component and proceed to the third tab, you can use a 
shortcut to specify PSOs before aPriori has even extracted GCDs. In the first tab, 
display the Routing Selection window and simply right-click a node. If any PSOs 
are available, the Process Setting Options menu item will be enabled. (The 
following example is from Casting process group.) 

 
See Selecting a process routing on page 182 for information about using this 
window. 

What you can do at different stages 
Costing a component is not an all-or-nothing operation. You can do different things with 
a component at different stages of costing. Knowing this might save you time depending 
on what you need to accomplish. 
When you first open a component, aPriori retrieves visualization information, displays 
the part in the component viewer, and displays the Cost Guide. At this point no GCDs 
have been extracted and no costing information has been processed.  This stage is 
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useful for quickly opening a CAD file and visually inspecting its contents. Since no 
information has been processed, you cannot save the part at this stage. 
As soon as you proceed to the second tab (see GCD Tolerances tab on page 30), the 
GCDs are extracted. At this stage, even though you have not yet costed the component, 
you can save it along with its automatically-generated thumbnail. This means that the 
component will now be viewable in search results, although its cost information will be 
blank or “0”. 
The final stage is costed: the component will appear in search results, and cost fields will 
be populated with values based on the most recent cost operation. 

Costing with CAD Properties 
Your aPriori system administrator may have configured your system to automatically 
extract properties or parameters from the CAD file and map those values to aPriori 
production inputs or User Defined Attributes (UDAs). If your CAD parts contain all the 
information that aPriori needs to successfully perform a costing (Process Group, VPE, 
Material , and Annual Volume), it is now possible to cost a part as soon as you open it, 
without the need for manually entering such information in aPriori. If you perform a role 
such as Design Engineer, this allows you to concentrate on part design and cost parts 
without worrying about production details that might be outside of your area of expertise.   

Note: You should still review any automatically-populated inputs to ensure that they 
seem reasonable for the part you are costing. 

This section concentrates on the production inputs that can be automatically mapped 
from CAD properties. Additional details and capabilities such as mapping to UDAs are 
discussed in the aPriori Professional System Administration Guide. The discussions in 
this section concentrate on the aPriori Professional user interface, but also apply to Bulk 
Costing (see Bulk Costing and Analysis).  
If this feature is implemented for your installation, you should be aware of the following 
changes from an installation where automatic CAD property extraction is not 
implemented: 

 Fields in the Cost Guide may be automatically set and updated without the need 
for you to manually enter values. 

 Properties that change in the CAD file may cause a Reconcile Inputs window to 
pop up, to allow you to tell aPriori whether to accept the new values or continue 
to use previously-entered aPriori values. For more information, see Reconcile 
Inputs below. 

When the values for aPriori fields are initially supplied from CAD properties, you can 
override those values in aPriori to explore the cost impact of different manufacturing 
scenarios.  Once you override a production input that is mapped to a CAD property, your 
override value continues to be used for subsequent costings unless it is cleared. There 
are two ways to clear the override: 

 By using the Cost Overrides Summary dialog (see Working with the Overrides 
Summary dialog) 

 By using the Reconcile Inputs dialog (see the following section).   
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Reconcile Inputs 
The Reconcile Inputs dialog informs you of CAD data changes that could significantly 
impact the aPriori cost estimate, and lets you determine how to proceed.   

 
This window appears only when: 

 A scenario already has been costed in aPriori. 
 The values of one or more CAD properties that are mapped to production inputs 

subsequently change in the CAD file. 
Rather than immediately changing the production inputs with the changed data and re-
costing the scenario, the Reconcile Inputs dialog will display that the CAD field value that 
now disagrees with the previously-used value for that input. For each field that has 
changed, you can then decide whether to use the updated value from the CAD file or to 
continue using the previously-specified value.  
The Reconcile Inputs dialog also provides some basic validation – it can tell you if you’ve 
selected an input which is not valid, either by itself or in the context of other selections.  
For example, in the following screenshot: 
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The CAD file had been updated to include a material “ZA6” which was not available in 
the selected VPE.  (Or, if the CAD file had contained a VPE name which didn’t exist in 
your deployment, it also would be flagged as invalid.)  This gives you the opportunity to 
change your selection. If you go ahead and click OK anyway when something is flagged 
as invalid, aPriori attempts to replace it with a default, or will fail to cost.  Specifically, it 
will use a default Material from user preferences or from the VPE’s default material, and 
for other fields generally will fail to cost. 

Using the Search tool 
Use the Search tool to find a cost component or group of components that meet specific 
criteria. The Search tool is available: 

 From the Search toolbar button   
 When opening a cost component (select File > Open) 
 When deleting cost components (select Tools > Delete Components) 
 When adding cost components to a rollup (select Edit > Add Component from within 

the rollup) 
 When copying cost settings (click the Copy From button in the Production Info or Cost 

Object window, or Recently used settings > Choose another... in the Cost Guide) 

 
Use the Search Criteria panel on the left to display all matching components and their 
scenarios on the right.  For example, to display all parts and assemblies, click the Part 
and Assembly checkboxes under Component Type then click Find. 

Note: System Administrators can control several aspects of the Search tool. They can 
set a system variable to restrict the display of search results to only those 
components to which the user has access. (This applies only to sites that have 
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implemented Access Control.) They can also turn on and off the display of 
searchable attributes in the Search Criteria panel, including searchable User 
Defined Attributes (UDAs). Administrators can also rearrange the order of search 
attributes. What you see on this screen may differ from the screenshots shown in 
this section. For more information about access-restricted searches, User 
Defined Attributes, and customizing the Search Criteria panel, see the aPriori 
System Administration Guide. 

You can combine any or all of these criteria to help you find cost components. If you do 
not wish to constrain your search by a given criteria, then leave that field blank. A  
While most of the search criteria fields are specified using drop-down menus or calendar 
controls, some of the search criteria fields allow you to enter text into the search field. 
These include Name/Part #, Description, Part Descriptor (which maps to an internal CATIA V5 
part name for SmarTeam, converted to lower case). You can use implied wildcards in 
these text fields. For example, if you type abc into the Name/Part # field, the Search tool 
will display all components with names containing the characters abc.  
Note that the Search tool displays all scenarios for a specific cost component (assuming 
that you have access permissions to them).  See Working with initial scenarios on page 
70 for more information. 
If your site implements Access Control and has set the system variable described above 
to display only results to which you have access, there may be a delay before you start 
to see results appear in the window. For example, if Search processes 10,000 scenarios 
before encountering one that passes the permissions check, it may be a while before 
you see the screen update with this result. The Search window now provides a Progress 
bar to inform you of how far the operation has proceeded through matching scenarios. 

 

Note: You can cancel a search by closing the search window. You can also reset the 
existing search by choosing different criteria and clicking Search again. 

Changing the file associated with a 
component 
Change the file association when the CAD file associated with a costed component has 
moved or if you want to associate the costed component with another file with the same 
name. 

Note: The "CAD File Association" option is only available in standalone aPriori, not in 
direct integration mode. 

To change the file association 

1 Save a scenario of the component to prevent data loss in case the file has significant 
geometry changes or was created in a different CAD system. 
For more information, see Working with scenarios on page 66. 

2 Select File > CAD File Association to display the Select New File Association 
window. 
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3 Navigate to the file you want to associate and select it. 
The file name must match the component name to change the file association. If the 
file name has changed, you must open a new component and copy the original cost 
settings instead. For more information, see Copying cost settings from one 
component to another on page 39. 

4 Click Open to associate the selected file with the costed component. 

Copying cost settings from one 
component to another 
Copy the cost settings from another costed component when you use aPriori to cost a 
part defined by a CAD file, then change the CAD filename. Copy the cost settings to 
avoid losing any costing changes you made when aPriori was referencing the previous 
file name.  
You may also want to copy the cost settings from another component to speed costing 
for parts that are identical or highly similar to previously costed parts. For example, if a 
component changed a part name or number, copying the cost settings lets you avoid 
manually re-specifying all the cost inputs for that component.  
You also have the option of copying either a single scenario or all scenarios from one 
component to another. 
You can also copy some or all of the cost settings for an assembly to each of the 
assembly’s children. 

To copy the cost settings from another costed component 

1 Select Edit > Production Info from the Manufacturing Process pane to display the 
Production Info window. 
You can also click Copy From on the Cost Object for an uncosted component. In an 
assembly, select an uncosted component in the component viewer or Geometric Cost 
Drivers pane, right-click it, and select Initialize from the context menu to display the 
Production Info window. 

2 Click Copy From to display the Copy Component From Existing window. 

3 Search for the donor component that contains the cost settings you want to copy. 
For more information, see Using the Search tool on page 37. 
To copy all scenarios of the donor component, select only the component’s entry in 
the Name/Part # column in the upper pane. 
To copy a single scenario, after selecting the component in the upper pane, also 
select the desired scenario in the lower pane. 
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4 Click OK to re-cost the recipient component using the cost settings copied from the 
donor component. 
When you copy cost settings from another costed component, aPriori maps GCDs 
and GCD settings from the donor component to the recipient component. Any GCDs 
that aPriori cannot map to the recipient component’s geometry are discarded. aPriori 
then creates new GCDs for recipient component geometry, as necessary. The GCD 
mapping works best for highly similar or identical parts, but we recommend that you 
confirm the correct mapping for all manually applied GCD settings by checking your 
green user  input indicators. 
Copied information will include component-level settings (such as process group, 
annual volume, VPE, and manually selected routings) and GCD-level settings (such 
as tolerance and roughness settings or manually selected operation sequences). 
If the component in aPriori is not connected to a CAD file, aPriori will copy all the 
donor component settings into the recipient component, including the appearance of 
the donor component. Once you connect the recipient component to a CAD file, its 
GCDs will automatically update to match the CAD file’s geometry. 

Copying assembly cost settings to children 
You can selectively copy the cost settings (including any user-defined attributes) applied 
to an assembly to the children of that assembly. Note: When Annual Volume and Batch Size 
values are copied to children, they are multiplied by the child quantity. Thus, if the 
assembly's annual volume is 10 and it has a child component that has a quantity of 5, 
then the child will get an annual volume of 50. 

To copy assembly cost settings to children 

1 Open an assembly. 

2 Select Scenario > Copy assembly inputs to children. (This is only visible for assemblies.) 
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3 Use the checkboxes in the resulting Select Assembly Inputs to Copy dialog to specify 
which values to copy. If you have user-defined attributes, use the scroll bar to view 
them at the bottom of the list. Click OK when done. 

 

Using the Cost Object Info window 
The Cost Object Info window contains many of the same fields as the Cost Guide (see 
Initial costing: the Cost Guide on page 21), and can be used to change settings for your 
component. aPriori displays the Cost Object Info window when you click Edit > 
Production Info, Edit > Administrative Info, or Edit > Quoted Cost from the 
Manufacturing Process panel. 

Note: Your aPriori System Administrator may have customized the Cost Object Info tabs 
so that the displayed fields reflect your company’s standards and workflows. This 
section describes how this Cost Object Info tabs appear out of the box and may 
differ from what you see on your screen. For more information, see the 
“Managing Dialog Views” section of the aPriori Professional System 
Administration Guide. 
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The Production Info tab 

  
You can specify the following information on the Production Info tab: 

• Select the process group from the Process Group drop-down list to make that 
group the default for subsequent new components. 

• If you need to modify the default VPE, click  next to the VPE field to display 
the Virtual Production Environment Selection window. 
The default VPE is specified by the selected process group.  

• Check the Use as default VPE for secondary processes box if you want 
secondary processes, such as heat treatments and surface treatments, to 
always use the same VPE as the primary process group, even if the VPE is 
changed. 

If the secondary processes are frequently performed at a different location than 
the primary processes, uncheck this box. 
• If you need to modify the default material, click  next to the Material field to 

display the Material Selection window. 
The default material is either the MCAD material value or the VPE default.  

• Enter the number of parts to be produced in one year in the Annual Volume 
field. 

• Enter the length of the product life cycle, in years, in the Production Life 
field. 

• Select the costing method. Select aPriori if you want aPriori to compute the 
component cost. Select Manual and select the currency from the drop-down 
list to enter the component cost. 

• Select the batch size. This is typically one month’s production. Select aPriori 
to have this automatically calculated from your Annual Volume/12. Select 
Manual to enter a specific value. 
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• Specify a value in the Target Cost field if you know how much you want or 
expect the fully burdened cost of the part to be and wish to compare it to the 
results of costing operations. (See Production Scenario Tab, Targets on page 
29 for more details about how to use this value.) 

• Specify a value in the Target Finished Mass field if you have a weight goal for 
your finished component. (See Production Scenario Tab, Targets on page 29 
for more details about how to use this value.) 

The Administrative Info Tab  
Use this tab to enter company attribute information about the component. 

 
See Production Scenario Tab, Company-Defined Attributes on page 27 for more 
information about the fields on this tab. 

The Quoted Cost Tab 
Use the fields on this tab to enter information that is used in cost per mass analyses and 
to compare it to the aPriori cost estimate. It can also be used in reports. 
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The following fields are available: 

• Factory (Source) – Enter the factory or source for the quoted cost 
information. 

• Material Composition – Enter the material used to create the quoted cost. 
• Process Routing – Enter the process used to create the quoted cost. 
• Total Cost – Enter the total quoted cost to manufacture the component. 
• Total Capital Investments – Enter the total quoted capital investment cost to 

manufacture the component. 
• Currency – Select the currency used for the quoted costs. 
• Annual Volume – Enter the quoted number of components to be produced 

per year. 

• Quoted Date – Click  and select the date of the quote. 

Notes about purchased parts 
You can specify that a component is a purchased part in several places within aPriori, 
including the Purchased checkbox in the Administrative Info areas of the Cost Object Info 
dialog, the Cost Guide, and the Bulk Loader, as well as the mapped Purchased field in the 
BOM Loader. Parts designated as "purchased parts" will be reflected as material costs 
for the assemblies in which they are included. This means the cost breakdown will match 
typical customer cost accounting practices.  The full detailed cost breakdown for the 
purchased part still can be viewed by opening the individual component.  In aPriori 
releases earlier the 2014 R1, the behavior of this feature could differ depending upon 
where it was set, but now the behavior is standardized throughout the product. For 
purchased parts: 

 material cost = piece part cost (PPC) 
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 all costs which are used for PPC calculation except % margin are zeroed out, but 
only for the component level 

 fully burdened cost = piece part cost + total amortized investment 
 rolling up costs is only available if a purchased component is inside an assembly 

or any other container. Otherwise it is a regular part/assembly. 

Note: In aPriori Release 2015 R1, the BOM Loader re-introduced the option of 
aggregating purchased part costs through a new checkbox. By default, the BOM 
Loader simply maps the Purchased Flag column to the Purchased Part checkbox 
specified in Administrative Info.  

Subsequent costing and costing with scenarios 
When you open a component that has been costed before, aPriori Desktop displays the 
saved cost information for the component on the Cost Object window. To display this 
window or edit production, administrative, or quote information, select Production Info, 
Administrative Info, or Quoted Cost from the Edit menu on the Manufacturing Process 
panel.   
aPriori provides several ways to update costing as a component changes: 

• auto-costing – Depending on a number of factors and settings described 
below, aPriori can sense when an object’s CAD information has changed and 
automatically recost the component 

• Cost buttons ( ) – aPriori provides Cost buttons at various places 
throughout the interface. Click this button when you want to manually initiate 
a costing operation. 

• The Cost menu – This menu exists in the aPriori menu bar and provides 
advanced costing options such as costing multiple component scenarios and 
“deep” costing of children components within assemblies. 

You can define different scenarios for parts, assemblies, cost comparisons, and roll-ups, 
and explore the impact of different inputs on the cost of a component. A part or 
assembly’s initial scenario is the official scenario by default. You can specify another 
scenario to be official. The official scenario is the default scenario to roll into an 
assembly depending on the setting of the Tools > User Preferences > Use Official 
Scenarios in New Assemblies, and if a specific scenario is not otherwise specified.  
This is the one that is costed when you perform a “deep cost” operation (Cost> Deep 
Cost Scenario & Children). This allows you to select a specific component scenario to 
roll into an assembly or to use the designated official scenario in a specific assembly.  In 
the latter case, changing which scenario of a component is designated as official will 
result in changing which scenario rolls into the assembly. Only one component scenario 
may be designated "Official". You can use the right-click Switch Scenario feature in the 
Assembly Details view to choose another scenario for child components other than the 
official one.  (Note that subcomponents must be initialized before you can switch 
scenarios.) You can cost all child scenarios, both official and non-official, by clicking 
Cost> Deep Cost All Scenarios. See Working with scenarios on page 66 for more 
information. 

Note: When you specify that the official scenario of a sub-component is to be used, the 
Assembly Details display will show that component with parentheses around the 
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scenario name. In the following screenshot, both 
AP_SHEETMTL_EXERCISE_EL0000 (which has a new scenario that is official) 
and WELD_SUPPORT_EL0000 (whose original "initial" scenario is official) have 
been specified to use their official scenarios.  

  
Unless a scenario has been set to “Inactive”, CAD changes to a CAD-connected part will 
be automatically picked up when the scenario is costed. However, if no CAD changes 
have occurred since the last costing, aPriori will not refresh GCDs in subsequent 
costings, even if the component is CAD-connected and set to “active”.  To refresh GCDs 
for an inactive scenario you can either: 

 Click the Refresh GCDs button (  ) on the aPriori toolbar. 
 Select Refresh GCDs from CAD Model from the right-click context menu in the 

Navigation pane.  

Subsequent costing in CAD Independent mode if the component is file-
connected 
aPriori checks the CAD-file for GCD changes done since the current cost was saved. 
aPriori can only detect the changes that have been saved into the CAD-file.  
If aPriori detects no changes in the CAD file, the current costing information is displayed. 
The  icon in the Cost Outputs pane indicates that the cost is current. 
If aPriori detects changes in the CAD file and if the scenario is not specified to be 
“Inactive” and One Click Costing™ is: 

 Off: aPriori immediately costs the component and displays the new cost 
information. (Disabling One Click Costing is the same as enabling auto-costing.) 

 On: aPriori displays the existing cost information, but the Cost Outputs pane is 
disabled and the  icon indicates that the cost is not current. Click  to cost 
the component.  

To cost an inactive scenario based on the most up-to-date CAD changes, you must click 
 in the aPriori toolbar to refresh GCDs. (But you can always cost an inactive scenario 

with the existing GCD data.  
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Subsequent costing in CAD Independent mode if the component is file-
disconnected 
aPriori has no way to detect GCD changes. The cost information is displayed as current. 
You are not allowed to perform any operations that require regenerating GCDs. 

Subsequent costing in Direct Integration mode 
aPriori checks the CAD system for GCD changes done since the current cost was 
saved.  

If aPriori detects no GCD changes, the current costing information is displayed. The  
icon in the Cost Outputs pane indicates that the cost is current. 
If aPriori detects GCD changes and if the scenario is not specified to be “Inactive”, then 
aPriori displays the existing cost information, but the Cost Outputs pane is disabled and 
the  icon indicates that the cost is not current. Click  to cost the component.  
To cost an inactive scenario based on the most up-to-date CAD changes, you must click 

 in the aPriori toolbar to refresh GCDs. (But you can always cost an inactive scenario 
with the existing GCD data.  

Using the Cost menu 
The Cost menu is useful for costing parts with multiple scenarios and assemblies with 
multiple sub-components and multiple scenarios. The options on the Cost menu invoke 
the same interface as the separately-licensed Bulk Costing and Analysis utility, but the 
features available from the Cost menu do not require a separate license.  
Here is a summary of the options on the Cost menu: 
Cost> 
 Cost Scenario – Cost just the current scenario for the selected component. 
 Cost All Scenarios – Cost all scenarios for the selected component. 
 Deep Cost Scenario – (Assemblies, Roll-ups, and Cost Comparisons only.) 
Cost the current scenario for the selected component, and the scenarios of all of its 
children.  
 Deep Cost All Scenarios – (Assemblies, Roll-ups, and Cost Comparisons only.) 
Cost all of the scenarios for the selected component, and all of their children. 
Note that when you perform a deep cost, aPriori will check all of the sub-components to 
see if any are open in the main UI with unsaved changes. If so, aPriori will prompt 
whether you want to save and close that component, leave it unsaved, or cancel the 
deep cost operation. It is important to realize that regardless of what you choose, the 
results of the deep cost will be determined by the inputs on the Bulk Costing and 
Analysis table, or any user inputs file, not by the changes to the sub-component in the 
UI. 
When deep costing assemblies, note that: 

 If a sub-component (scenario) with unsaved changes is open in the main UI, 
aPriori copies the sub-component scenario to the Bulk Cost Group. If a sub-
component is not open in the main UI, the component state is read from the 
database. 



aPriori Desktop Basics  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 48 

 If a sub-component does not exist in the database (and therefore cannot be 
opened), a new component scenario is created with default values. However, the 
component must be associated with a CAD file (unless the component is being 
costed in the User Guided process group). If an assembly has been initialized, 
the immediate sub-components are automatically associated with CAD files even 
if they have not been initialized. For deeper level children, aPriori assumes that 
those sub-component CAD files are located in the same directory as the root 
assembly.  If that is not the case, you must ensure they are CAD-file associated 
prior to clicking on Deep Cost menu 

When you deep cost an assembly and view the Bulk Costing & Analysis UI, the scenario 
of the top-level assembly is the same as the one you selected in the main aPriori UI. The 
sub-components are set to whatever scenarios are associated with this assembly – this 
may have been switched by the user in the UI or may have been specified during BOM 
loading. If nothing else has been specified, the Official scenario is the default. 

Note: You can deep cost a roll-up or a cost comparison with Cost-> Deep Cost 
Scenario, but only their sub-components will appear in the Bulk Cost Group. The 
roll-up or cost comparison themselves do not associate with any cost and 
therefore will not be costed. However, if a roll-up contains a sub-roll-up, then the 
components from that sub-roll-up are also included in the costing. 

To cancel a costing operation 
Once aPriori begins a costing operation, you can cancel it if a Cancel icon appears in 
the lower-right corner of the window: 

 
It is not always possible to cancel a costing operation. For example, the Cancel icon is 
not available from the Bulk Costing & Analysis window. 
When aPriori cancels a costing operation, note that: 

 The cancellation affects only costing; it does not affect GCD extraction. If you 
click the Cancel icon during GCD extraction, nothing will get cancelled until the 
GCD extraction is complete. 

 No routing is selected. (I.e., aPriori does not just pick the best routing up until that 
point).  

 The Manufacturing Process window displays information similar to what is shown 
when an error occurs during costing: aPriori displays red Xs as necessary with 
tool-tip text that reads “Costing Cancelled – previous manufacturing info shown”.  
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 In the Cost Summary tab, the information in the Current column moves to the 

Previous column and the Current column remains blank. Note that if you cancel 
two times in a row, the Previous column is not updated to blanks. Again, this 
behavior is similar to what happens when a costing error occurs: the Previous 
column simply displays the last successful, fully-costed results. 

 The Cancel icon works on a per-costing basis: whatever part is being costed 
when Cancel is clicked is what gets canceled, nothing more. If you are in an 
assembly and select multiple subcomponents that are uninitialized and select 
initialize, cancelling affects whichever part is currently being costed. aPriori then 
moves on to the next part and starts costing that one. The Cancel icon will not 
cancel all parts that are currently queued up for costing. 

More About Costing 
This section has introduced only the basics about costing. With aPriori, you can perform 
sophisticated costing operations with different scenarios, and by controlling factors such 
as whether to cost just at the top level of an assembly, or to “deep cost” all of the 
assembly’s children parts, and their scenarios. You can also apply some or all of an 
assembly’s production input values to its children, using a single command. 
For more information, see Using the Scenario Menu on page 67 and Bulk Costing and 
Analysis  on page 280. 

Component scenario tabs 
In aPriori Desktop, every component scenario is displayed in a separate tab. (For 
information about scenarios, see Working with scenarios on page 66.) To switch from 
one scenario to another, click on the corresponding tab.  

Note In Direct Integration mode, you can also switch to a specific MCAD component 
scenario by activating that component in the CAD tool. 
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An asterisk next to the component name on the tab label indicates that the scenario has 
been edited but not saved since the last time it was retrieved from the database. If no 
asterisk is shown, all edits have been saved. 
A part or an assembly scenario tab includes the following:  

 Component Viewer 
 Cost Outputs 
 Manufacturing Process 
 Geometric Cost Drivers 

For a part, the Cost Outputs section includes tabs for Part Summary, Design to Cost, Cost 
Summary, Part Details, and Investment, which are discuss in Chapter 9, aPriori Cost Tables. 
Assemblies do not have a Cost Summary tab, and have an Assembly Details tab instead of 
a Part Details tab. 

To change the component scenario tab layout 

1 Select View > Change Layout. 

2 Select one of the five available layouts. 

3 To make the selected layout the default choice for part or assembly, select: View > 
Use as Part Default Layout or View > Use as Assembly Default Layout. 
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Component Viewer 
The Component Viewer provides a three-dimensional image of a part or an assembly. 
The image is automatically saved to the database and is available whenever the part or 
assembly is opened. 
 

Icon
  

Function Usage 

 Reset Click this icon to reset the image to its original state.  

 Select Click this icon, then click anywhere on the image to select a 
specific Geometric Cost Driver (GCD). The selected GCD is 
highlighted in the Geometric Cost Drivers table and 
information related to this GCD is displayed. 
To select multiple GCDs of the same type, for example, 
multiple holes or welds, press the Ctrl key and click GCDs one 
by one. 
To deselect a selected GCD, press the Ctrl key and click the 
selected GCD. 

 Marquee 
Selection 

Use this tool to draw a box on the screen and select all GCDs 
within that box of the same type. Choose from: 
Bending/Forming, Volume, Holes, Surfaces, Joining, Other, 
Not Supported 

 Zoom To zoom in, click this icon, press the left mouse button and 
move the mouse toward you. 
To zoom out, click this icon, press the left mouse button and 
move the mouse away from you. 
Alternatively, move the middle mouse button wheel forwards 
and backwards to zoom in and out. 

 Pan To move to a certain part of an image, click this icon, press the 
left mouse button, then move the image by moving the mouse. 
Alternatively, press the Shift key and the middle mouse button 
to move the image. 
Panning is especially useful when the image is zoomed out so 
that it does not fit into the Component Viewer. 

 Rotate To rotate an image, click this icon, press the left mouse button, 
and move the mouse. Alternatively, press the middle mouse 
button and move the mouse 

 Render 
mode 

To change the way the image is displayed, click this icon and 
select Solid, Wireframe, Transparent. 

The viewer also provides the following shortcuts when you click on the origin symbol in 
the lower left of the view: 
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 Click on the origin: Reset. The part will snap to standard orientation, based on 
the position of the cursor relative to the axes on the origin. Continuing to click will 
toggle between different axes. 

 Click and hold on the origin: Rotate. The part will rotate about its centerpoint (as 
opposed to the Rotate operation described in the table above, which causes the 
part to rotate in relation to the position of the cursor). 

 CTRL-click and hold on the origin: Zoom. 
 SHIFT-click and hold on the origin: Pan. 

The Component Viewer also provides a number of tools and commands for displaying 
and editing Geometric Cost Drivers for the current part or assembly. For more 
information see Using the component viewer tools and commands on page 78. 
You can import bills of materials into aPriori using the BOM Loader in the VPE Toolset. 
For more information, see Importing on page 78. 

To change the size of the Component Viewer 
Click the right bottom corner of the component viewer and drag it with your mouse 
cursor. 

Cost outputs 
The Cost Output pane displays various views of cost information depending on the type 
of the current component. 
The clock icon indicates whether the displayed cost outputs are current: 

 The Current icon  indicates that the component has not been modified since 
this cost was calculated. 

 The Stale icon  indicates that the component has been modified since this cost 
was calculated.  

Place the mouse pointer over this icon to see when the displayed cost was saved.  

To change the display currency 
The default display currency is USD. You can create a list of available currencies in 
aPriori Administrator and use this list to change the display currency in aPriori Desktop. 

1 Select View > Change Currency. The Select Currency window is displayed. 

2 Select the currency from the Currency drop-down list.  

3 Select the version (if any) from the Version drop-down list.  

4 Click OK. 
For information about creating the list of available currencies and saving currency 
exchange rate versions, see the aPriori VPE Administration Guide.  
If currency conversion is required based on the default currency and the display 
currency, the value is displayed in italics. To see the conversion rate, place the mouse 
pointer over a value. 
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Note: You can also change the displayed currency from the Cost Guide IF the selected 
Process Group is set to Manually Costed. (The currency field is not deployed on 
the Cost Guide for any other process group.) 

Manufacturing process 
The Manufacturing Process pane shows information about the manufacturing processes 
available for each component and provides tools to edit the current manufacturing 
process. For details, refer to Manufacturing Process Information on page 134. 

Geometric cost drivers 
The Geometric Cost Drivers (GCDs) pane shows information about the GCDs available 
for each component and provides tools to edit current GCDs. For more information, refer 
to Geometric Cost Drivers on page 198. 
You can display GCD labels for the highlighted GCDs in the Component Viewer. In 
Direct Integration mode, you can also display GCD labels in the CAD application.  

To show GCD labels in the component viewer 

1 Click the Analysis button  in the Component Viewer tool bar.  

2 Select Show GCD Labels. 

3 Click on a GCD in the GCD pane. In the Component Viewer, the GCD is highlighted 
and the GCD label is displayed. 

To show GCD labels in the CAD application 

1 In your CAD application, select aPriori > Show GCD labels.  

2 In the aPriori Desktop, click on a GCD in the GCD pane. You can see the GCD label 
for this GCD in the CAD application.  

Status messages 
Status messages provide detailed information about the state of the aPriori system, 
especially cost estimation calculations. Any warnings or errors that occur during costing 
are displayed as status messages. 



aPriori Desktop Basics  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 54 

 

To view / hide messages 
Select / deselect View > Show Messages or click the  button.  

To clear all messages 
Click the Clear button in the messages pane.  

To export messages into a file 

1 Click the Export button in the messages pane. The Export Messages to a File window 
displays. 

2 Select the folder where you want to save the file. 

3 Enter a name for the file. 

4 Click Save. 

Saving cost information 
At any time during the costing process, you can save the current cost information for a 
component. After saving the cost information, you see the current cost information 
displayed in the Last Saved column. 

Note If you try to close a component without saving, aPriori prompts you to save the 
component. If you do not save the component, you will lose the unsaved 
changes. 
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To save current cost information for a component 

Click the  button or select Scenario > Save > Scenario.  
You can also use the following keyboard shortcut: 
Ctrl-s 

(For more information about aPriori scenarios and additional Save options, see Working 
with scenarios on page 66 and Using the Scenario Menu on page 67.) 

Refreshing the database connection 
At any time during the costing process, you can refresh aPriori Desktop with information 
stored in the database. When you refresh the database connection, you lose all unsaved 
changes. 

To refresh the database connection 

1 Select File > Refresh Database Connection. A window prompting you to confirm the 
refresh from the database is displayed. 

2 Click Yes. 

Note: This is an important step for VPE Administrators when importing VPE data using 
the command line. If you have completed such an import of VPE data and the 
VPE data appears to have remained the same, close the VPE and click File > 
Refresh Database Connection to see the new data. 

Changing user preferences 
aPriori User Preferences control various aspects of startup and costing behavior for both 
aPriori Desktop and the Cost Ticker. You can edit user preferences only in aPriori 
Desktop.  
You can set the following preferences by selecting from the Tools > User Preferences 
menu: 

 Start aPriori with CAD application 
 One Click Costing™ (enabling/disabling auto-costing in response to CAD 

changes) 
 Default Production Inputs 
 Cache New VPEs on Start-up 
 Default Scenario Name 
 Viewer 
 Use Official Scenarios in New Assemblies 

You can also select View > Show English Units from the aPriori menu to display units in 
English units instead of system (metric) units. 
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Once you have specified a user preference, it is “remembered” and subsequently takes 
effect each time you run aPriori. You may change user preference settings at any time. 

Start aPriori with CAD application 
Select Tools > User Preferences > Start aPriori with CAD Application. By default, this 
preference is enabled (checked), which means that aPriori starts automatically when the 
CAD application is started (Pro/ENGINEER direct integration only). Uncheck this option 
to disable automatic startup of aPriori. 

One Click Costing™ (enabling/disabling auto-costing in 
response to CAD changes) 
One Click Costing is the opposite of auto-costing: Auto costing means that aPriori 
automatically re-costs a component in response to each CAD change, such as adding or 
modifying a CAD feature, regenerating a component, or activating a window/component. 
One Click Costing, in contrast, requires that you click the Cost button to explicitly kick off 
a costing operation. If you make frequent design and cost estimate iterations and do not 
wish aPriori to automatically cost every time the CAD model changes, you should ensure 
that the One Click Costing™ preference is enabled. 
Select Tools > User Preferences > One Click Costing™. By default, this preference is 
enabled (checked).  

Note: In releases of aPriori prior to 2014 R1, One Click Costing was disabled by default 
(i.e., auto costing was enabled by default). Also, in earlier releases of aPriori, 
entering a Cost Override would cause the component to recost, even is One 
Click Costing was enabled. Now multiple Cost Overrides can be entered without 
re-costing until you explicitly click a Cost button.  See Overriding computed 
values for more information. 

Default Production Inputs 
Select Tools > User Preferences > Default Production Inputs… . The Default Production Inputs 
window appears. This window allows you to specify personalized default values for 
Production Info settings, including the default Process Group, VPE, Material, Annual 
Volume, Production Life, and Batch Size fields. Once you have specified your 
personalized default values, when costing a new component, the Cost Object Window 
and Cost Guide will be pre-populated using the specified defaults.  
This preference enables you to set defaults that are relevant to the types of parts or 
projects you are working on. They can be changed at any time. User-level production 
input preferences will take precedence over any site-wide defaults; if no user-level 
production inputs are specified, then the site-wide defaults will be applied. For more 
information on Production Inputs see Initial costing: the Cost Guide on page 21 and 
Using the Cost Object Info window on page 41. 

Cache New VPEs on Start-up 
By default, upon client start-up aPriori creates a local (or shared) cache of all VPEs. This 
process may take up to several minutes, depending on factors such as network speed 
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and the number and complexity of VPEs at your site. Subsequent start-ups simply 
update the cache and are typically much faster than the initial cache. 
Unchecking this preference causes aPriori to revert to older caching behavior, which 
does not retrieve and cache VPE data until you cost a part using that VPE. This older 
behavior sometimes introduces significant delays during the costing process, and also 
does not display progress messages like the newer, default behavior. 
Note: See the aPriori System Administration Guide for information about options to 
clean caches. 

Default Scenario Name 
By default, when you open a component in aPriori and perform the initial costing, an 
initial cost scenario for the component is created with the name “Initial”. Use this 
preference to change the name that aPriori uses for initial scenarios. 

Viewer 
By default, aPriori uses an Open GL graphics driver to render the cost component in the 
Viewer pane. Most users should have no need to change the graphics driver setting. If 
you are experiencing display issues (such as an image of the part that appears to be 
incomplete, with missing or extra triangles displayed on the window), then it may be 
resolved by specifying a different graphics driver.  
To change the graphics driver used by aPriori, select Tools > User Preferences > Viewer 
and then select from among the supported drivers. Please contact aPriori Support if you 
continue to experience display issues or instability. 

Use Official Scenarios in New Assemblies 
Use this setting to determine which scenario gets included when a new assembly is 
created, or when a new part is added to an existing assembly. This can be useful to 
handle situations such as catalog parts which have a consistent standard list price, even 
when included in different assembly scenarios representing different production 
conditions. This preference provides the following settings: 

 Always:  The Official scenario of the child will be used unconditionally. 
 When Component Exists But No Matching Scenario: The Official scenario of 

the child will be used only when the child component exists but does not have a 
scenario that matches the assembly. 

 Never: A new scenario matching the assembly scenario will be created and 
rolled into the assembly. 

The default is Never. 
Note: If you used the older "true/false" preference in a version prior to 2015 R1, you 
must re-select this option since this preference now has three states. If you have never  
used this preference before, you should review your current Catalog Parts workflows 
with your aPriori Account Team or aPriori Support to determine how best to leverage this 
functionality. 
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Multi-Body Options 
As of release 2019 R1, aPriori Professional provides a preference setting for Multi-Body 
Options. This enables you to specify how aPriori should interpret CAD model files that 
contain more than one distinct solid body.   
To open this dialog, select Tools  User Preferences  Multi-Body Options.   

 
This dialog provides three options: 

 Keep Free Bodies 
 Preserve CAD - (for NX Assembly files with Keep Free Bodies) – only applies 

when Keep Free Bodies is selected.  
 Ignore Missing Component – (for NX files with a rare error) – only applies 

when Keep Free Bodies is selected. 
Each option in the dialog is fully documented: 
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Prior to 2019 R1, the only way to change the processing of multi-body CAD files 
was to change the values of three corresponding entries in the 
apriori.properties file and then restart aPriori.  These three properties are: 
o apriori.keep.free.bodies 

o apriori.free.bodies.preserve.CAD 

o apriori.free.bodies.ignore.missing.component 

These properties are discussed in the aPriori Professional System Administration 
Guide, in the “apriori.properties” section. There is also a discussion later in this 
User Guide of using these properties with Bulk Costing at Costing multi-body 
parts (free bodies). 
The Multi-Body Options dialog allows you to make these changes more quickly 
and easily without restarting aPriori.  However, note that any changes to the 
options in this dialog will affect CAD files that you open subsequently, not to 
already opened files.  If you open a CAD file and the current settings of those 
options do not produce your desired results, delete the unwanted/incorrect 
scenarios to avoid confusion in the future, then change the Multi-Body Options 
settings and reopen the file and re-extract GCDs. 
Caution:  Note that aPriori always applies the current settings of the Multi-Body 
Options when opening previously-saved scenarios.  aPriori does NOT  
“remember and reapply” the settings which were in effect when the scenario was 
last saved.  If the current settings are different than when the scenario was 
saved, the scenario will become disassociated from its CAD file, as indicated by 
the “broken connection” icon (see screenshot below).   

 
If you observe this disassociation or otherwise believe the current Multi-Body 
Options settings are not appropriate for the scenario, do the following: 
• Close the scenario without saving it. 
• Change the Multi-Body Options settings as appropriate. 
• Re-open the scenario. 
• Re-associate the CAD file by clicking File  CAD File Association and 

selecting the CAD file. 

Displaying English units 
By default, aPriori displays cost component information using metric units. However, you 
can also display values and enter inputs using English units.  
The table below shows how aPriori converts between system units (metric) and English 
units. 
 

aPriori unit type System unit English 
unit 

Length millimeter inch 
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meter foot 

micron micro inch 

Mass kilogram pound (lbm) 

gram ounce 

Force newton pound (lbf) 

Time second second 

Angle degree degree 

Temperature Celsius Fahrenheit 

Energy  joule BTU 

Power joule/second BTU/second 

Pressure MPa PSI 

Some fields will not automatically be converted. For example, some cost model and VPE 
field definitions can be defined by manually entering a unit, rather than a unit type in the 
Unit Type Name field. If a unit in the cost model used by the VPE was defined by selecting 
an aPriori unit type from the cost model’s Unit Type Name field, that unit is converted. All 
units derived from system units (that is, derived units) are also converted. 
The Mass Units and Distance Units component GCD fields are never converted, because 
they are used to capture the mass and distance units used in the CAD file. These units 
do not change because they represent units defined in an external system. 

To display English units 

1 Select View > Show English Units from the aPriori menu bar to change labels to English 
units and convert values from system units to English units.  

2 Select Yes on the confirmation window to switch the display and input to English 
units. 
Converted values are displayed in italics. For example, a Hole GCD with a diameter 
of 25.4 millimeters is displayed with a Diameter property followed by (in.) instead of 
(mm) and has a value of 1.0 after you switch to English units. 

To display system (metric) units 

1 Deselect View > Show English Units from the aPriori menu bar to change labels to 
system (metric) units and convert values from English units to system units.  

2 Select Yes on the confirmation window to switch the display and input to metric units. 
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Connecting to and disconnecting from 
CAD 
In Direct Integration mode, aPriori connects directly to the CAD application to retrieve 
geometry data of the MCAD component that is active in the CAD application. The 
costing information for the component is saved in aPriori database.  
You can disconnect from the CAD application and reconnect as you need.  
You can reconnect aPriori to the CAD application directly in aPriori Desktop or in the 
CAD application. 

To disconnect from the CAD application in aPriori Desktop 

Click the  button. aPriori disconnects from the component that is currently active in 
the CAD application and you see the  button. 

To connect to the CAD application in aPriori Desktop 

Click the  button. aPriori connects to the CAD application and you see the  
button. 

To connect to aPriori in the CAD application 

Select aPriori > Start aPriori or click the  button. This feature is available only for CAD 
applications that support Direct Integration mode.  

Closing a component in aPriori Desktop 
To close a component, click the  button on the component tab. The component tab 
closes. 
In Direct Integration mode, when you close a part or an assembly in the CAD 
application, that part or assembly remains open in the aPriori Desktop. You can close 
any component in the aPriori Desktop except for the one that is active in the CAD 
application. 

Switching to aPriori Cost Ticker 
To switch to the aPriori Cost Ticker, click the  button in the aPriori Desktop toolbar. 
The Cost Ticker always shows cost information for the component that is active in the 
CAD application. 

aPriori Desktop icons and command 
buttons 
The following table lists all the icons and command buttons available in aPriori Desktop 
and explains how they are used. 
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Icon  Usage 

 Click this button to open a CAD file in CAD-Independent mode.  

 Click this button to search for a component.  

 Click this button to save the displayed cost. If the displayed cost is not 
current, the Save button is not available. If the Cost Outputs are not 
current, this button is unavailable. 

 Click this button to cost a component. 

 Click this button to update the Geometric Cost Drivers (GCDs) from the 
CAD model and calculate new cost using the updated GCDs. Place the 
mouse pointer over this icon to see the date and time when the GCDs 
were last updated.  
In CAD-Independent mode, this button is only available when the 
component is file-connected. 
In Direct Integration mode, this button is only available for components 
open in the CAD system. 

 Click this button to enable manual cost overrides in the Cost Summary 
tab. 

 (Pro/E Direct Integration mode only). Indicates that aPriori is connected 
to the CAD application. Click this button to disconnect from the CAD 
application. 

 (Pro/E Direct Integration mode only). Indicates that aPriori is 
disconnected from the CAD application. Click this button to connect to 
the CAD application. 

 Click this button to display system status messages. 
The color of the Message button indicates the system status: 
Green indicates the system is functioning normally 
Yellow indicates a warning 
Red indicates an error 

 Click this button to open the Production Info editor and specify the Total 
Cost Target. If the Total Cost Target is set and the current cost is: 
Between 90% and 110% of the target cost, the indicator on the Cost 
Target icon points straight up 
Less than 90% of the target cost, the indicator points to the left 
More than 110% of the target cost, the indicator points to the right 

 Click left and right arrows to navigate back and forward through the 
open item tabs in the order that they were last visited. 

 
Click this button to toggle the display of the Cost Guide. See Initial 
costing: The Cost Guide for more information. 

 Click this button to switch to aPriori Cost Ticker. 
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Icon  Usage 

 Appears if the current scenario is designated as “Official”; otherwise not 
present 

  Indicates whether the current scenario is locked or unlocked. 

  Indicates whether the current scenario is Active (will re-extract and 
update GCDs from CAD models) or Inactive (will not extract GCDs). 

  Indicates whether the current component is connected to a CAD file; 
hovering over the icon will display a tooltip with the path to the CAD file 
location or a statement that there is no associated CAD file (either 
because aPriori cannot locate it, or the component is a virtual part that 
has no CAD association). 

  indicates whether the current component costs are up-to-date, or they 
are "stale", meaning that the component has not been re-costed since 
costing inputs were modified.  Hovering the cursor over the icon will 
display when the component was last saved and by whom. 

 The Cancel icon appears in the lower-right corner of the aPriori 
desktop window during costing operations. See To cancel a costing 
operation on page 48 for details. 

 

Cost Status Icons 
The following icons appear in Status columns (such as in the Assembly Details view) to 
indicate the costing status of components within a table: 
 

Icon  Usage 

 Green: aPriori has successfully costed the component. 

 Yellow: aPriori has successfully costed the component, but with 
one or more warnings. 

 Red: aPriori was not able to successfully cost the component. 

 Gray: Component has not yet been costed. 

 Asterisk added to one of the above icons: The component has 
unsaved changes. To save the changes, right-click the 
component and select Save 

aPriori Desktop table controls 
aPriori uses tables to present data throughout the application. To help operate with table 
data, the following table features are provided in most tables: 

 Trees inside tables — In some tables a column can be a tree of data. To 
expand/collapse the tree, click on the +/– icon next to an item in the tree.  
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 Column groups — Some tables have groups of columns, which can be expanded 
and collapsed. Initially the groups are collapsed showing only the first three or 
four columns. Click the + icon on the last visible column to expand the group; 
click the – icon on the last expanded column to collapse the group. 

 One-click all column controls — In some large tables, one-click controls are 
provided to expand and collapse all trees and columns. To view these controls, 
move the cursor to the upper left corner of the table. You see a floating panel 
with the relevant controls. 

 
 

Icon  Usage 

 Expands all tree data. 

 Collapses all tree data. 

 Expands all column 
groups. 

 Collapses all column 
groups. 

 Resizes columns to fit 
data. 

These controls may not be available on all tables, particularly smaller tables in 
specialized windows. 

 Fixed leading columns — In aPriori tables the leading columns are fixed. 
 Copy — To copy data from the table into the clipboard, click the Edit menu for 

this table and select Copy. Only the visible data is copied to the clipboard. To 
copy all data from the table, use the one-click controls to expand all tree data and 
column groups. You can paste the data into any spreadsheet. 
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5 Using aPriori 
Desktop 

This chapter provides detailed information on how to use aPriori Desktop. 

This chapter includes the following topics: 
 Working with scenarios 
 Importing and exporting component costs 
 Importing BOMs 
 Using the component viewer tools and commands 
 Using roll-ups 
 Using dynamic roll-ups 
 Using functional groups 
 Reapplying functional groups templates 
 Comparing the costs of alternative designs 
 Creating new components without CAD 
 Working with non-CAD-based assembly components 
 Overriding computed values 
 Working with the Overrides Summary dialog 
 BOM reports 
 Spreadsheet Reports 
 Bulk editing components 
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Working with scenarios 
When you open a component in aPriori and perform the initial costing, an initial cost 
scenario for the component is created and displayed on a component scenario tab and 
within the component’s Scenarios folder on the Navigation pane. The initial scenario is 
shown with (Initial) in the name of the component scenario tab. As you make changes to 
the component’s geometry or manufacturing process, you can save those changes in 
multiple cost scenarios.  
You can create scenarios for parts, assemblies, roll-ups or comparisons: 

 A part scenario shows the cost of manufacturing the part using the specified 
GCDs and Manufacturing process.  

 An assembly scenario shows aggregate costs from the part sub-components, the 
assembly sub-components, and the assembly process. Creating an assembly 
scenario generates a new scenario for the current assembly which contains 
default scenarios of all subcomponents based on a User Preferences setting. 
You can also specify that other part scenarios roll into the assembly. You can 
change a single component, or a component and all of its children, using the 
Scenario menu (see Using the Scenario Menu below). From Assembly Detail 
view, you also have the option of selecting any number of components and using 
the right-click Switch Scenario option to rapidly change several components to 
other scenarios. See Switching Scenarios in Assembly/Roll-up Details view on 
page 74 for more details. 

 An assembly snapshot scenario shows aggregate costs from the part’s 
subcomponents, the assembly’s subcomponents, and the assembly process. 
Creating an assembly snapshot automatically creates locked associated 
scenarios for all assembly components. 

 A roll-up or comparison scenario contains aggregate costs from the part, 
assembly, and virtual cost objects components.  

You cost just the currently selected, top-level scenario, or you can cost all scenarios. In 
the case of assemblies, you can also “deep cost” – you can cost the current scenario 
and all of its children; and even cost all scenarios and all of their children. 
aPriori gives you a great deal of control over scenarios as you try different costing 
options. You can specify that different part scenarios – not just “official” -- roll into a 
given assembly scenario. You can specify whether or not scenarios are automatically 
updated by CAD changes (“active” or “inactive”). And you can specify whether scenarios 
(or scenarios and their children) are locked against changes. 
You can also copy changes from an assembly to all its children. 
For more information on containers, see Using roll-ups on page 95 and Comparing the 
costs of alternative designs on page 105. 

Note: In addition to the menu commands described in the next section, aPriori also 
provides the following keyboard shortcuts: 
Ctrl-S – Saves the current scenario 

Ctrl-Shift-L – Opens the Latest (i.e., “most recent”) scenario 
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Using the Scenario Menu 
The commands associated with scenarios have been consolidated on the top-level 
Scenario menu. Some of these options are also available on various right-click context 
menus.  

Note: The Scenario menu options do not apply to whatever is highlighted in the 
navigation pane – they apply only to what is currently open.  So, for example, if 
you want to use Scenario > Lock on a particular scenario that appears in the 
navigation pane, you must first open that scenario by double-clicking it, or right-
clicking and selecting Open. (Of course, similar options on the right-click menus 
do apply to the currently selected item in the navigation pane.) 



Using aPriori Desktop  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 68 

Scenario > 
Save > Scenario (if any) to 

children, 
– Save changes to the currently selected scenario. Do not 
save changes 

 Scenario & Children (Assemblies and roll-ups only) Save changes to the 
currently selected scenario and any changes to children. 

 All Scenarios & 
Children 

-Save changes to the currently selected scenario and 
any changes to children. 

Save as > Scenario Make a copy of the current scenario as a new scenario. 
The new scenario will have the same children as the 
original. 

 Scenario & Children (Assemblies and roll-ups only) Make a copy of the 
current scenario as a new scenario, and also make 
copies of any children. The name of any child scenario 
will have the name of the parent scenario appended. 

 Snapshot (Assemblies and roll-ups only) Make a copy of the 
current scenario and lock it and its children against 
further changes. 

Copy Assembly 
Inputs to Children 

- Displays the list of production values (such as VPE, 
annual volume, batch size, etc.) that applies to the 
assembly, along with a checkbox for each value. By 
checking the boxes, you can determine which of these 
values gets copied to each of the children in the 
assembly. User-defined attributes are included in this 
list, appended to the end. See Copying assembly cost 
settings to children on page 40 for more information. 

Copy Welds From - (Assemblies only) Brings up a Search dialog so that you 
can choose another assembly with similar geometry 
from which to copy virtual welds. See Virtual welds on 
page 80. 

Make Official - Specify that the current scenario is to be made the 
“official” scenario. When used in conjunction with the 
Tools > User Preferences > Use Official Scenarios in 
New Assemblies option, you can specify whether the 
official scenario by default gets rolled into its parent 
assembly or roll-up. This option is not available for 
uncosted or locked scenarios, or scenarios that are 
already marked official. 

Make 
Active/Inactive > 

Make Active 
(Scenario)/Make 
Inactive (Scenario) 

Specify whether or not the selected scenario is 
automatically updated with CAD changes. Note that roll-
ups cannot use this option since they are not CAD-
connected, but they have access to the following options 
for their members.)  

 Make Active 
(Scenario & 
Children) 

Specify that the selected scenario (if CAD-connected) 
and all of its children are automatically updated with 
CAD changes. (The status of any locked children 
remains unchanged.)  
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 Make Inactive 
(Scenario & 
Children) 

Specify that the selected scenario (if CAD-connected) 
and all of its children are NOT to be automatically 
updated with CAD changes. (The status of any locked 
children remains unchanged.) 

Lock/Unlock > Lock 
Scenario/Unlock 
Scenario. 

– Allow or disallow changes to the current part or 
assembly scenario. Roll-ups cannot be locked, but the 
options below can be used for the members of a roll-up 

 Lock Scenarios 
(Scenario & 
Children) 

Disallow changes to be made to the members of an 
assembly or roll-up (and also to the parent assembly). 

 Unlock Scenarios 
(Scenario & 
Children) 

Allow changes to be made to the members of an 
assembly or roll-up (and also to the parent assembly). 

Enable Cost 
Overrides 

- Displays checkboxes next to line items in the Cost 
Summary view that allow you to enter your own values 
for costing. Same as clicking the Cost Overrides icon (

 ) in the tool bar. See Performing Part Details 
overrides on page 113 for more information. 

Manually Costed - Displays checkboxes next to every editable cost value. 
In addition, all check boxes are checked and disabled, 
indicating that all costs are specified manually and are 
not affected by changes to the components GCDs, non-
geometric cost drivers, or VPE data. See Performing 
total cost summary overrides on page 120 for more 
information. 

Attach 2D Image - Provides the ability to associate a graphics file with a 
virtual component. The image is displayed as a 
thumbnail and in the component viewer. 

Remove 2D Image - Disassociates an image that has been associated with a 
component using the Attach 2D Image command.  

Create 
Comparison 

- Creates a Comparison Summary view starting with the 
currently selected scenario. See  

Creating and editing scenarios and snapshots 

To create a new scenario 

1 Activate the component scenario tab that you want to use as the starting point for the 
new scenario. 

2 Select Scenario > Save as > Scenario from the menu bar. For assemblies only, you also 
have the option of saving a Snapshot, which is a locked scenario. 
For all components, you also have the option of selecting Scenario & Children to 
perform a “deep” save, which saves not only the current scenario, but all of its 
children scenarios as well. 
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You can also access these operations by right-clicking the scenario name in the 
navigation pane. 

3 Enter a unique name for the scenario in the Name field.  

4 (Optional) Enter a description of your changes in the Description field. If the source 
scenario has a Description field defined, that text automatically populates the Description 
field on the Save As dialog. 

5 Click OK to display the scenario in a new component scenario tab and in the 
component’s Scenarios folder on the Navigation pane. 

To edit a scenario 

1 Activate the scenario tab that you want to edit. 

2 Make the changes. 

3 Click the  button to save the changes. 

Saving a scenario 
After making changes to a scenario you can: 

 Save your changes in the same scenario by clicking the  button or selecting 
Scenario > Save > Scenario. You can also perform a “deep” save by selecting 
Scenario & Children. 

 Enter a name for the new scenario. 

Working with initial scenarios 
When you open a component in aPriori and perform the initial costing, an initial cost 
scenario for the component is created and displayed on a component scenario tab and 
within the component’s Scenarios folder on the Navigation pane. The initial scenario is 
shown with the name Initial.  (You can change the default name that aPriori uses for initial 
scenarios with Tools > User Preferences > Default Scenario Name 
As you make changes to the component’s geometry or manufacturing process, you can 
save the changes in multiple cost scenarios. 

Working with official scenarios 
One scenario for each component must be the official scenario. The official scenario is 
simply the scenario which will roll-up into an assembly or roll-up by default, if you have 
not specified any other scenario. 
For snapshots, roll-ups, comparisons, or analyses, the initial scenario is always the 
official scenario.  
In versions of aPriori before 2014 R1, the official scenario also controlled whether a 
CAD-connected component could automatically be updated whenever its CAD file 
changed, but this is now controlled by a separate active/inactive setting. 
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When you open a component, the official scenario for the component opens by default. 
To open a different scenario, you can specify it from a list of the component scenarios, 
or by specifying it on the Open CAD File dialog. For more information, see Opening a 
component in aPriori on page 19. 

 To make a part or assembly scenario the official scenario 
Do one of the following: 

 In the Navigation pane, right-click a part or assembly scenario and select Make 
Official to make it the official scenario. 

 Select Scenario > Make Official from the aPriori menu bar to make the current 
component scenario the official scenario. 

Locking and unlocking scenarios 
As a component design is evolving, you might want to capture the cost at particular 
stages and keep it without changing for future references. If you do not want any 
changes to be made to a particular scenario, you can lock that scenario to prevent 
editing.  
Locking an assembly scenario does not lock the assembly’s subcomponent scenarios. 
Because the cost of active subcomponent scenarios can change, those changes are 
reflected in the locked assembly scenario costs. Create an assembly snapshot if you 
want to lock the assembly and all its subcomponents. For more information, see Using 
the Scenario Menu on page 67. 

To lock a scenario 
Do one of the following to lock a scenario: 

 Right-click the scenario in the Navigation pane and select Lock from the context 
menu. 

 Select Scenario > Lock Scenario from the aPriori menu bar. 
 Right-click a cost object on the Assembly Details tab and select Lock from the 

context menu. 
The scenario icon displayed in the Navigation pane and on the component scenario tab 
changes to show that the scenario is locked. The Assembly Details tab also provides a 
Locked column indicating the lock status of a scenario.  
Roll-up snapshots and comparison snapshots are locked automatically.  

To unlock a scenario 
Do one of the following to unlock a scenario: 

 Right-click the locked scenario in the Navigation pane and select Unlock from the 
context menu. 

 Select Scenario > Unlock Scenario from the aPriori menu bar. 
 Right-click a cost object on the Assembly Details tab and select Unlock from the 

context menu. 
The scenario icon displayed in the Navigation pane and on the component scenario tab 
changes to show that the scenario is unlocked, and the scenario can be edited. 
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Roll-up snapshots and comparison snapshots are locked automatically and cannot be 
unlocked.  

Locking the scenario of a part or assembly 
You can lock an assembly to preserve a specific state of the assembly costs and prevent 
unauthorized edits at the subcomponent level. 
Locking a component scenario affects the behavior of the application when refreshing 
GCDs or updating the CAD model. aPriori attempts to open and update any active 
scenario GCDs whenever a CAD model is opened or modified in the CAD system. If an 
active scenario is locked, the update is not possible, and you are presented with a 
window with the following options: 

 Open the locked scenario without updating. 
 Create a new scenario and update it with new GCDs. The new scenario does not 

become the official one, even if the original was the official scenario. The original 
scenario remains locked. 

 Pick another existing unlocked scenario and update it with new GCDs. The 
original scenario remains locked and unchanged. (Note: This last option is only 
available if other unlocked scenarios exist for the part) 

Locking the official scenario of an assembly prevents assembly GCDs from updating and 
prevents access to all assembly-level edit commands. The Assembly Details tab provides a 
Locked column indicating the lock status of a scenario. 

Refreshing the current scenario 
At any time during the costing process, you can cancel all unsaved changes and refresh 
the current scenario with information stored in the aPriori database. You might want to 
do this if you want to overwrite your current edits with the last saved version of the 
component. 

To refresh the current scenario from the database 

1 Select File > Refresh the current Scenario from the Database to display the 
Confirm Scenario Refresh window. 

2 Click OK to refresh the scenario with information saved in the database. All unsaved 
changes are lost. 

To refresh GCDs from the CAD model 
Right-click a scenario in the Navigation pane and select Refresh GCDs from CAD Model 
from the context menu. 
Use this command to pick up CAD changes that do not automatically trigger GCD 
changes in aPriori. 

Identifying types of scenarios 
The icons on the scenario tabs and in the navigation pane indicate the type of scenario: 
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Icon
  

Usage 

 Official part scenario. 

 Official scenario of the part that is: 
In Direct Integration mode – active in the CAD application. 
In CAD-Independent mode – file-connected and current in aPriori. 

 Locked official part scenario. 

 Unlocked part scenario 

 Locked part scenario 

 Official assembly scenario 

 Official scenario of the assembly that is: 
In Direct Integration mode – active in the CAD application. 
In CAD-Independent mode – file-connected and current in aPriori 

 Locked official assembly scenario 

 Unlocked assembly scenario 

 Locked assembly scenario or snapshot 

 Official roll-up scenario 

 Roll-up scenario 

 Roll-up snapshot 

 Dynamic roll-up scenario 

 Official comparison scenario 

 Comparison scenario 

 Comparison snapshot 

Deleting a scenario 
You can delete scenarios within the following guidelines. When you delete: 

 A non-official scenario of a component, only that scenario is deleted. 
 The official scenario, either by itself, or with one or more (but not all) other 

scenarios of the same component, the selected scenarios are deleted, and an 
arbitrary remaining scenario is made the official scenario. 

 All scenarios of a component, it is the same as deleting the component.. 

Note: You should use the Tools -> Delete Components.. menu option when deleting 
scenarios. Although the Navigation pane provides a Delete Scenario context 
menu option, this menu does not allow deleting multiple scenarios at once, not 
does it allow you to delete the official scenario. 
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To delete a scenario 

1 From the aPriori menu bar click Tools > Delete Components. 

2 In the Delete Cost Objects window, search for the scenarios of interest. (See Using the 
Search tool for more information.)  

3 Click on the scenario to delete. To expand your selection to multiple scenarios, use 
Shift-click and Ctrl click.  

 

4 Click OK, then click Yes when prompted to confirm the deletion. 

Switching Scenarios in Assembly/Roll-up Details view 
When in Assembly Details or Roll-up Details view, you have the option of selecting a number 
of sub-components and changing all of them to either a specific scenario, or to each of 
their official scenarios. 
The possible scenarios to switch to include those that exist for each selected 
component. For example, if "prelim" exists for all selected components, then that will 
show as an option. If "myCopy" only exists in one of the selected components, then it will 
not show up as an option. 
In addition to the common scenarios, the top of the pop-out menu also shows "Official 
Scenario (<various>)". This allows you to switch to the official scenario for all selected 
components. 

Note: There is a difference between selecting the scenario “Initial” and the official 
scenario which happens to also be “Initial”. Selecting the official one will put 
parentheses “( )” around the name in the viewer and more importantly it will “float”. 
That is, if someone changes what the official scenario is, it will automatically update 
in the respective assemblies. If just “Initial” is selected then it will not float. 
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When multiple components are selected, the pop out menu does not display a green 
status dot next to the currently selected scenario, since the status could be different for 
each component. A green dot appears only when one component is selected.  
Similarly, if only one component is selected, aPriori displays its official scenario name at 
the top of the pop-out menu. Otherwise, (<various>) is shown. 
If you attempt to switch to an inactive scenario, aPriori warns you that the geometry may 
not be up to date. See Active and inactive scenarios on page 18 for more information. 

Note: When only one component is selected, the popup menu will provide a  
Show More >> option. This displays the standard Search dialog, but with the 
Name/Part # and Component Type: fields pre-populated and uneditable. See Using 
the Search tool on page 37 for more information. 

To switch scenarios of assembly components 

1 From the Cost Object section of the Assembly Details view, select a component. 

2 Right-click and select Switch Scenario.

 

3 Select either Official Scenario at the top of the pop-out menu, or one of the options 
listed below Select Specific Scenario.   

Note: You can select multiple components and change all of them to their Official 
scenario(s). 
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Non-official scenarios are not available during multi-select. Further note that 
when you have only one row selected, the Switch Scenario fan-out menu also 
provides a Show More option, which displays the Search tool for finding additional 
choices. See Using the Search tool on page 37 for more information. 

Importing and exporting component 
costs 
aPriori allows you to export part and assembly cost information from one aPriori 
database and import it into a different aPriori database. The files used for these imports 
and exports have “.ap” extensions. This data-sharing capability enables manufacturers 
to collaborate with their suppliers and other third parties, such as consultants, who are 
supporting their design and sourcing activities. This functionality also allows users in a 
location with a slow connection to the primary database server to work with a local 
database to improve performance and then transmit the costed components to the 
primary database.  

Functional overview 
Import and Export can be accessed from the File menu.  

 File >Export > Current Scenario & Children exports the current scenario, (the part, 
assembly or rollup that you see on your screen) plus any children belonging to 
that scenario, to an .ap file that you specify. 
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 File > Export > Select Scenario(s) displays the search menu which you use to select 
the part, assembly or rollup (group of parts) that you want to export. 

 Tools File > Import allows you to select the .ap file that you want to import. 

Basic workflow for sharing data 
This example explains the workflow between two sites of the same manufacturing 
company or between a manufacturer and their contract engineering firm). For the 
purposes of this explanation, it is assumed that the Manufacturer is located in the US 
and the Contract Engineering Firm is located in India. 

1 An engineer in the US initiates a work order for costing a set of parts. This is typically 
10 -50 parts but could be up to 100. 

2 An engineer in India executes the work order by costing the parts in aPriori. 

3 An engineer in India saves each part as a new scenario, gives the scenario a unique 
name, and makes the scenario ‘official’. *  
Note: The scenario name must not contain a colon. 

4 On a periodic basis, or when the work order is complete, an engineer in India creates 
a rollup and adds all the scenarios in the work order into the rollup.** 

5 An engineer in India exports the rollup from aPriori which creates a file on disk. This 
will be a menu option from the aPriori user interface. 

6 The exported file is made available to users in the US. This could be done by simply 
being placed in a shared folder to which users in both the US and India users have 
access.  

7 A user in the US imports the file using aPriori.  
*The naming convention is to be determined by the aPriori customer. The purpose for 
the unique scenario is so that it does not overwrite data in the US database if the part 
already exists there (unless that is the desired behavior). Note that the scenario name 
must not contain a colon. 
**The timing of when the export is done is to be determined by the aPriori customer. 
When adding parts to the rollup, parts can be added based on a date range, VPE, or the 
user ID of the person who last saved the part, among others. There is a practical limit to 
the number of parts that can be placed in a rollup and exported. The exact number 
depends on the computer being used and the complexity of the parts in the rollup. On a 
typical 32-bit workstation, it should handle 100 parts without problem. This number is 
increased significantly by using a 64-bit workstation and increasing the amount of 
installed memory. 
The file transfer mechanism works in either direction. Therefore, if a user in the US makes 
changes to a part and wants a user in India to see those changes, the US user can 
export it, and the India user can import it. 
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Data Integrity: What happens when a part being imported 
already exists in the database 
It is important to understand the behavior when importing a part when that part number 
already exists in the database. 
When importing a part or group of parts, if any of the part number/scenario combinations 
already exist in the database, the list of parts which do already exist will be displayed. 
You will then have the option to cancel the import or proceed. If they choose to cancel, 
nothing will be imported. If they choose to proceed, all of the parts will be imported and 
the ones which already existed will be overwritten (regardless if they are locked or 
unlocked). If none of the parts being imported exist in the database, you will not be 
prompted at all. 
If part 123456.initial exists in the database and is the only scenario for part number 
123456, and 123456.india is imported. Scenario 123456.initial will remain and 
123456.india will be added. If 123456.india was official when it was exported it will 
become the official scenario when it is imported. 
Therefore, when a user in India costs a sub-assembly, they will need to export the 
“.initial” scenario so that its cost will be pulled into the higher-level assembly. As 
described above, if that sub-assembly already exists in the US database it will be 
overwritten upon import.  

Importing BOMs 
Documentation about the aPriori BOM Loader can now be found in the aPriori VPE 
Admin Guide. 

Using the component viewer tools and 
commands 
aPriori Component Viewer provides a number of tools and commands to display and edit 
GCDs for a part or an assembly. The available tools and commands vary depending on 
the Manufacturing Process Group.  

 

Note You can access the Component Viewer tools and commands only when the cost 
of the part or assembly displayed in the Component Viewer is current. If the cost 
is not current, click the Cost button to calculate the current cost and allow access 
to tools and commands. 

The following tools and commands are available in the Component Viewer: 
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 Analysis – Displays a list of characteristics that can be displayed on the 
component in the viewer 

 Welding – Create a virtual weld for an assembly 
 Setup Axis – Display setup & turning axes, Modify setup axes, and Limit turning 

axes 
 Stock Form and Alignment – Display the automatically-chosen stock shape and 

alignment and override it 
 Draw Direction/Ram Direction – For plastic molding, manually select the draw 

direction in which the part mold is opened. For Sheet Metal - Transfer Die, 
manually select the direction of the ram. 

 Geometry Analysis – Identify which GCDs have properties or characteristics that 
drive costs 

 Gear Definition -- Display the Gear Definition dialog; only enabled when displaying 
a part that includes gears, flutes, splines, or sprockets. See the "Working with 
Gears, Splines, Sprockets, and Flutes" section of the aPriori Cost Model Guide 
for more information. 

 Set Main Surface for Sheet Metal Parts -- Display the Set Main Surface dialog. Only 
enabled when displaying a sheet metal part. See the " Main Surface for Hard 
Tooled Sheet Metal " section of the aPriori Cost Model Guide for more 
information. 

 Flattening Options -- Displays the Flattening Options dialog. Only enabled when 
display a sheet metal part. See the "Flattening" section of the aPriori Cost Model 
Guide for more information.  

 Right-click menu commands 
 2D Images for virtual parts that have no CAD model image (available in 2014 R1 

SP1 and later) – Attach 2D Image, Remove 2D Image, and Close viewer 

Displaying part characteristics 
Click the  button in the Component Viewer tool bar to bring up the list of 
characteristics that you can display for the part opened in the Component Viewer. 
Different characteristics can be displayed for different Manufacturing Process Groups.  

Note The display options are available only for parts. 

Once you select a characteristic, it is displayed in the Component Viewer and the 
corresponding GCDs are highlighted in the GCD pane. 
The following display options are available: 

 Show GCD Labels — available for all Process Groups — displays GCD labels for all 
highlighted GCDs. 

 Setup Axes — available for Bar & Tube, Casting, Machining, and Sheet Metal 
Process Groups — shows the setup axes to be used for machining. The setup 
axes can be created automatically by aPriori or manually by you.  

 Cross Section — available for the Bar & Tube Process Group — shows the cross 
section of the stock material.  
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 Turning Profile — available for turned parts (Bar & Tube Fabrication or Casting 
primary process groups — displays the turning profile (cross-section of the part 
on a plane passing through the turning axis).  

 Note: to highlight axisymmetric volumes removed by turning operations in the 
Component Viewer, you can select Ring GCDs in the Geometric Cost Driver 
pane. 

 Parting Line — available for Casting and Injection Molding Process Groups — 
shows the line dividing the top/left side of the mold from the bottom/right side of 
the mold. 

 Projected CSA — available for Casting and Injection Molding Process Groups — 
shows projected cross section area for the part.  

 Thickness — available for Casting and Injection Molding Process Groups— shows 
the minimum and maximum thickness of the part walls.  

 Cores — available for Injection Molding Process Group — highlights moving side 
cores.  

 Material Nesting — available for Sheet Metal Process Group — shows how the 
part’s flat outline is nested within a stock material sheet.  

 Flat Outline — available for Sheet Metal Process Group — shows the smallest 
rectangle that encloses the part before bending.  

Copying the component image to the clipboard 
You can copy the image that is displayed in the component viewer to the clipboard for 
pasting into other utilities like Microsoft Word, Excel, or image editing packages. 

1 Click to select the image in the component viewer. 

2 Click Tools > Copy Image from the toolbar. 

Virtual welds 
Virtual welds are created in aPriori as opposed to a CAD application. You can create 
welds for assemblies, as well as for edges and holes of a single Sheet Metal or Bar & 
Tube part. Various weld processes (manual and robotic MIG and TIG welding, manual 
and robotic spot welding, and laser and electron beam welding) and types of welds 
(bevel groove, v-groove, j-groove, u-groove, square-groove, fillet, wrap-tie, tack welds, 
and plug welds) are supported.  Weld prep and weld cleanup processes (including bevel 
cutting, grinding, and wire brushing) also may be optionally included.   

For assemblies, you can create a virtual weld using the Welding tool  in the 
Component Viewer tool bar. 
To apply a weld to an edge or hole of a part, select the GCD, then right-click and select 
Edit Operation from the right-mouse popup menu.  The Operation Sequence Selection 
dialog appears, allowing you to specify the desired weld processes and weld types. 
Part-welding processes are included in a secondary process group called Part 
Assembly, and this capability is licensed along with the Welding module. 
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To create a virtual weld 

1 Open an assembly. 

2 Click the Welding tool  in the Component Viewer tool bar.  
The mouse cursor within the Component Viewer turns into a welding torch, the same 
as on the Welding button. The weld properties window opens. 

3 Specify the following weld properties: 
• Weld Type — Select the type of the weld. Different weld types are 

represented with schematic pictures. Move the mouse cursor over a picture 
to see the name of the weld type.  

• Production Mechanism — Select manual or robotic production mechanism. 
• Weld Width (mm) — Enter the width of the weld in millimeters. 
• Weld Depth (mm) — Enter the depth of the weld in millimeters. 
• Enable Intermittent/Pattern Weld — Check this box to create a non-

contiguous weld. For an intermittent weld, define: 

- Segment Length (mm) — The length of a weld segment in the 
intermittent weld. 

- Pitch (mm) — The distance from the beginning of one weld 
segment to the beginning of the next weld segment. 

• Override Total Length -- By default, aPriori automatically calculates the 
length of a weld, and displays this value in the CAD Reference Length field. You 
can override this value by clicking the checkbox and entering your own value 
in the Total Length field.  

4 Click on an edge in the Component Viewer where you want to create the weld. Click 
Create Weld button. To create a virtual weld consisting of multiple edges, click each 
edge and then click the Create Weld Button. 

5 Repeat steps 2 - 4 to create more welds.  

6 Close the weld properties window by selecting Cancel or the red X in the top right 
corner of the window. 

To edit a virtual weld 

1 Open an assembly. 

2 Highlight a virtual weld either in the Component Viewer or in the GCDs pane. 

3 Right-click the Virtual Weld and select Edit from the menu. The weld properties 
window is displayed. 
Note You can select multiple welds by holding down the Ctrl key or the Shift key and 

clicking the welds.  

4 Edit the weld properties as required. 



Using aPriori Desktop  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 82 

5 Click OK.  

To copy virtual welds 
Once you have created virtual welds for an assembly, other assemblies with similar 
geometry can import these welds through the Scenario > Copy Welds from...  menu option.  

1 Open an assembly. 

2 Click Scenario > Copy Welds From...  
This opens the Search window. (See Using the Search tool on page 37 for more 
information.) 

3 Use the Search window to find and open the assembly, which has the virtual welds 
that you want to copy to the open assembly. This source assembly must have 
geometry that is very similar to the open assembly -- in other words, they must be 
different versions of the same assembly that differ only in a few details, or which 
have different part numbers. 

4 At the end of the copy, aPriori generates a Weld Diagnosis spreadsheet report to 
help you evaluate the success of the copy operation, note that the information of 
interest in this report is on the first tab, "Copy Welds Analysis Report". The other tabs 
contain raw data that is used to create the first tab. (You can also run this report at 
any time using the Reports > Spreadsheet Reports menu item. (For more 
information about spreadsheet reports, see Spreadsheet Reports on page 316.) 
All existing virtual welds in the destination assembly are discarded and are replaced 
by the imported welds. The imported welds retain the same weld IDs they had in the 
source assembly. Any non-virtual (CAD-defined) welds in the target assembly are 
kept, but they moved to the end of the weld list (i.e., they have IDs that start after the 
imported weld ids). 
If there are no welds in the source assembly, or if aPriori fails to import all welds, 
then nothing changes in the target assembly; existing welds are not discarded. 

Note: Because the two assemblies that the welds are being copied between must be 
"substantially similar", the following limitations apply: 

• Mirrored assemblies are not supported.  Some welds may get copied, but the 
results will not be reliable. 

• Any weld that has more than about a 30% change in location or size will have 
varied copy results. 

To view virtual welds 

1 Open an assembly. 

2 In the Geometric Cost Drivers pane, click Joining > Welds > Virtual Welds. The list 
of virtual welds opens.  

3 Click on a virtual weld to display its properties in the GCD pane and to highlight it in 
the Component Viewer. 
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To delete a virtual weld 

1 Open an assembly. 

2 Highlight a virtual weld either in the Component Viewer on in the GCDs pane. To 
select several welds, hold the Ctrl button while you click on welds. 

3 Right-click the Virtual Weld and select Delete (in the Component Viewer) or Remove 
(in the GCDs pane) from the menu.  

Part setups for machining 
Please refer to the section "Working with Part Setups and SetupAxis GCDs" in the 
aPriori Cost Model Guide for a detailed discussion of part setups for machining. A part 
setup represents a particular orientation that a part may be placed in during the 
machining of that part. aPriori automatically determines the number of part setups 
required according to machining best practices. The Component Viewer tools allow you 
to add additional setups if desired and visualize the currently-used setups and additional 
potential setups. 
The Setup Axis tool is available in the Stock Machining Process Group and when 
machining is used as a secondary process in manufacturing the part. 

To display currently used setups and potential setups 

1 Click  in the Component Viewer tool bar. The list of display options opens. 

2 Select Active Setup Axes to see the setups that are actually being used in the 
machining of the part. 

3 Select Inactive Setup Axes to see the potential setup orientations that are not currently 
used for the selected machining routing and operations. 

4 Alternatively, you can click the Setup Axis tool  in the Component Viewer tool bar 
and then select Display Setup and Turning Axes… The resulting window allows you to 
independently display both active and inactive (candidate) setup axes. 

For more techniques about displaying setups and associated machining, see the section 
"Displaying Setups, Associated Operations, and GCDs" in the aPriori Cost Model Guide. 

To define or activate a setup axis 

1 Click on the Setup Axis tool  in the Viewer tool bar, then select Modify Setup 
Axes…. 

2 In the Modify Setup Axes window, click the +Add button to indicate you wish to add a 
new part setup orientation. aPriori will highlight all inactive setup axes as gray 
arrows. 

3 You can use your cursor to click on an inactive axis and select it. Alternatively, you 
can select on a planar face or curved wall GCD, to select the axis perpendicular or 
parallel to those surfaces respectively. 
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4 The axis will appear in the list of User-Activated axes and will be highlighted in blue 
in the Viewer window. 
Upon subsequent costing, aPriori now will consider any user-defined setups as well 
as system-computed setups when evaluating which machining operations are 
possible for different GCDs. 

To deactivate a setup axis 
You cannot de-activate setup axes that were automatically determined by aPriori. You 
can de-activate setup axes that were added by a user. In the Modify Setup Axes window, 
select an axis from the list of User-Activated Axes, and click the Make Inactive button. 

Turning axes 
A Turning Axis is the axis of revolution for axis-symmetric geometry, which could be 
manufactured by turning processes. A part may have more than one turning axis. See 
the section "Turning Axes" in the aPriori Cost Model Guide for more information on 
turning axes, including system-created and user-defined turning axes. 

To display turning axes for a part 
In the Geometric Cost Drivers pane, expand the Component node (click on the + icon), 
then click the Turning Axes node. All turning axes for the part will be displayed.  
To display individual turning axes, you can click on each distinct turning axis listed under 
the Turning Axes node. 

Defining stock form and alignment for the Stock Machining and 
Bar & Tube process groups 
aPriori analyzes the geometry of a part and automatically chooses the optimal stock 
shape and alignment. You can display the automatically-chosen stock shape and 
alignment and override it using the Stock Form and Alignment tool  in the Component 
Viewer tool bar. This tool is available only for the Stock Machining and Bar & Tube 
process groups. The available options and capabilities differ slightly between the two 
process groups, as described below. 
For more information, see the sections "Stock Machining" and "User Inputs for 
Machining" in the aPriori Cost Model Guide. 

To define stock form and alignment manually 

1 Click the Stock alignment tool  in the Component Viewer tool bar.  
The Stock Form and Alignment window is displayed, with several options to give you 
control over the stock form and how it aligns with the part. 

2 Specify the material stock form, using the drop-down menu choices: 
• Let aPriori Decide – this menu option is selected by default indicating that stock 

form and alignment is automatically determined by aPriori. The stock form 
chosen by aPriori is displayed in parentheses following the field. 
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• Round Bar, Square Bar, Rectangular Bar, Round Tube, Square Tube*, Rectangular 
Tube*, Channel Bar*, Angle Bar*, Hex Bar* or I-Beam* – if the actual part stock is of 
a different form than that chosen by aPriori, select it from the menu.  

* Square Tube, Rectangular Tube, Channel Bar, Angle Bar, Hex Bar, and I-Beam 
stock forms are available only in Bar & Tube Fabrication; they are not supported in 
Stock Machining. 
In Bar & Tube Fabrication, the selected stock form must be similar in shape and size 
to the finished part, otherwise aPriori will display the message "aPriori cannot find 
the requested stock form for this part". For example, for a turned part, aPriori 
supports selection of a round bar or round tube. However, if you select a square bar, 
aPriori will display the error message. This is because Bar & Tube Fabrication is 
intended to model the cost of fabricating parts from “as-supplied” stock forms, 
without the need for additional rough machining around the part boundaries.  
In the Stock Machining process group, you may select stock forms that do not 
closely match geometry of the part, since general rough machining is supported. 

3 Specify the stock axis/alignment direction - this is an optional field that allows you to 
indicate how the part is aligned with the stock axis. Typically, you will not need to use 
this field, as aPriori will analyze the part from multiple directions and determine which 
direction and stock form are viable. But in some cases, a part potentially could be 
made from more than one stock form, depending on what is assumed to be the 
stock-axis direction.  
To change this assumption in Bar & Tube Fabrication, click the Pick button and then 
click on an edge of the part this is parallel to the desired stock axis. As you move the 
mouse cursor over the part edges, the edges are highlighted. Highlight the edge 
along which you want to align the stock and click the left mouse button. Use the 
Clear button to revert to the stock alignment direction automatically determined by 
aPriori. 
To change this assumption in Stock Machining, click the Pick button and then select 
either an edge of the part or an axis of the part parallel to the desired stock axis 
direction, or a planar face on the part that is perpendicular to the desired stock axis 
direction. As you move the mouse cursor over the part edges or faces, they are 
highlighted in yellow; as you move them over available setup and turning axes 
(shown in gray), the axis arrow highlights and a dotted red line is displayed in the 
axis direction. Highlight the desired item, then click the left mouse button. Use the 
Clear button to revert to the stock alignment direction automatically determined by 
aPriori. 

4 Show Cross Section - Check this checkbox to show the stock material cross section 
superimposed against the part and display information about the stock shape and 
dimensions in the lower right corner of the Viewer pane. 

Defining draw direction for casting and injection molding 
The draw direction indicates the direction in which the part mold will be opened. aPriori 
selects draw direction automatically. To manually select draw direction, use the Draw 
direction tool  in the Component Viewer tool bar. This tool is available only for Casting 
and Injection Molding Process Groups.  
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To define draw direction manually 

1 Click the Draw direction tool  in the Component Viewer tool bar.  
• The following things change in the Component Viewer: 
• The mouse cursor turns into the Draw direction tool icon.  
• The part’s datum planes are displayed. 
• The suggested draw direction is displayed.  
• The Draw direction options selection box is displayed. 

2 You can select the following options: 
• aP Select (Auto) – This option button is selected by default indicating that draw 

direction is automatically determined by aPriori. 
• User Select – This option button indicates that draw direction is selected 

manually by you. 
• Show Parting Line – Check this checkbox to show the mold parting line. 
• Advanced/Simple – By default you define draw direction in Simple mode with 

the Advanced button available. As you move your mouse over GCDs (planar 
surfaces, holes, curved walls, or the default datums) the proposed draw 
direction is shown as an arrow on the window. Selecting a GCD changes the 
draw direction.  

If no suitable planar surface or hole is available to define a draw direction, click the 
Advanced button to define draw direction in spherical coordinate system. The values 
for Azimuth and Zenith for the parting line set by aPriori are displayed. To enter new 
values, do one of the following. 

• Click Select. As you move the cursor over the component, the Azimuth and 
Zenith values change. Click the left mouse button to select new values. 

• Use the up and down arrows in the Azimuth and Zenith fields to change the 
values or type in the new values. 

3 Click Apply to set the new parting line. Click the Simple button to return to the Simple 
mode. 

4 As you move the mouse cursor over the part, the axis, straight edges, datum planes, 
and flat surfaces that you can use to draw direction are highlighted. The suggested 
draw direction is displayed for the highlighted item. Highlight the item that you want 
to use as draw direction and click the left mouse button. 

Working with the Heat Map (Geometry Analysis) 
If you have costed your part with the Stock Machining process group, you can direct 
aPriori to display your part in the Component Viewer in the form of a heat map. Each of 
the part’s GCDs is filled in with a color that indicates the value range, for the GCD, of a 
specified metric.  
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To enable the heat map, click the Geometry Analysis tool, , in the Component Viewer 
tool bar. Your part is displayed as a heat map, and the Geometry Analysis bar graph 
appears. 

 
The bar graph includes a dropdown menu, labelled Criterion, which lists the heat map 
metrics. If you select, for example, the metric General Area Removal Rate, each GCD in 
the heat map is filled in with a color that indicates the rate of removal for finishing 
operations assigned to that GCD. If more than one finishing operation is assigned to the 
GCD, the color indicates the average rate across operations. Warmer colors (like orange 
and red) indicate higher values; cooler colors (like green and blue) indicate lower values.  
You can enter values into the Min and Max fields to adjust the colors used to display the 
range of values. Click Reset Color Thresholds to restore the default color spectrum for the 
component. 
The Design to Cost Tool for Machined Parts (introduced in Release 16.2 – see 
Validation and Design to Cost )  presents the same types of machinability issues as the 
Heat Map, but in a format that is more user-friendly for casual users who are not experts 
in machining. 

Note: Release 16.2 introduces the capability for aPriori System Administrators to 
configure and customize the heat map Criterion menu. See the aPriori System 
Administration Guide, “Configuring the Geometry Analysis Tool (Heat Map)” 
chapter.  

The Criterion menu is divided into several categories, with each category containing 
several specific criteria. Remember, these criteria (with the exception of Cycle Time) 
only generate heat map results if your current component has been costed in the Stock 
Machining process group. 

Cycle Time & Removal Rate 
 Contouring Removal Rate: rate at which the contouring operation for the indicated 

GCD removes material from the GCD’s surface, in unit area per unit time. 
Removal rate depends on feed, speed, tool diameter, and contact width. Cycle 
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time increases as removal rate decreases—see “Operation Cycle Time and Cut 
Time Calculations” in the Cost Model Guide.  
If the heat map indicates that removal rate for a GCD or group of GCDs is lower 
than you think it should be, consider making one or more of the following 
adjustments: 
o Increase feed for the GCD(s). See Requested Feed per Tooth in “Surface 

Finishing Milling Options” in the Cost Model Guide. 
o Increase speed for the GCD(s). See Requested Tool Cutting Speed in “Surface 

Finishing Milling Options” in the Cost Model Guide. 
o Modify the tool diameter. A larger tool diameter can increase removal rate, 

but it can also decrease corner accessibility, rendering certain operations 
infeasible. A smaller tool diameter can sometimes make a more efficient 
operation feasible. See Requested Tool Diameter in in “Surface Finishing Milling 
Options” in the Cost Model Guide.  

o Modify operation assignment, either by directly assigning an operation to the 
GCD(s), or else by modifying setups or thresholds. See “Modifying Machining 
Operation Assignments” in the Cost Model Guide. 

 Cutting Speed Reduction Factor: percentage by which the recommended speed is 
reduced due to limitations of the current machine. aPriori reduces the speed 
used for calculating removal rate, when aPriori’s recommended speed exceeds 
the machine’s speed capabilities. If the heat map indicates that the reduction 
factor is high, consider explicitly selecting a machine that supports higher 
speeds.  

 Cycle Time: time to perform the assigned operation on the indicated GCD. For 
example, if you want to understand which GCDs have the longest cycle times for 
a machined component, select this option to display GCDs with the fastest cycle 
time in blue (a faster cycle time results in a lower production cost), and those with 
the longest cycle times in  red. If the heat map indicates that the cycle time is 
high, examine other metrics for the indicated GCD, such as removal rate and tool 
diameter, or consider modifying operation assignment. 

Note: Cycle Time is the one criterion that can be displayed for process groups other 
than Stock Machining. 

 Facing Area Removal Rate: rate at which the facing operation for the indicated GCD 
removes material from the GCD’s surface, in unit area per unit time. Removal 
rate depends on feed, speed, tool diameter, tool path, and contact width. Cycle 
time increases as removal rate decreases—see  “Operation Cycle Time and Cut 
Time Calculations” in the Cost Model Guide. 
If the heat map indicates that removal rate for a GCD or group of GCDs is lower 
than you think it should be, consider making one or more of the following 
adjustments: 
o Increase feed for the GCD(s). See Requested Feed per Tooth in in “Surface 

Finishing Milling Options” in the Cost Model Guide. 
o Increase speed for the GCD(s). See Requested Tool Cutting Speed  in “Surface 

Finishing Milling Options” in the Cost Model Guide. 
o Modify the tool diameter. A larger tool diameter can increase removal rate, 

but it can also decrease corner accessibility, rendering certain operations 
infeasible. A smaller tool diameter can sometimes make a more efficient 
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operation feasible. See Requested Tool Diameter in in “Surface Finishing Milling 
Options” in the Cost Model Guide. 

o Modify operation assignment, either by directly assigning an operation to the 
GCD(s), or else by modifying setups or thresholds. See “Modifying Machining 
Operation Assignments” in the Cost Model Guide. 

 General Area Removal Rate: rate at which the finishing operation for the indicated 
GCD removes material from the GCD’s surface, in unit area per unit time. 
Removal rate depends on feed, speed, tool diameter, and contact width. Cycle 
time increases as removal rate decreases—see “Operation Cycle Time and Cut 
Time Calculations” in the Cost Model Guide. 
If the heat map indicates that removal rate for a GCD or group of GCDs is lower 
than you think it should be, consider making one or more of the following 
adjustments: 
o Increase feed for the GCD(s). See Requested Feed per Tooth in in “Surface 

Finishing Milling Options” in the Cost Model Guide. 
o Increase speed for the GCD(s). See Requested Tool Cutting Speed in in “Surface 

Finishing Milling Options” in the Cost Model Guide. 
o Modify the tool diameter. A larger tool diameter can increase removal rate, 

but it can also decrease corner accessibility, rendering certain operations 
infeasible. A smaller tool diameter can sometimes make a more efficient 
operation feasible. See Requested Tool Diameter in “Surface Finishing Milling 
Options” in the Cost Model Guide.  

o Modify operation assignment, either by directly assigning an operation to the 
GCD(s), or else by modifying setups or thresholds. See “Modifying Machining 
Operation Assignments” in the Cost Model Guide. 

 General Volume Removal Rate: rate at which the hole-making operation for the 
indicated GCD removes material from the part, in unit volume per unit time. 
Removal rate depends on feed and speed. Cycle time increases as removal rate 
decreases. If the heat map indicates that removal rate for a GCD or group of 
GCDs is lower than you think it should be, consider increasing feed or speed. 
See Requested Feed per Tooth and Requested Tool Cutting Speed in in “Surface 
Finishing Milling Options” in the Cost Model Guide. 

 Side Mill Area Removal Rate: rate at which the side milling operation for the indicated 
GCD removes material from the GCD’s surface, in unit area per unit time. 
Removal rate depends on feed, speed, tool diameter, and contact width. Cycle 
time increases as removal rate decreases—see  “Operation Cycle Time and Cut 
Time Calculations” in the Cost Model Guide. 
If the heat map indicates that removal rate for a GCD or group of GCDs is lower 
than you think it should be, consider making one or more of the following 
adjustments: 
o Increase feed for the GCD(s). See Requested Feed per Tooth in “Surface 

Finishing Milling Options” in the Cost Model Guide. 
o Increase speed for the GCD(s). See Requested Tool Cutting Speed in “Surface 

Finishing Milling Options” in the Cost Model Guide.  
o Modify the tool diameter. A larger tool diameter can increase removal rate, 

but it can also decrease corner accessibility, rendering certain operations 
infeasible. A smaller tool diameter can sometimes make a more efficient 
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operation feasible. See Requested Tool Diameter in “Surface Finishing Milling 
Options” in the Cost Model Guide. 

o Modify operation assignment, either by directly assigning an operation to the 
GCD(s), or else by modifying setups or thresholds. See “Modifying Machining 
Operation Assignments” in the Cost Model Guide. 

 Surface Finishing Tool Diameter: diameter of the tool selected for the assigned 
operation on the indicated GCD. If the heat map indicates that this value is too 
small for a GCD or group of GCDs, consider increasing tool diameter, either 
directly with a process setup option (See Requested Tool Diameter in “Machining 
Node Process Setup Options” in the Cost Model Guide. ) or indirectly by 
activating a setup that provides a better angle on the GCDs corners. 

 Time Tool Machines Air: percentage of engagement time that is non-chipmaking 
time, that is, percentage of time during which the tool is engaged (spinning) that 
the tool is not in contact with the GCD surface (see “Operation Cycle Time and 
Cut Time Calculations” in the Cost Model Guide). If the heat map indicates that 
this metric is too high, consider reducing tool diameter—see Requested Tool 
Diameter in “Surface Finishing Milling Options” in the Cost Model Guide. 

Design Standards 
 Concave Surfaces < Radius Threshold: This metric quickly show all "small" 

concave curved walls and surfaces that likely need to be filleted and indicates 
whether a range of fillet sizes is used rather than some consistent sizes that 
would reduce tool count and tool change time. In out-of-box VPEs, the Radius 
Threshold is set to 12% of (Part Height + Part Width), which is a typical rule of 
thumb for the max tool diameter. 

 Fillet Radii: The x-axis shows each distinct fillet radius value found in the part; 
bar height = count of hole GCDs with that value. 

 Hole Diameter: The x-axis shows each distinct hole diameter value found in the 
part for simple and multi-step holes; bar height = count of hole GCDs with that 
value. 

 Non-Standard Fillet Size: The x-axis shows each distinct NON-STANDARD fillet 
size value found in the part; bar height = count of fillet GCDs with that fillet value. 

 Non-Standard Hole Size: The x-axis shows each distinct NON-STANDARD hole 
diameter value found in the part; bar height = count of Hole GCDs with that 
diameter value. 

 Side Mill Length to Diameter Ratio: Tool length divided tool diameter. This ratio 
affects side-milling feasibility. See “Working with Features to Review” in the Cost 
Model Guide. 
If side milling would be appropriate, but the heat map indicates that this value is 
too small for side milling, check the PSO information entries to see if this caused 
side milling to be infeasible. If so, you can assign side milling either explicitly or 
by changing thresholds or setup axes. See Easy Side Milling Length to Diameter Ratio 
and  Maximum Side Milling Length to Diameter Ratio in “Machining Node Process 
Setup Options” in the Cost Model Guide. 

 Standard Fillet Size: The x-axis shows each distinct STANDARD fillet size value 
found in the part; bar height = count of fillet GCDs with that fillet value. 
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 Standard Hole Size: The x-axis shows each distinct STANDARD hole diameter 
value found in the part; bar height = count of Hole GCDs with that diameter 
value. 

Issues 
 Contour Milled Corner: Surfaces with the corner adjacent to a spherical fillet (or 

toroidal fillet), such that the corner must be contour-milled vs. faced or side-milled 
like the rest of the surface. This can be machined; it just requires a contouring 
operation to finish the corner of the surface. 

 Features to Review:  Applies to features that have been assigned to Features to 
Review or General Mill Finishing. Note that the labels in this view correspond to 
the “Machining Issues” listed in the Design to Cost (DTC) tab. See “Working with 
Features to Review” in the Cost Model Guide. 

 Obstructed Holes: The x axis shows a distinct tick for each type of obstructed 
hole/obstructed hole making op-type (if more than one), otherwise just one tick. 
Bar height = count of surface GCDs of that type. Bar height = count of surface 
GCDs of that type. 

 Obstructed Surfaces: The x-axis shows a distinct tick for each type of obstructed 
surface/obstructed op type, e.g. Obstructed-No Op Assigned, Facing + 
Contouring, Facing + Side Milling, etc. Bar height = count of surface GCDs of 
that type. 

 Sharp Internal Corner: This displays two types of issues. The first is sharp wall 
corners, where there is a missing radius between the wall and its adjacent 
neighbor, such that a side-mill can't reach into the corner. The second is sharp 
floor corners, where the floor surface is adjacent to a sharp wall corner situation 
such that a face-mill can't reach into the corner. Neither of these can be 
machined with a cylindrical tool. 

Machining Technique 
 Finish Milling Operation Type: The x axis shows a distinct tick for each type of 

finishing operation, e.g. Facing, Facing + Contouring, Facing + Corner Picking, 
Side-Milling, Flank-Milling, Contouring, etc. The bar height = count of surface 
GCDs assigned that type of operation 

 Multi-Approach Operation: Identifies any GCDs that require a multi-approach 
operation to complete machining. 

 Special Finishing Operations: The x- axis shows a distinct tick for each type of 
specialized finishing operation, e.g. Surface Grinding, Circular Grinding, 
Reaming, Honing, etc. 

Tolerances 
In general, the tolerance and roughness criteria show the effects of the various tolerance 
settings on geometric cost drivers. For example, surface tolerances show the 
permissible variation in a surface by displaying the GCDs with the highest (“loosest”) 
tolerance values in blue, and those with the lowest (“tightest”) values in red. Tightly-
toleranced features generally take longer to machine and therefore cost more. Likewise, 
roughness criteria show the permissible texture of a surface and which surfaces are 
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more or less expensive to machine. Position and diameter tolerances for hole GCD 
highlight the permissible variation in these criteria and their relative cost impact. 
See Specifying or importing tolerance and roughness values for details about specifying 
tolerances in aPriori. 

Using component viewer commands 
Right-click anywhere in the Component Viewer to access the Component Viewer 
Commands. The commands apply to the selected GCD or the selected part. 
The following commands are available when selecting parts in an assembly: 

• Initialize: Initializes the selected parts or assemblies. Every part in the 
selection is initialized to the same process group, VPE and production 
settings. 

• Open...: Opens the selected part in a new tab. This option is available only if 
just a single part is selected. 

• Save: Saves any changes in the selected parts or assemblies. 
• The following commands are available when selecting a GCD (in both part 

and assembly views): 
• Edit...: Opens the Geometric Cost Driver Editor for the highlighted GCD. If no 

GCD is highlighted, this command is unavailable.  
• Remove: Deletes the selected virtual welds or user created setup axes.  
• Edit Tolerances...: Opens the Tolerance Editor for the highlighted GCD. If no 

GCD is highlighted, this command is unavailable.  
• Auto-merge: Auto-merges an unmerged ComboVoid GCD. Available only for 

ComboVoid GCDs that have been unmerged using the Unmerge command 
below.  

• Unmerge: Unmerges a SimpleHole or a MultiStepHole GCD from a Void GCD 
in a ComboVoid GCD.  

• Viewer: Opens the list of the Component Viewer controls. 
• Tools: Opens the list of the Component Viewer tools. Different tools are 

available depending on the Primary Process Group. 

Specifying 2D Images for virtual components 
(This functionality is available in aPriori 2014 R1 SP1 and later.) If you have a virtual part 
or assembly scenario that is not locked, and that does not have a 3D image extracted 
from a CAD model, you can specify a static image file that will be associated with the 
component and displayed in the viewer area. You can specify this image file when you 
define the virtual component, or you can specify it later in the viewer area.  

Note: In mixed-client deployments, images specified with a 2014 R1 SP1 client may not 
appear in the viewer of a 2014 R1 client, even though it is visible in the Search 
window. 



Using aPriori Desktop  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 93 

To specify or change an image from the viewer 

1 Click the Attach 2D Image icon in the upper-left corner of the viewer. (If no image is 
currently specified, the viewer displays a gray camera icon.) 

 

2 Use the Select Image File dialog to navigate to the image file that you wish to associate 
with the component. Supported image formats are BMP, WBMP, JPG, JPEG, PNG, 
and GIF.  

 
You can use the same procedure to change image files if necessary. 

Note: You can also associate image files with CAD-less components when you define 
the component, or through the Bulk Loader or BOM. You can also attach or 
delete an image using Scenario > Attach 2D Image and Scenario> Remove 
2D image. 

Controlling the resolution of the Component Viewer 
By default, the resolution of the Component Viewer (and of Tools > Copy Image) is 600 
x 600 pixels. This is typically sufficient for users to view small GCDs, and to read GCD 
labels when displayed using the Show GCD labels command in the Analysis tool. If you 
prefer a different default resolution, you can change it by adding the following line: 
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apriori.display.copyImageToClipboard.ImageHeight = <n> 

 
to the following file: 
 

C:\Users\<user>\AppData\Local\aPriori\<version>\apriori.user.propertie
s 

 
where: 
<n> is the number of pixels in the height and width of the image 
<user> is the Windows username of the current user 

<version> is the aPriori version number. 

Controlling the colors of the Component Viewer 
By default, aPriori uses yellow and magenta to highlight selected surface and volumetric 
GCDs. CAD models that are colored similarly to aPriori highlighting colors are displayed 
in shades of gray in aPriori instead of their original color. Your system administrator can 
configure the thresholds at which component colors are considered “too similar” to 
aPriori highlighting colors. See the aPriori Professional System Administration Guide for 
more details. 
 

Collaboration and Usability 
As of Releases 2016 R2 and 2017 R1, aPriori Professional has added a number of new 
fields and features that can be used to better manage the process of preparing and 
refining a cost estimate, and to facilitate collaboration between multiple users. These 
features are reflected in Cost Insight Design.  

 Scenario Notes –  The  Notes toolbar button ( ) opens a Scenario Notes 
dialog through which users can enter and save text notes.  The Notes field is 
intended to support collaboration between different users working on the same 
scenario.  As users work with a scenario, they can add notes about decisions, 
changes, or any questions regarding the scenario. Other users -- both in aPriori 
Professional and Cost Insight Design -- then can access the notes and respond 
as appropriate.  Notes can be saved without requiring the part to be re-costed.    

 Assignee -- Each scenario has an attribute called Assignee, providing a way to 
assign cost estimation tasks to individual users.  This field is available both in the 
Cost Guide and the Administrative Info dialog.  You may select the Assignee 
from a drop-down list of aPriori users at your company.  To find scenarios 
assigned to yourself or other users, select FileOpen to invoke the Search 
dialog and enter the desired username in the Assignee field.  Alternately, you can 
make a Dynamic Roll Up which will return all scenarios assigned to the user of 
interest.  The assignee field can be updated and saved without re-costing.   
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 A Last Assigned Time field also is available, but this field currently is not 
updated automatically.  You can manually edit the time stamp when changing the 
Assignee field, if you wish to track when the assignee changed.  aPriori plans to 
populate this time stamp field automatically when the Assignee value is changed 
in a future release.  

 Status and Cost Maturity – these two fields allow a user to indicate the current 
state of a scenario, which can be used for tracking and reporting purposes or to 
implement a basic collaboration process for reviewing and refining cost estimates 
as design, manufacturing, and sourcing decisions are made.  These fields are 
available both in the Cost Guide and the Administrative Info dialog.  In Release 2017 
R1 the possible values of these fields are hardcoded but will be configurable in a 
future release.  Status currently can be left blank or set to New, (Under)Analysis,  
Waiting, Complete, or Closed.  Cost Maturity currently can be left blank or set to 
Initial, Low, Medium, or High.  The Status and Cost Maturity fields can be 
updated and saved without re-costing.   

Using roll-ups 
An aPriori roll-up is a set of components — parts, virtual parts, assemblies, or other roll-
ups. A roll-up is similar to an assembly; however, unlike an assembly, a roll-up: 

• Can include other roll-ups 
• Has no associated CAD component and process costs  
• Can include functional groups consisting of nested roll-ups 

Note: Roll-up subcomponents are not CAD-connected and therefore cannot fetch new 
GCDs. This means that you cannot change GCD-related settings such as the 
progress group for a subcomponent, unless it is also open in its own tab. This 
only applies to roll-ups – subcomponents of assemblies can be CAD-connected.  

Creating and editing roll-ups 
Roll-ups are created with a unique name and VPE. The VPE determines the base 
currency for the roll-up. For more information on VPEs, see Selecting a virtual 
production environment (VPE) on page 174. 

To create a roll-up 

1 Select File > New Roll-up. The New Roll-up window is displayed. 

2 Enter the Name for the new roll-up. 

3 To accept the default scenario name for the new roll-up, proceed to the next step. If 
you want to create a scenario with a different name, enter it in the “Scenario name:” 
field. Note that the “Scenario name:” field cannot be blank. For more information about 
scenarios, see Working with scenarios on page 66. 

4 Click OK. An empty roll-up is displayed. The roll-up is also added to the Open Items tab 
in the navigation pane.  
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To add a component to a roll-up 

1 Double-click the roll-up in the navigation pane.  

2 Add components to the roll-up by: 
• Dragging a component from the navigation pane to the roll-up. The Choose 

Action window is displayed. Select Add to Roll-up and click OK. 
• Selecting Edit > Add > Component(s) to display the Search window. Enter search 

criteria in the filter fields and click Find. The list of components that match the 
filter criteria is displayed. Select the component(s) from the list and click OK. 
The official scenario for each component in an assembly is used for costing 
by default. To use a different scenario for costing, select that specific 
scenario, rather than the part itself, in the Search window. For more 
information, see Using the Search tool on page 37.  

• Selecting Edit > Add > New. You can create and add either a new part, 
assembly, or roll-up to the active roll-up on the fly. The new component is 
added to the bottom of the list of roll-up components. 

• Right-clicking an existing roll-up within the active roll-up and selecting Add > 
Component(s) or New to access the same menus described in the previous two 
bullets. The existing or new components are added to the selected roll-up. 

The Status column shows the status of a component’s costing: 
 Green — costing completed successfully 
 Yellow — costing succeeded with a warning 
 Red — costing failed 
 Asterisk (*) — unsaved changes; to save the changes, right-click the component 

and select Save 
As soon as you add a component to a roll-up, the roll-up shows in the Roll-ups subfolder 
of the Where Used folder for this component.  

To copy a roll-up table 

1 Double-click a roll-up in the navigation pane.  

2 In the roll-up tab, select Edit > Copy Table. The table is copied to the clipboard. You 
can paste the table into another application such as Microsoft Excel. 

To define roll-up properties 

1 Double-click a roll-up in the navigation pane.  

2 In the roll-up tab, select Edit > Properties. The Property Editor is displayed. 

3 You can edit the following properties: 
• Enter a description for the roll-up in the Description field. 
• Uncheck the No Cost Target checkbox and enter the target cost for the roll-up 

in the Roll-up Target Cost field. 
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• Select the department that produced the roll-up from the Source drop-down 
list. 

• Select the level of cost estimate from the Level drop-down list. 

4 You can edit the following VPE information: 
• To select a user-defined VPE, check the User-Defined checkbox, enter the 

VPE name in the VPE field and select VPE Type and VPE Currency. 
• To use a pre-defined VPE, clear the User-Defined checkbox and select a VPE 

from the VPE drop-down list. VPE Type and VPE Currency are filled in 
automatically. 

5 Click Done. 

To edit a component quantity for a roll-up 

1 Double-click a roll-up in the navigation pane.  

2 Right-click the component you want to edit and select Edit Quantity. The Edit Quantity 
window is displayed. 

3 Enter new quantity. If you enter 0, the component will be removed from the roll-up. 

4 Click OK. The costs are updated to reflect the new quantity. Red up arrows indicate 
values that went up, green down arrows indicate values that went down. 

To remove a component from a roll-up 

1 Double-click a roll-up in the navigation pane.  

2 Right-click the component you want to delete and do one of the following: 
• Select Remove.  
• Select Edit Quantity and enter 0. 

The Confirm Delete window is displayed. 

3 Click OK.  

To edit a roll-up 

1 Double-click a roll-up in the navigation pane.  

2 In the roll-up table, select a component and edit the Manufacturing Process as 
desired. New cost reflecting the changes is calculated. Red up-arrows indicate 
values that went up, green down-arrows indicate values that went down. An asterisk 
appears next to the component’s name to indicate that there are unsaved changes. 

3 To save the changes, right-click the component and select Save. 
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To view last saved values 
In the roll-up tab, select View > Saved Values. The last saved values for the components 
are displayed without losing any unsaved changes. You cannot edit the saved values. 

To view current values 
In the roll-up tab, select View > Current Values. The changes that have been made since 
the values were saved are displayed. You can continue editing the current values.  

To view roll-up components 
Double-click a roll-up component in the roll-up table or in the navigation pane to open it 
in a new tab. 

To save a roll-up as a scenario 

1 Right-click a roll-up in the navigation pane and select Save as Scenario. The Save As 
window is displayed. 

2 Enter the Name and Description (optional) for the new scenario. 

3 Click OK. 

4 The roll-up is saved as a locked (uneditable) scenario. It captures a static version of 
the roll-up components and costs for later analysis. Once a scenario is created, it 
appears in the Scenarios folder in the navigation pane. For more information, see 
Working with scenarios on page 66.  

Cutting, copying, and pasting between roll-ups 
You can cut, copy, and paste components from one rollup to a new or existing roll-up. 
This enables you to quickly create alternative groupings of components for analysis 
purposes, or to dynamically organize product costs as the product structure evolves.  

To cut or copy a component to another roll-up 

1 Open a rollup and select one or more components you wish to cut or copy (Ctrl+click 
to select multiple components). 

2 Right-click and select Cut or Copy from the context menu. 

3 Right-click the destination roll-up in the active roll-up tab or open the destination roll-
up tab. 

4 Right-click and select Paste from the context menu. 

Using dynamic roll-ups 
An aPriori Dynamic roll-up is similar to a roll-up in that it appears to be a list of parts, 
virtual parts, and assemblies. However, unlike a roll-up, a Dynamic roll-up cannot 
contain roll-ups or other Dynamic roll-ups, because the contents of a Dynamic roll-up are 
determined by saved search terms that enable the list to update over time. 
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A Dynamic roll-up: 
• can include virtual parts 
• has no associated CAD component and process costs  
• can return different components over time 

A Dynamic roll-up allows you to save and reopen a search at any time to review the 
current results. For example, this can help you track activity associated with particular 
projects, users, or process groups over the last 30 days, at recurring intervals of your 
choosing. 
Where a roll-up is a fixed list of components that may be edited on a part by part basis, a 
Dynamic roll-up is a changing (or dynamic) list of components that is determined by fixed 
search criteria (which also may be edited). See Creating and editing roll-ups on page 95. 

Creating and editing dynamic roll-ups 
Dynamic roll-ups are created with a unique name and VPE. The VPE determines the 
base currency for the Dynamic roll-up. However, a Dynamic roll-up can include 
components from multiple VPEs. For more information on VPEs, see Selecting a virtual 
production environment (VPE) on page 174. 

To create a dynamic roll-up 

1 Select File > New Dynamic Roll-up. The New Dynamic Roll-up window is displayed. 

2 Enter the Name for the new Dynamic roll-up. 

3 To accept the default scenario name for the new dynamic roll-up, proceed to the next 
step. If you want to create a scenario with a different name, enter it in the “Scenario 
name:” field. Note that the “Scenario name:” field cannot be blank. For more information 
about scenarios, see Working with scenarios on page 66.   

Note: Dynamic roll-ups cannot have multiple scenarios like parts, assemblies, cost 
comparisons, and roll-ups do. 

4 Click OK. The Dynamic Roll-up window is displayed.  
The left-hand column in the Dynamic Roll-up window contains Dynamic Roll-up Criteria, 
which function as search filters. (Search filters are explained in Using the Search tool 
on page 37.) 
The Preview button executes the search and returns the components found by the 
entered search criteria. 

5 Selecting OK will create the Dynamic roll-up with the specified search criteria. The 
roll-up is also added to navigation pane > Open Items > Roll-ups. 

To edit a dynamic roll-up 

1 Double-click the roll-up in the navigation pane. 

2 In the Dynamic roll-up tab, select Edit > Edit Query. 
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The Query Editor window opens. The Query Editor is identical in function to the 
Dynamic Roll-up window. 

3 Edit your Dynamic Roll-up Criteria to refine your search. 

4 Preview and select OK to return the updated list retrieved by your new criteria. 
The Status column shows the status of a component’s costing: 

• Green — costing completed successfully 
• Yellow — costing succeeded with a warning 
• Red — costing failed 
• Asterisk (*) — unsaved changes; to save the changes, right-click the 

component and select Save 
As soon as you add a component to a roll-up, the roll-up shows in the Roll-ups 
subfolder of the Where Used folder for this component.  

To update dynamic roll-up components 
There are two ways to refresh the components returned in an open Dynamic roll-up: 

• Close and reopen the Dynamic roll-up 
• In the Dynamic roll-up tab, select Edit > Edit Query and select OK in the Query 

Editor. 

To copy a dynamic roll-up table 

1 Double-click a Dynamic roll-up in the navigation pane. 

2 In the roll-up tab, select Edit > Copy Table. The table is copied to the clipboard. You 
can paste the table into another application such as Microsoft Excel. 

To define dynamic roll-up properties 

1 Double-click a Dynamic roll-up in the navigation pane. 

2 In the Dynamic roll-up tab, select Edit > Properties. The Property Editor is displayed. 

3 You can edit the following properties: 
• Enter a description for the roll-up in the Description field. 
• Uncheck the No Target Cost checkbox and enter the target cost for the roll-up 

in the Roll-up Target Cost field. 
• Select the department that produced the roll-up from the Source drop-down 

list. 
• Select the level of cost estimate from the Level drop-down list. 

4 You can edit the following VPE information: 
To select a user-defined VPE, check the User-Defined checkbox, enter the VPE name 
in the VPE field and select VPE Type and VPE Currency. 
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To use a pre-defined VPE, clear the User-Defined checkbox and select a VPE from the 
VPE drop-down list. VPE Type and VPE Currency are filled in automatically. 

5 Click Done. 

To edit a component in a dynamic roll-up 

1 Double-click a Dynamic roll-up in the navigation pane.  

2 In the Dynamic roll-up table, select a component and edit the Manufacturing Process 
as desired. New cost reflecting the changes is calculated. Red up-arrows indicate 
values that went up, green down-arrows indicate values that went down. An asterisk 
appears next to the component’s name to indicate that there are unsaved changes. 

3 To save the changes, right-click the component and select Save. 

To view last saved values 
In the Dynamic roll-up tab, select View > Saved Values. The last saved values for the 
components are displayed without losing any unsaved changes. You cannot edit the 
saved values. 

To view current values 
In the Dynamic roll-up tab, select View > Current Values. The changes that have been 
made since the values were saved are displayed. You can continue editing the current 
values.  

To view dynamic roll-up components 
Double-click a Dynamic roll-up component in the Dynamic roll-up table or in the 
navigation pane to open it in a new tab. 

Using functional groups 
You can create functional groups for roll-ups to organize large product structures that 
may not be defined in CAD. Functional groups may help you: 

• Organize very large product structures for comparison across programs 
• Establish the framework for costing dynamic product configurations in very 

large product structures 
• Assign team responsibilities for function costs within a program 

Functional groups in a roll-up are just roll-ups created within that roll-up. You can create 
functional groups one at a time, or you can import a functional group template, which 
generates the entire functional group structure in one step. For example, if you want to 
generate consistent functional group structures within multiple roll-ups, you can use your 
functional group template for multiple roll-ups. For more information on reusing a 
template, see Cutting, copying, and pasting between roll-ups on page 98. Roll-ups can 
have functional groups applied both through the UI and through the BOM Loader (see 
the VPE Administrator Guide).  
The template is an XML file which describes the roll-up hierarchy to be created in the 
parent roll-up. The hierarchy represents your functional groups. You can create a 
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template by using the Microsoft Excel spreadsheet Functional Group Template 
Generator.xls in the install-support\templates directory of your aPriori 
installation.  

Reapplying functional groups templates 
If you apply a functional group template to a roll-up that has already had it applied, 
aPriori observes the following rules: 

• Any groups that have already been created will be skipped (that is, aPriori will 
not create a new version or scenario of the existing group).  

• Any groups that do not already exist will be created (that is, if additional 
groups have been added to the template, they will be added to the roll-up). 

• Any roll-up  groups that do not exist in the template will be ignored (that is, 
any groups that have been removed from the template will not be removed 
from the roll-up).  

Note: Before re-applying a functional group template, please read Best practices using 
functional groups below. 

Functional group naming conventions 
aPriori observes the following conventions when displaying roll-ups that have had a 
functional group template applied to their structure. Note that this behavior has changed 
as of aPriori Release 2014 R1: 

• Roll-ups that were created by applying a functional group template are 
represented as different roll-ups, not as different scenarios of the same roll-
up. The fully qualified name for a functional group is constructed as  
"<parent roll-up >.<functional group name>" 

• In the Details table, the Name column shows only the name of the roll-up, not 
the fully qualified name. For example, a group with the full name 
“Roll1.drivetrain.engine” will display only “engine”.  

• In the manufacturing process tree, and in the tab name for an opened 
scenario, and in the Search dialog, the fully-qualified name is displayed. 

Best practices using functional groups 
Although you can re-apply a functional group template, aPriori recommends the 
following practice: if you find that you want to apply a functional group template to a roll-
up that already has one (for example, you have updated the functional groups, or you 
applied the wrong functional group template to the roll-up and now wish to apply the 
correct one), create a new roll-up instead, and apply the updated or correct functional 
group template to new roll-up. 

To create a functional group template 

1 Open Functional Group Template Generator.xls in the install-support\templates 
directory of your aPriori installation. 
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2 Put the name of the functional group hierarchy in cell A1. This is a name of your 
choosing. It is used in the filename of the generated template. 

3 Specify the functional group structure as follows: 
• Put names of top-level functional groups in column B.  
• Put each child group in the column immediately to the right of its parent 

group. Put the first child on the line immediately below (and to the right of) the 
parent’s line. Put any additional children immediately below that. 

• Do not leave entirely blank any row or column that is within the structure 
specification. 

• Only one cell of each row should be occupied.  
• Insert additional columns as needed. 

4 Use the spreadsheet’s Browse button and/or the text field next to it to enter or 
navigate to the directory to contain the generated template. 

5 Click the spreadsheet’s Create Template button. The template file is created in the 
specified directory. The filename is the group name followed by .fgt.XML. 

6 You can use the spreadsheet’s xmlOutput tab to view the generated XML. 
Here is an example: 

 
The spreadsheet above generates the following functional group hierarchy: 
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In this example, the name of the parent roll-up is ATV, which precedes the node names 
of the functional groups that are created. 
As an alternative to using the template generator spreadsheet, you can create the XML 
yourself. Use a format like the following: 

 
Since XML does not allow numeric element names, use the following type of format to 
handle numerical functional group names: 
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Save the new file with the .fgt.XML extension so that aPriori can recognize the file as 
a functional group template. For example, a valid template filename is 
myFunctionalGroups.fgt.XML. If you are editing with Notepad and do not save the 
file with this extension, the file will be stored as a text file and aPriori will not be able to 
import it.  

To create functional groups using a functional group template 

1 Open a rollup. 

2 Select Tools > BOM > Apply Functional Group Template from the aPriori menu 
bar. 

3 Navigate to the location of your functional group template file, select it, and click Open 
to create the structure described within your template in the open roll-up. 

Comparing the costs of alternative 
designs 
aPriori provides the ability to compare different scenarios to identify the costs of 
alternative designs or manufacturing  approaches for a part, an assembly, or a roll-up.  
For example, you might cost a sheet metal component with a scenario produced in 
Mexico and a scenario produced in China.  You can add both scenarios to a comparison 
and analyze the price difference. 

Creating and editing Comparison Summary views 
You can create a Comparison Summary from three points in the UI: 

 From the Compare button (  ) on the toolbar, which starts with the 
currently-open scenario and prompts you to specify a second for comparison.  
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 From the Scenario > Create Comparison menu, which behaves identically to 
the Compare button. 

 From the File > New Cost Comparison menu, which prompts you to specify 
both scenarios to compare. 

To create and work with a Comparison  
The most common situation is when you are already working with one open  scenario 
and wish to compare it to another scenario. 

1 Ensure that the first scenario of interest is open and selected. 

2 Click the Compare button from the toolbar. (Alternatively, you can click the Scenario 
> Create Comparison menu.)  

 

3 In the resulting Create Comparison dialog, you can optionally edit the Name:, Scenario 
Name:, and/or Description: fields. Click OK when done. 
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4 In the resulting Search window, find and select the second scenario which you would 
like to compare. (For more information about using the Search window, see Using 
the Search tool.) Click OK when done. 

Note: You can increase your selection for additional scenarios to compare by using 
CTRL-Click in the Search tool.. 

 

5 In the resulting Comparison Summary view, the left-most component is considered the 
"Base". Any scenarios to the right of the Base scenario are compared to the Base, 
and variations from the Base are shown in the %Diff column. 
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6 In the Summary view you can: 
• Collapse and expand entries in the Name column, using either the "+/-" 

buttons, or the mouse-over menu in the upper-left corner of the column (see 
aPriori Desktop table controls for more information). 

• Add additional scenarios to compare against the Base scenario by clicking 
Add and using the Search tool as described above. (There is no practical limit 
to the number of scenarios you can add.) 

• Make a different scenario the Base by selecting its column and clicking the 
Set as Base button. 

• Remove a scenario from the comparison by selecting its column and clicking 
the Remove button. (You can expand the selection to remove multiple 
scenarios at once with Shift-Click and Ctrl-Click.) 

• Open a scenario by selecting its column and clicking the Open button. 

Note: If you recost a scenario, any changes are immediately reflected in the 
Comparison Summary  view. 

To save, find, and re-open Comparison Summaries 
Comparison summaries can be saved, searched for, and opened as scenarios like any 
other component. 
Use the options on the Scenario menu to save comparison summaries and to change 
their Active, Lock, and  
official status. 
For more information, see Working with scenarios on page 66.  
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Creating new components without CAD  
You can create a new component even when there is no CAD model from which to 
derive the cost. A component created without a CAD model is also referred to as a 
virtual component (part or assembly). For example, a virtual component may represent 
any of the following: 

• Component sourced from a supplier 
• Non-mechanical component, such as lubricant or packing supplies 
• User-defined process, such as inspection or handling 
• Early conceptual part, for which a CAD model does not yet exist 
• Early conceptual assembly, for which some or all CAD models do not yet 

exist 
Since a virtual component has no CAD model, aPriori cannot automatically derive 
geometric cost drivers, such as length or volume. However, you can enter some basic 
geometric information for a virtual component.  
A virtual component is assigned to the User Guided process group and that group’s 
default VPE, but the virtual component has no material or process routing by default. A 
virtual assembly component is assigned to the Assembly process group and that group’s 
default VPE.  
The assembly process routing is fully accessible from virtual assemblies, and all 
components contained within the assembly, virtual or CAD-based, contribute to the 
aggregate cost of the assembly. Assembly processes also reflect the costs of 
subcomponent assembly, as long as you provide a mass for each subcomponent. 
Assembly component geometric cost drivers may be specified in the Geometric Cost 
Drivers window. Volume, Surface Area, Length, Width and Height may be entered to 
describe assemblies that are not CAD-based.  
There are two ways to generate cost information for virtual parts. You can manually 
enter data for the individual cost component fields, and the aggregate cost fields, such 
as Total Variable Costs or Fully Burdened Cost, are computed by aPriori. Or you can 
use the aPriori User-Guided Costing module (licensed separately) to generate costs 
using the basic geometric information and other inputs you supply.  
Assembly components that are not CAD-based generate cost information just like CAD-
based assembly components. Subcomponent costs are aggregated, and assembly costs 
are calculated for the active assembly. You can enter cost information for manually 
costed assemblies, disengaging the aPriori cost engine, and use cost overrides to enter 
values for the aPriori cost engine. For more information about manual costing, see 
Overriding computed values on page 112. 

To create a non-CAD-based component 

1 Select File > New Component > Part or Assembly from the aPriori menu bar to 
display the Create a Virtual Part or Create a Virtual Assembly window. 
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2 Enter a part number in the Part Number field. 

3 To accept the default scenario name for the new part or assembly, proceed to the 
next step. If you want to create a scenario with a different name, enter it in the 
“Scenario name:” field. Note that the “Scenario name:” field cannot be blank. For more 
information about scenarios, see Working with scenarios on page 66.  

4 (Optional, available in 2014 R1 SP1 and later): In Image File Path:, click the folder 
icon to browse to an image that you want associated with the component. 

 
Supported image formats are BMP, WBMP, JPG, JPEG, PNG, and GIF. 
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5 (Optional) Enter a description in the Description field. 

6 Click OK to display the Production Info tab of the Cost Object Info window. 

7 Select the Costing Method: 
• Manual to manually enter cost data for the part, 
• aPriori if you have licensed the aPriori User Guided Costing module and will 

be entering inputs to drive a user-guided cost model, 

8 Select the Batch Size.  
•  Auto to have aPriori calculate the monthly production size from your Annual 

Volume value/12.   
• Manual to provide a specific value. 

9 (Optional) Check the Target Cost and /or the Target Finish Mass box and enter a value in 
their fields to associate target values with the component. 

10 Click OK.  

Working with non-CAD-based assembly 
components 
Once an assembly component has been created without CAD, you can edit the 
assembly structure and associated components using commands in the Assembly Details 
tab. 
An assembly may be created independently from CAD and can contain subcomponents 
based on CAD models as well as subcomponents that are non-CAD-based. You can 
manually associate new or existing subcomponents to an active assembly regardless of 
the assembly’s association to a CAD model.  
You may build around an existing CAD-based assembly, create a new assembly 
component which incorporates CAD-based assembly and part components, or create an 
entirely virtual assembly component. However, CAD-based assembly structures cannot 
be contradicted. That is, you can add subcomponents to a CAD-based assembly, but 
you cannot remove subcomponents (or change their quantity) in the aPriori assembly 
component(s) based on a CAD model.  
aPriori creates assembly structures automatically from a CAD model. When your 
assembly is not based on a CAD model you have to create the structure manually in the 
Assembly Details tab.  Each manually associated subcomponent (part or assembly, CAD-
based or non-CAD-based) displays  in the Status column. 
Virtual assembly structures may also be created using the BOM Loader. For more 
information, see the aPriori VPE Administration Guide. 

To modify an assembly structure 
Use the following assembly commands in the Assembly Details tab to create the assembly structure. 
Right-click a subcomponent within the assembly to display the following options in the context 
menu:  
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• Copy – Copies the selected subcomponent for pasting 
• Cut – Removes a manually associated subcomponent from an assembly for 

pasting 
• Paste – Inserts cut or copied components to the selected assembly  
• Add > Component(s) – Displays the Search window, where you can select one or 

more components to add to the selected assembly 
• Add > New > Part or Assembly – Displays the Create a Virtual Part or Create a Virtual 

Assembly window, where you can create a new part or assembly 
subcomponent 

• Edit Quantity – Enter a quantity for the selected manually associated 
subcomponent 

• Remove – Remove the selected manually associated subcomponent from the 
assembly  

You can also drag and drop a manually associated subcomponent to move it within the 
assembly structure. 

Overriding computed values 
In aPriori Desktop, you can manually specify a component’s associated values, 
overriding the values computed by aPriori using the component’s geometric cost drivers 
(GCDs), non-geometric cost drivers (such as selected routings, production volume, etc.), 
properties from the CAD file, and VPE data. This is useful for a wide array of situations 
that call for customization of cost-related factors. For example, you can override the 
aPriori labor rate data to better match the labor rates quoted by a supplier, for quote 
validation purposes. 
aPriori Desktop provides two kinds of computed-value override: 

• Part details overrides: overrides values, such as Labor Time, which are 
presented in the Part Details or Assembly Details tab. These reflect values for 
the various processes and operations used to create the component. 
Overriding a value affects all values that depend on it. 

• Cost summary overrides: overrides costs, such as Material Cost or Logistics, 
that are presented in the Cost Summary tab of aPriori Desktop. These reflect 
costs for the entire routing used to create the component (rather than costs 
for any individual process or operation). See Performing Part Details 
overrides and Performing total cost summary overrides. 

The Cost Overrides Summary dialog (not to be confused with overrides in the Cost 
Summary tab) provides a summary of the various overrides and user inputs that are in 
effect. See Working with the Overrides Summary dialog. To remove overrides, use the 
Cost Overrides Summary dialog. 

A note about Cost Overrides and One Click Costing 
In releases of aPriori prior to 2015 R1, entering a Cost Override would automatically 
cause the component to re-cost, even if One Click Costing was enabled. (See One Click 
Costing™ (enabling/disabling auto-costing in response to CAD changes) for more 
information about One Click Costing.) This could be very inefficient if you needed to 
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enter several overrides. In aPriori Release 2015 R1 and later, Cost Overrides entered in 
the Part Details, Assembly Details, and Roll-up views will not automatically cause a re-cost 
when One Click Costing is enabled. However, any Cost Overrides entered in the Cost 
Summary tab will still cause an immediate recosting, regardless of the One Click Costing 
setting. 

Performing Part Details overrides 
In the Part Details or Assembly Details views, you can double-click on a table cell in 
order to override the value of that cell. aPriori dynamically re-calculates any fields that 
depend on overridden values. For example, if you override either the Labor Rate or 
Number of Operators for a process, aPriori updates the value of the Labor Cost field for 
that process accordingly. This update is then propagated to values that depend on it, 
ultimately affecting the total labor cost for the part. 

Note: A value depends on another value only if its formula takes the other value as an 
input. The exact inputs to each value’s formula are not always apparent. For 
example, some formulas for Material Cost (which can be calculated from Part 
Mass) do not have Part Mass as an input, but rather have both Part Volume and 
Material Density as inputs. In these cases, Material Cost is not affected by an 
override of Part Mass. The Cost Model Workbench includes detailed information 
about each formula. 

When you override a field value, you can optionally enter a comment to indicate the 
reason for the override.  Editable fields are denoted with a “pencil” icon.  Overridden 
cells are displayed in red font. 
Sourcing engineers will find this cost override capability useful when they are trying to 
validate supplier quotes – they can input their supplier’s labor and overhead rates and 
profit margins, for example, to estimate the expected supplier cost. Manufacturing and 
cost engineers, with their more in-depth knowledge of manufacturing practices and time 
standards, might wish to override lower levels of detail, including individual process cycle 
times. 
Generally, it is recommended that you override fields at the specific process level, rather 
than a higher level of the manufacturing tree. This is because the formulas that define 
relationships between various fields are generally defined at the process level, so 
updates to one field will only ripple to other fields if they are applied at that process level. 
In the example below, aPriori allows you to override the Labor Time field for the Band 
Saw process, but not for the Saw node above it.  The updates will then be properly 
propagated up to the Saw row. 
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Notes:  1. You cannot override the material's Utilization % in the Part Details tab. To override 
the material utilization, use the Material Selection dialog. See Selecting material on 
138 for more details. 
 
2. In some cases, overriding a field will not have the expected effect on another 
field. This can happen if the manufacturing process cost model does not actually 
have equations defined that relate the second field to the first updated field. 
Please contact aPriori Support if you have questions about cost overrides and 
unexpected behavior. 

To enter overrides in the Details tabs 

1 Double-click a cell with a pencil icon (  ).  

2 Type the new value followed by Enter. 

Note: When you override a formula, any cells that contribute to that formula display 
dashes and cannot be overridden. 
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Show Formula Dependencies 
When you right-click a cell in the Part Details or Assembly Details tab, you are 
presented with a context menu containing the option Show Formula Dependencies.  

 
Clicking this displays a window populated with information regarding the value in the cell. 
For a simple value like "Batch Size", the display might be relatively sparse, with just a 
description and a link to the CSL code: 

 
For a more complex, calculated value like Direct Overhead Rate, the Formula 
Dependencies window can display a large amount of information in tree format showing 
not only the current formula, but also which formulas contribute to it.  

 
Clicking on a formula under the CSL column opens the Cost Model Workbench on the 
page where that formula is defined: 
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Note: The behavior of Show Formula Dependencies can change if you change the 
mode by which overhead rates are calculated. This mode is controlled by the 
Use Computed Overhead Rate VPE variable (see the section "VPE Variables, 
Machine Properties, and Overhead Costs" in the aPriori Cost Model Guide).  
When set to True (the default for release 2015 R1 and later) Show Formula 
Dependencies displays all direct and indirect overhead rates as computed. If set 
to False, or if you change the VPE to one where this variable is set to False (the 
default mode prior to 2015 R1),  Show Formula Dependencies will display a 
value of "0" or any overridden value, even though these formulas are no longer 
relevant in the costing of the part. 

When using Show Formula Dependencies, you should generally select fields from 
process level or die-station rows, rather than at the process-group or part-level rows.  
Process-group and part-level rows simply aggregate the rows below, so for most fields 
the formula dependencies dialog does not provide additional information about the 
contributors to those formulas.  (Formula dependencies are available only for a select 
number of fields at the part level, listed below).  In the example below, a user should 
select the Labor Time cell at the Turret Press row, not at the Sheet Metal row, to get 
drill-down visibility into the Labor Time cost model.   
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The resulting Formula Dependencies for Turret Press Labor Time is shown below: 

 
Formula Dependencies are provided for the following Process-Level fields: 

 Direct Overhead Rate – introduced in aPriori 2015 R1 
 Indirect Overhead Rate – introduced in aPriori 2015 R1 
 Total Overhead Rate 
 Final Yield 
 Lifetime Scrap Parts 
 Labor Time 
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 Cycle Time 
 Batch Setup Time 
 Finish Mass 
 Scrap Mass 
 Rough Mass 
 Utilization 
 Material Cost 
 Labor Cost 
 Direct Overhead Cost 
 Amortized Batch Setup 
 Logistics 
 Material Overhead 
 Expendable Tooling 
 Additional Direct Costs 
 Extra Costs 
 Other Direct Costs 
 Total Variable Cost 
 Indirect Overhead Cost 
 SG&A 
 Margin 
 Piece Part Cost 
 Hard Tooling (amortized) 
 Fixture Cost (amortized) 
 Programming Cost (amortized) 
 Additional Amortized Investments 
 Total Amortized Investments 
 Fully Burdened Cost 
 Unit Cost 
 Hard Tooling 
 Fixture Cost 
 Programming Cost 
 Total Capital Investments 

Formula Dependencies are provided only for the following Part-Level fields.   
 Batch Cost 
 Annual Cost 
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 Lifetime Cost 
 Total Production Volume 

To use the Show Formula Dependencies feature 

1 In any cell in a Details tab, right click and select Show Formula Dependencies.  

2 If the Formula Dependencies window displays a collapsed tree, expand it to explore 
what formulas contribute to this one. 

3 (Optional): Enter overrides in fields with a pencil icon (  ). 

4 (Optional): Click any formula to be taken to the Cost Model Workbench (CMWB) 
definition of the formula. 

Performing selective Cost Summary overrides 
The Enable Cost Overrides command allows you to override individual Cost Summary 
values for a part or assembly. This command is available from the Scenario menu and 
from an icon (  ) on the tool bar. 
When you select this command, a check box is displayed next to every cost value. 
Those that are editable have a checkbox with a 3D shadow; plain checkboxes indicate 
values that cannot be overridden.  

 
In general, you cannot override amortized values, but you can override the Capital Costs 
fields, and these values will be amortized and will be reflected in the Fixed Costs fields.  
Checking a specific check box opens the corresponding cost value for editing. You can 
override one or more values. 
The cost value that has been checked for manual costing is no longer affected by 
changes to the component’s GCDs, non-geometric cost drivers, or VPE data. However, 
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if you disable cost overrides, aPriori discards the manually specified values, re-evaluates 
the CAD geometry and computes the cost values for the component. 
You can use cost overrides for cost values that can be calculated by aPriori as well as 
for those that aPriori does not consider at the moment.  
For example, the material used to fabricate a part may require a special vendor-supplied 
finish or processing that is not reflected in the cost of the material stock specified in the 
VPE. In this case, you can override the material cost for this part to reflect the cost of 
material with the required finish. Alternatively, you may wish to override the material unit 
cost, which is used to compute the total material cost, using the Material Selection 
window. For more information on how to do this, see Change material unit cost on page 
141. 
You can also use cost overrides to include the logistic cost to fabricate a component, 
such as internal or external shipping and handling, since by default aPriori does not 
compute logistics costs but does provide a Logistics field in the cost taxonomy.  

To enable and enter cost summary overrides 

1 Click the  icon or select Scenario > Enable Cost Overrides. In the Cost Summary 
table, you see check boxes for the editable cost values. 

2 Select a check box for each cost value that you want to edit. The cost value field 
becomes editable. 

3 Enter a new value, then press Enter or move to another field. The cost totals 
associated with the value automatically re-calculate. 

4 If desired, enter a note about the purpose or contents of the override in the 
Comment: window that appears just below the cost value field. After you have 
entered a comment for a cost override value, a small red triangle will appear in the 
upper right corner of the cell. You can click on that triangle to view or edit the 
comment in the future. 

5 Click the Save button. 

To disable cost summary overrides 

1 Click the  button or select Scenario > Enable Cost Overrides. aPriori discards the 
manually specified values, re-evaluates the CAD geometry and computes the cost 
values for the component. 

2 Click the Save button. 

Performing total cost summary overrides 
The Scenario > Manually Costed command allows you to specify all cost summary values for 
a part or assembly.  

When you select this command (or when you select the Manually Costed process group in the 
Cost Guide and click Cost Now),  a check box is displayed next to every editable cost value in 
the Cost Summary tab.. All check boxes are checked and disabled indicating that all costs are 
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specified manually and are not affected by changes to the components GCDs, non-geometric 
cost drivers, or VPE data.  

If you disable manual costing, aPriori discards the manually specified values, re-evaluates the 
CAD geometry and computes the cost values for the component. 

Manually costed components are typically used when the cost for the component is not 
determined by its geometry or production facility. For example, you may design a CAD model for 
a part that will be sourced from a supplier. In this case, the cost for the part will be determined by 
the supplier and manually entered into the aPriori Desktop. 

While the GCDs and Manufacturing Process information do not impact the cost for a manually 
costed component, they can impact the process level costs when that component is used in an 
assembly.  

To create a manually costed component 

1 Open a component (part or assembly). 

2 Select Scenario > Manually Costed. Editable fields in the Cost Outputs pane change 
color. 

3 For each field you want to edit, enter a new value and press Enter or move to another 
field. The cost totals associated with the value automatically re-calculate. 

4 Click the Save button. 

To convert a manually costed part to aPriori costed 

1 Open a manually costed part or assembly. 

2 Select Scenario > Manually Costed. aPriori discards the manually specified values, re-
evaluates the CAD geometry and computes the cost values for the component. 

3 Click the Save button. 

Precedence of production input overrides 
aPriori allows you to set and override production inputs in a variety of ways. Production 
inputs include settings such as Process Group, VPE, Material , Annual Volume, and 
Batch Size. 
Here is the precedence aPriori follows for production inputs, in descending order: 

 4: User Override, if specified. For example, manually entering a value in the Cost 
Guide (see Initial costing: the Cost Guide), or providing a value on the input 
spreadsheet or via the UI for Bulk Costing (see Bulk Costing and Analysis). User 
overrides always "win".  

 3: CAD Property value, if provided. See Costing with CAD Properties for more 
information. 

 2: Preference value from Tools > User Preferences > Default Production Inputs….(see 
Default Production Inputs). 

 1: Site or VPE default, if specified. This will be used if none of the above apply. 



Using aPriori Desktop  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 122 

Working with the Overrides Summary 
dialog 
As a companion to the ability to override computed values, aPriori provides a Cost 
Overrides Summary dialog.  

 
This dialog summarizes the many different types of inputs and overrides you may have 
provided when costing a component, and also allows you to revert all or selected 
overrides. 
Select Edit > Cost Overrides Summary from the Manufacturing Process pane to invoke the 
dialog.  The dialog presents numerous types of overrides made to the part, including:   

 Overridden fields in the Cost Summary, Part Details, and Assembly Details tabs. 
See Overriding computed values on page 112. 

 Material selections (if a user explicitly selected a material rather than using the 
default material for the VPE). See Selecting material on page 138. 

 Routing selections (if a user explicitly selected a routing rather than allowing 
aPriori to auto-select the routing based on lowest cost). See Selecting a process 
routing on page 182. 

 Machine selections (if a user explicitly selected a machine rather than using the 
one chosen automatically by aPriori). See Selecting a machine for an operation 
on page 175. 

 Feasibility rule overrides (if the user unchecked the box indicating the system 
should apply the default process and machine feasibility rules). See Selecting a 
process routing on page 182. 

 Process Setup Option settings (if the user edited the default setting for any 
process setup options). See Editing process setup options on page 177. 

 Tolerance and Roughness settings (if the user explicitly specified any tolerance 
or roughness values). See Specifying or importing tolerance and roughness on 
page 143. 

 GCD Properties (such as indicating a hole is threaded). See Editing values in the 
GCD properties table on page 201. 

 Production inputs if your installation has been configured to automatically map 
CAD properties. See Costing with CAD Properties on page 35.. 
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In addition to organizing and summarizing these many types of inputs and overrides, the 
Cost Overrides Summary dialog also allows you to undo (revert) all or selected 
overrides.  The Clear All Overrides button removes all inputs and overrides applied to the 
component, allowing you to start fresh.  Alternatively, you can remove only selected 
overrides, such as all the overrides related to a given process, or a single field.   Just 
select the desired row or set of overrides, right click, and select Remove Override from the 
popup menu. 

Note: aPriori Professional Release 2018 R1 introduces three new override features: 
1. Overrides that were not previously shown in the Overrides Summary dialog 
are now displayed: 

Override Process Group(s) 
Flattening options Sheet Metal-based process groups 
Main Surface selection Sheet Metal 
User-defined Forms Sheet Metal-based process groups 
Build Direction Additive Manufacturing 
Draw Direction Casting-Die, Casting-Sand, Forging, Powder Metal, 

Plastic Molding, Roto & Blow Molding, Sheet Plastic 
Ram Direction Sheet Metal - Transfer Die, Sheet Metal – Stretch 

Forming 
GCDs excluded from slide/lifter 
bundling 

Casting – Die, Plastic Molding 

GCDs Unmerged from ComboVoids Casting-Sand, Casting-Die, Plastic Molding, Roto & 
Blow Molding 

Stock Form and Alignment Stock Machining, Bar & Tube Fabrication 
User-defined Setup Axes Stock Machining, secondary machining 
Limit Turning Axes Stock Machining, secondary machining 
User Defined Attributes* All process groups 
Tolerance Policy settings All process groups 

*Previously an override to a User Defined Attribute field was shown only if the field supplied a 
default value. Now all overrides to User Defined Attribute fields are shown. 

2. The Overrides Summary dialog now includes a Comments column, which 
displays any comments that may be associated with formula overrides. 
3. Finally, information about the overrides made to an aPriori scenario can now 
be included in a spreadsheet report. See Including information about scenario 
overrides in Chapter 11 for more information. 

BOM reports 
aPriori provides two reports to compare the differences between two large assemblies 
and roll-ups: 

 BOM Comparison Report Piece Part Cost 
 BOM Comparison Report Fully Burdened Cost  

To generate a BOM report 

1 Open an assembly or roll-up in aPriori. 
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2 Select Reports > BOM from the aPriori menu bar and select one of the following 
options: 

• BOM Comparison Report Piece Part Cost – Select this option to list piece part 
costs and weights down to the component level, calculates the difference 
between these values for two assemblies or roll-ups line by line, and 
highlights the differences 

• BOM Comparison Report Fully Burdened Cost– Select this option to list fully 
burdened costs and weights down to the component level, calculates the 
difference between these values for two assemblies or roll-ups line by line, 
and highlights the differences 

3 Select the assembly or roll-up for comparison against the active assembly or roll-up. 

Spreadsheet Reports 
Documentation about aPriori Spreadsheet reports is now covered in its own chapter: 
Spreadsheet Reports 

Bulk editing components 
In aPriori Desktop, you can simultaneously edit multiple objects: 

 components within a single container — an assembly, a roll-up, or a comparison 
 GCDs for a specific component 

To change the Primary Process Group for multiple components included in an assembly, 
a comparison, or a roll-up, aPriori must be able to retrieve the GCDs required to 
calculate the cost. To make it possible: 

 In Direct Integration mode, all components must be loaded into the MCAD 
system. 

 In CAD-Independent mode, all components must be file-connected. 
You can simultaneously edit only those values that the multiple objects have in common.  
For example, to bulk edit the material for a set of components, the selected components 
must be set to the same facility, because materials are associated with a particular 
facility.  
Similarly, to bulk edit the machines for a set of components, the selected components 
must be set to the same routing, because machines are associated with a particular 
routing.  
To select multiple objects: 

 Ctrl-Select — Hold down the Ctrl key and click on each object. 
 Shift-Select — Select an object, hold down the Shift key, and select a second 

object. All the objects between the two selected objects (including the selected 
objects) are selected. 

 Left-mouse-Select — Hold down the left mouse button, select an object, and 
drag the cursor to select multiple objects above or below. 
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6 Access Control 

This section describes aPriori's Access Control mechanism.  

This chapter includes the following topics: 
 Access Control Overview 
 How it is implemented 
 How this might affect you 
 Access Control Principles 
 Additional details 
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Access Control Overview 
aPriori provides administrators with the ability to define which users have specific 
permissions to access particular elements within aPriori. As an end user, you do not 
need to be too concerned about this capability other than to be aware of whether or not it 
has been implemented at your installation. This chapter describes at a very high level 
how Access Control works, and how it might affect your day-today use of aPriori. 
Detailed information about configuring Access Control is available in the aPriori System 
Administration Guide. 
If you are not sure whether Access Control has been implemented at your site, you may 
want to ask your system administrator. If it has not been implemented, then nothing in 
this chapter applies to you. If it has been implemented, then this chapter will help you to 
understand certain behaviors or error messages that you might encounter. 

How it is implemented 
aPriori Access Control consists of three basic parts: 

 Groups 
 Permissions 
 Resources 

Groups are collections of users. Every aPriori user belongs to one or more groups. 
Permissions such as Read, Create, Delete, Update, etc. are associated with Groups. 
Resources such as components, roll-ups, VPEs, etc. are the targets to which 
permissions grant or deny actions.  
Administrators use these building blocks to reflect your organization's structure, so that 
individuals have access to the things they need to get their work done, but which protect 
things from users who should not have access to them. 
For example, you might belong to groups that allow you to read and update components 
from your own department, and which allow you to read -- but not update -- components 
from related departments. And you may not have any access at all to components from 
a different division of your company. 
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This is a very over-simplified example, and your administrator may have implemented a 
completely different model, but it gives you an idea of how Access Control might affect 
your day-to-day work. 

How this might affect you 
Knowing that Access Control has been implemented at your site -- and understanding a 
few basics -- can help you to understand why certain things work the way they do. 
For example, if you search for a component that you know exists, but cannot find it, then 
it might be due to the fact that you do not have permission to view ("Read") it. Or if you 
open a component, make some costing overrides in the Part Details panel, and then are 
unable to save it, this might be due to you not having permission to Update that 
component. 
These are relatively obvious situations, but some types of access issues can be more 
subtle, such as when working with Assemblies or Roll-ups where you have Read and 
Update permission to most, but not all, child components.  

Note: If you are not comfortable trying to read and interpret log files, just ask your aPriori 
administrator to use the following procedures to understand the situation you are 
encountering.  

Error messages and log files 
Where possible, aPriori displays an informative error message and adds it to the 
message tree whenever it denies access to something. Here is an example of an error 
message you might see: 
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And here is the related message as it might appear in the message tree: 

 
aPriori also appends detailed information about access denials to the log file: 

 
These are the first sources of information that you should check when trying to 
understand why aPriori is not allowing you to do something.  

Note: For security reasons, aPriori cannot always provide detailed enough information 
about access denial situations to identify exactly what target resource has failed 
which access check. For example, if there is a proprietary or otherwise sensitive 
component in an assembly that a group of users is not allowed to even see, then 
it would defeat the purpose of Access Control to deliver a detailed message that 
says something like "You do not have permission to read 
SecretComponentXYZ." 

Also note that in certain circumstances, aPriori aborts after reporting the first error. For 
example, if you try to deep-cost an assembly which contains child components to which 
you do not have Read access, aPriori displays a message about the first such 
component and stops trying. You will not get error messages about other non-readable 
components in the Assembly. See Access Control Principles on page 131 for more 
information. 

Using Search 
For the aPriori Search mechanism, Access Control checks are performed when you try 
to open an entity that appears in the search results, not when the search is performed. 
When you use Search, ALL scenarios that meet the search criteria are displayed, just 
the same as if Access Control has not been implemented at your site. Even if an entity 
does not have Read permission, it will still be listed in the Component Scenarios area. 
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However, only a small sub-set of its fields are displayed: no cost data is shown, and no 
thumbnail is displayed. This approach strikes a balance between performance and 
security: to perform comprehensive Access Control checks during the search, aPriori 
would need to load everything and check it on-the-fly, which could cause unacceptable 
slow-downs.  
When you place the cursor over such an entity, a tooltip message appears informing you 
that you do not have access to the component. 

 
Once you try to open such an entity, aPriori displays an access error message as 
described in the previous section. 

Note: This behavior is observed wherever Search is used in aPriori:  for example, 
switching components in Assemblies, deleting components and adding 
components to Rollups, etc. 

VPEs 
VPEs have some special Access Control requirements. If you do not have Read access 
to a VPE, it is like it does not exist. If you have just Read access to a VPE, you can view 
it, but you cannot cost a part against it. To be able to cost parts against a VPE you must 
have both Read and Cost Using permissions (Cost Using is a special permission 
implemented specifically for VPEs). 

Costing 
To cost a component against a specific VPE, you must have Read + Cost Using 
permissions for that VPE.  
This means that if your component uses multiple VPEs for different routings, you must 
have these permissions for every VPE. 
Note that if you do not have Read + Cost Using permissions for a VPE, it will not appear 
as an option in the Virtual Production Environment Selection dialog. 

Deep Costing and Costing All Scenarios 
Deep Costing and Cost All Scenarios are the same as basic component costing except 
that you must have Read + Cost Using permissions for all VPEs covering all scenarios 
and child components. These operations follow the "Keep going & notify" principle (see 
the next section, "Access Control Principles").  

Material Catalog 
Cost Using is not necessary to specify a VPE for the Material Catalog; only Read 
permission is required. 
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Overlay VPEs 
Overlay VPEs are created from one or more VPEs to which they maintain a link, so that 
that updates to the parents ("antecedents") get passed on to the child. This is a 
somewhat advanced topic which is covered in the aPriori VPE Administrator Guide. 
If your site makes use of overlay VPEs: 

 For costing, you must have Read + Cost Using permissions on the overlay VPE, 
but no access is required to the antecedent VPE(s). 

 For editing, you must have Read + Update permissions on the overlay VPE, but 
no access is required to the antecedent VPE(s). 

VPE Manager 
To use the VPE Manager window, you must have Read permission to a VPE to open 
and view it. 
To edit and delete a VPE, you must have Update and Delete permissions to it.  You 
must also be a VPE Administrator (the same as when Access Control is not in effect).  

Viewing a Costed Component 
To view an existing, costed component, you do not need VPE access. However, any 
VPE to which you do not have access that appears in the Manufacturing Process pane 
is displayed with a "strikethrough" name (similar to a deleted VPE). 
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Access Control Principles 
This section gets into some advanced concepts regarding how Access Control is 
implemented. If you are an end-user, feel free to skip over this material. You do not need 
to know it to get your job done. But if you are curious about how Access Control works, 
this section can help explain how things behave in an Access Control environment. 
aPriori has implemented Access Control so that it performs its job securely in as 
unobtrusive a manner as possible, adhering to the following principles. The first four are 
always true: 

1 You cannot grant yourself new permissions as a result of updating an entity. For 
example, you cannot change the value of an attribute to give yourself Update rights if 
you did not have those rights already. 

3 You cannot give away permissions you had as a result of updating an entity. For 
example, if you had Read + Update rights, you cannot change the value of an 
attribute so that you cannot Read or Update it anymore. 

4 Fail fast when possible: For example, in order to BOM load, you need to be able 
either to Create and Read and/or Update the parent rollup and potentially any 
functional group rollups. aPriori checks these conditions up front and fails 
immediately if it finds a problem, before starting the BOM load operation. 

5 Check before destroy:  aPriori checks Access Control permissions before deleting 
data. For example, using File > Import to import scenarios from an ".ap" file will 
delete any existing scenarios that conflict with the ones being imported. Before 
performing the delete, aPriori verifies that the importing user has the necessary 
permissions for the entire import to succeed. 

One of the next two rules will apply depending on the situation: 

1 Keep going and notify: Once past the initial "fail fast" checks, for operations that 
involve manipulation of multiple scenarios, aPriori skips over scenarios that fail due 
to Access Control but logs the issue and notifies the user. For example, after the 
initial check for rollups, the BOM loader loads everything it can and notes any access 
control failures. 

2 Abort the entire operation: If any part of an Update operation fails due to Access 
Control, the entire operation is aborted and aPriori attempts to clean up (delete) any 
scenarios created up to that point. For example, Scenario > Save As > Scenario & 
Children could fail an Access Control check after already processing some number 
of scenarios. In this case, aPriori stops the save and cleans up any scenarios that 
were created.  (Spreadsheet reports work in the same manner, except that there is 
no need to clean up.) 

Note: "Fail fast when possible" does not apply in this situation for performance 
reasons.  It would not be efficient to visit each scenario to check if all 
permissions are okay before performing the Save operations.  
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Some additional guidelines to remember 
In addition to the principles listed in the previous section, there are some basic Access 
Control rules that might help you to understand how things work: 

1 You might belong to multiple groups. Every aPriori user belongs to at least one 
group: All Users. But your administrator has probably also made you a member of 
one or more other groups that reflect something like your region, or the project(s) you 
work on, or the type of work you do.  

2 In general, to have particular access permission to a particular entity, you must 
belong to at least one group that grants that permission, and not belong to any group 
that denies that permission. (However, administrators can tweak this rule so that 
grants and denials are strengthened or weakened.)  

3 The most restrictive permission is the one that counts. For example, you might 
belong to one group that allows you to update a component, and to another group 
that explicitly prohibits you from updating that component. In this case, the "deny" 
permission takes precedence and you will not be able to update the component. 

Additional details 
Again, as a day-to-day user, you probably do not need to get any deeper into the details 
of Access Control -- that is an area for your system administrator. However, if you are 
trying to figure out a behavior that you are seeing, the additional details below may help 
you understand how Access Control is working. 

Resources 
Here are all the target resources that aPriori Access Control can create rules for: 

 Components (includes Parts and Assemblies) 
 Roll-ups (includes basic Roll-ups, Dynamic Roll-ups, and Cost Comparisons) 
 VPEs 
 There are also advanced resources for Groups and Permissions, so that 

administrators can implement "Access Control for Access Control". But this is an 
advanced administration feature that should not concern you. 

Permissions 
Permissions are actually expressions made up of resources, actions, and rules, but for 
the purposes of this discussion, we will only consider the action -- the aPriori operations 
that can be permitted or denied by Access Control: 

 Create 
 Read 
 Update 
 Delete 
 Cost Using 
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These are mostly self-explanatory except for Cost Using. This permission action applies 
only to VPEs and determines whether you can cost a component against a particular 
VPE. There is also another advanced permission called "Associate" which 
administrators use with Permissions and Groups.  
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7 Manufacturing 
Process Information 

The Manufacturing Process pane contains manufacturing input information for 
components. This section provides information on the manufacturing process 
routing tree/table and the manufacturing process commands. 

This chapter includes the following topics: 
 Manufacturing process routing tree/table 
 Manufacturing process commands 
 Selecting a primary process group 
 Selecting material 
 Editing production, administrative, or quote information 
 Specifying or importing tolerance and roughness 
 Editing yields 
 Selecting a virtual production environment (VPE) 
 Selecting a machine for an operation 
 Editing process setup options 
 Selecting a process routing 
 Creating custom processes and routings 
 Highlighting associated GCDs 
 Specifying simultaneous operations 
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Manufacturing process routing tree/table 
The Manufacturing Process tree/table shows the sequence of steps required to 
manufacture a component. 

 
Each manufacturing step may include further operations. Operations are organized by 
manufacturing technique. You can drill down into the GCDs for each specific operation. 
Each manufacturing step presents iconic status and user input indicators. The status 
indicator provides a red/yellow/green icon to indicate an error/warning/success status. 
The user input indicator provides a green user icon to indicate that you have made an 
explicit component or process level edit (e.g. machine selection or Process Setup 
maintenance). 
The following icons are used in the routing tree/table: 
 

Icon  Usage 

 An operation. 

 An operation selected by aPriori. 

 An operation selected by you. 

 Multiple operations. 

 Multiple operations selected by aPriori. 

 Multiple operations selected by you. 

 A sub-operation selected by aPriori. 

 A sub-operation selected by you. 

 A GCD. 
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Icon  Usage 

 A GCD selected by aPriori. 

 A GCD selected by you. 

 Multiple GCDs 

 Multiple GCDs selected by aPriori 

 Multiple GCDs selected by you. 

A status indicator in the Status column shows the costing status of the operation: 
 Green — costing completed successfully. 
 Yellow — costing succeeded with a warning. Typically, a warning means that the 

requested operation could not be used in costing, but costing succeeded with an 
alternative operation. 

 Red — costing failed. 

Manufacturing process commands 
The command buttons and the Edit and right-click menus in the Manufacturing Process 
pane provide commands for viewing and/or editing the details available for each step in 
the manufacturing process. Commands that are not allowed for a step are disabled.  
The following commands are available in the Manufacturing Process pane: 
 

For an aPriori component 
To change the primary 
process group 

Click the Primary Process Group command button. 

To display the Primary 
Process Group details 

Click the  command button next to the Primary 
Process Group button. 

To edit material details Click the Material command button or select 
Edit > Material Selection. 

To display the details of 
the currently selected 
material 

Click the  command button next to the Material button. 

To edit production 
information 

Select Edit > Production Info. 

To edit the tolerance policy 
for a component 

Select Edit > Tolerance Policy. 

To select and edit a routing Edit > Routing Selection or right-click > Routing 
Selection. 

 

For a process step in the routing tree 
To edit yields Edit > Edit Yields or right-click >Yields. 
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For a process step in the routing tree 
To select a VPE Edit > VPE Selection or right-click > VPE Selection. 

To display VPE details Edit > Show VPE details or right-click > Show VPE 
details. 

To manually select a 
machine for a process 

Edit > Machine Selection or  
right-click > Machine Selection. 

To edit the process setup 
options 

Edit > Process Setup Options or  
right-click > Process Setup Options. 

To select and edit a routing  Edit > Routing Selection or right-click > Routing 
Selection. 

To highlight associated 
GCDs 

Edit > Highlight Associated GCDs or right-click > 
Highlight Associated GCDs 

Selecting a primary process group 
A process group is a group of processes of the same manufacturing type. For example, 
the Sheet Metal process group includes such processes as Laser Cut, Bend Brake, 
Shear, etc.; while a Casting process group includes Cool, Cleaning, Hot Box, Melting, 
etc.  
Some components may be completely manufactured using processes in a single 
process group. Other components require multiple process groups; for example, Casting 
and Machining.  
The name of the process group that is primarily used to manufacture a component 
shows on the Primary Process Group button. 

To display the primary process group details 

In the Manufacturing Process pane, click the  button to the right of the Primary 
Process Group button. The Process Group Details window is displayed. 
To select a different Primary Process Group, click Edit.  
To close the Process Group Details, click Close.  

To change the primary process group 
To change the Primary Process Group for a component, aPriori must be able to retrieve 
the GCDs required to calculate the cost. To make it possible: 

 In Direct Integration mode, the component must be CAD-connected. 
 In CAD-Independent mode, the component must be file-connected. 

1 In the Manufacturing Process pane, click the Primary Process Group button, 
Primary Process Group: Casting. The Select Primary Process Group window is 
displayed. 

2 Select a process group from the drop-down menu. The required GCDs are 
immediately retrieved and the component is re-costed. 
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3 Click Close. The new Primary Process Group shows on the command button. 

Selecting material 
Material is the name of a chemical composition or alloy of which a part is made.  
Material can be selected only for parts. 

To display the details of the currently selected material 

Click  to the right of the Material button to display the Material Details window. 
Click Edit to edit Material Details or click Close to close the window. 

To edit material details 

1 In the Manufacturing Process pane, click the Material button . 
The Material Selection window is displayed. 

 
The Part Number and VPE selected for this part are displayed in the window 
header. The list of materials shows all the materials available for the selected VPE. 
Material automatically selected by aPriori is highlighted and the related properties 
are displayed in the Properties list. The Description panel shows material stock 
size and form. 

2 In this window you can: 
• Change material catalog 
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• Change selection policy 
• Select material 
• Change material stock 
• Change material unit cost 
• Change material utilization 

3 After making changes, click: 
• Ok — to apply changes, recalculate the cost, and close the Material Selection 

window. 
• Apply — to apply changes and recalculate the cost without leaving the 

Material Selection window. 
• Cancel — to close the Material Selection window without applying the 

changes. 
Status indicators appear separately for Material Composition and Material Stock. 
An overall results status indicator appears in the Results area.  
A status indicator shows the costing status of the input: 

• Green — Costing completed with the requested input. 
• Yellow — Costing completed with warnings. Typically, indicates that the 

requested input was invalid and a different input, based on selection policy, 
was used for costing. 

• Red — Costing failed. 
You can see the warnings in the Status Messages pane. 
Note If the costing results are outdated, the status indicator is not displayed. 

Change material catalog 
By default, the current material catalog is the catalog associated with the current VPE. 
You can change the current material catalog to the catalog associated with a specified 
VPE. 

To change the material catalog 

1 In the Manufacturing Process pane, click the Material button. 

2 In the Material Selection dialog, click the button next to the label Material Catalog. By 
default, the button is labeled with the name of the current VPE.  

3 In the Material Catalog Selection dialog, select the VPE associated with the desired 
catalog. Click OK. The Material Catalog button is now labeled with the name of the 
new current catalog’s associated VPE. 

Change selection policy 
The selection policy describes: 

 how the material selection input is provided — by you or through the CAD system 
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 what aPriori does if the provided input is invalid 

To change the selection policy 

1 In the Manufacturing Process pane, click the Material button. 

2 In the Material Composition panel, click Edit Selection Policy. The Composition 
Selection Mode panel opens. 

3 Select: 
• MCAD — this is the default source for material selection. If the MCAD choice 

is not provided or not available for the selected VPE, the VPE default material 
is selected.  

• VPE Default — The default material must be defined for every VPE.  
For information on how to define the default material for a VPE, see aPriori 
Administrator Guide. 

• Manual — Material selected manually by you. The VPE default is selected if 
your specified choice cannot be costed. 

4 Click Ok to apply changes, recalculate the cost, and close the Material Selection 
window, or Apply to apply changes and recalculate the cost without leaving the 
Material Selection window. 
The Material Composition Mode that you select here shows in the Requested field. If 
the material selected using this mode is invalid for costing, aPriori chooses a 
different mode according to the selection policy. However, the requested mode 
remains the same until you change it manually. 
For example, if you selected MCAD, but the material specified by the CAD system is 
unavailable for the selected VPE, the VPE default material will be used for costing. 
The Requested mode will be MCAD and the Selected mode will be VPE default.  

Select material 

To select material 

1 In the Manufacturing Process pane, click the Material button. 

2 Select a material from the list. This changes the selection policy to Manual. 
The Selected field shows the selection policy and the selected material. 

3 Click Ok to apply changes, recalculate the cost, and close the Material Selection 
window; or click Apply to apply changes and recalculate the cost without leaving the 
Material Selection window. 

Change material stock 
The Material Stock panel shows the following information: 

 Requested — the requested stock source, Auto or Manual. A third option, 
Custom Cut, is available for Bar & Tube Fabrication parts. 
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 Selected — the presently selected stock. 

To change material stock 

1 In the Manufacturing Process pane, click the Material button. The Material Selection 
window is displayed. 

2 Click the button in the Material Stock panel. The Material Stock panel expands. 

3 Select a material stock mode. 
• Auto — aPriori selects the material stock. This is the default option.  

The algorithm for automatic stock selection is defined as part of the facility 
model. Typically, the stock selection algorithm depends on geometry 
constraints, material utilization, machine selection, and routing selection.  
If no valid stock is available, aPriori computes the cost with virtual stock. 

• Manual — You select the material stock from the list of material stock 
available for the selected material composition.  

• Custom Cut — Available for Bar & Tube Fabrication parts only, you specify a 
custom stock length, either by specifying the total length or indicating size-to-
fit with a specified trim allowance. 

4 Choose Manual and select an available material stock from the list. Stock that is not 
valid is disabled.  
or  
For Bar & Tube Fabrication parts, Specify Custom Stock inputs (total length or trim 
allowance). 

5 Click Ok to apply changes, recalculate the cost, and close the Material Selection 
window; or click Apply to apply changes and recalculate the cost without leaving the 
Material Selection window. 
Note If no appropriate stocks are found in the list of available material stocks, then 

the Manual option is grayed out, and the system will create a virtual stock. This 
can happen, for example, if all stock cross-sections are too small to 
accommodate the part.  

Change material unit cost 
The Material Unit Cost panel shows the unit cost (cost per mass) of the selected material 
composition/stock. By default, aPriori uses the unit cost value that is specified in the 
VPE for that material composition/stock. However, if this value does not reflect the value 
that will actually be in effect for this part (for example, if material prices have changed 
significantly since the VPE last was updated), you can override the value used for the 
current part.  

To override material unit costs for the current part 
Click the Override radio button in the Material Unit Cost panel, and enter the new 
material unit cost (take care to note the units) 
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To revert to using the value specified in the VPE 
Click the VPE Material Unit Cost radio button 

Change material utilization 
The Material Utilization panel shows the selected utilization mode. Material utilization 
can be computed or can be entered different ways to drive starting material mass and 
cost. 

To change material utilization 

1 In the Manufacturing Process pane, click the Material button. The Material Selection 
window is displayed. 

2 Click the  button in the Material Utilization panel. The Material Utilization panel 
expands. 

3 Select the material utilization mode: 
• Computed — aPriori computes utilization with a facility defined algorithm. 

The algorithm used varies by process group; more detail is given in the 
chapters for each process group in the aPriori Cost Model Guide. 

• Machine Default — aPriori uses the selected machine’s default utilization 
value. 

• Override — You specify the material utilization value in the % field. If you 
selected Override, enter the value in the % field. 

4 Click Ok to apply changes, recalculate the cost, and close the Material Selection 
window; or click Apply to apply changes and recalculate the cost without leaving the 
Material Selection window. 

Editing production, administrative, or 
quote information 
Production information includes parameters related to component production that affect 
the cost or the component.  

To edit production, administrative, or quote information 
In the Manufacturing Process pane, select Edit >: 

• Production Info to display the Production Info tab of the Cost Object window.  
• Administrative Info to display the Administrative Info tab of the Cost Object 

window 
• Quote Info to display the Quote Info tab of the Cost Object window 

For more information about the fields on these tabs and their impact on costing and 
analysis, see Using the Cost Object Info window on page 41 and Initial costing: the Cost 
Guide on page 21. 
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Specifying or importing tolerance and 
roughness values 
You can specify geometric and dimensional tolerances (G&DT) and surface roughness 
requirements for GCDs. You can also automatically import many of these values directly 
from CAD model Product Manufacturing Information (PMI) attributes. Tolerance and 
surface roughness requirements can have a large impact on the process or operation 
selected to manufacture a GCD and the cycle time required to complete it. 
aPriori stores tolerance capability data for each manufacturing process in the lookup 
table tblGtolProcessCapabilities (see * CAD Angularity GD&T callout maps to Bend GCD in 
Bar & Tube only. Entered manually only. 
How aPriori calculates achievable tolerance ranges). When aPriori costs a GCD, it 
selects only those processes and operations which can meet the specified tolerances 
and roughness requirements for that GCD. If the primary process group cannot meet the 
tolerance or roughness requirements, aPriori selects secondary machining operations. If 
no secondary machining operations are available or capable of achieving the specified 
tolerance and roughness, the GCD fails to cost. 
If no tolerance or roughness values are specified  (by either importing or manually 
entering the desired value), aPriori assumes all processes can achieve the desired 
tolerance and roughness; aPriori does not set default desired tolerances. 
Tolerance and roughness specifications also affect the cycle time required to complete 
an operation. For example, lower finish machining feed rates are required to achieve 
tighter (smaller) tolerance values, which results in increased cycle times. aPriori 
machining cost models account for this best practice. See How aPriori determines cycle 
time adjustment factors. 
You can specify tolerance and roughness requirements in one of three ways: 

 By manually setting default values for all of a component’s GCDs through the 
Tolerance Policy Editor. 

 By manually setting values for specific GCDs either through the Tolerance Editor, 
or by using the fields in the Geometric Cost Drivers panel. 

 By importing semantic PMI annotations directly from the CAD model. 

Note: aPriori stores and displays tolerance values as total tolerance. This means, for 
example, that if a CAD system specifies a tolerance of “±0.25”, you should enter 
the total tolerance, "0.5”. If you import such a tolerance from a PMI attribute, the 
aPriori will display it as a total tolerance. 
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How tolerances map to GCDs 
Each tolerance and roughness type applies only to certain GCD types. The following 
table which shows what types of tolerance apply to each GCD type, and whether they 
can be imported as PMI from CATIA, Creo, NX, and SolidWorks: 
 

 Symbol Curved 
Surface 

Curved 
Wall 

Keyway Planar 
Face 

Simple 
Hole 

Complex 
Hole 

MultiStep 
Holes 

Edge 
/Edge-
Segment 

Bend 
(B&T) 

Lance Import from 
PMI? 

Tolerance 
(coordinate)  

 X X X X X X  X  X N 

Roughness 
Ra  X   X X      Y, except  

Solidworks 
Roughness 
Rz 

 X   X X      Y, except 
Solidworks 

Diam 
Tolerance 

 X X   X      Y 

True Position    X  X X   X  X Y 

Bend Angle 
Tolerance 

         X*  N* 

Circularity   X   X      Y 

Concentricity   X   X      Y 

Cylindricity   X   X      N 

Flatness     X       Y 

Parallelism   X  X X    X  Y 

Perpendicular
ity 

  X  X X      Y 

Profile of 
Surface 

 X X  X       Y 

Runout  X X   X      Y 

Total Runout   X   X      Y 

Straightness   X X X X      Y 

Symmetry  X X X X X      Y 
* CAD Angularity GD&T callout maps to Bend GCD in Bar & Tube only. Entered 
manually only. 
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How aPriori calculates achievable tolerance ranges  
Given a process and a GCD’s size, aPriori can determine the range of tolerances that 
the process can achieve for that GCD. The achievable tolerance range helps determine 
operation feasibility (the tolerance required for the GCD must be no tighter than the best 
achievable tolerance for the operation’s parent process). The achievable tolerance range 
also helps aPriori adjust cycle times based on required tolerance (see How aPriori 
determines cycle time adjustment factors). 
aPriori determines the best and worst tolerance that a given process can achieve for a 
given GCD as follows: 

1 Determine the best and worst achievable tolerance grade for the process: the lookup 
table tblGtolProcessCapabilities associates two International Tolerance (IT) Grades 
with each process, the best achievable tolerance grade and the worst achievable 
tolerance grade. (Some entries in the table refer to a group of processes, rather than 
an individual process; in this case, every process in the group has the same best and 
worst achievable tolerance grades.) aPriori looks up the best and worst achievable 
grades by process (or group) in tblGtolProcessCapabilities. Note that IT Grades are 
independent of feature size but can be used together with size to obtain a literal 
tolerance range.  

2 Determine a size value for the GCD as follows: 
 

GCD GTOL Category GCD Size 
Simple Hole Position Tolerance Part length/2 
Simple Hole All other GTOL 

categories 
Diameter 

Curved Wall Diameter Tolerance Diameter or bend 
diameter (if diameter is 

null. If both are null, use 
Sqrt(Finished area) 

Curved Wall Position Tolerance Part length / 2 
Keyway Symmetry Max of GCD length, 

width, and height 
Remaining GCDs Remaining Categories Sqrt(Finished area) 

 

3 Use the size value (obtained in step2) and the best or worst achievable tolerance 
grade (obtained in step 1) in the formula below, in order to calculate best or worst 
achievable tolerance. This is the literal tolerance value that takes GCD size into 
account: 
Tolerance = 10^(0.2 * (Grade - 1)) * (0.45 * Size ^ (1 / 3) + 0.001 * Size) / 1000 

Note that, unlike achievable tolerances, the achievable roughness for a process and 
GCD does not depend on the GCD’s size. Literal achievable roughness ranges are 
stored directly in tblGtolProcessCapabilities, and they require no conversion based on 
GCD size. 

Note: As of Release 16.2, aPriori has added roughness “Rz” to the existing roughness 
specification found in earlier releases. Throughout the UI, all Rz and Ra 
specifications are clearly labeled. If you encounter a roughness specification with 
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no Rz or Ra label, it is Ra. By default, if no Roughness Rz value is specified, the 
default “Best Achievable”/”Worst Achievable” values for Roughness Rz are 4.5 
times the value of the specified Roughness Ra. 

Besides GCD size and process, another factor that can affect best achievable tolerance 
is the GCD’s distance from some relevant datum feature, but aPriori does not currently 
take this into account.  

Note: The Injection Molding process allows for significantly tighter “Best Achievable” 
surface roughness than machining processes (such as those that might be used 
to make the mold). This is because the best tolerances in Injection Molding are 
achieved via hand polishing of the mold surface, which is not available in other 
processes. This results in Injection Molding being more capable than other 
processes with regard to tolerance/surface finish. 

How aPriori determines cycle time adjustment factors 
Cycle times for a given GCD and process are adjusted with a compensation factor that is 
based on the following: 

 Tolerance that you specify (or import) for the GCD 

 Tolerance range for the process and the GCD (see * CAD Angularity GD&T 
callout maps to Bend GCD in Bar & Tube only. Entered manually only. 

 How aPriori calculates achievable tolerance ranges) 
 Compensation factor range specified by plant.gtolWorstAchievableFactor (0.75 in 

the Starting Point VPEs) and plant.gtolBestAchievableFactor (1.5 in the Starting 
Point VPEs). 

The position of the specified tolerance within the tolerance range determines the position 
of the compensation factor within the compensation factor range. If the tolerance 
specified for a GCD is at the midpoint of the tolerance range, then the compensation 
factor is 1. If the tolerance specified is in the bottom half of the tolerance range, the 
compensation factor is between plant.gtolWorstAchievableFactor and 1. If the tolerance 
specified is in the top half of the tolerance range, the compensation factor is between 1 
and plant.gtolBestAchievableFactor.  
In particular, if the tolerance  specified is a certain fraction of the way from the worst 
achievable tolerance to the midpoint of the tolerance range, the compensation factor is 
that same fraction of the way from plant.gtolWorstAchievableFactor to 1.  
Similarly, if the tolerance  specified is a certain fraction of the way from the midpoint of 
the tolerance range to the best achievable tolerance, the compensation factor is that 
same fraction of the way from 1 to   plant.gtolBestAchievableFactor. 
If a tolerance for a GCD has not been specified, the compensation factor is 1. 
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Using the Tolerance Policy Editor 
You use the Tolerance Policy Editor to enter tolerance and roughness values for all GCDs 
in a component. You also use it to control the import of PMI attributes from the CAD 
model (see the next section). 

To open the Tolerance Policy Editor 

1 There are two ways to open the Tolerance Policy Editor: 
• From the middle tab of the Cost Guide, or 
• From the Edit menu in the Manufacturing Process panel. 
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2 The Tolerance Policy Editor provides the following features: 
• A: A set of fields for manually entering tolerance and roughness values that 

should be applied by default to GCDs in the component. 
• B: Radio buttons and checkboxes for controlling tolerance and roughness 

behavior, including whether or not to import PMI values directly from the CAD 
file. 

• C: A reference panel showing common drafting symbols for supported 
tolerance and roughness specifications. 

 
The tolerance mode controls include: 

• Assume tolerance and roughness achieved by the manufacturing 
operation selected for that GCD is sufficient — This is the default 
tolerance policy. If you do not manually enter tolerance or roughness 
requirements for any GCDs, and do not import PMI attributes from the CAD 
model, the GCD tolerance and roughness requirements are set to 
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unspecified and aPriori evaluates routings assuming that the processes 
have sufficient tolerance capabilities to manufacture the GCD. That is, aPriori 
does not determine that a process or operation is infeasible or check 
secondary machining operations based on achievable tolerance and 
roughness requirements. If you do specify or import tolerance or roughness 
requirements for a GCD, tolerance and roughness capabilities are evaluated 
during routing and operation sequence selection. 
For more information on explicitly setting tolerance and roughness values for 
a GCD, see Editing values in the GCD properties table and GCD commands. 

• Use the following values — Select this option to enter the default tolerance 
and surface roughness for the part. These values are used for each GCD that 
does not have values manually set at the GCD level.  

• Use CAD model values —Select this option if you want aPriori to use the 
tolerance and roughness specified by semantic PMI attributes in the CAD 
model (currently supported for Creo, CATIA, and NX).  

• Replace CAD tolerance values less than: -- If the CAD model has overly 
tight tolerance values (which sometimes occurs if tolerance defaults are set 
by CAD PMI imports), check the box, enter a limit for the overly tight 
tolerance values, and enter a replacement value. 

Use current settings as my default… -- Check this box if you have changed tolerance 
policy settings and want these settings to be the default settings for all future (new) cost 
components. 

To edit the tolerance policy for a component 

1 Open the Tolerance Policy Editor as described in the previous procedure. 

2 Click the Use the following values: radio button and enter values for the tolerance 
and/or roughness settings you wish to control. 
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Refer to the table in How tolerances map to GCDs for information about specific 
settings. 

3 Click OK to apply changes, recalculate the cost, and close the Tolerance Policy Editor.  
You can also click Apply to apply changes and recalculate the cost without leaving 
the Tolerance Policy Editor. 
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Manually editing specific tolerances 
You can enter individual values for tolerance and roughness fields for a specific GCD. 
You can edit these tolerances in one of two ways: 

 From the Tolerance Editor (not to be confused with the Tolerance Policy Editor 
described in the previous section). 

 From the editable tolerance and roughness fields in the Geometric Cost Drivers 
pane. 

To enter tolerance and roughness values using the Tolerance Editor 

1 There are two ways to open the Tolerance Editor. Select a GCD either: 
• From the middle tab of the Cost Guide, and click the Edit Tolerances button, 

or 
• From the Geometric Cost Drivers, and select Edit Tolerances from the right-

click context menu. 
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2 The Tolerance Editor displays, showing a list of tolerances that apply to that type of 
GCD (see the table in the section How tolerances map to GCDs for more 
information). 

 

3 For the tolerance value(s) that you wish to set, click Manual, and enter the value in 
the associated field. 

4 Click OK when done. 

To enter tolerance and roughness values using the Geometric Cost Drivers pane 

1 Go to the Geometric Cost Drivers pane and navigate to the GCD to which you wish to 
add tolerance information. 
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The Name column lists the tolerances that apply to this GCD (along with other 
values). See the table in the section How tolerances map to GCDs for more 
information. 
The pencil icon indicates fields that can be edited.  

2 Double-click the field in the Property Result column to enter the value you wish to 
apply. 
Note that override values are displayed in red italic and a green “User Override” icon 
appears in the left column.  

3 To remove an existing tolerance value, you can double-click and delete the entered 
value, or right-click the value and select Return to Auto-Select from the context 
menu to re-display unspecified in the field. 

4 Press Enter, Tab, or click on another property. 

Importing PMI from CAD 

aPriori supports the import of certain semantic Product Manufacturing Information (PMI) 
values defined in supported CAD systems. PMI is often added to CAD models to specify 
non-geometric attributes necessary for the correct manufacturing of the part. These can 
include Geometric Dimensioning and Tolerancing (GD&T), surface texture 
specifications, etc. 
Two flavors of PMI exist: 
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 Non-semantic or “graphical” PMI – This is an older implementation and is simply 
the addition of displayable textual annotations (represented by lines and 
characters) to the CAD model. These annotations are human-readable but are 
usually not fully associated with the underlying part geometry in machine-
readable form. 

 Semantic PMI – These annotations are implemented as CAD model metadata in 
a well-defined and machine-readable (as well as human-readable) fashion.  

Note: aPriori only reads semantic PMI. (There are some minor, CAD-system-dependent 
exceptions to this blanket statement. But in general, you can only import 
semantic PMI annotations into aPriori.) 

It can be difficult to determine if an annotation visible in a CAD model is sematic or non-
semantic, so most CAD systems provide ways of flagging non-semantic PMI 
annotations, such as appending a red squiggly line beneath the annotation. 
A complete discussion of PMI is far beyond the scope of this aPriori document. You 
must consult the documentation and Support resources for your CAD system regarding 
how to properly construct and identify semantic vs. non-semantic PMI in CAD models. 
Note that some CAD systems may require you to acquire and install an additional 
module for creating PMI annotations. For example, CATIA requires that you have access 
to their Functional Tolerancing and Annotation module.  
For more information, refer to: 

 Reputable third-party sites such as the National Institute of Standards and 
Technology (NIST, http://www.nist.gov). 

 The PMI sections of the documentation, training, and Support resources for your 
CAD system(s) 

 Notes about specific CAD systems and PMI, later in this chapter. 

aPriori Support for PMI 
As of Release 2018 R1 (18.1), aPriori supports importing certain sematic PMI values 
from the following CAD systems: 

 CATIA 
 Creo 
 NX 
 SolidWorks 

Note: As noted earlier, there are a couple of non-semantic PMI annotations that aPriori 
can import, such as Diameter and Roughness annotations. However, in general if 
aPriori encounters non-semantic PMI when reading a CAD model, it logs the 
presence for diagnostic purposes, but does not store the information or attempt 
to use it for costing.  

The following types of PMI are generally supported, with some restrictions for different 
CAD systems: 

 Diameter tolerances 
 Most geometric tolerances 

http://www.nist.gov/
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 Surface Roughness Ra & Rz 
 “Virtual” Threads/Taps (see Notes about virtual threads and taps below) 

aPriori takes the imported PMI data and applies it to the appropriate GCDs for costing. 
(See Chapter 8, Geometric Cost Drivers .) You control PMI import behavior through the 
Tolerance Policy Editor. 

Notes about virtual threads and taps 
Although threaded hole information does not fall under the category of tolerance or 
roughness annotations, it is imported from the CAD model to aPriori using the same 
mechanism. 

Note: In general, aPriori currently does not import PMI from Assembly models, just part 
models. This includes thread information for holes created as assembly features 
rather than part-level features.  However, if you are working in the Creo Direct 
Integration version of aPriori, information about threaded holes made as 
assembly-level features is provided to aPriori. In all other cases, users will have 
to indicate that these holes are threaded inside the aPriori application.   

Each supported CAD system supports multiple ways to specify that a hole or shaft is 
threaded, without actually modeling the threads (hence the term “virtual”).  The concepts 
are the same across the different CAD systems, although the ways they are 
implemented differ. 
In general, CAD systems offer two ways to specify virtual threads: 

 As a property or set of properties of a hole feature, typically implemented as a 
checkbox that says “threaded”, plus fields for entering other data such as thread 
length or depth, pitch, etc. 

 As a separate distinct feature. These features are named differently in different 
systems:  
o CREO: “cosmetic thread” 
o Catia: “thread/tap feature” 
o NX: “symbolic thread” 
o SolidWorks: “cosmetic thread”, “tapped hole” 

aPriori currently supports all these methods EXCEPT SolidWorks thread and tapped 
hole information. 
In addition, aPriori Direct Integration mode (see Direct Integration mode) supports both 
property and feature approaches for CREO. 
Regardless of how you import virtual thread information, aPriori costs them simply based 
on the fact that the hole is threaded and uses the diameter and the thread length to 
compute cycle time. Any other data such as thread pitch is ignored.  In summary, only a 
subset of thread metadata which may exist in a CAD model is actually imported into 
aPriori and used to calculate cost. 

Importing and reviewing PMI from CAD 
Supported semantic PMI annotations are imported to aPriori when you open or refresh a 
supported CAD file IF you set the Use CAD model values… checkbox in the Tolerance 
Policy Editor. You must set this checkbox to import semantic PMI information from a CAD 
model, otherwise it will be ignored. 
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Note: The following sections describe how to import PMI with the interactive aPriori 
client. For Interactive Bulk Costing, you must set the Tolerance Policy for the 
Bulk Costing run, for all or selected scenarios. Tolerance Policy cannot be 
specified from the command line or the  input spreadsheet in aP 2016 R2. 

 

How aPriori imports roughness (Ra and Rz) values 
CAD systems provide a variety of ways to completely specify Roughness. aPriori has 
observed inconsistent use of the available Roughness inputs across our customer base.  
Therefore, we have adopted a specific method for processing and interpreting the 
incoming roughness data found in a CAD file, as described below. Note that Roughness 
import is NOT supported for SolidWorks. 
Up to nine Roughness Related fields may be populated, across the varying CAD 
systems supported by aPriori: 

 
where:  

 Field 1: Roughness value Ra 
 Field 2: Unused 
 Field 3: Minimum material removal 
 Field 4: Production method 
 Field 5: Roughness cutoff 
 Field 6: Roughness value other than Ra (e.g., Rz) 
 Field 7: Direction of lay 
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 Field 8: Rarely used. 
 Field 9: Rarely used. 

aPriori looks at any values defined in these nine fields according to these rules: 

1 Find all fields that look like "Ra number" (case insensitive and ignoring whitespace 
around "Ra" and around the number). 

2 Find all fields that look like "Rz number" (case insensitive and ignoring whitespace 
around "Rz" and around the number). 

3 If Ra and/or Rz is found then aPriori uses the smallest value of each for the GCD 
properties. 

4 If neither Ra nor Rz is found then aPriori tries to parse the contents of Field 1 and 
Field 6 as numbers. Field 1 contains "Roughness value Ra", Field 6 contains 
"Roughness value other than Ra". aPriori uses any number in Field 1 for the 
RoughnessRa property and any number in Field 6 for the RoughnessRz property. 
For example, if Field 1 (the nominal Roughness Ra field) is populated with "32" and 
Field 5 (the Roughness Cutoff field) is populated with "Ra 64", aPriori will use Field 5 
since it contains the Ra string and Field 1 does not, even though the VALUE of Field 
5 is larger than the value of Field 1. 

To import PMI 

1 Open the Tolerance Policy Editor.as described in To open the Tolerance Policy Editor. 

2 In the Tolerance Policy Editor click the Use CAD model values… radio button.  

 

3 Click OK, then Cost the model. 

4 To confirm that the expected PMI values have been correctly imported, go to the 
Geometric Cost Drivers pane and navigate to a GCD that should have the PMI value 
from the CAD model. 
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In this example, note that the “+.005/-.001” CAD PMI tolerance appears in aPriori as 
a total “.006” tolerance. 

Troubleshooting PMI 
aPriori can write entries to the log file whenever it encounters a PMI attribute that it 
cannot map to a GCD. The following messages are “WARN” level and by default are 
written to the log file: 

<PMI NAME> ignored because it is specified on an inactive surface, 

<PMI NAME> was not associated with any GCDs, and  

<PMI NAME> was not used because it is not semantic and has no 
magnitude. It would have been associated with GCD(s) <LIST OF GCDs> 

To reduce the number of entries written to the log files, several other PMI messages are 
only written if the logging is set to DEBUG level.  

To set DEBUG-level logging for PMI: 

5 Open <apriori_install>/log4j.properties in an editor. 

6 Add the following line: log4j.logger.com.fbc.util.cad.pmi.PmiLog=debug 

7 Save the file and restart aPriori. 

To view PMI log messages: 

8 Click Help > Explore Logs Directory 

9 Open apriori.log in a text editor. Search for entries starting with PmiLog. These 
messages contain information that allow you to identify the PMI attribute that failed 
and the nature of the failure. For example: 
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DEBUG PmiLog:285 - [Dim tolerance NIST PMI FTC 06 ASME1|Annotation Set.1|Linear 
Size.30 LINEAR 7.9375[-0.508:0.508]] were ignored because aPriori currently does 
not support non-radial/diametrical dimensional tolerances. 

Since aPriori imports only semantic PMI, and since it is not always easy to identify 
semantic vs non-semantic PMI in a CAD system, aPriori logs entries similar to the 
following when it encounters non-semantic PMI attributes: 
 

WARN PmiLog:285 - Gtol turning|Annotation Set.1|Geometrical Tolerance.13 [SYMMETRY 
-1]  Note:.0005|| is not semantic 

 

Notes about specific CAD systems and PMI 
Details about implementing PMI attributes within various CAD systems is far beyond the 
scope of this aPriori documentation. aPriori encourages you to get expert guidance 
regarding best practices for creating semantic (machine-readable) PMI from your CAD 
vendor, particularly since CAD vendors are also making enhancements in this area of 
functionality. However, we have found some hints they may help you get started in 
identifying and creating PMI attributes in your CAD system that can be imported into 
aPriori. 

CATIA 
The following notes may help you to create PMI annotations in CATIA that can be 
imported into aPriori. 

1 Creating Semantic PMI in CATIA generally requires the separately-licensed 
Functional Tolerancing and Annotation (FTA) module. Once this is installed, you can 
turn on tolerance toolbar options by clicking Start > Mechanical Design > 
Functional Tolerancing & Annotation. (Do not click the similarly-named “Product 
Functional Tolerancing & Annotation” option higher on the same menu. This 
option will make your part disappear.) 

2 To enter semantic PMI in CATIA, select a surface and then click either Insert > 
Annotations > Tolerancing Advisor, or click the Tolerancing Advisor icon in the 
toolbar. 
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Note: If you use a different path or command to enter tolerance annotations (for 
example, Insert > Annotations > Tolerancing > Geometric Tolerance), 
you will generally be creating non-semantic PMI and the dialog titles will not 
say “Semantic”. The annotations you are create will typically not get imported 
into aPriori. However, see the next section for an exception. 

The Semantic Tolerancing Advisor dialog allows you to create various types of GD&T 
annotations that are appropriate for the selected surface/entity. Some types of 
callouts need you to indicate a datum reference. Once you do so, more types will be 
available for selection. In the following example, a planar surface is selected, and 
datum reference A is selected in the Advisor. As a result, the possible valid callouts 
are Perpendicularity, Profile of Line, and Profile of Surface. Parallelism is not 
presented, because CATIA knows that datum A (the bottom surface of the part) is 
not parallel to the selected surface. 
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3 As mentioned above, there are some exceptions to the rules that only semantic PMI 
can be imported to aPriori from CATIA, or that using the procedures above will ONLY 
create one type or the other: 

• Roughness –  Roughness annotations in CATIA are non-semantic but 
aPriori is able to parse these annotations if they match certain patterns and in 
many cases is able to import them. 

• Flatness and Cylindricity – Some CATIA GD&T callouts defined using the 
“non-semantic" menu path (Insert > Annotations > Tolerancing > 
Geometric Tolerance) actually produce semantic PMI that can be imported 
by aPriori. These appear to be “single surface” types that do not require 
multiple surfaces or datum references.  

4 Best practices for entering roughness values: -- Ra roughness values should be 
entered in the upper-left field; Rz values should be entered in the lower right field. If 
roughness numbers are entered in these fields, you do not need to use the “Ra” and 
“Rz” prefixes. 
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See How aPriori imports roughness (Ra and Rz) values above for more information. 

 

NX 

1 To turn on PMI in NX, go to the Application tab and click PMI: 

 

2 Once PMI is enabled, you can access PMI capabilities from the PMI tab and from the 
PMI menu item on the main drop-down menu: 



Manufacturing Process Information  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 163 

 



Manufacturing Process Information  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 164 

3 To specify and apply geometric tolerances to model features, click either the Feature 
Control Frame icon in the tool bar, or Menu > PMI > Feature Control Frame, then 
fill in the fields on the Feature Control Frame dialog. 

 
It is important to use the Associated Objects control to select the correct geometry 
reference (typically a surface or a hole) and associate it with the annotation you are 
creating. Note that aPriori does not read PMI associated on edges. 
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4 To specify and apply roughness requirements to model surfaces, click either the 
Surface Finish icon in the tool bar, or Menu > PMI > Surface Finish, then fill in the 
fields on the Surface Finish dialog. Enter use the Roughness (a) field. If the value that 
you want is not provided by the drop-down menu, type in the value such as “Ra 1.5” 
or “Rz 10”. 

 
As mentioned with above for GD&T PMI, you must use the Associated Objects 
control to select the correct geometry reference and associate it with the roughness 
annotation you are creating.  



Manufacturing Process Information  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 166 

Creo 
Deprecated functionality (Creo direct integration only): Prior to Release 2016 R2, 
aPriori extracted linear size/position tolerances, but assigned them to more faces than 
intended. (For example, the tolerance on the  dimension callout between two opposing 
sides of a rectangular block would be imported into aPriori but applied to all faces of the 
block). In Release 2016 R2, aPriori  no longer extracts linear size/position tolerances, 
but now extracts Diameter tolerance, Surface Roughness, cosmetic threads, and GD&T 
callouts 

Displaying existing annotations -- By default Creo turns off the display of most 
annotations to simplify the display. If you are opening a part that contains PMI (such as 
the NIST PMI test models available from http://www.nist.gov) you may need to turn on 
the display of these annotations. Using a NIST test part as an example: 
Go to the View tab, then click Manage Views > Display Combined Views. At the 
bottom of the screen, click Mbd_A. 

 
Creating tolerance annotations in Creo -- Creating PMI annotations in Creo requires 
that you select surfaces and locations in a very specific order. The initial steps are fairly 
intuitive, but the final steps can be less than obvious, and you can end up with one or 
two dialog boxes open with no clear direction as to how to complete the operation. The 
following steps walk you through an annotation procedure. Note that this is not 
necessarily the best or only way to add a geometric tolerance to a Creo model. It is 
intended only as a sample path to help users exploring this functionality for the first time. 
Please refer to official Creo technical support, training, and documentation resources for 
recommended procedures and best practices.  

http://www.nist.gov/
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1 Click the Annotate tab (1), then click Annotation Feature (2). In the Annotation 
Feature window, click the “Geometric Tolerance” icon (3), and in the Geometric 
Tolerance window, click the type of annotation you wish to create – in this example, 
“Circularity” (4). 

  

2 In the Geometric Tolerance dialog box, click Select entity (1), then click the surface to 
be associated with the tolerance (2). Then click Place gtol (3) and again click the 
associated surface (4). 

 



Manufacturing Process Information  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 168 

3 Select the dimension that was just added to the surface, and then click Ok in both 
the Geometric Tolerance dialog box and the Annotation Feature dialog box. 

 

4 When you finish creation of the annotation, you may need to explicitly turn on its 
display. If so, click Show Annotations (1), then click the Geometric Tolerances tab 
in the Show Annotations dialog (2), click the annotation you wish to display (3), and 
select its checkbox (4). Click Ok when done. 
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SolidWorks 
aPriori supports importing PMI from SolidWorks as of Release 2018 R1. 

Note: aPriori does not support the import of roughness or virtual thread/tap PMI from 
SolidWorks. 

The following information is based on SolidWorks 2016 and 2017. 
The primary way to create PMI items in SolidWorks is to use the DimXpert tool, which 
enables you to create dimensions in 3D space on the 3D model (similar to creating 2D 
dimensions on a 2D drawing). Note that DimXpert does not allow you to create different 
views with only certain dimension shown. That is done with SolidWorks MBD. The 
dimensions and annotations that DimXpert creates are not driving dimensions, but 
driven dimensions. They are not created when the features are created. 

5 Open the model you want to dimension in SolidWorks. 

6 Either click the DimXpert tab or click the Tools > DimXpert menu item. 
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7 Use the options on the toolbar or on the menu to create PMI. However, note that not 
all of these options create semantic PMI. The following table indentifies which 
options create semantic PMI. 
 

Item Type Sematic? 
Dimensions Yes 

Datums Yes 

Geometric Tolerances Yes 

Datum Targets No 

Notes (including thread Callouts) No 

Surface Finish Symbols No 

Balloons No 

Weld Symbols No 

 

Editing yields 
aPriori allows you to enter yield information to more accurately reflect the cost of waste 
due to bad parts or to material that is discarded during the manufacturing process. This 
yield feature is available in all process groups. 

Good Part Yield and Final Yield 
For any process, you can specify a Good Part Yield or GPY (sometimes referred to as 
Throughput Yield or TPY) value that represents: 

# parts out/# parts in 

Default GPY values are stored as machine variables and can be overridden as 
percentage values in the Part Details tab as described below. By default, aPriori sets all 
Good Part Yield values to “1” (100%). 
Final Yield (or FY) differs from Good Part Yield in that it is calculated for all downstream 
processes rather than just for the current process. Final yield is displayed in the Part 
Details tab and is used to calculate material cost. 
Calculations involving yield values make use of production volume and the number of 
scrap parts at the process and routing level. Examples of scrap parts are damaged, 
broken, or out of tolerance parts. Note that aPriori does not include reworked parts in 
scrap calculations. 
It is important to understand that yield calculations begin at the end of the routing, using 
the Total Production Volume as the starting point, and working upstream, process by 
process. The relationship of volume, scrap, and yield in the aPriori environment is 
summarized in the following illustration: 
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The end result of yield calculations is that the manufacturing process may require more 
material, direct labor, and direct overhead in each process. 
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Viewing and setting Good Part Yield values 
To view the Good Part Yield column for a component: 

1 Go to the Part Details tab, and click Table View > Select Table View > All Data 

 

2 In the Cost Object panel, expand all the processes. 

 

3 In the Manufacturing Info panel, expand Process Group, and scroll to the right. The Good 
Part Yield column is just to the right of the Labor and Overhead Rate columns. 
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4 Enter override values as necessary for specific processes. For example, to continue 
the values shown in the illustration above, you could enter “98” for the Hammer 
process row and “99” for the Trim process row. The Final Yield and Lifetime Scrap Parts 
columns update as you enter overrides. Note: You should not enter Good Part Yield 
values in any field except a process field, even if the field is editable. 

 

Note: The Lifetime Scrap Parts column sums up scrap parts at each node, but only 
processes are included in the total at “Current”, not nodes.  The following 
modified example shows which values are actually included in the total.  

 
Assume that you change the Trim process to 100% GPY, but change the Band 
Saw process under the Saw node to 99% GPY. The total scrap parts in this 
example changes to “0” for the Trim process, and “11” for the Band Saw process, 
which is also reflected on the Saw node row. However, only the process row “11” 
counts toward the Current total, not the node row “11”. An easy way to distinguish 
between node rows and process rows is that process rows always have labor 
and overhead rate values, while these columns are blank for node rows. 
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Calculations related to yield 
The following are yield calculations: 

 Num. of Scrap Parts = (Output Volume / Good Part Yield) – Output Volume 
 Output Volume = Total Production Volume + Downstream Num. of Scrap Parts  
 Input Volume = Output Volume + Num. of Scrap Parts (process-level) 
 Downstream Num of Scrap Parts = Num. of Scrap Parts + Downstream Num of Scrap Parts 

This calculates the sum of all scrap downstream (to the right in the block diagram 
above), not including the current process. This value simply stores the scrap 
value for the next upstream process.  

 Final Yield =  Output Volume / ( Input Volume + Downstream Num of Scrap Parts) 
The following are calculations affected by yield: 

 Labor Cost = (Labor Rate * Labor Time) / Final Yield 
 Direct Overhead Cost = ((Labor Cost * Overhead Multiplier) + (Overhead Rate * Cycle Time)) 

/ Final Yield 
 Expendable Tooling Cost Per Part = (Expendable Tooling formula) / Final Yield 
 Additional Direct Costs = (Additional Direct Costs formula) / Final Yield 
 Material Cost = (Rough Mass * Stock Cost Per Kg) / Final Yield 

Selecting a virtual production 
environment (VPE) 
A Virtual Production Environment (VPE) represents a manufacturing facility. aPriori 
provides a set of Starting Point VPEs representing average costs of manufacturing in 
various geographic regions. The elements that make up Starting Point VPEs, aPriori 
Manufacturing Cost Models and aPriori Regional Data Libraries, are separately licensed. 
Additionally, you may configure a VPE to represent your in-house manufacturing 
environment and cost structure or a supplier’s manufacturing environment and cost 
structure. 
By default, aPriori selects VPEs automatically (depending on how your installation is 
configured). For certain process steps you can display the current VPE details and 
manually select a different VPE (to determine the cost of performing them at a different 
facility with different manufacturing capabilities and cost structures). If the VPE 
commands are not available for a process step, they are disabled on the menu.  

To display VPE details 

1 In the Manufacturing Process pane select Edit > Show VPE Details or right-click on 
the process step and select Show VPE Details. The VPE Details window appears, 
containing information and usage notes about the VPE, its groups and processes, 
and a log/description of changes made to the VPE over time. 

2 To select a different VPE, click Edit.  
To close the VPE Details, click Close.  
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To select a VPE 

1 In the Manufacturing Process pane select Edit > VPE Selection or right-click on a 
process step and select VPE Selection. The VPE Selection window displays. (You 
can also select a VPE from the Basic Options section of the Cost Guide, as described in 
Initial costing: the Cost Guide on page 21.) 

2 Click the User Select button. 

3 Select a VPE from the list. 

4 Click Ok to apply changes, recalculate the Fully Burdened Cost, and close the VPE 
Selection window; or click Apply to apply changes and recalculate the cost without 
leaving the VPE Selection window. 
A status indicator shows the costing status of the input: 

• Green — Costing completed with the requested input. 
• Yellow — Costing completed with warnings. Typically, indicates that the 

requested input was invalid and a different input, based on selection policy, 
was used for costing. 

• Red — Costing failed. 
You can see the warnings in the Status Messages pane. 

Selecting a machine for an operation 
When you select a routing, aPriori automatically selects a machine for each process, 
based on machine feasibility and selection rules defined for each process. For example, 
for most processes, the machine must be physically large enough to accommodate the 
part. Of the machines that meet the feasibility rules, the machine that is selected 
typically is the machine of that set with the lowest overhead rate. You may manually 
select a different machine than the one that aPriori selects automatically.  
The machines available for a process are defined by the selected VPE. 

To view the machines that can be used by a process 
Do one of the following to display the machine properties for a process’ machines on the 
Machine Selection window: 

 If the process is included in the current routing, right-click the process in the 
Manufacturing Process pane and select Machine Selection from the context menu. 

 If the process is not included in the current routing, select Edit > Routing 
Selection in the Manufacturing Process pane to display the Routing Selection 
window, then right-click the process and select Machine Selection from the 
context menu. 

If the Machine Selection option is disabled on the context menu, machine selection is not 
allowed for the process. 
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To manually select a machine for a process 

1 View the machines that can be used for a process on the Machine Selection window 
(see above). 

 

2 Select a machine from the list.  
If you cannot select a machine, machine selection is not allowed for the process. 

3 To change selection policy, click Advanced Options. You can choose from the 
following options: 

• Check feasibility; if not feasible, auto select. 
• Check feasibility; if not feasible, fail to cost. 
• Do not check feasibility. 

4 Click Ok to apply changes, recalculate the cost, and close the Edit Machine 
Selection window; or click Apply to apply changes and recalculate the cost without 
leaving the window. 
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Editing process setup options 
Process setup options (also referred to as a PSOs or setup options) allow you to 
configure the costing of an individual part. For example, if you cost a part using the 
Plastic Molding process group, you can use a setup option to specify the number of mold 
cavities that should be assumed for that part.  

 
All PSOs have reasonable default settings (except for some process setup options in 
user-guided process groups--see the chapter User Guided Process Groups in the Cost 
Model Guide). You only need to use a setup option when you want to override the 
default. 
You set PSOs with the Process Options Editor: select Process Setup Options from the Edit 
menu in the Manufacturing Process pane. 

 
The left pane of the Process Options Editor displays the current routing as a tree, just as 
the Manufacturing Process pane does. 
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Each process setup option applies either at the process level or at the individual GCD 
level. A process-level setup option (such as Number of Cavities, mentioned above) has a 
single setting for a given part, while a GCD-level setup option can be set differently for 
different operations on different GCDs. For example, you can use a setup option to 
specify the load time for a particular insert in an Assembly Molding part. 
To set a process-level option, click the relevant process in the navigation pane of the 
Process Options Editor: 

 
To set a GCD-level option, click the relevant GCD under the relevant operation 
occurrence in the navigation pane of the Process Options Editor: 
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You can set a PSO on multiple GCDs at once: in the navigation pane of the Process 
Options Editor, click the first GCD and then either shift-click to select the end of a range 
of GCDs or ctrl-click to select additional GCDs: 

 
In addition to accessing PSOs from the Edit menu of the Manufacturing Process pane 
(described above), you can also access setup options from the following: 

 Cost Guide: 

 
 Routing Selection dialog: 
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 Operation Sequence Selection dialog: 

 

Note: When you override a default with a PSO, aPriori validates your setting based on 
the information last extracted from the current part's CAD model. If you change 
the CAD model, the existing PSO setting is not re-validated. A value that is no 
longer valid can cause the part or some GCDs to fail to cost. 
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For details about the process setup options available for each process group, see the 
Cost Model Guide. 
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Selecting a process routing 
A process routing is a sequence of processes that completes manufacturing of a 
component (part or assembly); for example, Cut-to-Length > Laser Cut > Bend Brake. 
Since alternative and optional processes may be used to manufacture a component, 
multiple routing options exist for the same component. aPriori evaluates feasibility and 
cost of available routing options and auto-selects the best routing for the component. 
You can use the aPriori Routing Selection window to select an alternative routing 
manually and/or change routing options.  
For details about the process setup options available for a specific process group, refer 
to the Routings section within the process group chapters. 

To display the Routing Selection window 
In the Manufacturing Process pane, select Edit > Routing Selection or right-click and 
select Routing Selection. 
The Routing Selection window displays: 

 Alternative routings for the selected process. 
 Optional processes for every routing. 

 
The Process Routing column of the routing table shows all routing choices for the 
process. Every row in the routing table represents a routing choice.  
The Cost column shows the cost of every routing. The last costed routing is highlighted 
and marked Last Costed.  
See the tables below for an explanation of the symbols and conventions used in this 
display.  
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Viewing options 
The View menu gives you two options – Show Routings with Incomplete Cost and 
Show Uncosted Processes within Visible Routings. Using these options, you can 
create different views of the Routing Selection window: 
If both options are unchecked, only the routings that have been costed without warnings 
are displayed.  
If the Show Routings with Incomplete Cost option is checked, routings that costed 
with warnings and available routings that were not costed are displayed in addition to the 
routings that were costed without warnings.  
If the Show Uncosted Processes within Visible Routings option is checked, all 
uncosted nodes within the routing are displayed. A node could be uncosted if the 
process it is representing is not required for manufacturing the component or has been 
manually excluded from the routing. 

Understanding the legend 

Nodes 
Click the Legend button to display the explanatory list of node types.  

 A beige background indicates that this node represents a choice between 
two or more alternative processes. Selecting a row that contains this type 
of node causes the system to auto-select between the underlying 
alternative processes. 

 A solid border indicates that this node is marked as required. A feasibility 
rule failure at one of these nodes will cause an entire routing alternative to 
fail. 

 A dashed border indicates that this node is marked as optional. It may be 
included or excluded via a right-click menu. 

 A clear background indicates that this node was not evaluated by the 
system in the last costing event. This is either because of a feasibility rule 
failure, because the node has been excluded from the routing by a user, 
or because the node was not required for the manufacturing of the 
component.  

 A green border and user-override symbol indicate that the routing was 
customized, and this node was added. It may be removed from the routing 
via a right-click menu. 

Node status icons 

 The node succeeded (i.e., it passed feasibility evaluation). 

 A yellow status icon on a node indicates that the node passed feasibility 
evaluation but has some uncosted GCDs. Click on the icon to see which 
GCDs failed to cost. 
A yellow status icon over a GCD icon in the Cost column indicates that this 
routing, although costed, has some uncosted GCDs associated with it. 
Hover the cursor over the icon to see what GCDs failed to cost. 
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 A red status icon indicates that the node failed to cost. Click on the 
indicator to see why the process failed feasibility evaluation. 

 This node has Process Setup Options (PSOs) that can be customized by 
the user. Click the hammer or right-click the node and select Process 
Setup Options.  

 User override: .The routing has been customized. 
 

Expandable nodes 
Nodes with a plus sign (  ) are expandable. When you click on the plus sign, the next 
level of detail is displayed. The node can expand vertically or horizontally: 

 Alternative nodes expand vertically displaying two or more new lines underneath 
the node. Each line represents an alternative routing available for the node. You 
can select only one routing.  

 Conjunctive nodes expand horizontally, displaying all available options in one line 
underneath the node. You can manually include one or more options into the 
routing.  

Selecting and editing a routing 
Clicking a row in the Routing table selects the routing this row represents. Clicking a 
node selects the node and the row. 
Selected node shows the cost status indicator: 

 Green — Costing on this node completed successfully. 
 Yellow — Costing on this node completed with warnings. Typically, indicates that 

feasibility rules were not evaluated or that there are uncosted GCDs associated 
with the process. 

 Red — Costing on this node failed. Click on the red status indicator to see which 
GCDs failed to cost. 

To select and edit a routing 

1 In the Manufacturing Process pane Select Edit > Routing Selection or right-click 
and select Routing Selection. The Routing Selection window is displayed. 

2 Select a routing.  

3 Change routing options as needed by Selecting alternative processes on page 185 
and Using the right-click menu on page 187. 

4 You can even customize the routing for the component by inserting or reordering 
processes. This includes creating and inserting Custom Processes. For more 
information, see Creating custom processes and routings on page 190. 
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5 Click Ok to apply changes, recalculate the cost, and close the Routing Selection 
window; or click Apply to apply changes and recalculate the cost without leaving the 
Routing Selection window. 
Once you selected a routing and closed the Routing Selection window, aPriori 
remembers the costs calculated in the last costing event only. This is sometimes 
called a pinned routing – this allows you to manually select a preferred routing so 
that aPriori does not spend time calculating several alternative routings when 
costing.  When you open the Routing Selection window again, only the routings that 
were costed in the last costing event have values in the Cost column. The uncosted 
routings are displayed only if the View > Show Routings with Incomplete Cost 
option is selected.  

Selecting alternative processes 
Alternative node is an expandable node representing a choice between two or more 
alternative processes. Each alternative process represents a separate routing. aPriori 
automatically selects a routing for costing, but you can manually select a different 
alternative. Only one routing can be selected. 
When you expand an alternative node: 

 Alternative routings for this node are displayed based on the selection in the 
View menu. 

 The node and the entire scope of aPriori auto-select options is highlighted and 
surrounded by the Auto border. 
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If you click OK or Apply at this point, aPriori will automatically select a routing within the 
Auto border. You can also select a routing manually. 

  If you manually select one routing under the alternative node, the scope of 
aPriori auto-select options changes and becomes limited to alternatives within 
that routing. 
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You can again click OK or Apply to let aPriori make a selection within the Auto border 
or make the selection manually. 

Reverting to aPriori auto-selected routing 

To revert to the routing automatically selected by aPriori 
In the Routing Editor, select the highest-level node in the routing tree. This is the node 
specifying the Primary Process Group.  
Click OK or Apply. 

Using the right-click menu 
Right-clicking a node selects the node and the row and opens a menu with the following 
options: 

 Inclusion menu – this option is only available for the nodes that can be manually 
included into and excluded from the routing: 

Let aPriori decide – initially this option is selected, since by default aPriori decides 
whether to include or exclude the node.  
Include – Select this option to manually include the selected node in the routing. The 
green icon on the node indicates that the node was manually included. Select Let 
aPriori decide to revert to the aPriori choice.  
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Exclude – Select this option to manually exclude the selected node from the routing. 
The node becomes crossed out and the green icon on the node indicates that the node 
was manually excluded. Select Let aPriori decide to revert to the aPriori choice. 

 Machine Selection – this option allows the selection of a machine for the 
selected process. This has the same effect as selecting a machine from the 
Manufacturing Process tree. 

 Process Setup– this option allows the selection of Process Setup options for the 
selected process. This has the same effect as selecting Process Setup from the 
Manufacturing Process tree. 

 Rules/Status – this option displays the evaluation feasibility status for the node. 
For nodes representing alternative and optional processes it also displays the 
User Selection Policy Options window. In this window you can:  

Select whether or not to check feasibility rules. For any node you can check the Process 
check box to evaluate the process feasibility rules.  
Processes that have no more underlying processes associated with them must be 
assigned a machine. aPriori assigns a machine automatically. If you override aPriori 
choice and select the machine manually, a Machine check box becomes available in the 
User Selection Policy Options window, so you can check the machine feasibility rules. 
Choose what to do if a rule fails – Fail to cost or Revert to auto-select. 

Selecting an unfeasible machine for a process 
In some situations, aPriori considers a process to be unfeasible for auto-selected routing 
because there is no feasible machine for the process.  

To select an unfeasible machine for a process 

1 In the Routing Editor, select View > Show Uncosted Nodes within Visible 
Routings. The unfeasible nodes are displayed with a red status sign. To see the 
message indicating why the process is not feasible, right-click on the process and 
select Rules/Status. 

2 Select an unfeasible process and click OK. In the Manufacturing Process tree, the 
newly added process appears with a red status sign.  

3 Right-click the newly added process and select Machine Selection. 

4 Select the desired machine and click Advance Options. 

5 Check the Do not check feasibility option. aPriori costs the component with 
manually selected process and machine while ignoring the feasibility rules for that 
process/machine. 

6 Click OK. 
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Using the auto-select parent process command 
The Auto Select Parent Process command is available only for punched holes in Bar & 
Tube Primary Process Group. You can use this command to revert to the aPriori 
selected punching process from a manually selected punching process.  
The following sequence of steps illustrates how you can use the Auto Select Parent 
Process command: 

1 Open a Bar & Tube part with punched holes. You will see holes listed under 
Punching\SimpleHoles or Punching\ComplexHoles in the Routing Tree.  

2 Select Edit > Routing Selection to open the Routing Selection window, see 
Selecting a process routing on page 182.  

3 Select All Processes from the View menu.  

4 Expand the Routing Tree until you see an uncosted Punching process.  

5 Right-click the uncosted Punching process and select Include from the Inclusion 
menu. 

6 Click OK. The Routing Selection window closes, and you can see two punching 
processes in the Routing Tree in the Manufacturing Process pane – Punching and 
Punching 2.  

7 Select one or more holes under Punching and drag them to Punching 2. The Cost 
Output information becomes stale. 

8 Click the Cost button. The Cost Outputs information is updated, and you can see the 
holes that you dragged under the Punching 2 process.  

9 Right-click a hole under Punching 2. The Auto Select Parent Process command is 
now available. Select this command to revert the hole to aPriori selected parent 
process. The Cost Outputs information becomes stale. 

10 Click Cost. The cost outputs are updated, and you can see the hole back under the 
Punching process. 

No Cost Feature 
aPriori provides a "No Cost Feature" operation for handling GCDs that should not 
contribute to the cost of a component. For example, if an operation on one GCD also 
happens to apply to an adjacent GCD, applying "No Cost Feature" to that adjacent GCD 
prevents double costing. aPriori automatically applies "No Cost Feature" when possible, 
but you can also apply this manually as needed.  
An initial version of this functionality was introduced for machining in aPriori Release 
2014 R1, but as of 2015 R1, this option is available across all process groups. 

To apply a No Cost Feature in the Routing Selection editor 
In the Routing Selection editor, right-click the optional No Cost Feature operation and select 
Include. A sandcasting part is shown in the following example. 
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To apply a No Cost Feature to a GCD 
To apply No Cost Feature to a specific GCD, see GCD operation sequence selection on 
page 202. 

Creating custom processes and routings 
You can create a custom routing for a part or assembly by inserting additional processes 
(including simple user-defined custom processes), reordering processes, and excluding 
processes. You may also customize an operation sequence performed to a specific 
GCD. This allows you to provide a routing variation and capture complete costs in 
situations where the pre-defined routings do not completely represent the actual 
manufacturing production processes performed on that component. Common situations 
where this may be useful include routings which use multiple instances of a single 
process (e.g., a part that is initially cut on one waterjet machine and later undergoes 
another cutting operation on a second waterjet machine), or routings which include 
simple secondary processes such as Inspections that are performed at various points 
throughout the routing. It is also very common to manually add surface treatments at the 
end of a routing.  
Note that some processes cannot be manually added, such as milling or turning, 
progressive die, etc. Any processes that can be manually added are listed in the column 
displayed for Customize Routing. 

Note aPriori Services can also extend your VPEs to extend the set of processes and 
pre-defined routings that are always available). 
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Creating a custom routing 

To create or edit a custom routing 

1 In the Manufacturing Process panel, click on the Edit menu and select Routing 
Selection… The Routing Selection editor window will appear. 

2 Select Customize Routing… from the Edit menu. A panel will appear on the left side 
of the Routing Selection window, which lists processes available to insert into the 
routing. Processes are grouped by process group. 

3 If necessary, create one or more custom processes to use in your routing. See 
Creating a custom process on page 193.  

4 For each process you are interested in adding to your routing, click on the process in 
the list of available processes, hold down the left mouse key, and drag the process 
from the panel onto the routing. As you do so, the User Interface will dynamically 
display arrows indicating where the process will be inserted if you release the mouse 
button. Drag the process to the desired position and release the left mouse key.  
If you wish to insert the process in a different location, you can simply drag-and-drop 
it to the new location. 
To remove the process from the routing, right-click on the node and select Remove 
from the popup menu. 

5 If you wish to exclude any processes that are already in the routing, you can right-
click on the node and select Exclude from the popup menu. 

6 Depending on how you have customized your routing, it also may be necessary to 
customize the operation sequence for one or more GCDs. For more information, see 
Creating a custom operation sequence on page 191. 

7 Depending on how you have customized your routing, you also may need to 
manually assign operations on specific GCDs to different processes. See Assigning 
operations to different processes on page 195 for more information. 

Creating a custom operation sequence 
If you have customized a process routing, it also may be necessary to customize the 
operation sequence for one or more GCDs. This is because the order of operations in a 
GCDs operation sequence must be consistent with (i.e., must not conflict with) the order 
of processes in the component routing. We will illustrate this using an example from the 
aPriori starting point VPE routings. 
For example, a sheet metal part may be costed with the process routing ‘Laser Cut’ ‘3 
Axis Mill’ ‘Internal Grinder’ 
A SimpleHole GCD is assigned the operation sequence ‘Laser Cutting’ ‘Reaming’. By 
default, there is no ‘Internal Grinder’ operations in that sequence, so you will need to 
customize the operation sequence if you wish both reaming and grinding operations to 
be applied to SimpleHoles.  
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You can customize the operation sequence by inserting the ‘ID Finish Plunge Grinding’ 
operation after the ‘Reaming’ operation, so that the custom operation sequence 
becomes:  
‘Laser Cutting’ ‘Reaming’ ‘ID Finish Plunge Grinding’ 
This is a valid customization, because the order of the operations is consistent with the 
order of the processes in the process routing. 
However, if you customize the operation sequence by inserting the ‘ID Finish Plunge 
Grinding’ operation before the ‘Reaming’ operation: 
‘Laser Cutting’ ‘ID Finish Plunge Grinding’ ‘Reaming’ 
then the order of operations for the SimpleHole GCD will conflict with the order of 
processes in the parent routing. This is an invalid state. If you cost the part at this time, 
you will get an error message in the message tree. 
To correct the order consistency problem, you must either: 

 Leave the ‘Internal Grinder’ process after the 3 Axis Mill and insert the ‘ID Finish 
Plunge Grinding” operation after the Reaming process 

 Customize both the process routing and the operation sequence so that the 
Internal Grinder process comes prior to the 3-Axis Mill process and so the ID 
Finish Plunge Grinding operation comes before the Reaming process. Note that 
although this addresses the consistency issue, it does not make much sense 
from a manufacturing perspective.  

To create or edit a custom operation sequence 

1 In the Geometric Cost Drivers panel, right click on the GCD(s) of interest and select 
Edit… from the popup menu. The Operation Sequence Selection editor window will 
appear. 

2 Select Customize Routing… from the Edit menu. A panel will appear on the left side 
of the Operation Sequence Selection window, which lists operations available to 
insert into the sequence (grouped by their parent processes).  

3 For each operation you are interested in adding to the operation sequence, click on 
the operation in the list of available operation, hold down the left mouse key, and 
drag the operation from the panel onto the routing. As you do so, the User Interface 
will dynamically display arrows indicating where the operation will be inserted if you 
release the mouse button. Drag the operation to the desired position and release the 
left mouse key.  
If you wish to insert the operation in a different location, you can simply drag-and-
drop it to the new location. 
To remove the operation from the sequence, right-click on the node and select 
Remove from the popup menu. 

4 Depending on how you have customized your sequence, it also may be necessary to 
customize the parent process routing so that the order of processes is consistent 
with the order of operations.  
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Creating a custom process 
Custom processes provide a way to represent and account for extra processing that isn’t 
included in a VPE’s predefined routings. You can create a custom process, supply inputs 
via process setup options, and drag the custom process into a routing. 
To create a custom process: 

1 In the Manufacturing Process pane, Select Routing Selection… from the Edit menu. 
The Routing Selection editor appears. 

2 In the Routing Selection editor, select Create Custom Process… from the Edit menu.  

 
The Custom Process/Operation window appears. 

 

3 In the Name field, enter a name for your custom process. 

4 Enter General Inputs: 
• Capital Investment Cost 
• Margin Percent  

5 Choose a Model Type (see below). 

6 Enter the remaining inputs that are relevant to the Model Type you chose. 
There are two general categories of model type: 

 Cycle-time-based model types: 
o Cycle Time  
o Cycle Time Per Length 
o Cycle Time Per Each 
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 Cost-based model types: 
o Cost Per Surface Area 
o Cost Per Mass 
o Cost Per Length 
o Cost Per Each 

For all cycle-time-based models, you enter the following: 
 Labor Time (if you want to override labor time as calculated from cycle time—see 

below) 
 Number of operators 
 Batch setup time 
 Labor rate 
 Overhead information (either overhead rates or machine and workcenter 

information for bottom-up overhead-rate calculation) 
You also enter the following model-type-specific information: 

 Cycle Time model:  
o Cycle Time: enter the total cycle time required for a part. 

 Cycle Time Per Length model:  
o Cycle Time Per Length: enter a time per unit length.  
o Length: enter the length that should drive cycle time, or else specify that it 

should be driven by the part length. 
 Cycle Time Per Each model:  

o Cycle Time Per Occurrence: enter the cycle time per feature, for some cost-
driving feature of parts, or enter the cycle time per item or operation for some 
item or operation associated with part manufacture.  

o Number of Occurrences: enter the number of occurrences of the feature, item, 
or operation for a single part. 

For cost-based models, you enter the following model-type-specific information: 
 Cost Per Surface Area model:  

o Surface Area: enter a surface area or specify that the model should use the 
part’s surface area.  

o Surface Area Affected: enter the percentage of the specified surface area that 
should drive the cost of the part.  

o Surface Area Rate: enter a cost per unit area. 
 Cost Per Mass model:  

o Part Mass: enter a mass or specify that the model should use the part’s mass.  
o Mass Affected: enter the percentage of the specified mass that should drive the 

cost of the part.  
o Mass Rate: enter a cost per unit mass. 

 Cost Per Length model:  
o Length: enter a length or specify that the model should use the part’s length.  



Manufacturing Process Information  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 195 

o Length Affected: enter the percentage of the specified length that should drive 
the cost of the part.  

o Length Rate: enter a cost per unit length. 
 Cost Per Each model:  

o Cost Per Occurrence: enter the cost per feature, for some cost-driving feature of 
parts, or enter the cycle time per item or operation for some item or operation 
associated with part manufacture.  

o Number of Occurrences: enter the number of occurrences of the feature, item, 
or operation for a single part. 

Cycle-time-based models calculate overhead costs and rates as described in the Cost 
Model Guide chapter Direct and Indirect Overhead. They also use standard formulas for 
labor and batch setup costs per part: 
Labor Cost = (Cycle Time * Number of Operators * Labor Rate) / Final Yield 
Amortized Batch Setup =  

(Batch Setup Time * (Labor Rate + Direct Overhead Rate)) / Batch Size 
Labor Time Standard for the custom process is assumed to be 1. Labor handling time is 
assumed to be 0. 
Yields are calculated as described for the current process group in the Cost Model 
Guide. Good Part Yield for the custom process is assumed to be 1. 
Cost-based models categorize costs (excluding capital investment and margin) under 
Additional Direct Costs .  
To include the custom process in a routing, simply drag it and drop it into the desired 
routing sequence. After it is included in the routing, you can modify the definition or 
inputs to the custom process by right-clicking the node in the routing editor and selecting 
Process Setup Options. 
Note that custom processes created within one scenario are not available for reuse in 
other parts. 

Assigning operations to different processes 
Depending on how you have customized your routing, you also may need to manually 
assign operations on specific GCDs to different processes.  
For example, you may have added a second instance of a “2Axis Lathe” process, so that 
roughing of curved wall GCDs can occur on the first lathe and finishing of the curved wall 
GCDs can occur on the second lathe. By default, all operations are assigned to the first 
instance of a process, so you will need to manually assign the finishing operations to the 
second lathe process. 

To manually assign GCD operations to another process 

1 In the Manufacturing Process pane, click on the + symbols to expand the process 
nodes of interest (in this example, you would see a node named “2 Axis Lathe” and 
another node named “2 Axis Lathe:2”).  

2 Each process node will have sub-nodes representing the operations assigned to that 
process and the GCDs they are being performed on. (In this example, you would see 
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that the first “2 Axis Lathe” node contains a Rough Turning node and a Finish 
Turning node, each with Curved Wall GCDs under them. The second lathe process 
“2 Axis Lathe:2” would not initially have any operations or GCDs under it, as all 
operations are by default performed on the first lathe).  

3 For each operation/GCD pair of interest, click on the GCD node and drag-and-drop it 
onto the new process node (In this example, you would click on a curved wall GCD 
located under the Finish Turning node and drag it from the “2 Axis Lathe” node onto 
the “2 Axis Lathe:2”). You can multi-select GCDs or GCD/Operation pairs to drag by 
holding down the Ctrl-key. If you are unable to drop the operation/GCD pair on the 
process node of interest, see Note: below. 

4 The Manufacturing Process pane will update to reflect how GCDs/operations are 
now assigned. (In this example, you will now see a Finish Turning node under the “2 
Axis Lathe:2” process, and a curved wall GCD under it indicating that curved wall is 
now being finished on the second lathe.) Continue dragging-and-dropping until all 
operations/GCDs are assigned to the appropriate lathe processes. 
If you are unable to drop the operation/GCD pair on the process node of interest, you 
may also need to change or edit the Operation Sequence routing.  
Building on the earlier example, if you customize the process routing to insert a new 
3 Axis Lathe process (instead of the second 2 Axis Lathe) following the original 2 
Axis Lathe process, you will not initially be able to drag curved wall operations to the 
3 Axis Lathe. This happens because the currently-selected operation sequence for 
the curved wall does not contain 3 Axis Lathe operations. To fix this, open the 
Operation Sequence Selection window for the GCD(s) of interest and select an 
operation sequence that includes the 3 Axis Lathe. In other examples, you may need 
to customize the Operation Sequence to include the processes that were added to 
the part routing. For more information on customizing operation sequences, see 
Creating a custom operation sequence on page 191. 

Highlighting associated GCDs 
The Highlight Associated GCDs command allows you to select a manufacturing step 
from the Routing Tree and highlight the GCDs associated with this step in the 
Component Viewer and in the Geometric Cost Drivers table.  
In Direct Integration mode, if the component is opened in the active window in the CAD 
system, the associated GCDs are highlighted in the CAD model.  

To highlight associated GCDs 
Right-click a step in the manufacturing process and select Highlight Associated GCDs. 

Note: You can also highlight GCDs of a particular type directly from the Component 
Viewer. (See the description of the Marquee Selection Tool in the Component 
Viewer on page 51. 
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Specifying simultaneous operations 
With aPriori Manufacturing Cost Models, you can specify simultaneous operations for 
turned parts manufactured on a 4-axis or 6-axis lathe. Custom VPEs can be more 
broadly configured to contain operations assignment logic with includes support for 
automatic determination of simultaneous operations. 

To specify simultaneous operations 

1 Select a routing that contains a 4-axis or 6-axis lathe process 

2 In the Manufacturing Process pane, expand the tree to display the lathe process 
node and the operations and associated GCDs below that node. Under the lathe 
process node, you also will see a node called "Simultaneous Group.  

3 You can drag-and-drop operations on specific GCDs into the "Simultaneous Group" 
node, to indicate they should be performed simultaneously:  

• First click on the GCD row; it will be highlighted in blue.  
• Next, click on the same GCD row and hold down the mouse key, drag it over 

to the Simultaneous Group node, and release the mouse key.  
• The operation and GCD nodes will be moved under the Simultaneous Group 

node.  
• Select a routing that contains a 4-axis or 6-axis lathe process 

To remove an operation from the simultaneous Group node 
Use the same technique described in step 3 above to drag-and-drop the GCD back to 
the 4-axis or 6-axis lathe process node. The operation/GCD will be moved back to its 
original location and no longer appear under the Simultaneous Group node. 
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8 Geometric Cost 
Drivers 

A Geometric Cost Driver (GCD) is a geometric attribute in the solid model of an 
MCAD component (part or assembly) that drives cost on the manufacturing floor. 
A GCD may be a physical concept, such as the thickness of sheet metal or the 
finished mass of a cast part; or it may be a geometrical concept, such as a bend, 
a hole, or a draft angle. 
Each GCD can occur in multiple instances per component. In part manufacturing, 
GCDs are generally obtained through geometric analysis of the CAD model (for 
example, holes, straight bends, side cores, etc.). In assembly manufacturing, 
GCDs are often user defined (for example, ProWelds and virtual welds).  

This chapter includes the following topics: 
 Overview 
 Geometric cost drivers tree/table 
 GCD commands 
 GCD operation sequence selection 
 "Not Supported" GCD Messages 
 GCD categories 
 Component GCDs 
 Volume GCDs 
 Bending/forming GCDs 
 Holes GCDs 
 Surfaces GCDs 
 Weld GCDs 
 2-Model GCDs 
 GCD relations 
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Overview 
A Geometric Cost Driver (GCD) is a geometric attribute in the solid model of an MCAD 
component (part or assembly) that drives cost on the manufacturing floor. A GCD may 
be a physical concept, such as the thickness of sheet metal or the finished mass of a 
cast part; or it may be a geometrical concept, such as a bend, a hole, or a draft angle. 
Each GCD can occur in multiple instances per component. In part manufacturing, GCDs 
are generally obtained through geometric analysis of the CAD model (for example, 
holes, straight bends, side cores, etc.). In assembly manufacturing, GCDs are often user 
defined (for example, ProWelds and virtual welds). 
The details and options available for GCDs vary between components and across 
process groups. 

Working with large parts 
Large parts might contain thousands of GCDs in a single category (such as Curved 
Walls or Curved Surfaces). To avoid performance issues when working with this many 
GCDs, aPriori automatically highlights and selects GCDs only when the GCD Category 
node has fewer than 2000 GCDs. GCDs will not be highlighted if more than this number 
is selected. Note that your aPriori System Administrator can modify this setting with the 
gcds.to.highlight.threshold property in the apriori.properties or apriori.user.properties file. 
See the System Administration Guide for more details. 

Displaying GCDs 
Use the following procedures to the display some or all GCDs for a component. 

To display all GCDs for a component 
In the GCDs pane, select Show > All.  

To display only relevant GCDs for a component 
In the GCDs pane, select Show > Relevant. This is the default selection. 

Note Curved Bend and Closed Bend GCDs in Sheet Metal are no longer used. They 
are supported for backward compatibility to existing models but are not shown by 
default in the GCD tree. To view these GCDs, use the Show > All option. 

There are additional discussions regarding the display of GCDs at: 

 Working with large parts above 

 Component Viewer on page 51 
 Highlighting associated GCDs on page 196 
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Geometric cost drivers tree/table 
The left side of the GCDs panel displays a tree of GCDs and GCD relations for the 
active component. You can drill down to the level of detail you want to view. The right 
side of the panel displays details about the highlighted GCD.  

 
On the highest level of the GCD tree, you have GCD types, such as Component, 
Holes, or Surfaces. Every part or assembly has Component type GCDs. Component 
GCDs provide the highest-level information for a part or an assembly, such as overall 
dimensions, volume, or cross section. GCDs included in the component type vary 
depending on the Manufacturing Process Group. 
The rest of the GCD types correspond to types of features and to manufacturing 
approach, for example Holes or Bending/Forming. These types vary depending on the 
Manufacturing Process Group. Each GCD of such type corresponds to a specific 
manufacturing operation.  
Each GCD presents iconic status and user input indicators. The status indicator provides 
a red/yellow/green icon to indicate an error/warning/success status. The user input 
indicator provides a green user icon to indicate that you have made an explicit GCD edit 
(e.g. operation or tolerance change). 
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The following icons are used in the GCD tree: 
 

Icon  Usage 

 A GCD Type. The number in brackets indicates the number of GCDs of that 
type for the selected component. 

 An Individual GCD. GCDs can be primary or nested. A primary GCD serves 
as a primary input to costing or analysis. A nested GCD belongs to a higher 
GCD level. Nested GCDs have less information and fewer options than 
primary GCDs. 

 A GCD Relation Type. The number in brackets indicates the number of 
GCDs of that type for the selected component. 

 A GCD Relation. 

Double-click a GCD Type or GCD Relation Type to see all GCDs/relations of that type in 
the GCD tree. Each row represents one GCD.  
When you select an individual GCD: 

 The GCD properties are displayed in the table on the right. Fields with the  icon 
are editable.  

 The GCD is highlighted in the Component Viewer. 
 Manufacturing process steps related to this GCD are highlighted in the 

Manufacturing Process pane. 
When you select a GCD relation, the related GCDs are highlighted in the Component 
Viewer.  

Editing values in the GCD properties table 
In the GCD Properties Table, fields with the  icon are editable. 

To edit a value 

1 Double-click on the field. 

2 Type a new value. 

3 Press Enter.  

Costing a component after editing GCD properties 
When in Auto-Costing mode, the component will be costed as soon as the GCD edit is 
made. When in One Click Costing mode, the component will not be costed until you 
explicitly click the Cost button. This allows you to make several GCD level edits and cost 
these changes in a single costing event. 
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GCD commands 
Select a GCD and right-click in the GCDs pane to see the GCDs command menu. Use 
the Shift and Ctrl keys to select multiple GCDs of the same type for bulk editing. 
Commands in the menu apply to the highlighted GCDs. Commands unavailable for the 
highlighted GCDs are disabled.  
The GCDs command menu includes the following commands: 

 Edit: Opens the Geometric Cost Driver Editor for the highlighted GCDs. 
 Remove: Deletes the selected virtual weld. 
 Edit tolerances: Opens the Tolerance Editor for the highlighted GCDs. If no 

GCD is highlighted, this command is unavailable.  
 Alternatively, you can edit tolerance and roughness values directly in the GCD 

Properties table. 
 Auto-merge: Auto-merges an unmerged ComboVoid GCD. Available only for 

ComboVoid GCDs that have been unmerged using the Unmerge command 
below.  

 Unmerge: Unmerges a SimpleHole or a MultiStepHole GCD from a Void GCD in 
a ComboVoid GCD.  

GCD operation sequence selection 
To open the Operation Sequence Selection window 
Double-click a GCD or highlight a GCD, right-click and select Edit. Use the Shift and 
Ctrl keys to highlight multiple GCDs of the same type. 

Note: The Operation Sequence Selection window opens only if editing operation 
sequence is allowed for the selected GCD. 
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To assign the No Cost Feature operation to a GCD 
The No Cost Feature operation allows you to specify that a GCD should not contribute to 
a part's cost. (See   
No Cost Feature on page 189). 
You assign this operation to a GCD in the Operation Sequence Selection window by 
selecting the No Cost Feature operation block and clicking OK. Once set, this override 
is displayed in the Geometric Cost Drivers pane. After successful costing, the Selected field 
will also reflect "No Cost Feature". 

 
In general, applying "No Cost Feature" to a GCD with children will also apply to the 
children (there are some exceptions such as Edge, CurvedSurface, CurvedWall, and 
PlanarFace). If you apply "No Cost Feature" to a child GCD, the parent's Selected field 
will note "<child_gcd>/No Cost Feature" after successful costing. 
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"Not Supported" GCD Messages 
If aPriori encounters a GCD that it does not support, it lists the problem GCD in the "Not 
Supported" list along with a brief cause, and also highlights the GCD (if possible) in the 
viewer. 

 
Here is summary of the "Cause" messages and what they mean: 
NON_MANIFOLD_EDGES: An edge is attached to 3 or more surfaces, indicating 
impossible solid geometry to manufacture.  
 
SURFACE_GEOMETRY: The model contains only surface geometry, no solid body.  
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DIFFERENT_THICKNESS: Geometry has different thickness than the rest of the part, 
which is not supported in Sheet Metal. 
 
DISCONNECTED_SURFACES: The CAD file contains surfaces without edges likely due 
to a CAD modeling or translation error. This issue is not visible in the viewer.  
 
VOID_GEOMETRY_NON_MANUFACTURABLE: Void “bubble”: the void has no 
openings to the outside. Void bubbles cannot be manufactured in some Process Groups 
such as Casting or Machining. They can be manufactured in other Process Groups such 
as Rotational and Blow Molding, or Bar & Tube Fabrication. 
 
DETACHED_SOLID:  Multiple bodies exist in the model.  Only the largest body is used, 
and the remainder are ignored.  This is a result of “free body” processing mode. (See 
Costing multi-body parts on page 295 for more information.)  
 
TESSELLATION_VOID: Tessellation/translation error:  the tessellation (the 3D image 
displayed in the viewer) contains a void that does not exist in the BREP (the CAD 
model).  
 
TESSELLATION_BUBBLE: Similar to above, but there is an extra solid body formed by 
the tessellation that does not exist in the BREP. 
 
UNRECOGNIZED_FEATURE: aPriori cannot process the GCD. This can be due to 
many different reasons, differing by process group. For example, in Bar & Tube 
Fabrication, a feature might be considered “unrecognized” because it requires volumetric 
machining rather than the processes available in Bar & Tube. Or it might be 
unrecognized if the end of a tube is modeled as a solid bar instead of a tube. 
 
UNKNOWN: The migrated part had GCDs extracted prior to aP 2014 R2. If you have 
access to the CAD file, please open it in aPriori and recost the component to reextract 
GCDs in the current version of aPriori. 

Operation sequence table 
The Operation Sequence table for the selected GCD shows: 

 The sequence of operations 
 All alternative operations 
 All optional operations 
 The time to perform the selected sequence 
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Viewing options 
The View menu gives you two options – Show Routings with Incomplete Cost and 
Show Uncosted Processes within Visible Routings. Using these options, you can 
create different views of the Operation Sequence Selection window: 

 If both options are unchecked, only the sequences that have been costed without 
warnings are displayed.  

 If the Show Routings with Incomplete Cost option is checked, sequences that 
costed with warnings and also available sequences that were not costed are 
displayed.  

 If the Show Uncosted Processes within Visible Routings option is checked, 
all uncosted nodes within the sequence are displayed. A node could be uncosted 
if the operation it is representing is not required for the GCD or has been 
manually excluded from the sequence. 

Understanding the legend 
Click the Legend button to display the explanatory list of node types.  

 A node required by aPriori for the selected Manufacturing Process Group. 
A failure at one of the required nodes causes the entire routing to fail. 

 An expandable node representing a choice between two or more 
alternative processes. Each alternative represents a routing. 

 A copy of a node created as a result of expanding the original node. Copy 
nodes appear faded, but they are still costed in every routing. 

 A node that was not costed by aPriori because it was not required for 
manufacturing the component or has been manually excluded from the 
routing. Uncosted nodes are displayed only when you select Show 
Uncosted Nodes within Visible Routings from the View menu. 

Node Borders 

 Solid border indicates that the node is included by aPriori and cannot be 
included or excluded manually. 

 Dashed border indicates that the node can be included or excluded 
manually. 

Expandable nodes 
Nodes with the plus sign are expandable. When you click on the plus sign, the next level 
of detail is displayed. The node can expand vertically or horizontally: 

 Alternative nodes expand vertically displaying two or more new lines underneath 
the node. Each line represents an alternative sequence available for the node. 
You can select only one sequence.  

 Conjunctive nodes expand horizontally, displaying all available options in one line 
underneath the node. You can manually include one or more options into the 
operation sequence.  
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Selecting and editing an operation sequence 
Clicking a row in the Operation Sequence table selects the operation sequence this row 
represents. Clicking a node selects the node and the row. 
Selected node shows the cost status indicator: 

 Green — Costing on this node completed successfully. 
 Yellow — Costing on this node completed with warnings. Typically, indicates that 

feasibility rules were not evaluated for the operation. 
 Red — Costing on this node failed. Indicates that operation failed feasibility 

evaluation.  

To select and edit an operation sequence 

1 In the Geometric Cost Drivers pane, highlight a GCD, right-click and select Edit. The 
Operation Sequence Selection window is displayed. 

2 Select an operation sequence.  

3 Change operation sequence options as needed by Selecting alternative operations 
(see page 207) and Using the right-click menu (see page 209). 

4 Click Ok to apply changes, recalculate the cost, and close the Operation Sequence 
Selection window; or click Apply to apply changes and recalculate the cost without 
leaving the Operation Sequence Selection window. 

Note Once you selected an operation sequence and closed the Operation Sequence 
Selection window, aPriori remembers the costs calculated in the last costing 
event only. When you open the Operation Sequence Selection window again, 
only the sequences that were costed in the last costing event have values in the 
Time column. The uncosted sequences are displayed only if the View > Show 
Routings with Incomplete Cost option is selected.  

Selecting alternative operations 
Alternative node is an expandable node representing a choice between two or more 
alternative operations. Each alternative operation represents a separate sequence. 
aPriori automatically selects a sequence for costing, but you can manually select a 
different alternative. Only one sequence can be selected. 
When you expand an alternative node: 

 Alternative sequences for this node are displayed based on the selection in the 
View menu. 

 The node and the entire scope of aPriori auto-select options is surrounded by the 
Auto border. 
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If you click OK or Apply at this point, aPriori will automatically select a sequence within 
the Auto border. You can also select a sequence manually. 

 If you manually select one sequence under the alternative node, the scope of 
aPriori auto-select options changes and becomes limited to alternatives within 
that sequence. 
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You can again click OK or Apply to let aPriori make a selection within Auto border or 
make the selection manually. 

Using the right-click menu 
Right-clicking a node selects the node and the row and opens a menu with the following 
options: 

 Inclusion menu – this option is only available for the nodes that can be manually 
included into and excluded from the operation sequence: 

Let aPriori decide – initially this option is selected, since by default aPriori decides 
whether to include or exclude the node.  
Include – select this option to manually include the selected node in the operation 
sequence. The green icon on the node indicates that the node was manually included. 
Select Let aPriori decide to revert to the aPriori choice.  
Exclude – select this option to manually exclude the selected node from the operation 
sequence. The node becomes crossed out and the green icon on the node indicates that 
the node was manually excluded. Select Let aPriori decide to revert to the aPriori 
choice. 
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 Tool – this option is only available for machining operations which have no more 
underlying operations underneath them. It displays information about the tool 
selected for the specified operation (see the section "Tool Selection for 
Machining" in the aPriori Cost Model Guide), including tool type and tool family. 
For information about tool diameter, select Process Setup Options from the 
right-click menu. 

 Process Setup Options – displays GCD-specific process setup options. 

 Rules/Status – this option displays the evaluation feasibility status for the node. 
For nodes representing alternative and optional operations it also displays the 
User Selection Policy Options window. In this window you can:  

Check the Operation check box to evaluate the operation feasibility rules.  
Choose what to do if a rule fails – Fail to cost or Revert to auto-select. 

GCD properties 
The GCD properties are displayed in the Properties table. Fields with the  icon are 
editable. Double-click on the field and enter a new value.  
When in Auto-Costing mode, the component will be costed as soon as the GCD edit is 
made. When in One Click Costing mode, the component will not be costed as soon as 
the GCD edit is made. You must explicitly click the Cost button. This allows you to make 
several GCD level edits and cost these changes in a single costing event. 

GCD categories 
The details and options available for GCDs vary between components and across 
process groups. aPriori GCDs are grouped into the following categories: 

 Component GCDs 
 Volume GCDs 
 Bending/forming GCDs 
 Holes GCDs 
 Surfaces GCDs 
 Weld GCDs 
 2-Model GCDs 
 GCD relations 

Component GCDs 
The Component GCD Category includes the following GCD Types: 

 Base Properties 
 Blank 
 Main Surface 
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 Parting Line 
 Subcomponents 

Base Properties 
The Base Properties GCD Type includes a single GCD named Component, which 
represents the base properties of the component. This GCD is available for all process 
groups. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. This 

information is an identifier only and is not used in 
any cost calculation. 

Properties Volume (mm3) The volume of the area contained by the GCD. 

 Surface Area 
(mm2) 

The surface area of the GCD. 

 Length (mm) The length of the GCD. 

 Width (mm) The width of the GCD. 

 Height (mm) The height of the GCD. 

 CAD Material Name The material defined in the CAD model 

 CAD Distance Units The distance units defined in the CAD model 

 CAD Mass Units The mass units defined in the CAD model 

 CAD Temperature 
Units 

The temperature units defined in the CAD model 

 CAD Time Units The time units defined in the CAD model. 

Blank 
The Blank GCD Type includes a single GCD named Blank, which represents the 
flattened sheet metal part after the external contour is cut. This GCD is available for the 
Sheet Metal process group. The GCD details include: 
 

Cost drivers  Description 
GCD Name The name and number that identifies the GCD. This 

information is an identifier only and is not used in 
any cost calculation. 

Properties Perimeter (mm) The sum of lengths of all edges in the contour. 

 SER Length (mm) The length of the smallest enclosing rectangle. This 
value can be edited by you if aPriori determines an 
incorrect blank size. 



Geometric Cost Drivers  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 212 

Cost drivers  Description 
 SER Width (mm) The width of the smallest enclosing rectangle. This 

value can be edited by you if aPriori determines an 
incorrect blank size. 

 Thickness (mm) The thickness or gauge of the sheet metal blank or 
part (mm). This value is extracted from the CAD 
model. 

 Chamfer Direction Indicates the direction of the chamfer with respect 
to the main surface. 

 Curved Length 
(mm) 

The sum of lengths of non-straight edges in the 
contour. 

 Is Chamfered Indicates if the edges of the GCD are chamfered. If 
true, the edges are chamfered. 

 Max Radius (mm) The maximum radius of the curvature for non-
straight edges of the contour. The value equals 0 if 
all edges are straight. 

 Min Radius (mm) The minimum radius of curvature for non-straight 
edges of the contour. 

 Number of Coining 
Chains 

The number of contiguous chains of coined edges. 

 Num Curved Edges The number of non-straight edges in the contour. 

 Num Edges The number of edges in the contour. 

 Straight Length 
(mm) 

The total length of the straight edges on the 
perimeter of the part. 

 Worst Peninsular 
Ratio 

The maximum (Peninsula Length/Peninsula Width) 
for all peninsula on a contour. Peninsula are the 
outstanding tabs on a contour of blank or complex 
hole. 

 Worst Peninsular 
Ratio2 

The maximum (Peninsula Length/Peninsula Width2) 
in 1/mm. Peninsula are the outstanding tabs on a 
contour of blank or complex hole. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing failed.  
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Main Surface 
The Main Surface GCD Type includes a single GCD named MainSurface, which 
represents the surface of the part that remains fixed and predominantly parallel 
throughout the development of bends and forms. This GCD is available for the Sheet 
Metal process group. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. This 

information is an identifier only and is not used in 
any cost calculation. 

Technique Selected  The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time (s) The time (in seconds) that it takes to complete work 
on a GCD or technique. If there is more than one 
occurrence of the GCD or technique, this field 
shows the sum of the occurrences. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing failed.  

Parting Line 
The Parting Line GCD Type includes a single GCD named PartingLine, which 
represents the division of the top/left side of the mold from the bottom/right side of the 
mold. aPriori automatically determines this GCD. However, you can manually define the 
parting line. This GCD is available for the Casting process group. The GCD details 
include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. This 

information is an identifier only and is not used in 
any cost calculation. 

Properties Draw Direction The direction in which the mold separates. 

 Height (mm) The height of the GCD. 

 Parting Type The shape of the parting line. This value can be 
FLAT or NON-FLAT. 

 Projected Area 
(mm2) 

The projected area from the mold parting line. 

 Projected Perimeter 
(mm) 

The perimeter length of the GCD as projected onto 
a given plane. 
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Subcomponents 
The Subcomponents GCD Type includes a GCD for each subcomponent (that is, parts 
and/or sub-assemblies) included in an assembly. These GCDs are available for the 
Assembly process group. The GCD details include: 
 

Cost drivers Description 
Part Number The component identifier as specified in the CAD model. 

Quantity The number of a subcomponent’s instances in the component. 

Weight (kg) The total finished mass of material in the subcomponent. 

Length (mm) The longest dimension of the subcomponent. 

Width (mm) The widest dimension of the subcomponent. 

Height (mm) The tallest dimension of the subcomponent. 

Surface Area 
(mm2) 

The total surface area of the subcomponent. 

Volume (mm3) The total finished volume of material in the subcomponent. 

Volume GCDs 
The Volume GCD Category includes the following GCD Types: 

 Stock Trims 
 Bulk Removals 
 Pockets 
 Rings 
 Void 
 ComboVoid 
 AxiGrooves 
 Heligroove (Helical Groove) 
 SlideBundles 
 LifterBundles 

Stock Trims 
The Stock Trims GCD Type includes a single GCD named StockTrim, which represents 
the volume of material removed by roughing with an endmill. The material removed is 
the material cross-section between the smallest possible box that fits around the finished 
part (the bounding box) and the material stock that encloses the part times, the bounding 
box, and the cutoff. The material represented by the Stock Trim GCD typically is first 
roughed away, and then additional machining is performed to create the features on the 
finished part. 
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Stock trim is a virtual GCD. It is computed after aPriori selects the appropriate stock size 
from the bounding box. This GCD is available for the Machining process group.  
For parts machined from rectangular stock, aPriori now displays the Stock Trim GCD in 
the Component Viewer pane. The stock trim is rendered with red outlines representing 
the stock surfaces and yellow outlines representing the bounding box. 
The GCD details include: 
 

Cost drivers  Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Volume (mm3) The volume of the GCD. 

 Max Tool Diameter 
(mm) 

For surfaces, this is the largest tool diameter 
entering from a given setup axis without touching 
other part surfaces. If there is no limiting diameter, 
Max Tool Diameter = -1. For pockets and bulk 
removal, this is the diameter of the of the sphere 
used to calculate the pocket or bulk removal skin. 

 Tool Reach (mm) The minimum tool reach required to contact the 
bottom surface from the part exterior in the 
direction of the setup axis. For an exterior surface, 
Tool Reach = 0. 

 Min Radius (mm) The minimum radius found on the GCD. 
Note The minimum radius is determined in a plane 
perpendicular to the setup axis from which the 
GCD is being machined. 

 Max Radius (mm) 
 

The maximum radius found on the GCD. 
Note The maximum radius is determined in a 
plane perpendicular to the setup axis from which 
the GCD is being machined. 

 Size (mm) A metric used to drive calculations involving the 
overall GCD size. 

Technique 
  

Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results
  

Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 
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 Volume Removal 
Rate (mm3/sec) 

The total volume removed per second. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Bulk Removals 
The Bulk Removals GCD Type includes one primary BulkRemoval GCD per component. 
The BulkRemoval GCD includes one BulkRemovalCore nested GCD and zero to many 
CornerPick nested GCDs. These GCDs are available for the Machining process group. 
The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Max Tool Diameter 
(mm) 

For surfaces, this is the largest tool diameter 
entering from a given setup axis without touching 
other part surfaces. If there is no limiting diameter, 
Max Tool Diameter = -1. For pockets and bulk 
removal, this is the diameter of the sphere used to 
calculate the pocket or bulk removal skin. 

 Total Volume 
(mm3) 

The volume of the GCD. 

 Corner Pick Count The number of corner picks in the GCD. 

 Corner Pick 
Volume (mm3) 

The total volume of the corner picks in the GCD. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful; a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  



Geometric Cost Drivers  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 217 

Pockets 
The Pockets GCD Type includes the Pocket primary GCD. The Pocket GCD includes 
one PocketCore nested GCD and zero to many CornerPick nested GCDs. The Pocket 
GCD exists mainly as a single roll-up entity, enabling the system to hang the cumulative 
results of creating a pocket core and the associated corner picks. A pocket is a generic 
volume found inside of the bulk removal skin representing the effort of creating the 
pocket. These GCDs are available for the Machining process group. The GCD details 
include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Max Tool Diameter 
(mm) 

For surfaces, this is the largest tool diameter 
entering from a given setup axis without touching 
other part surfaces. If there is no limiting diameter, 
Max Tool Diameter = -1. For pockets and bulk 
removal, this is the diameter of the of the sphere 
used to calculate the pocket or bulk removal skin. 

 Total Volume 
(mm3) 

The volume of the GCD. 

 Corner Pick Count The number of corner picks in the GCD. 

 Corner Pick 
Volume (mm3) 

The total volume of the corner picks in the GCD. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful; a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Rings 
The Rings GCD Type represents an axisymmetric volume of material to be removed. It 
is available in the Bar and Tube Fabrication, Casting, and Forging process groups. Ring 
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GCDs are comprised of PlanarFace GCDs and CurvedWall GCDs. Ring GCD Details 
include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Volume (mm3) The volume of the GCD. 

 Axial Section Area 
(mm2) 

Cross section area of the ring, for a plane passing 
through the axis of rotation. 

 Riser Area (mm2) The total area of all ring-shaped planar faces 
(annulus) that are children of the ring. 

 Tread Area (mm2) The total area of all curved wall (cylindrical) 
surfaces that are children of the ring. 

 Is Mirror Symmetric 
 

True if the GCD has mirror symmetry about the 
tool axis; tool axis angle is specified via an isAbout 
relation. 

 Depth (mm) The depth of the Ring GCD, as measured with 
respect to the Approach From direction (see 
below) 

 Approach From The direction from which the machine tool 
approaches. Possible values include FACE_A, 
FACE_B, ID, OD, SLANTED, NONE. 

 Approach From Alt 
 

An alternative direction of approach of the machine 
tool. Possible values include FACE_A, FACE_B, 
ID, OD, SLANTED, NONE. 

 Accessibility Directions from which the GCD can be entered. 
Possible values include SIDE_A, SIDE_B, 
THROUGH, UNDERCUT, OBSCURED, 
UNKNOWN. 

 Min Wall Thickness 
(mm) 

The minimum wall thickness of the GCD. 

Technique 
 

Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 
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Cost drivers Description 
 Status The costing status of the GCD or technique. A 

green icon indicates that costing was successful; a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Void 
The Void GCD Type includes the Void GCD, which represents any recess or cavity in 
the component that is not a hole or multi-step hole. Note that a casting void and a 
machining pocket can refer to the same geometric entity. These GCDs are available for 
the Casting and Machining process groups. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Accessibility The directions from which the GCD can be 
entered. Possible values include OBSCURED, 
SIDE_A, SIDE_B, THROUGH, and UNDERCUT. 

 Void Direction 
Accessible 

Indicates accessibility in the core movement 
direction. 

 Box Height (mm) The smallest dimension of the bounding box. 

 Box Length (mm) The longest dimension of the bounding box. 

 Box Width (mm) The middle dimension of the bounding box. 

 Exposed Area 
(mm2) 

The cumulative area exposed by openings. 

 Num Openings The number of openings exposed to the part 
exterior. 

 Num Surfaces The number of part surfaces. 

 Perimeter (mm) The sum of lengths of all edges in the contour. 

 Surface Area 
(mm2) 

The surface area of the GCD. 

 Tool Reach (mm) The minimum tool reach required to contact the 
bottom surface from the part exterior in the 
direction of the setup axis. For an exterior surface, 
Tool Reach = 0. 

 Void Shape 
 

The classification of the void shape. Possible 
values include EXTRUDED and COMPLEX. 

 Volume (mm3) The volume of the final part. 
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Cost drivers Description 
 Dir Core Prints Box 

Height 
The number of directions that core prints stick out 
along the height axis of the smallest enclosing box. 
0 = no core prints on either height wise face, 1 = 
core print(s) stick out of only one face in height 
wise direction, 2 = core print(s) stick out of both 
faces in height wise direction. 

 Dir Core Print Box 
Length 

The number of directions that core prints stick out 
along the length axis of the smallest enclosing box. 
0 = no core prints on either length wise face, 1 = 
core print(s) stick out of only one face in length 
wise direction, 2 = core print(s) stick out of both 
faces in length wise direction. 

 Dir Core Print Box 
Width 

The number of directions that core prints stick out 
along the smallest enclosing box. 0 = no core 
prints on either width wise face, 1 = core print(s) 
stick out of only one face in width wise direction, 2 
= core print(s) stick out of both faces in width wise 
direction. 

 Max Tool Diameter 
(mm) 

The largest diameter tool that can machine the 
GCD. 

Technique
  

Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results
  

Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status  The costing status of the GCD or technique. A 
green icon indicates that costing was successful; a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

ComboVoid 
The ComboVoid GCD Type includes one or more ComboVoid GCDs with one or more 
SimpleHole GCDs. ComboVoid GCDs are required for more advanced merging of cores 
for Sand Casting. These GCDs are available for the Casting process group. The GCD 
details include: 
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Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Accessibility The directions from which the GCD can be 
entered. Possible values include OBSCURED, 
SIDE_A, SIDE_B, THROUGH, and UNDERCUT. 

 Void Direction 
Accessible 

Indicates accessibility in the core movement 
direction. 

 Box Height (mm) The smallest dimension of the bounding box. 

GCD Name The name and number that identifies the GCD. 
This information is an identifier only and is not 
used in any cost calculation. 

 Box Length (mm) The longest dimension of the bounding box. 

 Box Width (mm) The middle dimension of the bounding box. 

 Exposed Area 
(mm2) 

The cumulative area exposed by openings. 

 Num Openings The number of openings exposed to the part 
exterior. 

 Num Surfaces The number of part surfaces. 

 Perimeter (mm) The sum of lengths of all edges in the contour. 

 Surface Area 
(mm2) 

The surface area of the GCD. 

 Tool Reach (mm) The minimum tool reach required to contact the 
bottom surface from the part exterior in the 
direction of the setup axis. For an exterior surface, 
Tool Reach = 0. 

 Void Shape The classification of the void shape. Possible 
values include EXTRUDED and COMPLEX. 

 Volume (mm3) The volume of the final part. 

 Dir Core Prints Box 
Height 

The number of directions that core prints stick out 
along the height axis of the smallest enclosing box. 
0 = no core prints on either height wise face, 1 = 
core print(s) stick out of only one face in height 
wise direction, 2 = core print(s) stick out of both 
faces in height wise direction. 

 Dir Core Print Box 
Length 

The number of directions that core prints stick out 
along the length axis of the smallest enclosing box. 
0 = no core prints on either length wise face, 1 = 
core print(s) stick out of only one face in length 
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Cost drivers Description 
wise direction, 2 = core print(s) stick out of both 
faces in length wise direction. 

 Dir Core Print Box 
Width 

The number of directions that core prints stick out 
along the smallest enclosing box. 0 = no core 
prints on either width wise face, 1 = core print(s) 
stick out of only one face in width wise direction, 2 
= core print(s) stick out of both faces in width wise 
direction. 

 Max Tool Diameter 
(mm) 

The largest diameter tool that can machine the 
GCD. 

Technique 
 

Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful; a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

For details about SimpleHole GCDs, refer to Simple Holes on page 232. 

AxiGrooves 
AxiGrooves are axisymmetric GCDs that represent gears, splines, sprockets, and flutes. 
Child GCDs of an AxiGroove include the bottoms and sides of the tooth valleys. They do 
not include the tops of the teeth, and they do not include surfaces normal to the axis of 
rotation. See the section "Working with Gears, Splines, Sprockets, and Flutes" in the 
aPriori Cost Model Guide for more information. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Approach From Ap direction of approach of the machine tool: OD 
(from the outside), ID (from the inside), or NONE. 

 Axial Length (mm) Length of the AxiGroove along turning axis in 
millimeters. 
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 Cone Angle (deg) Cone angle of the AxiGroove in degrees. This is 

one half the apex angle of the AxiGroove’s root 
cone. (The gear’s axis of rotation is the root cone’s 
axis of symmetry. The surface of the root cone 
coincides with the bottoms of the tooth valleys.) 
The angle is 0 for cylindrical AxiGrooves, positive 
for conical AxiGrooves, and -1 if the valley profile 
is not cylindrical or conical. 

 Distance To 
Shoulder A (mm) 

Distance to the shoulder along the turning axis (in 
direction A) in millimeters. For external 
AxiGrooves, this is the distance between the end 
of the AxiGroove and the closest point on the 
turning profile that is higher than the valleys 
between teeth. For internal AxiGrooves, it is the 
distance to the closest point on the turning profile 
that is lower than the tooth valleys. A dash, -, is 
displayed when there is no shoulder. 

 Distance To 
Shoulder B (mm) 

Distance to the shoulder along the turning axis (in 
direction B) in millimeters. For external 
AxiGrooves, this is the distance between the end 
of the AxiGroove and the closest point on the 
turning profile that is higher than the valleys 
between teeth. For internal AxiGrooves, it is the 
distance to the closest point on the turning profile 
that is lower than the tooth valleys. It is -1 when 
there is no shoulder. 

 Groove Depth 
(mm) 

Depth of the grooves in millimeters. 

 Helix Angle (deg) Helix angle of the AxiGroove in degrees. This is 
positive for right-handed AxiGrooves, and negative 
for left-handed AxiGrooves. 

 Helix Total Twist 
Angle (deg) 

Total twist of the AxiGroove in degrees. This is set 
to -1 when either of the following holds: 
 AxiGroove’s inner surface is neither cylindrical 

nor conical. 
 For external AxiGrooves, the bottom groove 

points are not on a spiral; for internal 
AxiGrooves, the top groove points are not on a 
spiral.  

 Max Diameter 
(mm) 

Maximum diameter of the AxiGroove in 
millimeters. This is twice the maximum distance 
from a tooth or valley surface to the turning axis. 

 Min Diameter (mm) Minimum diameter of the AxiGroove in millimeters. 
This is twice the minimum distance from a tooth or 
valley surface to the turning axis. 
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Cost drivers Description 
 Number of Teeth Number of teeth in the AxiGroove. 

 Radial Undercut 
Volume Ratio 

Ratio of the radial undercut volume to the whole 
volume of the AxiGroove. 

 Shoulder Diameter 
A (mm) 

Diameter of the shoulder in direction A in 
millimeters. For external AxiGrooves this is the 
largest diameter of the turning profile on one side 
of the AxiGroove. For internal AxiGrooves it’s the 
smallest diameter. This is -1 for AxiGrooves with 
no shoulder. 

 Shoulder Diameter 
B (mm) 

Diameter of the shoulder in direction B in 
millimeters. For external AxiGrooves this is the 
largest diameter of the turning profile on one side 
of the AxiGroove. For internal AxiGrooves it’s the 
smallest diameter. This is -1 for AxiGrooves with 
no shoulder. 

 Surface Area 
(mm²) 

Area of all grooves in mm². This is the area of the 
walls and bottoms of the tooth valleys. It excludes 
the area of the tooth faces. 

 Tooth To Valley 
Volume Ratio 

Ratio of tooth volume to valley volume. 

 Valley Axial Extent Axial length of valley extent in millimeters. This is 
the total length of all inner faces of the axigroove 
adjacent to the turnable (recognized) surfaces. 

 Volume (mm³) Volume of axigroove in mm³. 

Technique
  

Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected  The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results
  

Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status  The costing status of the GCD or technique. A 
green icon indicates that costing was successful; a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  
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Heligroove (Helical Groove) 
Deprecated—see AxiGroove. The Heligroove (helical groove) GCD Type represents a 
repeating groove with helical symmetry about an axis. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Num Lobes The total number of lobes about the helix axis. 

 Pitch (mm) The axial distance between grooves (of the same 
helical groove). 

 Groove Angular 
Span (deg) 

The angular span of the groove; the angle is 
measured at the point of intersection with the 
external cylinder that encloses it. 

 Max Diameter 
(mm) 

The diameter of the groove, about the helical axis, 
as measured to the top of the lobe. 

 Min Diameter (mm) The diameter of the groove, about the helical axis, 
as measured to the bottom of the groove. 

 Axial Length (mm) The extent of the helical groove, as measured 
along the helix axis. 

 Surface Area 
(mm2) 

The surface area of the helical groove (Note: does 
not include the area of the outer cylindrical 
surfaces). 

Technique
  

Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected  The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results
  

Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status  The costing status of the GCD or technique. A 
green icon indicates that costing was successful; a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  
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SlideBundles 
The SlideBundle GCD represents groups of holes or voids that can share a slide. See 
the section "How aPriori Assigns Holes and Voids to Slides and Lifters" in the aPriori 
Cost Model Guide for more information. 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Start (mm) Number that indicates the position of the first GCD 
contained in the bundle. The difference between 
End and Start is the width of the bundle.  

 End (mm) Number that indicates the position of the last GCD 
contained in the bundle. The difference between 
End and Start is the width of the bundle. 

LifterBundles 
The LifterBundle GCD represents groups of holes or voids that can share a lifter. See 
the section "How aPriori Assigns Holes and Voids to Slides and Lifters" in the aPriori 
Cost Model Guide for more information. 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Start (mm) Number that indicates the position of the first GCD 
contained in the bundle. The difference between 
End and Start is the width of the bundle. 

 End (mm) Number that indicates the position of the last GCD 
contained in the bundle. The difference between 
End and Start is the width of the bundle. 

Bending/forming GCDs 
The Bending/Forming GCD Category includes the following GCD Types: 

 Bends 
 Multiple Bends 
 Forms 
 Lances 
 ShearForms 
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 Ends 

Bends 
The Bends GCD Type includes one or more StraightBend GCDs, which represent only 
co-axial cylinders having the same radius. These GCDs are available for the Sheet 
Metal and Bar and Tube process groups. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Bend Angle (deg) The total angle that the bend passes through. 
Unbent, this angle equals 0. A hem equals 180 
degrees. 

 Clock Angle (deg) Angle measured in a plane perpendicular to the 
tube/bar axis 

 Bend Direction Indicates the direction of the bend with respect to 
the main surface. Possible values include UP, 
DOWN, BOTH, EITHER, and UNKOWN. 

 Bar Position, From 
(mm) 

Distance from the bar origin to the start of the bend 
GCD. 

 Bar Position, To 
(mm) 

Distance from the bar origin to the end of the bend 
GCD. 

 Length (mm) The length of the GCD. 

 Min Bend Radius 
(mm) 

The minimum radius of any bend surface along the 
chain measured from the bend interior. 

 Neutral Bend 
Radius 

Radius of bend measured to the neutral axis. 

 Bend Flap Size The maximum distance between two neighboring 
bends or a bend and a neighboring blank contour. 

 Is Straight Indicates whether the bend goes along a line axis. 
If true, the bend is straight. 

 Is Gusset Indicates whether the bend has a gusset (a special 
type of emboss) put across the bend as a 
strengthener. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results
  

Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful; a 
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Cost drivers Description 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Multiple Bends 
The Multiple Bends GCD Type includes one or more Multibend GCDs with one or more 
StraightBend GCDs. Multibends GCDs represent the merging together of two or more 
bends. These GCDs are available for the Sheet Metal process group. The GCD details 
include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Bend Angle (deg) The total angle that the bend passes through. 
Unbent, this angle equals 0. A hem equals 180 
degrees. 

 Bend Direction Indicates the direction of the bend with respect to 
the main surface. Possible values include UP, 
DOWN, BOTH, EITHER, and UNKOWN. 

 Length (mm) The length of the GCD. 

 Min Bend Radius 
(mm) 

The minimum radius of any bend surface along the 
chain measured from the bend interior. 

 Bend Flap Size The maximum distance between two neighboring 
bends or a bend and a neighboring blank contour. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

For details about StraightBend GCDs, see Bends on page 227. 

Forms 
The Forms GCD Type includes one or more Form GCDs, each representing a 
deformation of metal other than bends. Usually, this is achieved by pressing a shaped 
punch into the material from one side. The far side can either deflect or not. Depending 
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on their aspect ratios, forms are made by a variety of operations: coining/swaging when 
the metal thickness is significantly changed, embossing when the deformation depth is 
relatively shallow, drawing when the metal is significantly stretched, and deep drawing 
when the metal is extremely stretched. These GCDs are available for the Sheet Metal 
process group. The GCD details include: 
 

Cost drivers  Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Area (mm2) The area of the GCD in a flattened state. 

 SER Length (mm) The length of the smallest enclosing rectangle. 

 SER Width (mm) The width of the smallest enclosing rectangle. 

 Sub Type The sub type of the current GCD type. Possibilities 
include TAB, BRIDGE, EMBOSS, and STAMP. 

 Depth Down (mm) The depth of the form. This is measured as the 
maximum distance that any point on the form’s 
main surface is displaced. It is always a positive 
number. 

 Depth Up (mm) The depth of the form. This is measured as the 
maximum distance that any point on the form’s 
main surface is displaced. It is always a positive 
number. 

 Perimeter (mm) The sum of lengths of all edges in the contour. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Lances 
The Lance GCD Type includes one or more Lance GCDs, each representing a slit in the 
sheet metal requiring no material loss. Usually, a lance lies on a form. Lances are rarely, 
if ever, made by themselves. Normally, they occur next to a form to make design 
features such as louvers or bridges. Lancing and forming are usually done at a single 
die. These GCDs are available for the Sheet Metal process group. The GCD details 
include: 
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Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Length (mm) The length of the GCD. The length is measured in 
the flattened state. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

ShearForms 
The ShearForms GCD Type includes one or more ShearForm GCDs, each with a Form 
GCD combined with one or more Lance GCDs. These GCDs are available for the Sheet 
Metal process group. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Area (mm2) The area of the GCD in a flattened state. 

 SER Length (mm) The length of the smallest enclosing rectangle. 

 SER Width (mm) The width of the smallest enclosing rectangle. 

 Sub Type The sub type of the current GCD type. Possibilities 
include TAB, BRIDGE, EMBOSS, and STAMP. 

 Depth Down (mm) The depth of the form. This is measured as the 
maximum distance that any point on the form’s 
main surface is displaced. It is always a positive 
number. 

 Depth Up (mm) The depth of the form. This is measured as the 
maximum distance that any point on the form’s 
main surface is displaced. It is always a positive 
number. 

 Length (mm) The length of the GCD. For ShearForm, this is the 
combined length of all lances. 

 Perimeter (mm) The sum of lengths of all edges in the contour. 
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Cost drivers Description 
Technique 
 

Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Ends 
The Ends GCD Type includes one or more End GCDs. These GCDs are available for 
the Bar and Tube process group. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Area (mm2) The area of the GCD. 

 Bar Position (mm) Distance from the bar origin to the GCD location 
on the bar. 

 Is Planar? True if the GCD consists entirely of planes with 
convex edges. 

 Maximum Cut 
Angle (deg) 

Maximum angle between a plane in the GCD and 
the plane perpendicular to the stock axis. 

 Number of Planes The count of plane surfaces contained within a 
GCD. 

 Outer Perimeter 
(mm) 

Perimeter measured along the outside of the part. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

Holes GCDs 
The Holes GCD Category includes the following GCD Types: 

 Simple Holes 
 Complex Holes 
 Multi Step Holes 
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 Ringed Holes 

Simple Holes 
The Simple Holes GCD Type includes one or more SimpleHole GCDs, each 
representing an unbroken 360-degree hole having a circular cross section on one of the 
sheet metal faces. These GCDs are available for the Casting, Machining, and Sheet 
Metal process groups. The GCD details include: 
 

Cost drivers  Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Diameter (mm) The diameter of the hole interior where the hole is 
in its final shape. 

 Is Countersunk Indicates whether or not the GCD has a 
countersink. If true, the GCD has a countersink. 

 Is Flanged Indicates whether or not the GCD has a flange. If 
true, the GCD has a flange. 

 Countersink 
Direction 

Indicates the direction of the countersink with 
respect to the main surface. Possibilities include 
UP, DOWN, BOTH, EITHER, and UNKOWN. 

 Flange Direction Indicates the direction of the flange with respect to 
the main surface. Possibilities include UP, DOWN, 
BOTH, EITHER, and UNKOWN. 

 Length (mm) The length of the GCD.  

 Blind Indicates whether or not the GCD passes entirely 
through the part. True if the bottom of the GCD 
passes out of the other side of the part. 

 Cone Angle (deg) An angle <= 90 degrees measured from the hole’s 
central axis. Through holes have their cone angle 
set to 90 degrees. 
Note Cone angle is not currently used for tool 
feasibility, but it is used to compute the total drilling 
stroke. Through holes should have their cone 
angle set to 90 degrees. 

 Roughness (µm) The average roughness of the GCD surface.  
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient surface finish capability to 
manufacture the GCD. 

 Threaded Indicates whether or not the hole is threaded. If 
true, the hole is threaded. 
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Cost drivers  Description 

 Diam Tolerance 
(mm) 

The diametrical tolerance of a hole. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Position Tolerance 
(mm) 

The tolerance on the location of the center line of a 
hole. 
Note For a hole, this specifies the diameter of a 
cylinder that the center of a hole must be within. 
If set to <unspecified>, aPriori assumes that the 
chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Parallelism (mm) The parallelism tolerance of a hole. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient surface finish capability to 
manufacture the GCD. 

 Perpendicularity 
(mm) 

The perpendicularity tolerances of a hole. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient surface finish capability to 
manufacture the GCD. 

 Runout (mm) The runout tolerance of a hole. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient surface finish capability to 
manufacture the GCD. 

 Volume (mm3) The volume of the final part. 

 Surface Area 
(mm2) 

The surface area of the GCD. 

 Min Wall Thickness 
(mm) 

The minimum wall thickness of the GCD. 

 Accessibility The directions from which the GCD can be 
entered. Possible values include OBSCURED, 
SIDE_A, SIDE_B, THROUGH, and UNDERCUT. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
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more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Complex Holes 
The Complex Holes GCD Type includes one or more ComplexHole GCDs, each 
representing a non-circular interior contour. Note that flanges around a complex hole are 
not recognized as a hole property (they are recognized as a separate form). A lance is 
recognized as a complex hole with zero area. These GCDs are available for the Sheet 
Metal process group. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Area (mm2) The area of the GCD in a flattened state. 

 Sec Diameter (mm) The diameter of the smallest circle that will fit 
around the GCD. 

 Mec Diameter 
(mm) 

The diameter of the largest circle fitting into the 
hole. 

 Perimeter (mm) The sum of the lengths of all edges in the contour. 

 SER Length (mm) The length of the smallest enclosing rectangle. 

 SER Width (mm) The width of the smallest enclosing rectangle. 

 Tolerance/Profile of 
Surface (mm) 

The most constraining tolerance among the 
dimensions defining the GCD. You can view it as a 
+/- tolerance. Tolerance is persisted and computed 
as a total tolerance by the system.  
Note: If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Roughness (µm) 
 

The average roughness of the GCD surface.  
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient surface finish capability to 
manufacture the GCD. 
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 Chamfer Direction Indicates the direction of the chamfer with respect 

to the main surface. Possibilities include UP, 
DOWN, BOTH, EITHER, and UNKNOWN. 

 Flange Direction Indicates the direction of the flange with respect to 
the main surface. Possibilities include UP, DOWN, 
BOTH, EITHER, and UNKNOWN. 

 Is Chamfered Indicates whether or not the edges of the GCD are 
chamfered. If true, the edges are chamfered. 

 Is Flanged Indicates whether or not the GCD has flange. If 
true, the GCD has a flange. 

 Max Radius (mm) The maximum radius of curvature for non-straight 
edges in the contour. Equals 0 if all edges are 
straight. 

 Min Radius (mm) The minimum radius of curvature for non-straight 
edges in the contour. 

 Number of Coining 
Chains 

The number of contiguous chains of coined edges. 

 Num Curved 
Edges 

The number of non-straight edges in the contour. 

 Num Edges The number of edges in the contour. 

 Num Straight 
Edges 

The number of straight edges in the contour. 

 Worst Peninsular 
Ratio 

The maximum (Peninsula Length/Peninsula Width) 
for all peninsula on a contour. Peninsula are the 
outstanding tabs on a contour of blank or complex 
hole.(“Peninsular ratio” used for the stamping 
processes such as progressive die to determine 
what elements on a part can be grouped together 
for punching.) 

 Worst Peninsular 
Ration2 

The maximum (Peninsula Length/Peninsula 
Width2) in 1/mm. Peninsula are the outstanding 
tabs on a contour of blank or complex hole. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
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warning, and a red icon indicates that costing 
failed.  

Multi Step Holes 
The Multi Step Holes GCD Type includes one or more GCDs with one or more 
SimpleHole GCDs. A multi-step hole is the generalization of the counterbored hole. It is 
a counterbored hole with an arbitrary number of steps. aPriori estimates the 
manufacturing time by splitting it into a set of simple holes, each hole representing one 
step. The results of the individual computations are summed together by aPriori. Any 
additional one-time estimating elements are also added. The step diameter sizes must 
be monotonically decreasing. These GCDs are available for the Casting and Machining 
process groups. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Max Diameter 
(mm) 

The maximum diameter of the GCD. 

 Min Diameter (mm) The minimum diameter of the GCD. 

 Min Tolerance 
(mm) 

The minimum tolerance of the GCD. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Total Length (mm) The length of the GCD. 

 Total Volume 
(mm3) 

The volume of the final part. 

 Step Count The total number of hole steps. 

 Countersink Count The total number of countersinks in the hole. 

 Blind Indicates whether or not the GCD passes entirely 
through the part. True if the bottom of the GCD 
passes out of the other side of the part. 

 Accessibility The directions from which the GCD can be 
entered. Possible values include OBSCURED, 
SIDE_A, SIDE_B, THROUGH, and UNDERCUT. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 
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Results Time(s) The time (in seconds) that it takes to machine the 

GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Ringed Holes 
The RingedHole GCD Type is created only for routings which contain Turning processes 
(Lathes) and is used to support parts with internal turned geometry. It includes a 
SimpleHole GCD which represents the smallest interior diameter of the part, and one or 
more Ring GCDs which represent additional internal co-axial volumes. The RingedHole 
GCDs is available for the Bar & Tube, Casting, and Forging process groups. 

Surfaces GCDs 
The Surfaces GCD Category includes the following GCD Types: 

 Planar Faces 
 Curved Walls 
 Curved Surfaces 
 Sharp Edge 

Planar Faces 
The Planar Faces GCD Type includes one or more PlanarFace GCDs, each 
representing any flat surface to be finished. Depending on the orientation of the setup 
axis with the surface, this GCD may be machined by face milling, side milling, or 
ballnose finishing (kellering). Under some conditions, finish machining is assumed to be 
combined with bulk machining. Under other conditions of little or no bulk machining, 
separate finish machining is required. Tools normal to the surface are assumed to 
perform facing. Tools parallel to the surface are assumed to perform side milling. Finally, 
tools oblique to the surface are assumed to perform kellering. Knowing the normal to the 
face and the associated setup axis direction, aPriori can compute the required finishing 
process. These GCDs are available for the Casting and Machining process groups. The 
GCD details include: 
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GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Finished Area 
(mm2) 

The area that requires finishing machining. 

 Max Tool Diameter 
(mm) 

For surfaces, this is the largest tool diameter 
entering from a given setup axis without touching 
other part surfaces. If there is no limiting diameter, 
Max Tool Diameter = -1. For pockets and bulk 
removal, this is the diameter of the of the sphere 
used to calculate the pocket or bulk removal skin. 

 Tool Reach (mm) The minimum tool reach required to contact the 
bottom surface from the part exterior in the 
direction of the setup axis. For an exterior surface, 
Tool Reach = 0. 

 Bend Diameter 
(mm) 

The bend diameter of the surface. The surface’s 
smallest positive curvature (edges curved toward 
viewer). If there is no positive curvature, Bend 
Diameter = -1. 

 Tolerance/Profile of 
Surface (mm) 

The most constraining tolerance among the 
dimensions defining the GCD. You can view it as a 
+/- tolerance. Tolerance is persisted and computed 
as a total tolerance by the system.  
Note: If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Roughness (µm) 
 

The average roughness of the GCD surface.  
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient surface finish capability to 
manufacture the GCD. 

 Flatness (mm) The flatness tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Parallelism (mm) The parallelism tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Perpendicularity 
(mm) 

The perpendicularity tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
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the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 On Bounding Box Indicates whether the part’s face coincides with the 
bounding box. If true, the face coincides with the 
bounding box. This property allows the system to 
decide whether the required finish can be achieved 
simultaneously by the bulk milling operation. 

 Direction Type Indicates the direction type. 1 = normal to surface, 
2 = parallel to surface, and 3 = oblique to surface. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Surface Finishing 
Rate (mm3/sec) 

The total volume finished per second. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
warning, and a red icon indicates that costing 
failed.  

Curved Walls 
The Curved Walls GCD Type includes one or more GCDs, each representing a tabular 
cylinder, possibly with a <= 5-degree draft. This surface can be machined by side milling 
or kellering. Knowing the wall direction and the direction of the associated setup axis, 
aPriori can compute whether this surface requires side milling or kellering. These GCDs 
are available for the Casting and Machining process groups. The GCD details include: 
 

Cost drivers Description 
GCD Name The name and number that identifies the GCD. 

This information is an identifier only and is not 
used in any cost calculation. 

Properties Finished Area 
(mm2) 

The area that requires finishing machining. 

 Max Tool Diameter 
(mm) 

For surfaces, this is the largest tool diameter 
entering from a given setup axis without touching 
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other part surfaces. If there is no limiting diameter, 
Max Tool Diameter = -1. For pockets and bulk 
removal, this is the diameter of the of the sphere 
used to calculate the pocket or bulk removal skin. 

 Tool Reach (mm) The minimum tool reach required to contact the 
bottom surface from the part exterior in the 
direction of the setup axis. For an exterior surface, 
Tool Reach = 0. 

 Bend Diameter 
(mm) 

The bend diameter of the surface. The surface’s 
smallest positive curvature (edges curved toward 
viewer). If there is no positive curvature, Bend 
Diameter = -1. 

 Threaded Indicates whether or not the surface is threaded. 
Used with the "Thread Length (mm)" property (see 
below) 

 Thread Length 
(mm) 

Used for threaded surfaces (Threaded = True) to 
indicate the extent of threading on the curved wall 
surface. 

 Tolerance/Profile of 
Surface (mm) 

The most constraining tolerance among the 
dimensions defining the GCD. You can view it as a 
+/- tolerance. Tolerance is persisted and computed 
as a total tolerance by the system.  
Note: If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Roughness (µm) The average roughness of the GCD surface.  
Note: If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient surface finish capability to 
manufacture the GCD.. 

 Circularity The circularity tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Concentricity The concentricity tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Cylindricity The cylindricity tolerance of the GCD surface. 
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Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Perpendicularity The perpendicularity tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Runout The runout tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 Straightness The straightness tolerance of the GCD surface. 
Note If set to <unspecified>, aPriori assumes that 
the chosen manufacturing process and operations 
have sufficient tolerance capability to manufacture 
the GCD. 

 On Bounding Box Indicates whether the part’s face coincides with the 
bounding box. If true, the face coincides with the 
bounding box. This property allows the system to 
decide whether the required finish can be achieved 
simultaneously by the bulk milling operation. 

 Direction Type Indicates the direction type. 1 = normal to surface, 
2 = parallel to surface, and 3 = oblique to surface. 

Technique Requested The technique selected by you. If you have not 
selected a technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested 
technique cannot be used, aPriori will select a 
technique that can be used. 

Results Time(s) The time (in seconds) that it takes to machine the 
GCD or complete work on a technique. If there is 
more than one occurrence of the GCD or 
technique, this field shows the sum of the 
occurrences. 

 Surface Finishing 
Rate (mm3/sec) 

The total volume finished per second. 

 Status The costing status of the GCD or technique. A 
green icon indicates that costing was successful, a 
yellow icon indicates that costing succeeded with a 
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warning, and a red icon indicates that costing 
failed.  

Curved Surfaces 
The Curved Surfaces GCD Type includes one or more CurvedSurface GCDs, each 
representing a GCD with areas of double curvature, requiring the use of a ballnose mill 
or equivalent rounded tool. The machining process is always kellering. For a curved 
surface, the tool is always assumed oblique to the surface. aPriori does know during 
which setup that a curved surface will be machined, so there is no association with the 
axis ID. These GCDs are available for the Casting and Machining process groups. The 
GCD details include: 
 

Cost drivers Description 
GCDs Name The name and number that identifies the GCD. This 

information is an identifier only and is not used in any cost 
calculation. 

Properties Finished 
Area (mm2) 

The area that requires finishing machining. 

 Max Tool 
Diameter 
(mm) 

For surfaces, this is the largest tool diameter entering from 
a given setup axis without touching other part surfaces. If 
there is no limiting diameter, Max Tool Diameter = -1. For 
pockets and bulk removal, this is the diameter of the of the 
sphere used to calculate the pocket or bulk removal skin. 

 Tool Reach 
(mm) 

The minimum tool reach required to contact the bottom 
surface from the part exterior in the direction of the setup 
axis. For an exterior surface, Tool Reach = 0. 

 Bend 
Diameter 
(mm) 

The bend diameter of the surface. The surface’s smallest 
positive curvature (edges curved toward viewer). If there is 
no positive curvature, Bend Diameter = -1. 

 Tolerance 
(mm) 

The most constraining tolerance among the dimensions 
defining the GCD. You can view it as a +/- tolerance. 
Tolerance is persisted and computed as a total tolerance 
by the system.  
Note If set to <unspecified>, aPriori assumes that the 
chosen manufacturing process and operations have 
sufficient tolerance capability to manufacture the GCD. 

 Roughness 
(µm) 

The average roughness of the GCD surface.  
Note If set to <unspecified>, aPriori assumes that the 
chosen manufacturing process and operations have 
sufficient tolerance capability to manufacture the GCD. 

 Runout The runout tolerance of the GCD surface. 
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Note If set to <unspecified>, aPriori assumes that the 
chosen manufacturing process and operations have 
sufficient tolerance capability to manufacture the GCD. 

 On 
Bounding 
Box 

Indicates whether the part’s face coincides with the 
bounding box. If true, the face coincides with the bounding 
box. This property allows the system to decide whether the 
required finish can be achieved simultaneously by the bulk 
milling operation. 

 Direction 
Type 

Indicates the direction type. 1 = normal to surface, 2 = 
parallel to surface, and 3 = oblique to surface. 

Technique Requested The technique selected by you. If you have not selected a 
technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested technique 
cannot be used, aPriori will select a technique that can be 
used. 

Results Time (s) The time (in seconds) that it takes to machine the GCD or 
complete work on a technique. If there is more than one 
occurrence of the GCD or technique, this field shows the 
sum of the occurrences. 

 Surface 
Finishing 
Rate 
(mm3/sec) 

The total volume finished per second 

 Status The costing status of the GCD or technique. A green icon 
indicates that costing was successful, a yellow icon 
indicates that costing succeeded with a warning, and a red 
icon indicates that costing failed. 

Sharp Edge 
The Sharp Edge GCD Type includes one or more SharpEdge GCDs, each representing 
a pair of surfaces intersecting along a zero or nearly zero radius internal or external 
edge. This GCD will be used to automatically identify surfaces to machine. Below a 
certain radius, casting cannot produce a sharp enough edge. When this happens, the 
surfaces that the edge lies on must be machined. Adjacent sharp edges (that is, with 
connecting endpoints) having the same radius and Convex value will be merged into a 
single edge. These GCDs are available for the Casting process group.  
Note that Sharp Edge GCDs are not viewable by default. To view these GCDs, select 
Show > All. The GCD details include: 
 

Cost drivers  Description 
GCDs Name The name and number that identifies the GCD. This 

information is an identifier only and is not used in any cost 
calculation. 
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Properties Edge 

Length 
(mm) 

The length of the corner edge. 

 Round 
Radius 
(mm) 

The radius of the round. 

 Convex Indicates whether the edge is convex. If true, the edge is 
convex. 

Technique Requested The technique selected by you. If you have not selected a 
technique, this field is set to auto-select. 

 Selected The technique used by aPriori. If the requested technique 
cannot be used, aPriori will select a technique that can be 
used. 

Results Time (s) The time (in seconds) that it takes to machine the GCD or 
complete work on a technique. If there is more than one 
occurrence of the GCD or technique, this field shows the 
sum of the occurrences. 

Weld GCDs 
The Weld GCDs include: 

 Pro Welds: created in the CAD model, through the use of Creo with the 
Pro/Welds module. 
Note: Pro welds are available in aPriori only when you are working in Creo Direct 
Integration mode. 

 Virtual Welds: created in the aPriori Viewer, with the Welding tool. See Virtual 
welds in Using the component viewer tools and commands. 

These GCDs are available for the Assembly process group. Each weld GCD represents 
an individual weld on the assembly. The GCD details include: 

Cost drivers  Description 
GCDs Name The number that identifies the weld. This information is an 

identifier only and is not used in any cost calculations. 

 Type The type of weld. Possibilities include Fillet, Square 
Groove, V-Groove, J-Groove, U-Groove, Bevel Groove, 
Flared V-Groove, Flared Bevel Groove, Plug, Spot, Slot, 
Tack, and Wrap Tie. 
Certain less-common weld types of Creo Welds, such as 
butt welds, are not fully supported by aPriori. If such a weld 
is imported into aPriori, the Type property is set to 
UNKNOWN, and the weld fails to cost. You can edit the weld 
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to select one of the available weld types, in order to 
approximate the cost. 

Properties Interval Indicates whether the weld is intermittent/pattern or 
continuous/individual. 

 Total 
Length 
(mm) 

The total length of a weld. 

 Width (mm) The face width of the weld; for fillet welds, this is the leg 1 
length. 

 Depth (mm) The depth of the weld; for fillet welds, this is the leg 2 
length. 

 Segment 
Length 
(mm) 

The length of the weld segment in an intermittent/pattern 
weld. 

 Pitch (mm) Distance from beginning to beginning of an 
intermittent/pattern MIG weld or spot weld. 

 # Segments The number of segments used in an intermittent/pattern 
weld. 

 CSA (mm2) The cross sectional area of the weld (where applicable). 

 Volume 
(mm3) 

The total finished volume of material in the weld. 

Technique Method Indicates whether the weld method is robotic/automated or 
manual. 

Status  Indicates whether the GCD is costable in aPriori. Green 
indicates that the GCD is costable; red indicates that the 
GCD is not costable. 

You can edit certain weld properties, such as Type, Depth, and Width, by right-clicking a 
Weld GCD (in the Manufacturing Process or Geometric Cost Drivers pane) and selecting 
Edit Operation. The Welding dialog is displayed in the lower right-hand pane of the 
Operation Sequence dialog: 
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This dialog allows you to specify Type, Width, Depth, Segment Length, Pitch, and Total 
Length, as well the Production Mechanism for the weld (Manual or Robotic).  aPriori 
computes the weld’s Volume, CSA (cross-sectional area), and Number of Segments based 
on the other properties. 
Note that overriding a Pro weld in aPriori does not affect the definition of the weld in the 
Creo CAD model. However, the overrides remain in effect in aPriori, even as the CAD 
model is updated in Creo. To remove the overrides for a given Pro Weld GCD, and 
revert to using the CAD-defined values, open the Cost Overrides Summary dialog, right-
click the weld(s) of interest, and select Remove Override from the popup menu. 
In some cases, if aPriori is unable to obtain the width of a Pro weld from the values 
specified in the CAD model, it estimates the width from the actual as-modeled surface 
weld geometry (for "surface-type" welds), or it estimates the width based on the weld 
depth. For more information, see Pro Welds in the Assembly Welds section of the 
Assembly Process Group chapter in the Cost Model Guide. 
If aPriori is unable to obtain the width of a Pro weld from the values specified in the CAD 
model, and it uses neither of the above estimation methods, the width is set to 0.  
aPriori sets to 0 width, depth, and length values that it is unable to obtain or estimate. 
Welds with 0-valued width, depth, or length have 0 volume. In starting point VPEs, such 
welds fail to cost. To address missing dimension values, users can either update the 
Creo model parameters in Creo, or override the weld properties in aPriori. 
See also Virtual welds. 
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2-Model GCDs 
The 2-Model Machining process group extracts two GCDs in addition to the other GCDs 
used in the Machining cost model: 

 source model 
 flat 

For a detailed discussion of these GCDs, see the section "2-Model GCDs" in the aPriori 
Cost Model Guide. 
 

Cost drivers  Description 
GCDs Source 

Model 
Allows you to visualize the difference between the initial raw 
part (the “source” model”) and the finished machined part by 
displaying a transparent representation of the source model 
while you are viewing the finished model. 

 Flat Represents geometry that is typically spot-faced (for 
example, to clean off a surface so that it mates better with 
another part or fastener). It typically is generated only for 
geometry that is milled and not turned, as Ring GCDs 
typically will be generated for turned geometry 

GCD relations 
The GCD Relations Category indicates relations between GCDs on component. It 
includes the following GCD relation types: 

 Ends On 
 Intersects 
 Lies Near 
 Lies Outside 
 Parallel 

Ends On 
The Ends On GCD Relation Type indicates when the end edge of the first GCD lies on 
the contour of the second GCD. The GCD details include: 
 

Cost drivers  Description 
GCDs First The name and number that identifies the first GCD. This 

information is an identifier only and is not used in any cost 
calculation. 

 Second The name and number that identifies the second GCD. This 
information is an identifier only and is not used in any cost 
calculation. 
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Intersects 
The Intersects GCD Relation Type indicates when a portion of the two GCD boundaries 
are coincident or touching at one or more points, or when the boundary of one lies inside 
the boundary of another. The GCD details include: 
 

Cost drivers  Description 
GCDs First The name and number that identifies the first GCD. This 

information is an identifier only and is not used in any cost 
calculation. 

 Second The name and number that identifies the second GCD. This 
information is an identifier only and is not used in any cost 
calculation. 

Properties Distance 
(mm) 

The distance between the second GCD and the curved part 
of the emboss. 

 Is Planar Distance is computed only if this value is True. 

Lies Near 
The Lies Near GCD Relation Type indicates when the distance between the two GCDs 
is less than the recognition distance defined for the combination of GCD types and their 
attribute values. The GCD details include: 
 

Cost drivers  Description 
GCDs First The name and number that identifies the first GCD. This 

information is an identifier only and is not used in any cost 
calculation. 

 Second The name and number that identifies the second GCD. This 
information is an identifier only and is not used in any cost 
calculation. 

Properties Distance 
(mm) 

The minimum distance between the boundaries between 
two non-intersecting GCDs. 

Lies Outside 
The Lies Outside GCD Relation Type indicates the main surface is defined and the first 
GCD lies in the same bend step path as the second GCD, and there are less ‘steps’ 
along the path to get to any blank edge in increasing distance for the first GCD than for 
the second GCD. The GCD details include: 
 

Cost drivers  Description 
GCDs First The name and number that identifies the first GCD. This 

information is an identifier only and is not used in any cost 
calculation. 
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Cost drivers  Description 
 Second The name and number that identifies the second GCD. This 

information is an identifier only and is not used in any cost 
calculation. 

Parallel 
The Parallel GCD Relation Type indicates that both bends are straight and end on the 
same GCD, and the distance between the bend axes are less than a given recognition 
distance, and the angle between them is less than some constant. The GCD details 
include: 
 

Cost drivers  Description 
GCDs First The name and number that identifies the first GCD. This 

information is an identifier only and is not used in any cost 
calculation. 

 Second The name and number that identifies the second GCD. This 
information is an identifier only and is not used in any cost 
calculation. 

Properties Angle (deg) The angle between the straight axes of the bends. The 
relation can only be established between two bends with Is 
Straight equal to True. 

 Distance 
(mm) 

The maximum distance between the bend axes. 
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9 aPriori Cost Tables 

This chapter explains how to display cost information about objects in aPriori, 
using system-defined and custom table views. 

This chapter includes the following topics: 
 Overview 
 Cost Summary 
 Part Details and Assembly Details 
 Investment 
 Assembly tracker 
 Assembly process detail 
 Creating new views 
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Overview of the cost tables 
All cost objects in aPriori have a common cost result structure. For example, each cost 
object has variable costs, fixed costs, and period overhead. The variable costs are made 
up of material, labor, direct overhead, and other direct costs. 
aPriori provides cost information and guidance for parts and assemblies in a series of 
views, each shown in its own tab: 

 Part Summary  (New in aPriori 2016 R1) -- aggregated key cost information 
targeted for design engineers and other non-cost experts.   

 Design to Cost (New in aPriori 2016 R2)— a series of tabs and panes providing 
detailed guidance and functionality enabling design engineers to identify and 
address possible cost savings. Initially available only for the Stock Machining 
and Plastic Molding process groups. 

 Cost Summary – summarized costing information for a part or an assembly. 
 Part Details and Assembly Details – detailed information about manufacturing times 

and costs for a part or assembly, respectively. The Part Details and Assembly 
Details tabs provide some standard out-of-the-box views and also can be 
configured by users to display specific views, containing specific sets of 
information.  

The Assembly Details tab also provides some predefined views for convenience, 
including the Assembly Process Detail view. 
 Investment – information about the hard tooling, fixturing, programming, and other 

amortized investment expenses. 
 Assembly Tracker – graphically summarizes and presents assembly and 

subcomponent cost information in pie charts and bar charts. 
Each view, except for the Part Summary, Design to Cost,  and the Assembly Tracker, provides 
Current, Previous, and Last Saved information. 
Cost outputs for Roll-ups, Comparisons, and Analyses, show the following: 

 For a Roll-up – the sum of cost details of all the components included in the Roll-
up. 

 For a Comparison – cost details for each component included in the Comparison 
on a separate line. This provides a convenient way to compare cost details.  

 For an Analysis – cost details for each component included in the Analysis on a 
separate line. Additional tools are provided to analyze the price difference. 

A note about Fully Burdened Cost 
aPriori provides a plant variable named "disableInvestmentAmortization", which enables 
you to control whether Amortized Tooling and other Investment Costs are included in the 
Fully Burdened Cost of a component, to correspond with your  organization's cost 
accounting practices.  At some sites, accounting practices are such that tooling and 
other capital costs are attributed to a separate budget and are not considered part of the 
component’s Fully Burdened Cost, nor should they affect the determination of the lowest 
cost routing.  By default, this plant variable is set to FALSE and tooling/investment costs 
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are included in Fully Burdened Cost.  Note that if you want to enable this setting, you 
must set it to TRUE for each VPE and process group where these accounting practices 
apply, including those for secondary processes. 

Part Summary tab 
The Part Summary tab pulls together key cost information from across the aPriori user 
interface and summarizes it in a single view. Some displayed values are extracted from 
other areas of aPriori like the Part Details tab, while others are calculated on the fly by the 
Part Summary tab to make the information easier to understand. The Part Summary tab 
displays information that focuses on material, geometry and high-level production 
information. 

 
The fields in the Part Summary are not editable or overridable like they are in the Part Details 
tab. The Part Summary tab is displayed only for parts, not for assemblies. 
Examine the different panes to quickly identify areas of cost that exceed targets and 
expectations, and which could be targeted for cost reduction at the design level.  
The following sections show where the Part Summary extracts its values. You can go to 
these more detailed sections of the UI to drill down for more information when 
necessary. 
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Component Information 
This mass and part size summary combines information from the Component properties 
of the Geometric Cost Drivers panel and the Component Mass section of the Part Details tab: 

 

Production Information 
This summary of production info comes from values found on the Cost Guide (and 
replicated in the Cost Object window). Lifetime Volume is calculated by the Part Summary tab 
from the Annual Volume and Production Life values. 
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Material Information 
The Material Information panel summarizes information that can be found in the Material 
Info section of the Part Details tab and the Material Selection window (available from the 
Manufacturing Process panel). 
A low Utilization (%) value can alert you to possible actionable issues. For example, a cast 
part is typically a "near net" shape and should have a high utilization part. A high Unit 
Cost might indicate a design element that requires a premium material. Values that 
depart from expectations can indicate something to explore. 

 
Note that if you are working with a process group that uses stock material, such as 
Sheet Metal, Bar & Tube, etc.), the "Stock" field of the Material Information panel will be 
populated with relevant info from the Material Stock section of the Material Selection 
window: 
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Cost by Category (%) 
The Cost by Category (%) panel shows you at a high level where most of your costs are 
coming from. The Part Summary tab extracts various key values and calculates the 
percentage they represent of the Fully Burdened Cost for the part. Material, Labor, Overhead, 
Setup, and Investment all come from single values that can be viewed in the Part Details tab 
as shown below. Other is calculated by summing together multiple values: Logistics, Other 
Direct, Margin, Period Indirect Overhead, and SG&A. You can easily view the source for these 
percentages by holding your mouse over an entry to display a tooltip. 

Note: Adding together the Labor, Overhead, and Setup percentages will tell you how much 
of the total cost is being spent on processes, the details of which can be viewed 
in the next panel (Cost by Process). 
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Cost by Processes (%) 
The Cost by Process (%) panel shows which process(es) are contributing the most to the 
cost of manufacturing the part. A process that seems excessively costly may be a 
candidate for further investigation and possibly a design improvement. 
The percentage contribution of each process is calculated by comparing the sum of 
various process-related costs for that specific process, to the sum of these costs across 
all processes used in the routing. This sum is used rather than basing the percentage on 
Piece Cost or Fully Burdened Cost (FBC), because for some processes the Material cost 
is included in Piece Cost and FBC and would result in a skewed comparison. Therefore, 
the Cost by Process calculations assume no contributions from Material, Material 
Overhead, SG&A, or Margin. 
The calculation is: 

Process: 
(Labor Cost + Direct Overhead + Logistics + Amortized Batch Setup Costs +  

(Other Direct Costs - Material Overhead) + Indirect Overhead Costs + 
Fixed Costs) for the process 

Divided by:  
Sum of (Labor Cost + Direct Overhead + Logistics + Amortized Batch Setup Costs +  

(Other Direct Costs - Material Overhead)  + Indirect Overhead Costs +  
Fixed Costs) for ALL processes 

 
Note that clicking the Process column heading will sort the table alphabetically and clicking the 
Percent Cost heading will sort the table numerically. 
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Component Costs and Targets 
The Component Costs and Targets panel provides a quick indication of how the part stands 
regarding cost and mass goals (allow for some rounding differences). Targets are 
typically set in the Cost Guide. 
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Validation and Design to Cost 
The Validation and Design to Cost tabs are intended for design engineers using the 
following process groups: 

 2-Model Machining 
 Casting – Die 
 Casting - Sand 
 Plastic Molding 

 Sheet Metal 
 Stock Machining 

(But note that a basic Validation tab is available for other process groups—see 
Prerequisites.) These tabs provide centralized information, functionality, and context-
sensitive guidance to help you validate/modify assumptions made by aPriori, and then 
evaluate and address design details.  
This is a self-documenting area of the UI: aPriori has brought together information and 
functionality from across the product and consolidated it with detailed in-UI explanations 
and suggestions intended to guide the design engineer in identifying and evaluating 
common areas for cost savings, and providing recommendations to make improvements 
in either aPriori or the CAD model. 
This section walks you through the basic steps of how to use the Validation and Design 
to Cost tabs for Stock Machining. The same basic approach will be applicable to other 
Process Groups. 

Prerequisites 
The Validation and Design to Cost tabs display information only if the current 
component has been costed in one of the supported Process Groups.  
If you click on the Validation or Design to Cost tab while displaying an uninitialized 
(uncosted) component, aPriori displays the following error message: 
“Please initialize the component by costing it.” 

If you click on the Design to Cost tab while displaying a component that has been 
costed in an unsupported Process Group, aPriori displays the following error message: 
“A Design to Cost view is not yet available for this process group.” 

If you click on the Validation tab while displaying a component that has been costed in 
an unsupported Process Group, the displayed validation information is limited to 
information on uncosted GCDs: those that could not be recognized by geometry 
extraction and those that failed to meet the feasibility requirements for assignment to 
some operation sequence. 
Use the Cost Guide to initialize the component with one of the supported Process 
Groups (if appropriate). See Initial costing: The Cost Guide for more information.  

Note: The Validation and Design to Cost tabs work best when your Windows screen 
resolution is set to “100%” or “Smaller”. The details for accessing this setting can 
vary between Windows versions, but in general it can be found in the “Display” 
window of the Control Panel: 
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Workflow 
The Validation and Design to Cost tabs are designed for a very logical workflow: Start 
with the Validation tab so that you can understand and evaluate (and potentially adjust) 
some of the basic assumptions that aPriori has made when costing your part. You 
should also note if there are any Uncosted GCDs, so you can investigate this further. To 
investigate further, use the Issues pane on the Design to Cost tab or use the 
Messages pane to see how the GCD was processed. Then you can use the Design to 
Cost tab to understand and evaluate (and potentially adjust) the design-related cost 
driver details. 

Validation and Design to Cost: Stock Machining 
The following sections describe the Stock Machining version of Validation and Design to 
Cost. 

To validate aPriori’s assumptions about Stock Machining 
Use the following illustration to step through the validation phase for Stock Machining. 
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1 Click the Validation tab.  

2 Read the boxed information in the first panel to understand how aPriori’s 
assumptions can affect your cost.  

3 Click the Information Help button ( ) in the first panel. 

4 Read the Help display for more detailed information on how this area can affect 
costs, and how best to proceed. 

5 Click the provided button(s) to review and/or adjust aPriori’s assumptions for this 
aspect of costing.  

6 These buttons display various dialog boxes or editors for you to evaluate and adjust 
(if necessary) the settings that aPriori chose for this particular area of costing. When 
you click Apply or Ok for these windows, aPriori immediately recosts the component 
with your adjusted setting(s). 

7 Repeat Steps 2 through 5 for each of the Validation panels that are relevant to your 
component.  

Once you have validated and adjusted these basic settings, you are positioned to 
evaluate and adjust design-related cost driver details using the Design to Cost 
Information tab. 

To use the Design to Cost tab for Stock Machining 
The Design to Cost Information tab provides the designer with very specific cost driver 
details, and places at his or her fingertips both detailed context-sensitive help to 
understand the cost ramifications of these details, as well as the ability to evaluate and 
adjust these details. The workflow is similar to that of the Validation stage but goes into 
greater detail. 



aPriori Cost Tables  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 261 

Note: Some panes may identify issues that could prevent the part from being 
manufactured, while others might identify costing considerations where the part 
could be redesigned to be manufactured more efficiently and less expensively. In 
most cases, aPriori does not identify problems that you must address; rather, it 
flags potential issues, or cost drivers that might be good candidates for 
evaluation and possible change. 

Use the following illustration to step through the validation phase for Stock Machining. 

 

1 Click the Design to Cost tab. 

2 Click the Information Help button ( ) in the first panel. 

3 Read the Help display to understand how this area can affect costs, and how best to 
proceed. 

4 Click the provided button(s) to evaluate and adjust the settings for this area. 

5 The dialogs and windows will vary depending on the cost drivers you are working 
with. Some may go down an additional level or two to provide the proper resolution 
and control of the displayed details. Read the information in each dialog for guidance 
about how to proceed. Some suggestions may direct you to aPriori settings, while 
others provide ideas that you may want to consider for incorporation in the CAD 
model itself. 
Note that when you select items in these windows, the window often displays further 
context-sensitive guidance based on your selection and may also highlight relevant 
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geometry in the viewer and in the Manufacturing Process and Geometric Cost Driver 
panels. 

6 Where provided, take advantage of additional Information Help buttons.  

7 The additional help panels can provide very specific guidance regarding your current 
selection. These are often context-sensitive and will display different information 
depending on what you have selected. 

Repeat Steps 2 through 7 for each of the panels that apply to your specific component. 

Notes and examples for Validation and Design to Cost 
You may find the following examples helpful in demonstrating how to use the various 
panes and controls of the Validation and Design to Cost tabs. Since the tabs are 
designed to be self-guided, this section provides notes and examples that are specific to 
the Stock Machining process group, but the general usage patterns are similar for other 
process groups: 
Validation, Stock Form: Say that aPriori chose Plate stock for your part, but you feel 
that Rectangular Bar might be a better option. This pane allows you to easily review the 
existing choice -- and then easily change that choice – without searching throughout the 
aPriori UI and system Help for the specific displays, settings, and guidance that you 
need.  
Validation, Routing: Perhaps aPriori chose a 3-Axis Mill for machining your part, but you 
have access to a 4-Axis Mill and have reason to believe that this might be a better choice for this 
particular part. Clicking the Edit button in this pane brings up the Routing Selection window to 
allow you to easily evaluate your options and choose a different routing if you like. 

Validation, Milling & Turning Setups: aPriori is relatively conservative about 
recommending setups – it tends to minimize the number of setups due to the cost of re-fixturing. 
The Setups sections allow you to easily review and edit the aPriori recommended setups. The 
Milling Setups sections also allows you to review additional possible setups that aPriori identified 
but did not choose.  

Note: For 4-axis and 5-axis mill routings, you may see different axes referenced in different 
parts of the DTC user interface. For example, the Validation tab might list two axes 
(the active rotational axes), while the Active Setup Axes table in the Modify Setup Axes 
dialog box lists four axes, with two of them labeled “Unused”. This is because the 
dialog is displaying both the inactive primary and secondary principal (non-rotational) 
axes, as well as the active primary and secondary rotational axes. Inactive axes are 
labeled “(Unused)”. Both are displayed because the only way to specify which axes are 
rotational setups is by modifying the non-rotational setups. 

Design to Cost, Machining: The Machining panel identifies issues that can actually prevent 
the part from being successfully manufactured and provides guidance on how to address such an 
issue. Select the issues and/or the related GCDs to highlight them in the viewer and the client UI. 
Take advantage of the detailed help provided by the Information icons to learn more about 
specific issues and the steps you can take to address them. 

Note that some “Obstructed Surfaces” may be categorized as “Missing Setups” issues rather than 
“Obstructed Surfaces”. If the GCD could be machined from a setup which exists but is not active, 
it is considered "Missing Setup". However, if it is obstructed from ALL setups, it is considered 
“Obstructed”.  



aPriori Cost Tables  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 263 

Design to Cost, Material: aPriori does not make a recommendation on whether or not you 
should change the selected material, it just simply identifies it to you as a major cost driver and 
gives you the tools you need to easily evaluate it and, if necessary, change it. Note that the gauge 
shows “Cost per Volume” rather than “Cost Per Mass” which makes it easier to compare 
materials of differing density. 

Design to Cost, Stock and Utilization: aPriori cannot make a determination whether a stock 
utilization of (for example) "18%" is good or bad, but this panel allows you to consider whether 
you can adjust allowances to reduce the space between the part outline and the stock outline. Or 
perhaps you might consider dividing the part into two parts that are then joined together, to avoid 
generating a large amount of scrap. If you have a lot of space between the part outline and the 
stock outline, you can easily adjust allowances from here, rather than searching out and adjust 
specific Process Setup Options (PSOs). You can also select ANY stock in the VPE that is large 
enough to accommodate the part, which gives you more flexibility than provided by the standard 
Material Selection dialog where your choices are sometimes more limited.  

Design to Cost, Tolerance & Finishing: This display can be of some general interest, but 
the "Features with specialized finishing" list shows if those tolerances are driving special 
operations and are therefore significant cost drivers. If you can loosen up your tolerance to the 
"Best Achievable" value possible so that fewer GCDs require a special finishing operation, you 
can significantly reduce your cost.  

Design to Cost, Holes & Fillets: Use this panel to identify if you can limit the number of 
different-sized holes and fillets in your part to reduce the number of tool changes required to 
manufacture it. Also evaluate whether your part uses standard sizes so that common (rather than 
specialized or custom) tools can be used. 

Design to Cost, Slow Operations: This panel identifies ball-end milling operations that 
are valid, but which take a long time to complete (and therefore drive up cost). Consider 
whether these operations could instead be performed by facing or side-milling 
operations, either through part design modifications or different setups. 

Thickness Violations in Casting and Plastic Molding Design to 
Cost 
For the process groups Plastic Molding, Casting-Die, and Casting-Sand, the Thickness 
panel of the Design to Cost tab displays Recommended Maximum and Recommended  
Minimum thickness values for the selected part material. These fields are displayed in 
red if the recommended thresholds are violated. The tab also displays the ratio of the 
part’s maximum thickness to its minimum thickness. A ratio near 1, that is, near-uniform 
thickness, is recommended. 

 
Click the Review Thickness button to display the Thickness dialog. 
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Click Alternate Materials to see the recommended thickness thresholds for all materials. 
Click Show Thickness to display thickness violations in the Viewer. Violations are 
displayed as red spheres. A label is displayed that points to the location of minimum 
thickness. 

 
To modify the maximum and minimum thickness thresholds, click the Manual Input radio 
button and enter values into the Max and Min fields. Then click Show Thickness to display 
thickness violations in the Viewer using the modified thresholds.  
You can also display thicknesses that are in a specified range. Click one of the following 
radio buttons (some or all of them appear in the dialog), and then click Show Thickness: 

 > 150% of Recommended Max: click this radio button, and then click Show Thickness 
to display thicknesses that are greater than 150% of the recommended 
maximum. A label is displayed that points to the location of maximum thickness. 
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 100%-150% of Recommended Max: click this radio button, and then click Show 
Thickness to display thicknesses that are between 100% and150% of the 
recommended maximum. A label is displayed that points to the location of 
maximum thickness. 

 100%-50% of Recommended Min: click this radio button, and then click Show 
Thickness to display thicknesses that are between 100% and 50% of the 
recommended minimum. A label is displayed that points to the location of 
minimum thickness. 

 < 50% of Recommended Min: click this radio button, and then click Show Thickness to 
display thicknesses that are less than 50% of the recommended minimum. A 
label is displayed that points to the location of minimum thickness. 
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Cost Summary 
The Cost Summary tab displays detailed costing information for a part or an assembly. It 
provides Current, Previous, and Last Saved information. The Cost Summary tab includes: 
 

Cost type Cost name Description 
Variable 
Costs 

Material The cost of the material used to manufacture the part. 
Includes allocation of scrap material wasted during 
manufacturing. Does not include consumable material, 
such as weld wire or adhesives, only primary material. 

 Labor The cost of labor needed to manufacture the part or 
assembly. Usually includes hourly wages and benefits. 

 Direct 
Overhead 

Costs associated with machine operation, such as the 
machine's power costs, depreciation, or maintenance, 
based on time. 

 Batch Setup 
(amortized) 

The cost configuring a machine to run a batch of a given 
design (accounts for machine downtime and labor 
incurred). The cost is amortized to individual parts or 
assemblies by dividing by the number of components in 
a batch. 

 Logistics The cost of transportation between supply chain 
facilities. 

 Material 
Overhead 

Overhead costs associated with the purchase and 
storage of material, as well as with moving material to 
the work center. 

 Expendable 
Tooling 

The cost of tooling, such as a drill bit or turret press 
punch, consumed during manufacturing of many 
different parts. 

 Additional 
Direct Costs 

Other miscellaneous costs not accounted for in above 
categories. The default value is zero. 

 Extra Costs A “placeholder” line item to be used for miscellaneous 
costs. The default value is zero but your VPE may be 
customized to use this field to capture specific types of 
costs and relabeled as needed (see the aPriori 
Administration Guide, Managing Cost Taxonomy Display 
Labels). 

 Other Direct 
Costs 

The subtotal of Expendable Tooling, Additional Direct 
Costs, and Extra Costs. 

 Total Variable 
Costs 

The sum of all cost items above, Total Variable Costs is 
the marginal cost associated with making “one more” 
part of a give design. This includes all Variable Costs 
associated with the creation of a part but does not 
include depreciation of capital tooling. 
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Cost type Cost name Description 
Period 
Costs 

Period 
Overhead 
Allocations 

Period or indirect overheads are expenses that are 
expensed each financial period (factory depreciation, 
light bills, SG&A) that cannot be associated or amortized 
to a specific design. 

Margin Margin The profit margin charged on each part/assembly. 
Calculated by multiplying a margin percentage value by 
the sum of the above costs. The margin percentage 
defaults to 0 in the Regional Data Libraries but can be 
configured by customers. 

Piece 
Part Cost 

Piece Part Cost The sum of all cost items above, Piece Part Cost is cost 
of making a part, including margin if applied but 
excluding Fixed (tooling-related) Costs. 

Fixed 
Costs 

Hard Tooling 
(amortized) 

The cost of capital or hard tools that are needed to 
manufacture one specific design and cannot be used to 
create other designs. 

 Fixture Cost 
(amortized) 

The cost of devices that hold a specific part or assembly 
in the correct orientation on a machine during 
manufacture or assembly. These devices are not 
supposed to be re-used for a part or an assembly of a 
different design. 

 Programming 
Cost 
(amortized) 

The cost of creating a computer program that Computer 
Numerical Control (CNC) machines will follow to make or 
assemble parts of a specific design. 

 Additional 
Amortized 
Investments 

Other miscellaneous costs not accounted for in the 
above categories. 

 Total Amortized 
Investments 

The sum of all fixed costs. Fixed costs must be incurred 
before the start of manufacturing. In aPriori, all fixed 
costs are amortized to the individual part or assembly by 
dividing the total, up-front cost for the fixed cost (the 
capital cost) by the Total Product Volume. 

 Fully Burdened 
Cost of 
Assembly 
Processes 

The sum of Piece Part Cost and Fixed Costs for the 
Assembly Processes. This cost applies only to 
assemblies. 

 Fully Burdened 
Cost of 
Subcomponents 

This is the total of the Fully Burdened Costs for all the 
first level children (parts and assemblies) of the top-level 
assembly or roll-up. This cost applies only to 
assemblies. 

 Fully Burdened 
Cost 

For parts, the sum of Piece Part Cost and Fixed Costs.  
For assemblies, the sum of Fully Burdened Cost of 
Assembly Processes and Fully Burdened Cost of 
Subcomponents. 
For Roll-ups, the sum of Piece Part Cost and Fixed 
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Cost type Cost name Description 
Costs for all first level children (parts, assemblies, roll-
ups). 
(See A note about Fully Burdened Cost).  

Capital 
Costs 
 

Hard Tooling Capital or hard tools are purchased for creating one 
specific design and cannot be used to create others. The 
Capital Cost is the price to buy one set of the tooling. 

 Fixture Cost The cost of devices that hold a specific part or assembly 
in the correct orientation on a machine during 
manufacture or assembly. These devices are not 
supposed to be re-used for a part or an assembly of a 
different design. The capital cost is the price to buy one 
set of the tooling. 

 Programming 
Cost 

The cost of creating a computer program that Computer 
Numerical Control (CNC) machines will follow to make or 
assemble parts of a specific design. 

 Total Capital 
Investments 

Capital investment is the total amount a company must 
invest in fixed costs before the first part or assembly can 
be made. This cost is 'fixed' because the company 
incurs the cost whether it makes one part or the total 
number of parts allowable before tooling must be 
refurbished or replaced. 

Part Details and Assembly Details 
The Part Details and Assembly Details tabs display a wealth of detailed information 
about the part or assembly, respectively, and its cost (for a given Virtual Production 
Environment (VPE) and process routing). Various categories of information can be 
configured into different views or sets of information. These categories include 
descriptive information; current cost and quote data; production information; VPE, 
process, and machine information; manufacturing times and costs, as well as input rates 
(such as hourly labor and overhead rates and material unit costs) used in the cost 
computations. The Part Details and Assembly Details views provide Current, Previous, 
and Last Saved information.  

Note: In the Assembly Details table for an assembly, you can open an assembly 
component by double-clicking on the row in the table.  

Some of the fields presented in these views are editable. See Overriding computed 
values for more information. 
The Assembly Details tab includes four pre-defined views which provide different sets of 
fields, for different purposes. These pre-defined views include the Assembly Summary 
view, the Assembly Cost Detail view, the Sourcing Summary view, and the Assembly 
Process Detail view. These views are described later in this chapter. 
Both the Part Details and Assembly Details tab provide a number of pre-defined views 
that you can display by clicking Table View ->Select Table View: 



aPriori Cost Tables  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 269 

 
These pre-defined views help you focus the data display on a specific area of interest 
such as the Overhead Summary (which was added to support the direct and indirect 
overhead enhancements introduced in release 2015 R1). aPriori also provides  an All 
Data view, which provides a superset of all data fields available for the part, grouped into 
categories. The All Data view provides a useful starting point for the creation of new 
customized views. For more information, see Creating new views on page 277. 
The Part Details and Assembly Details tables include the following fields and more: 
 

Cost drivers  Description 
Process Process The cost associated with a particular type of 

manufacturing process that a machine performs. 

 Machine 
Name 

The machine used by the cost engine to compute 
costs for the given process. 

Manufacturing 
Times 

Labor Time 
(s) 

The time that someone is paid to perform an 
operation/process on one part/assembly. 

 Cycle Time 
(s) 

The actual time that a machine/process is operating 
on a given part/assembly. 

 Parts Per 
Hour   

Computed as 3600 seconds per hour divided by Cycle 
Time. 

Variable 
Costs 

Material Cost Cost of the physical material used in the manufacture 
of the part. Material Cost includes both the material in 
the physical part and an allocation of scrap material 
that is wasted during the manufacturing process. 
Material cost does not include consumable material 
(for example, weld wire, adhesives, etc.), only primary 
material. 

 Labor The amount that labor is paid to manufacture the part 
or assembly. The customer determines which 
components of labor compensation are included in the 
labor rate that is used to calculate labor cost. 
However, labor cost usually includes hourly wages 
and benefits. 
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Cost drivers  Description 

 Direct 
Overhead 

Direct Overhead costs are costs that can be 
specifically associated with the manufacture of specific 
part through a machine. For example, most machines 
have a machine or direct overhead rate that allocates 
the machine's power costs, depreciation, 
maintenance, etc. to parts that run on the machine 
based on time. 

 Batch Setup 
(amortized) 

The cost in machine downtime and labor incurred 
when a machine is configured to run a batch of a given 
design. This cost is amortized to individual parts or 
assemblies by the number of parts in a batch. 

 Logistics The cost of transportation between supply chain 
facilities. 

 Expendable 
Tooling 

Tooling that is consumed during manufacturing, but 
not tied to a specific part. For example, a drill bit, turret 
press punch, etc. are used in the manufacture on 
many different part designs. 

 Additional 
Direct Costs 

Other miscellaneous costs not accounted for in the 
above categories. 

 Extra Costs A placeholder line item to be used for miscellaneous 
costs. The default value is zero but your VPE may be 
customized to use this field to capture specific types of 
costs and relabeled as needed (see the aPriori 
Administration Guide, Managing Cost Taxonomy 
Display Labels). 

 Other Direct 
Costs 

The subtotal of Expendable Tooling, Additional Direct 
Costs, and Extra Costs 

 Total 
Variable 
Costs 

The sum of all cost items above, Total Variable Costs 
is the marginal cost associated with making “one 
more” part of a give design. This includes all Variable 
Costs associated with the creation of a part but does 
not include depreciation of capital tooling. 

Period Costs Period 
Overhead 
Allocations 

Period or indirect overheads are expenses that are 
expensed each financial period (factory depreciation, 
light bills, SG&A) that cannot be associated or 
amortized to a specific design. 

Margin Margin The profit margin charged on each part/assembly. 
Calculated by multiplying a margin percentage value 
by the sum of the above costs. The margin percentage 
defaults to 0 in the Regional Data Libraries but can be 
configured by customers. 

Piece Part 
Cost 

Piece Part 
Cost 

The sum of all cost items above, Piece Part Cost is 
cost of making a part, including margin if applied but 
excluding Fixed (tooling-related) Costs. 
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Cost drivers  Description 
Fixed Costs Hard Tooling 

(amortized) 
Capital or hard tools are purchased for creating one 
specific design and cannot be used to create others. 

 Fixture Cost 
(amortized) 

Devices used to hold a specific part or assembly in the 
correct orientation on a machine during manufacture 
or assembly. Fixtures and jigs under the Fixed Cost 
category are created for a specific design. It is 
assumed that these fixtures will not be re-used on a 
different design in the future. 

 Programming 
Cost 
(amortized) 

The cost of creating a computer program that 
Computer Numerical Control (CNC) machines will 
follow to make or assemble parts of a specific design. 

 Additional 
Amortized 
Investments 

Other miscellaneous costs not accounted for in the 
above categories. 

 Total 
Amortized 
Investments 

The sum of all fixed costs. Fixed costs must be 
incurred before the first part or assembly of a given 
assembly can be made. In aPriori, all fixed costs are 
amortized to the individual part or assembly by 
dividing the total, up-front cost for the fixed cost (the 
capital cost) by the Total Product Volume. 

Fully 
Burdened 
Cost 

Fully 
Burdened 
Cost 

For parts, the sum of Piece Part Cost and Fixed Costs.  
For assemblies, the sum of Fully Burdened Cost of 
Assembly Processes and Fully Burdened Cost of 
Subcomponents. 
For Roll-ups, the sum of Piece Part Cost and Fixed 
Costs for all first level children (parts, assemblies, roll-
ups). 
(See A note about Fully Burdened Cost.) 

Unit Cost Unit Cost For assemblies, the unit cost is the cost of one part, 
regardless of the quantity of parts in the assembly. 

Capital Hard Tooling Capital or hard tools are purchased for creating one 
specific design and cannot be used to create others. 
The Capital Cost is the price to buy one set of the 
tooling. 

 Fixture Cost 
 

Devices used to hold a specific part or assembly in the 
correct orientation on a machine during manufacture 
or assembly. Fixtures and jigs under the Fixed Cost 
category are created for a specific design. It is 
assumed that these fixtures will not be re-used on a 
different design in the future. The capital cost is the 
price to buy one set of the tooling. 

 Programming 
Cost 

The cost of creating a computer program that 
Computer Numerical Control (CNC) machines will 
follow to make or assemble parts of a specific design. 
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Cost drivers  Description 
 Total Capital 

Investment 
Capital investment is the total amount a company 
must invest in fixed costs before the first part or 
assembly can be made. This cost is fixed because the 
company incurs the cost whether it makes one part or 
the total number of parts allowable before tooling must 
be refurbished or replaced. 

Investment 
The Investment table displays information about the processes, tool types, and tool 
categories for a part. It provides Current, Previous, and Last Saved information.  

 
The Investment table includes: 
 

Column Heading Description 
Name The manufacturing process. 

Tool Name The general type of tool that is being costed (for example, 
Blanking Die, Cam-actuated Die, etc.). 

Type Name The category of tooling the tool falls under. That is, Hard Tooling 
(Capital Tooling treated as a fixed cost) or Expendable Tooling 
(treated as a direct variable cost). 

Value Total capital investment. 

Unit Currency setting. 

Assembly tracker 
The Assembly Tracker tab graphically displays a summary of cost information for an 
assembly, using pie charts, bar charts, and gauges. The Assembly Tracker charts 
include: 
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 Summary of Assembly Costs - a pie chart that breaks down total assembly 
costs into assembly process costs (the costs of assembly subcomponents) and 
the costs of manufacturing those subcomponents themselves.  

 Summary of Component Costs - a pie chart that decomposes the cost of the 
subcomponents into constituent costs (Material Cost and Labor & Direct 
Overhead costs) 

 Status of Component Costs - a bar chart that displays the percentage of 
subcomponents that have been costed (useful for identifying if any 
subcomponents were not previously costed and therefore appropriate costs are 
not rolling up into the assembly costs). 

 Type of Costs - a bar chart that displays the percentage of subcomponents with 
a given type of cost (as specified in the Administrative Info tab of the Cost Object 
window for the subcomponent) 

 Manufacturing Locations (VPE) - a bar chart that displays the various VPEs 
used in costing the assembly process and the assembly subcomponents, and the 
percentage of subcomponents costed at each VPE.  

 Comparison of Alternatives - a bar chart that compares the Current assembly 
cost to the Previous cost and the Last Saved cost, and breaks down each cost 
into some significant component costs (Material, Labor & Direct Overhead, 
Amortized Batch Setup) 

 Finish Mass Target Analysis - a gauge which compares the actual finish mass 
of the assembly and its subcomponents to the mass targets specified and 
computes the variance. 

 Cost Target Analysis - a gauge which compares the actual cost of the assembly 
and its subcomponents to the cost targets specified and computes the variance. 

Assembly process detail 
The Assembly Process Detail view displays detailed process information about an 
assembly, as well as Current, Previous, and Last Saved information. The Assembly 
Process Detail view is one of the predefined views available on the Assembly Details 
tab.  

To select the Assembly Process Detail view 

1 Click on the Assembly Details tab. 

2 Click on the Table View menu, and then click on the Select Table View menu item.  

3 Click on Assembly Process Detail menu item. The Assembly Process Detail view will 
be displayed.  

The Assembly Process Detail view includes the following fields (depending on which 
manufacturing processes are used or relevant): 
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Cost type
 
  

Cost name Description 

Total 
Times 
and 
Costs 

Total Labor 
Time (secs) 

The time that someone is paid to perform an 
operation/process on one part/assembly. 

 Total Cycle 
Time (secs) 

The actual time that a machine/process is operating on a 
given part/assembly. 

 Manual 
Cycle Time 
(secs) 

The time for a person to perform all tasks to weld one 
assembly (loading, clamping, arcing, etc.). 

 Robot Cycle 
Time (secs) 

The time for a robot and its operator to perform all tasks to 
weld one assembly (loading, clamping, arcing, etc.). 

 Total Labor 
Cost 

The amount that labor is paid to complete the assembly 
task. The customer determines which components of labor 
compensation are included in the labor rate that is used to 
calculate labor cost. However, labor cost usually includes 
hourly wages and benefits. 

Fixture 
Loading 

Load Time 
(secs) 

The time that operator(s) are paid to load parts into the 
welding fixture. 

 Clamp Time 
(secs) 
 

The time that operator(s) are paid to clamp the parts down 
in the welding fixture. 

 Unload Time 
(secs) 

The time that operator(s) are paid to unload the welded 
assembly from the fixture. 

 Labor Time 
(secs) 

The total time that operator(s) are paid to perform the 
fixture load, clamp, and unload operations. 

 Cycle Time 
(secs) 

The actual time to perform all the tasks to load, clamp, and 
unload the fixture. 

 Labor Cost The amount that labor is paid to load, clamp, and unload 
the fixture. The customer determines which components of 
labor compensation are included in the labor rate that is 
used to calculate labor cost. However, labor cost usually 
includes hourly wages and benefits. 

Manual 
MIG 
Welding 

Gun 
Manipulation 
Time (secs) 

The time for a person to manipulate the MIG welding gun 
between the welds. 
 

 Gun 
Manipulation 
Cost 

The cost associated with manipulating the MIG welding gun 
between the welds. 

 Gun Clean 
Time (secs) 

The time for a person to clean the nozzle of the MIG 
welding torch/gun. 
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Cost type
 
  

Cost name Description 

 Arc Time 
(secs) 

The time for a person to perform only the manual arcing to 
MIG weld one assembly (includes any manual tacking 
operations). 

 Arc Cost The cost associated for a person(s) to perform only the 
arcing to MIG weld one assembly. 

 Labor Time 
(secs) 

The total time that operator(s) are paid to perform the 
welding operation (that is, gun manipulation, gun cleaning, 
and arcing). 

 Cycle Time 
(secs) 
 

The actual time for all the welding tasks on one assembly 
(gun manipulation, gun cleaning, and arcing). 

 Labor Cost The amount that labor is paid to perform the welding task 
(that is, gun manipulation, cleaning, and arcing). 

Robot 
MIG 
Welding 

Gun 
Manipulation 
Time (secs) 

The time for a robot to manipulate the MIG welding 
torch/gun. 

 Gun Clean 
Time 

The time for the robot system to clean the nozzle of the 
MIG welding torch/gun. 

 Arc Time 
(secs) 

The time for a robot to perform only the arcing to MIG weld 
one assembly. 

 Arc Cost The time for a robot to perform only the arcing to MIG weld 
one assembly. 

 Labor Time 
(secs) 

Any operator time required to support the robot welding 
operation. 

 Cycle Time 
(secs) 

The time for a robot and its operator to perform all the 
welding tasks for one assembly (that is, gun manipulation, 
cleaning, and arcing). 

 Labor Cost Any labor time that is paid to perform the robot welding task 
(that is, gun manipulation, cleaning, and arcing). 

Manual 
SPOT 
Welding 

Gun 
Manipulation 
Time (secs) 

The time for a person to manipulate the spot-welding 
torch/gun. 

 Gun 
Manipulation 
Cost 

The cost associated with manipulating the spot-welding 
torch/gun. 

 Weld Time 
(secs) 

The time for a person to perform only the arcing to spot 
weld one assembly. 

 Weld Cost The cost associated for a person to perform only the arcing 
to spot weld one assembly. 
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Cost type
 
  

Cost name Description 

 Labor Time 
(secs) 

The total time that operator(s) are paid to perform the 
welding operation (that is, gun manipulation, gun cleaning, 
and arcing). 

 Cycle Time 
(secs) 

The actual time for all the welding tasks on one assembly 
(that is, gun manipulation, gun cleaning, and arcing). 

 Labor Cost The amount that labor is paid to perform the welding task 
(that is, gun manipulation, cleaning, and arcing). 

Robot 
SPOT 
Welding 

Gun 
Manipulation 
Time (secs) 

The time for a robot to manipulate the spot-welding 
torch/gun. 

 Weld Time 
(secs) 

The time for a robot to perform only the arcing to spot weld 
one assembly. 

 Weld Cost The cost associated for a robot to perform only the arcing to 
spot weld one assembly. 

 Labor Time 
(secs) 

Any operator time required to support the welding 
operation. 

 Cycle Time 
(secs) 

The time for a robot and its operators to perform all the 
welding tasks for one assembly (that is, gun manipulation, 
cleaning, and arcing). 

 Labor Cost Any labor time that is paid to perform the robot welding task 
(that is, gun manipulation, cleaning, and arcing). 

3 Axis 
Mill 

Labor Time
  

Labor time for any machining operations on the assembly 

 Labor Labor cost 

 Cycle Time Cycle time for any machining operations on the assembly 

 Material Material Cost  

 Direct 
Overhead 

Direct overhead cost for assembly machining 

 Expendable 
Tooling 

Cost of exp. tooling based on production volume & life  

 Logistics Any manually entered logistics costs 

 Setups 
(amortized) 

Setup costs 

 Add Direct 
Costs 

Any manually entered additional direct costs 
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Creating new views 
The Part Details and Assembly Details tabs display descriptive, manufacturing and 
costing information about parts and assemblies, respectively.  
Users can also create additional views, containing just the data fields of interest for a 
particular purpose, organized in a desired order. These views can then be selected to be 
displayed on the Part Details and Assembly Details tabs. 

To create a new view 

1 From the Part Details or Assembly Details tab, click Table View -> Manage Part 
(or Assembly) Details Views. From the resulting Manage...Details Views window, 

click the "plus sign" Add icon ( ). 

 

2 In the Create New View window, enter a View Name and Description, then use the 
Base View On drop-down menu to indicate which pre-configured view to use as a 
starting point (All Data is the default, since it contains all available fields).  
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3 Check the Shared checkbox if you want the new view you create to be available to 
other users. If you want  the view to be Private (available only to yourself), leave the 
box unchecked. 

Note: A shared view can be deleted by any user who shares it. To ensure that a 
view that you want to keep is not inadvertently deleted, first create a private 
view. Then duplicate it and check the 'Shared' box. This creates a copy of the 
view so that it is always available in your private list even if someone else 
deletes the shared view. 

4 Click OK. The Customize Part/Assembly Details View window will update to show the 
name of the new view you are creating, and whether it is a Private or Shared view.  

5 The right panel of the window shows a list of Available Fields and Displayed Fields. Click 
the right arrow to move fields from the Available list to the Displayed list (use the left 
arrow to remove fields from the Displayed list). You can hold down the Ctrl key to 
move multiple fields at once. Use the up and down arrows to order the Displayed 
Fields as desired. 

6 Click OK when you are satisfied with the contents and order of the new view.  

7 To display the new view you have just created, click on the tab’s Table View menu, 
then click the Select Table View menu item. A popup list of available views will 
appear. Select the view you just defined. 

8 If you wish to edit the view further, once again choose Manage Part/Assembly 
Details Views. In the left panel, click on the view you just created (or any other view 
you wish to edit). The right-hand panel will update to show the configuration of the 
selected view, and you may reselect and reorder displayed fields as needed. 

Changing the Number of Decimal Places 
By default, aPriori displays two significant digits after the decimal point. in various views 
including: 
Cost Summary tab 
Part Details and Assembly Details tab 
Investment tab 
Rollup Summary and Comparison Summary views 
You can specify that more decimal places should be displayed in these views by adding 
the following line: 

cost.table.decimal.places = <n> 

to the following file: 
C:\Users\<user>\AppData\Local\aPriori\<version>\apriori.user.propertie

s 

where: 
<n> is the number of significant digits to display 
<user> is the Windows username of the current user 
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<version> is the aPriori version number 

Note: Certain dialogs will NOT be affected by this option and will always be displayed 
with two decimal places. This includes the Cost Ticker, the Materials Selection 
dialog, and PDF reports.
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10 Bulk Costing and 
Analysis 

This section describes the Bulk Costing and Analysis module. This module is 
licensed separately.  

This chapter includes the following topics: 
 Overview 
 User inputs files 
 Bulk costing groups of parts 
 Bulk costing part scenarios and assemblies 
 Bulk costing data fields 
 Editing bulk costing inputs 
 Costing a bulk cost group 
 Costing without a CAD file 
 Reviewing bulk costing and analysis results 
 Running from the Command Line 
 bulkLoad.cmd 
 bulkLoad.properties file 
 plugin.properties file 
 Running as a Scheduled Task 
 Bulk Costing Usage Reports (System Admins) 
 Understanding cost failures during bulk costing 
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Overview 
The separately-licensed Bulk Costing and Analysis module enables you to generate 
costs for multiple parts at the same time, and then analyze groups of parts to identify 
outliers for cost reduction opportunities.  
A sub-set of features is also available in the main aPriori user interface without a 
separate license, for costing components with multiple scenarios, and for assemblies 
with multiple subcomponents and scenarios. 
Bulk costing allows you to specify different scenarios so that you can compare the costs, 
for example, of producing parts in different areas of the world, or at different volumes. 
After an initial costing, subsequent re-costings do not require that GCDs be re-imported 
from CAD parts.  
You can access Bulk Costing in a variety of ways: 

 From the Tools>Bulk Costing & Analysis menu, for costing arbitrary groups of 
parts, optionally including CSV or Excel input sheets for further input. 

From the command line, using CSV or Excel input sheets for input. 
From the Cost menu, to cost parts and assemblies with multiple scenarios. (The Cost 
menu does not require a separate license). 
The module allows you to quickly generate preliminary costs for groups of parts in bulk 
by setting their initial costing parameters using a tabular interface and then batch costing 
them.  
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Note that when you perform a bulk costing, aPriori will check all of the sub-components 
to see if any are open in the main UI with unsaved changes. If so, aPriori will prompt 
whether you want to save and close that component, leave it unsaved, or cancel the 
deep cost operation. It is important to realize that regardless of what you choose, the 
results of the deep cost will be determined by the inputs on the Bulk Costing and 
Analysis table, or any user inputs file, not by the changes to the sub-component in the 
UI. 

User inputs files 
Bulk costing accepts an optional user inputs file in either Excel or CSV (comma-
separated values) format files. This allows you to specify parts, production information, 
overrides for CSL values, and other cost inputs from a spreadsheet.  
Production input values provided in this file take precedence over values from other 
sources. See Precedence of production input overrides for more information. 

Note: aPriori strongly advises against manually creating input columns. Instead, 
generate the input spreadsheet as described in this section. 

One way to get started with an inputs file is to create a new bulk cost group, edit its 
values in the Bulk Costing & Analysis UI, and then save the data with File > Export 
User Inputs Spreadsheet. This will create a user inputs file in Excel spreadsheet 
format. If you wish to create a CSV file, you can Save As .csv from Excel. 
The columns in the spreadsheet files map to the columns in the Bulk Costing & Analysis 
UI in a fairly obvious manner. 
Some of the less obvious mappings are covered in the following sections. 

Process Setup Option columns 
Process Setup Option columns must be named in the form "<Process Name>:<Option 
Name>" and are case-sensitive. The available options vary from cost model to cost 
model, the following table lists some common process setup options and are intended as 
examples only. 
Note that you can optionally add "mode name" in the column heading by using the "#" 
character:  
<Process Name>:<Option Name>#<Mode Name> 
The default value of mode name is "user". 

Option Name  Purpose  Example column heading 
includeOptionalRouting  Selects an 

optional process  
Wet Coat Line:includeOptionalRouting 

machine  Selects the 
machine for a 
specific process  

3 Axis Mill:machine 

vpe  Selects an XPG 
VPE  

Surface Treatment:vpe 
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CSL Formula Override columns (non-custom processes only) 
Like Process Setup Option columns, CSL Formula Override column names begin with 
 <Process Name>:.   
The heading has the format of "<Process Name>:override.<Formula Name>".  The data 
type of override values should be Double.  
Note: CSL overrides in bulk costing are subject to the same limitations as in the main 
aPriori UI. See Overriding computed values on page 112. 

Custom (User defined) Attribute columns 
Any columns with column headers start with "customAttributes." 
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Pinned Routings 
As of Release 2018 R1, you can now specify a desired Bulk Costing routing via the User 
Inputs spreadsheet. Previously, this “pinning” capability was available only through the 
Routing Selection dialog and the interactive Bulk Costing user interface. This 
enhancement makes it more efficient and less error-prone to perform bulk costing of 
many scenarios with known routings, as well as to perform cost model validation and 
calibration, since it is possible to save all costing inputs in an User Inputs spreadsheet 
for repeated costings. It also enables companies to more easily include routing data 
received from other enterprise systems.  
The spreadsheet column for this feature is pinnedRouting. Also, for Release 2018 R1, 
users can have aPriori skip all feasibility checks by providing the value TRUE in a new 
ignoreAllProcessFeasibility column. 

 
The pinnedRouting column accepts a comma separated list of process(es) and/or node(s) 
that specify a non-ambiguous routing, such as “VerticalAutomatic, 3 Axis Mill” in the 
Casting – Sand process group. The column is case-sensitive.  

Note: “Non-ambiguous” does not mean “unique”. A pinned routing string is considered 
ambiguous and will be rejected if it matches a disjoint set of routings. In other 
words, aPriori allows anything that you can achieve via the Routing Selection 
view, where you can pin a single routing or group of routings, including all down-
stream alternatives, but does not permit multi-selections. 

If you specify only “VerticalAutomatic” in the pinnedRouting column, aPriori will evaluate 
only the VerticalAutomatic routing branch in Casting – Sand, but it will evaluate all 
possible secondary machining routings for that scenario.  
If you specify “VerticalAutomatic, 3 Axis Mill”, only the 3 Axis Mill secondary routing for 
VerticalAutomatic will be evaluated.  
If you enter “aPriori” in the pinnedRouting column, then any previously pinned routings 
for the specified process group will be un-pinned and all possible routings will be 
evaluated.  
If the components to be costed do not already exist in the database then the Pinned 
Routing may be left blank and all possible routings will be evaluated. 
If you specify an ambiguous routing, aPriori will generate an error message when it 
attempts to open a Bulk Loader that reads this spreadsheet. (Error messages are 
displayed as soon as the error is encountered. You may need to iterate through multiple 
errors and fixes when debugging changes to a User Inputs spreadsheet.) 
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Specifying routings with canonical format 
Specifying valid routings requires an understanding of routing formats and how routings 
are represented in the Routing Selection window (see Selecting a process routing in 
Chapter 7). 

 
The key to specifying a valid routing is to identify relevant Alternative nodes (which are 
prominently highlighted in beige in the Routing Selection window), and then specifying one 
of the nodes under the Alternative node. (If you do not specify a node underneath a 
particular Alternative node, then all possible sub-routings downstream from that 
Alternative node are evaluated.) 
This is not a required approach: aPriori will accept any routing specification that results 
in a non-ambiguous routing, and it is possible to specify a valid, non-ambiguous routing 
in multiple ways. However, it is best practice to specify the routing in canonical format. 
This means specifying one of the options underneath every Alternative node (down to 
the level at which you want aPriori to consider all alternatives), while omitting the names 
of any other nodes.  
Consider the following Waterjet Cut routing in the Sheet Metal process group:  



Bulk Costing and Analysis  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 286 

 
In this particular situation, you could specify the same valid, non-ambiguous routing in at 
least two ways: 
Non-canonical: "Waterjet Cut" 
Canonical: "[CTL]/Waterjet/[Bend]" 
The non-canonical specification which names a leaf-node (“Waterjet Cut”) within the 
routing works in this case because there is only one “Waterjet Cut” – it happens to 
specify a non-ambiguous routing, as would canonically specifying the 
"[CTL]/Waterjet/[Bend]" node underneath the “Sheet Metal” Alternative node.  
However, in a similar process in the Bar & Tube process group, specifying the non-
canonical “Punching” node would not work because it exists in more than one routing. 
You need to specify the canonical format “Bent Part, [CTL]/[Punch]/[Bend]” (or at least 
“[CTL]/[Punch]/[Bend]”) to successfully specify a non-ambiguous routing. 

 
The efficiency of the canonical format becomes more obvious with more complex 
routings. For example, compare: 
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Non-canonical: "Sheet Metal/Machining, Sheet Metal, [CTL]/Laser/[Bend], Material 
Stock, Laser Cut, Bend Brake, Drill Press Routing, Drill Press" 
Canonical: "[CTL]/Laser/[Bend], Drill Press Routing" 
Both resolve to the same routing when the inputs spreadsheet is imported: 

 

Note: When defining comma-separated routings, it can be helpful to collapse/expand 
nodes using the Routing Selection UI to visualize the nodes that you do and do not 
need to specify. Further note in the example above that Machining (in this case, 
Drill Press Routing) is a secondary process and it applies to all the routing 
options under the Primary process. So, no matter what path is chosen from the 
primary routing, when you exit, you enter the machining routing. 
In general, the best way to see the proper syntax for a pinned routing is to pin the 
routing and then export it from the Bulk Costing UI. 

Routing and feasibility columns 
You may notice that the Bulk Costing UI displays two columns next to each other: 
Process Routing and Pinned Routing.  

 
When you create a new Bulk Loader, the Process Routing column will be populated IF the 
scenario had a routing pinned in the GUI. If you then create a User Inputs spreadsheet 
from the Bulk Loader, this value will populate the pinnedRouting column in the 
spreadsheet: 

 
If you change this value (say, to HorizontalAutomatic) and then open the Bulk Loader UI 
with this User Inputs spreadsheet, both Process Routing and Pinned Routing columns get 
updated to the new routing. 



Bulk Costing and Analysis  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 288 

 
To implement the “ignore feasibility” feature, append a column to the User Inputs 
spreadsheet and name it ignoreAllProcessFeasibility. Set a value of TRUE for any row for 
which you wish to turn off process feasibility checks. 

 

Note: When creating a new User Inputs spreadsheet by using File > Export User 
Inputs Spreadsheet, this column will only appear and be populated if the 
scenario that created the Bulk Loader had the feasibility rules checkbox 
unchecked.  

 

How to specify different datatypes in CSV files 
To specify various datatypes in a CSV file, use the following rules: 

1 If the value is alphabetic or begins with a single quote ('), it is a string and the first 
apostrophe is stripped. For example, the following are all strings: 

abc 
'abc (becomes abc) 
'123 (becomes 123) 
''123 (becomes '123) 
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2 If the input is recognized as numeric, the datatype is a Double. For example, the 
following are all converted to Doubles 

100.00 
 1 
-100.00 
-1 
0 

3 The following are all recognized as Boolean values: 
True 
TRUE 
tRue 
FALSE 
false 

4 Anything that is not covered above is considered a String. 

Bulk costing groups of parts 
To start the licensed version of the Bulk Loader, select Tools > Bulk Costing & 
Analysis from the aPriori menu bar to display the Bulk Costing & Analysis window.

 

To create a new bulk cost group 

1 Determine where (on your computer or network) the parts and assemblies you wish 
to cost and analyze are located, and how they are organized. The parts that you wish 
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to analyze together must reside within or underneath the same folder, so you may 
need to organize the parts and assemblies into either a single folder or a set of sub-
folders underneath a single, top-level folder.  

Note: If the folder contains a part/assembly for a scenario that already exists in the 
database, aPriori behavior depends on the processingInputRule preference 
setting described at Scenario support fields.  

2 Select File > New Bulk Cost Group from the aPriori Bulk Costing & Analysis menu bar 
to display the New Bulk Cost Group window.  

 

3 Name: Enter a name for the group. If you do not enter this, it will default to the folder 
name specified in the next step. 

4 Components Directory: Click  next to the field and navigate to and select the 
folder where the parts and assemblies are located. 
aPriori will import all parts and assemblies located in the selected folder and any/all 
subfolders. 

5 Inputs File: (Optional) Click  next to the field to navigate to and select a user 
inputs file spreadsheet (in either Excel or CSV format) of cost inputs. For more 
information, see Editing bulk costing inputs. 

Only cost components in spreadsheet: (Optional) This checkbox appears only when 
you have specified an inputs file. Leave this box unchecked to cost all of the CAD 
models in the directory you specify. Check this box to cost only those CAD models 
specified in the inputs file. 

6 Rollup Name: (Optional) Specify a name for the rollup that will be created from the 
results of this bulk load. It is good practice to use a descriptive name such as: 
bulk_load_test_mm-dd-yyyy.  If you leave this field blank the parts will not be added 
to a rollup. If you specify a name the dialogue will update and display a new optional 
field Output Report File.   

Output Report File: (Optional) This field appears only if you have specified a Rollup 
Name as described above. This field allows you to specify an Excel file that the 
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Spreadsheet Report will be written to.  The name of the file must end in .xls or xlsx.  If 
you do not specify an output file, no Spreadsheet Report will be created. 

7 Set values that will serve as scenario defaults for all components. To specify inputs 
for individual components, go to the Bulk Costing & Analysis window, or the Inputs File 
spreadsheet. 

• Part Process Group – Select the default process group (Casting, Forging, 
Sheet Metal, etc.) that will be assigned to parts when not otherwise defined. 

• Part VPE – Select the default VPE (Virtual Production Environment, such as 
“USA”, China”, “India”, etc.) that will be used to cost non-parent components 
unless otherwise defined. 

• Assembly VPE – Select the default VPE (Virtual Production Environment, 
such as “USA”, China”, “India”, etc.) that will be used to cost assemblies 
unless otherwise defined. This makes it easier to cost products that are 
assembled in one location using parts produced in other locations. 

• Description – (Optional)  Enter text that might be helpful to identify or explain 
the purpose of this Bulk Cost group. 

• Scenario Name – See Scenario support fields on page 298. 
Processing Rule if Scenario Exists – See Scenario support fields on page 298. 

• Active – See Scenario support fields on page 298. 
• Official – See Scenario support fields on page 298. 

8 Click OK. The parts and assemblies will be displayed in the aPriori Bulk Costing & 
Analysis window, but not yet costed or analyzed. 

9 Click the Save button or select Save from the File menu if you wish to store the bulk 
cost group at this time. 
To enter bulk costing parameters and other information about the components, see 
Editing bulk costing inputs on page 300.  

To open an existing bulk cost group 

1 Select File > Open Loader File from the aPriori Bulk Costing & Analysis menu bar to 
display the Open Loader File window.  

2 Navigate to the desired loader file (loader file filenames end with .loader.xml), 
select it, and click Open. 

3 This displays a pre-populated instance of the New Bulk Cost Group window. This gives 
you the opportunity to adjust the values provided by the loader file. When done, click 
OK to display the Bulk Costing & Analysis window with the saved Bulk Cost Group. 

To edit, add, and refresh components from a bulk cost group 

1 If you specified an Inputs File on the New Bulk Cost Group, all entries defined in that 
spreadsheet will by default be read-only in the Bulk Costing & Analysis window. To edit 
an entry, you must first select its checkbox under the Ignore Excel Inputs column. (This 
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column is not displayed if you did not specify an Inputs File.

 

2 Fields that are editable in the Bulk Costing & Analysis window are highlighted; 
uneditable fields are grayed.  You can edit individual entries directly, or you can 
select multiple entries and change them together using the right-click context menu 
or the Edit menu in the menu bar. (When clicking to select multiple rows, make sure 
to do so within grayed columns, or you may inadvertently change checkbox settings 
while selecting.)  

3 To temporarily remove a component from the costing operation, click its Ignore 
checkbox. You can also remove a component permanently if the bulk cost group has 
been recently created but not yet saved, by deleting its file from the Components 
Directory and clicking File > Refresh.  

Note: A component will not disappear from the Bulk Costing & Analysis UI even 
after you remove its CAD file from the Components Directory if: 
• It is defined in a user inputs file.  
• The bulk cost group was opened from a loader.xml file. 

4 Click the Save button or select Save from the File menu to save your edits. 
For more information, see Bulk costing data fields on page 297, and Editing bulk costing 
inputs on page 300. 

5 To add new entries for files that have been added to the Components Folder, select 
File > Refresh Files. 

To create a new row from an existing row 
You can quickly create a new row in the Bulk Costing & Analysis UI using an existing 
row as a starting point: 

1 Select the existing row. 

2 Click Create from this row...  from either the Edit  menu or the right-click context 
menu. 

This menu item is enabled only if: 
 One row is selected 
 A user inputs file is not provided for this row. 
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 The component row is CA-connected (“Components Directory” is populated), 
such that Bulk Costing knows where the CAD file is located. 

All inputs of the selected row will be copied to the new row except for the scenario name 
and the setting of the "official" field. 

Note: aPriori disables the Create From This Row menu item if the CAD file for the 
selected row is not CAD-connected. The new scenario will fail to cost if there are 
no GCDs for the new scenario I.e., the Bulk Costing Child process will not copy 
the scenario). 

Bulk costing part scenarios and 
assemblies 
The Bulk Costing & Analysis utility can simultaneously cost multiple component 
scenarios, and it can also cost assemblies along with all of their child components 
(“deep” costing). When you use this facility from the main UI, aPriori pre-populates fields 
with values from the component(s) you selected.  
This means that you can use the Bulk Costing & Analysis tool to generate multiple 
“what-if” scenarios for a component within a single batch run, making it much easier and 
faster to compare alternative manufacturing scenarios.  For example, you could quickly 
generate cost estimates for manufacturing a part at two different volume levels, in each 
of 3 locations by specifying a distinct scenario name to store for each distinct set of Bulk 
Costing inputs and results. 
To use the Bulk Costing & Analysis utility from the main aPriori UI, use the Cost menu 
(see Using the Cost menu on page 47). 
You can also bulk cost scenarios and assemblies from the separately-licensed Bulk 
Loader available from the Tools > Bulk Costing & Analysis menu option, or from the 
command line. In these cases, rather than selecting components in the main aPriori UI, 
you populate the fields directly in the Bulk Costing & Analysis user interface, or through 
a User Inputs spreadsheet in either Excel or CSV format. 
Regardless of how you use access the bulk costing functionality, scenario and assembly 
support is the same. 
For costing different scenarios, see Scenario support fields on page 298. 
For deep costing assemblies see the next section. 

Deep costing assemblies 
 “Deep costing” an assembly means costing the assembly and all of its child 
components. aPriori visits and costs every component of the assembly, including sub-
assemblies. The total cost is calculated as the sum of the costs of all sub-components. 

Note: If you specified an optional Rollup Name for output when defining the Bulk 
Cost Group, the roll-up will NOT include components at the top level if they are sub-
components of costed assemblies. They are already included or displayed as 
children of costed assemblies. 

To deep cost an assembly from the main aPriori user interface, open the assembly and 
select Cost > Deep Cost Scenario. This brings up the Bulk Cost & Analysis user 
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interface, pre-populated default values for the assembly. Edit the fields as necessary 
and click the Cost button. 
To deep cost an assembly as a Bulk Cost group, select Tools > Bulk Cost & Analysis 
and follow the same general procedures described in User inputs files on page 282 for 
other bulk costing operations. Ensure that the Deep Cost checkbox is checked 
You must ensure that the Bulk Loader is provided with either or both of the following:  

 A directory containing the top-level CAD assembly file to be costed, as well as 
the CAD files for all of the assembly’s sub-components. This is most likely when 
costing new assemblies that have not been costed before. If a User Inputs file is 
not provided (see below), default values will be used for costing. 

 User Inputs file in either Excel or CSV (comma-separated values) format, 
containing sub-components with user-defined values rather than default values 
for costing. This is useful for re-costing assembly scenarios with different user 
options for comparison analysis. You can create assembly scenarios using the 
Bulk Loader, but you cannot define the structure of the assembly. You can only 
specify various user options for the assembly scenario. 

Deep cost behavior 
Deep-costing of an assembly tree takes place from the leaves up and occurs in two 
passes to ensure cost accuracy:  

 Pass 1 analyzes the structure of the assembly (that is, it identifies the sub-
components).  

 Pass 2 costs the assembly after all the sub-components are costed. 
If a component scenario belongs to more than one assembly, the component scenario 
will be costed once. 
If a component scenario is set to "ignore", the component scenario will not be costed 
even if it is a sub-component of a deep costing assembly.  
For a multi-level assembly, a sub-assembly will be deep-costed automatically if its 
parent is deep-cost enabled, even if the sub-assembly is not deep cost enabled. This 
allows you to deep-cost an assembly recursively without needing to know the exact 
structure of the top-level assembly or the deep-cost setting of its sub-assemblies. 

Deep cost status 
When deep costing an assembly and all of its children, the Bulk Costing user interface 
displays the following messages in the Status column. Note that these apply only to 
assembly deep-costing operations. 

 Processing First Pass...  - The Bulk Loader is analyzing the assembly to determine 
its structure. 

 First Pass Success  - The Bulk Loader has completed its analysis of the assembly 
structure. 

 Processing Second Pass...  - The Bulk Loader has costed all sub-components of the 
assembly and is now completing the assembly costing operation. 
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Costing multi-body parts (free bodies) 
aPriori can be configured to recognize multi-body CAD files as collections of free body 
parts and cost them as an assembly. This behavior is controlled by various properties. 
For interactive costing, these properties are set in the apriori.properties file, or (as of 
release 2019 R1) can be set in a Multi-Body Options preferences dialog. The 
apriori.properties settings are documented in the “Properties Files” chapter of the aPriori 
System Administration Guide. The Multi-Body Options preferences dialog is described 
at Multi-Body Options. 
For Bulk Costing and Analysis, those properties and an additional one are set in 
plugin.properties and prefaced with “launcher.set” (for example, 
launcher.set.apriori.keep.free.bodies=true).  

This section specifically discusses costing multi-body parts with Bulk Costing and 
Analysis. 
When bulk costing encounters a multi-body, it first creates the structure and then cycles back to pick up the 
additional bodies.  
To enable multi-body bulk costing, set the following properties: 
In <install>\apriori.properties: 

apriori.keep.free.bodies=true 

In <install>\ext\analysis-purchasing-module\ plugin.properties: 
launcher.set.apriori.keep.free.bodies=true 

launcher.set.apriori.cost.free.bodies.as.assembly=true 

Note: Ensure that there is no trailing space after “true”. 

launcher.set.apriori.cost.free.bodies.as.assembly is a setting that is recognized only 
in Bulk Costing. When set to true, aPriori will cost each body as a part with the same 
costing inputs and then aggregate the costs at the assembly level. When free body parts get 
added to the Bulk Loader automatically (that is, if you load a multi-body CAD file containing free body 
parts), the free body parts appear in their own rows in the Bulk Costing & Analysis UI for the purposes of 
showing costing status. However, they are not editable, and they will not be saved in the Bulk Loader files 
(*.loader.xml), or to any exported CSV or Excel spreadsheet file. They inherit all their inputs from the 
parent assembly/multi-body part.  

Note: If launcher.set.apriori.keep.free.bodies=true and 
launcher.set.apriori.cost.free.bodies.as.assembly=false, then only the top-
level assembly will be costed and rows for assembly sub-components will not be added to the bulk cost 
group.  

IMPORTANT: It is critical that you keep the common settings (i.e., all free body properties OTHER 
than apriori.cost.free.bodies.as.assembly) in apriori.properties and 
plugin.properties consistent. If you change the free.bodies setting in one, you must 
change it the same way in the other. Failure to do so can result in unexpected behavior such as 
assemblies being created with no subcomponents. 

It should also be noted that bulk costing does not notify you if multi-body component scenarios are open in 
the UI when you initiate a bulk costing operation. However, when the bulk costing is finished, aPriori does 
display a list of components (including multi-body components) that are opened in the UI and which should 
be refreshed. 
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Limitations with multi-body STEP assemblies 

Bulk costing STEP assemblies with multi-bodies present some special challenges and 
require some workaround procedures. You cannot directly Deep Cost and save multi-
body STEP assemblies, but you can Deep Cost the resulting Rollup. The limitation with 
this workaround is that you cannot save and later re-open the Bulk Cost file: you must 
Deep Cost the Rollup scenario again. 

To bulk cost a multi-body STEP assembly 

5 Make sure that the free body properties are set as described in the previous section. 

6 Create a new bulk cost group for the multi-body STEP assembly as described in . 
To create a new bulk cost group 

Make sure to specify a Rollup Name. Click Ok in the New Bulk Cost Group dialog 
box when done. 

3 Click the Cost button in the aPriori Bulk Costing & Analysis window, then click OK when 
the Bulk Costing Complete window appears. 

4 When the main aPriori window comes up showing the rollup you specified in Step 2, 
click Cost > Deep Cost Scenario. This displays the aPriori Bulk Costing & Analysis 
window again, this time showing the rollup, with all the subcomponents  accessible 
and visible in the table. However, note that the Bulk Cost file cannot be saved to re-
open later, and that you will need to Deep Cost the Rollup scenario again to get back 
to the table. 

Bulk Costing 2-Model Machining Parts 
To bulk cost 2-Model Machining components, you must specify the source component 
though the user inputs file. (For general information about 2-Model Machining, see the 
chapter 2-Model Machining Process Group" in the aPriori Cost Model Guide.) 

1 Create a user inputs Excel file that contains columns sourceModel and 
sourceModelScenario. If sourceModelScenario is blank, the effective scenario is the 
Official scenario. Also note that the processGroup of the finished model should be "2-
Model Machining". 

 

2 Create a Bulk Cost Group in the Bulk Loader UI using your spread sheet and 
source/finished model CAD files. 
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3 Click the Cost button. The Status of the finished model is "Processing Deferred" until 
the source model is costed. 

 

Note: The Bulk Loader first scans the inputs file for any 2-model components. If it 
finds any, it first costs the non-2-model components, and then afterwards 
cycles back  and costs the 2-model components. 

Bulk costing data fields 
There are four groups of input data fields associated with the components in a bulk cost 
group: Production Info, Quoted Cost Info, Administrative Info and Process Routing. 
Production Info fields are required to initially cost the part or assembly and include: 

 Process Group 
 Annual Volume 
 Production Life  
 Plant Name (VPE) 
 Material Composition 

If the values for these fields are not specified in the Bulk Cost Group, aPriori will use the 
VPE default values. 
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Quoted Cost Info fields allows a user to enter a current cost or quote information, which 
is used subsequently in cost per mass analyses and for comparison to the aPriori cost 
estimate. These are optional fields and include the following:  

 Quote Total part Cost 
 Quote Tooling Cost 
 Quote Material Composition 
 Quote Process Group 
 Quote Annual volume 
 Quote Routing 
 Quote Date 
 Quote Factory 

Administrative Info groups optional fields containing descriptive information about the 
parts, which may be useful for subsequent searching and analysis. These fields include: 

 Part Description 
 Product Line 
 Model Number 
 Project 

Process Routing fields display the routing specified and/or chosen by aPriori for the 
component.  
By default, the Process Routing field is blank initially, and aPriori will automatically 
determine the routing and machine which will result in the lowest cost. 
You also can specify the routing and machine to be used when bulk costing 
components. To do this, select one or more parts in the table and select Edit > Edit 
Process Routing. (Edit Process Routing also is available from the right mouse button 
popup menu). See Selecting a process routing on page 182 for detailed instructions. 

Note: If a bulk costing part includes required UDAs (User Defined Attributes), verification 
that the required UDA(s) exist is done during initialization of components. This 
means that if a required UDA is not specified, you get an error message only 
once all components in the bulk cost group are initialized/costed. 

Scenario support fields 
aPriori provides several fields to support multiple scenarios: 

• scenario – You can specify that multiple scenarios for a single part or 
assembly should be costed during the Bulk Cost operation. Each scenario 
requires a different row in the Bulk Costing & Analysis UI and in the User 
Inputs spreadsheet. The Scenario field in the Bulk Costing & Analysis UI 
provides a pull-down menu showing the scenarios that are legal to change to. 
You cannot, for example, have two instances of the same scenario for the 
same part. You also cannot edit the scenario if the row is not defined in a 
User Inputs file. 
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 official – When set to TRUE in the User Inputs spreadsheet, or “checked” in 
the Bulk Costing & Analysis table, the scenario specified in the row is made 
the official scenario. (Default = FALSE.) Note that if a component has not 
been initialized, the first scenario created by the Bulk Loader is made official 
even if this field is False.  If the Bulk Loader processes a subsequent 
scenario that is marked “Official” for the component, it will supersede the  
official status of the first scenario.  However, note that you cannot assume in 
what order the Bulk Loader will process rows: variables such as sorting by 
column in the UI, or setting bulkload.concurrent.loader.count to a value 
greater than “1” in plugin.properties, can result in rows being processed 
in a different order than you might expect.  

 
• active – When set to TRUE in the User Inputs spreadsheet, or checked in the 

Bulk Costing & Analysis table, CAD-connected components will be updated 
whenever the CAD part changes. Setting a part to Inactive means that GCDs 
remain static even if the CAD part is updated and must be updated manually 
before changes to the CAD files will be reflected in the Bulk Cost operation. 
This field is optional; if not explicitly set, the default is TRUE. 

• deep cost – (Default = FALSE) When set to TRUE in the User Inputs 
spreadsheet, or checked in the Bulk Costing & Analysis table, the children of 
assemblies or roll-ups will also be costed. This field is disabled in the UI for 
non-parent components. 

• processingInputRule – What to do if the scenario already exists: 
 Update – (Default) Add new inputs to the existing scenario and retain any 

existing inputs that are not changed through the Bulk Cost update. This 
merges new inputs into the existing scenario, overriding the specified input 
selections. 

 Skip – Do not process; skip component scenario. 
 Create New Scenario – Create a new scenario by copying from the existing 

scenario and then applying the inputs provided through Bulk Costing. If the 
scenario name already exists, increment it. For example:  Final(2) 

 Clear Existing Data & Reload -- Clear all inputs and outputs for the scenario 
and recost using the inputs defined in the Bulk Cost run. 

Bulk costing required User Defined Attributes 
If you provide a scenario name that exists in the database when you initialize bulk 
costing, aPriori populates the inputs with everything that currently exists for that 
scenario. Therefore, if you have User Defined Attribute values for “Part1-scenario1”, and 
you start a bulk costing that includes “Part1” and “scenario1” in the New Bulk Cost 
Group dialog box, then the existing UDA values will be used.  Since they exist, they will 
be used no matter what Processing Input Rule you have selected.  
If you change the scenario name in the bulk costing UI, then aPriori does not load that 
data from the database, and whatever values you provide in the bulk costing UI is used 
(again, regardless of what Processing Input Rule you have selected).  So if you create a 
new bulk cost group with scenario name “scenario0” and then in the bulk cost UI you 



Bulk Costing and Analysis  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 300 

change the scenario name to “scenario1”, it doesn’t matter that Part1 already has UDA 
values in aPriori --  the bulk costing UI is not filled out with UDA values. 
In summary, you can enter values for UDAs when bulk costing, and must provide values 
for required attributes. If you are bulk cost existing components and want to use existing 
required attribute values, you must do one of the following: 

o Collect all scenarios into a container (assembly, roll-up, or dynamic roll-up) 
and use Deep Costing. The existing UDA values will be pulled in for all 
scenarios. 

o If all scenarios have the same scenario name, ensure that that scenario is 
used when creating the new bulk cost group.  All existing UDA values will be 
pulled into the bulk costing UI. 

Creating scenarios through Bulk Costing 
This section describes some things to consider when you are creating or running a Bulk 
Costing Group without any scenarios already in the database. 
Suppose the parts you are bulk costing have not been previously costed and therefore 
do not yet exist in the database. If you run bulk costing with an Excel User Inputs 
spreadsheet that specifies two scenarios, you should specify one (and only one) of the 
two scenarios to be official. If you specify more than one scenario for the same part to be 
official, aPriori displays an error message when you try to run the Bulk Loader. 
If neither scenario is specified to be official, the Bulk Loader makes the first scenario it 
processes the official one. 
If parts are already stored in the database and an official scenario already exists, you 
can set "official" to put any scenario in official status. If "official" is left blank or set to 
FALSE, the Bulk Loader will not alter official status. 

Editing bulk costing inputs 
There are four ways to enter information about the components in a bulk cost group: 

1 Enter information one part at a time in the aPriori Bulk Costing & Analysis table.  
For each field you wish to edit, select the field and enter the desired value. Many 
fields can be typed in by simply double-clicking on the field. You can also select an 
option from the right-mouse popup menu. 

2 Enter identical information for multiple parts at a time 
Select multiple parts, holding the control key and clicking the left mouse button to 
select the fields you want to edit. Then click the right-mouse button and select the 
appropriate menu option corresponding to the group of data that you want to edit 
(Production Info, Administrative Info, Quoted Cost, or Process Routing). A pop-up 
window will appear where you can set the inputs. Enter the desired data and click 
OK. 

3 Use Microsoft Excel to facilitate mass-entering of bulk cost data fields 
• Copy the data in the aPriori Bulk Costing & Analysis table to Microsoft Excel 

by selecting Copy Entire Table from the Edit menu. 
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• Paste the information into Microsoft Excel.  
• Enter the desired values into the Microsoft Excel worksheet 
• Select the data in Microsoft Excel and paste back into aPriori (select Paste 

from the Edit menu in the aPriori Bulk Costing & Analysis window). If pasting 
the entire table, move the cursor to the first row of the table in aPriori, click, 
and Paste from the Edit menu.  

Parts must be in the same order in the Bulking Costing Tool and Excel when copying 
data from Excel into aPriori. 
All fields except for Process Routing can be specified in Excel. If you would like to 
set a specific routing for a part or group of parts, it must be set in aPriori. 

Note: You cannot enter TRUE/FALSE data in Excel cells that are of type = 2. You 
must change the cells to be type = 4 for them to work properly. 

If setting the material composition field in Excel, you must use the exact same 
material composition name that is used in the selected VPE’s material table. 

4 Specify an external spreadsheet (Inputs File) to provide inputs to Bulk Costing and 
Analysis. If an Inputs File is specified, data from the file takes precedence over 
information entered directly into the Bulk Costing & Analysis table.  

5 After you have completed entering/editing information about the components in a 
bulk cost group, Save the bulk cost group and proceed to costing. 

Note: Production input values provided in this file take precedence over values from 
other sources. See Precedence of production input overrides for more 
information. 

Bulk Costing Menu Reference 
The Bulk Costing & Analysis window provides the following commands and features on 
both the right-click context menu and the Edit menu. (Some of these features are also 
available as fields in Bulk Costing tabular user interface ):  
 

Menu Command Description 
Copy Entire Table 
Copy 
Paste 

(Edit menu only) Copy applies to the currently 
selected row(s). Copy Entire Table is useful for 
capturing all contents of the window for pasting into a 
spreadsheet or other document. Paste copies 
clipboard data into the table. See Editing bulk costing 
inputs above for details. 

Create From This Row Create a new row in the Bulk Costing & Analysis UI 
using an existing row as a starting point. See To edit, 
add, and refresh components from a bulk cost group 
above for details. 

Edit Production Info 
Edit Administrative Info 
Edit Quoted Cost 

For Production Info, Administrative Info, and Quoted 
Cost, see the description at Using the Cost Object 
Info window. 
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Menu Command Description 
Edit Process Routing 
Edit Cost Overrides 
Summary 
Edit Process Setup 
Options 

For Process Routing, see Selecting a process 
routing. 
For Cost Overrides, see Working with the Overrides 
Summary dialog. 
For Process Setup Options, see Editing process 
setup options. 

Make Official 
Undo Make Official 

Specify whether or not the selected scenario is to be 
made the scenario that by default gets rolled into its 
parent assembly or roll-up. See the description for 
the  Scenario menu in the main UI at Working with 
scenarios.  

Make Active (Scenario) 
Make Inactive (Scenario) 

Specify whether or not the selected scenario is 
automatically updated with CAD changes. See the 
description for the  Scenario menu in the main UI at 
Working with scenarios. 

Extract GCDs 
Do Not Extract GCDs 

Controls whether or not aPriori should re-extract the 
latest geometry of the CAD model. If you are sure 
that the geometry of a component’s CAD file has not 
changed since the last time the part was costed and 
saved in the aPriori database, then you can choose 
to not extract GCDs.  aPriori will simply use the 
previously-saved set of GCDs without re-analyzing 
the CAD model, reducing the total amount of time 
required for aPriori to cost the component.  

Deep Cost  
Undo Deep Cost 

Set whether or not deep costing is enabled. See 
Scenario support fields for more details. 

Edit Processing Input 
Rule... 

Specify how aPriori should handle existing 
scenarios. See the description at Scenario support 
fields for more details. 

Ignore 
Undo Ignore 

If a component scenario is set to "ignore", the 
component scenario will not be costed even if it is a 
sub-component of a deep costing assembly. See the 
section "A note about Ignore, Hide, and their effect 
on costing" in the aPriori Cost Model Guide for more 
details. 

Ignore Excel Inputs 
Undo Ignore Excel Inputs 

Control whether fields in the Bulk Costing & Analysis 
UI are updated from the Excel input file or can be 
edited locally. See To edit, add, and refresh 
components from a bulk cost group for more details. 

Select Image File (Context menu only) Specify the full path of a 2D 
image file to associate with a CAD-less (virtual) part 
or assembly. See Associating an image without a 
CAD file for more details. 
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Costing a bulk cost group 
Once you have set the bulk cost input fields as desired, you are ready to cost the bulk 
cost group. The time required to cost the group is dependent on the number and 
complexity of the components in the group.  

To cost a bulk cost group 

1 Select the  button to cost the group of parts.  

2 If any of the components in the bulk cost group have previously been costed, the 
Begin Bulk Costing window will appear with a message that identifies these 
components and asks if you want to continue.  

• If you select Yes, the official scenarios of the previously costed parts will be 
overwritten.  

• If you do not want to overwrite the previous official scenarios, you can 
remove the component(s) from the bulk cost group. Alternatively, before bulk 
costing, you could first go to the main aPriori application and create a new 
scenario for a part that is a copy of the official scenario. This new scenario 
will then retain the previously-costed value. 

3 Specify how to group cost results once the bulk costing has completed on the Add to 
Rollup window. You can: 

• Add to existing rollup 
• Include in new rollup 
• Do not include in a rollup 

By default, all the components in the bulk costing group are included in a new roll-up.  
If you are costing a large group of unrelated parts that you ultimately want to analyze 
in smaller cohesive groups, select “Do not include in a rollup.” When the parts have 
completed costing, then you can create rollups based on relevant groupings (i.e., all 
plastic parts in a specific project, sheet metal parts costed on a specific date etc.) 
For more information on using Rollups, see Using roll-ups on page 95. 
Select an option and click OK. 

4 aPriori will begin costing each component in turn in the main aPriori window. When 
aPriori has completed costing the bulk cost group, the Bulk Costing Complete 
window will appear.  
The window will note the total number of components processed and the number 
that costed successfully. If any components failed to cost or only partially costed, the 
system will identify those components and provide details of the costing issues for 
each component. For more information on understanding costing failures during Bulk 
Costing, see Understanding cost failures during bulk costing on page 314. 
Click OK to dismiss the window. The Bulk Cost and Analysis results will be displayed 
in a rollup in the main aPriori window. 
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Costing with CAD properties 
Your aPriori System Administrator may have configured your deployment to 
automatically extract properties or parameters from the CAD file and map those values 
to aPriori production inputs or User Defined Attributes (UDAs). (See Costing with CAD 
Properties in this document, and the chapter “Using CAD Properties” in the aPriori 
Professional System Administration Guide.) 
If so, you can specify that bulk costing extract these properties directly from the CAD file 
as soon as you load the bulk costing screen. There is a property that enables this 
behavior in <aPriori_install>\ext\analysis-purchasing-module\lugin.properties: 
bulkload.readCadProperties=true. There is also a Read CAD Properties checkbox 
which reflects this setting,  which appears in the New Bulk Costing Group dialog: 

 

Note: If your administrator has a CAD properties mapping file in place and your CAD 
file(s) contain those properties, loading the bulk costing UI will incur a 
performance cost due to the property extraction process. You can choose 
whether to take that performance hit up front (by checking the Read CAD 
Properties checkbox, or later during costing (by leaving the box unchecked). If 
you check the box, the extraction process will be cached for two days. If the 
leave the box unchecked, you will encounter the performance hit whenever you 
cost your bulk costing group. aPriori recommends that you leave the box 
checked. 

 

Costing without a CAD file 
The aPriori Bulk Loader provides the ability to cost or re-cost a part without having a 
CAD file present. This capability is available in two situations: 

 After costing a part once with the CAD file present, you can re-cost that same 
part without the CAD file. This is useful, for example, if a non-designer like a cost 
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analyst wants to try recosting a part with different inputs, but who may not have 
access to the engineering CAD files. Ensure that: 

The Process Group specified in the userinputs.xls file is the same as the one used 
when the scenario was costed with the CAD file present. The CAD-less process group 
must be the same as when the component was originally costed. 
In the Bulk Cost Group dialog, the Only cost components in spreadsheet checkbox is 
enabled. 
In the Bulk Cost Group dialog, the Processing Rule if Scenario Exists is set to Update. 

 You can also define a non-CAD part in a User Inputs file, specifying basic 
component geometry fields such as volume, surface area, length, height, width, 
and cost it with the Bulk Loader without having any CAD file at all. The 
component MUST be cost with the User Guided process group. 

Associating an image without a CAD file 
As of aPriori Release 2014 R1 SP1, you can associate an image file with a CAD-less 
(virtual) part or assembly. This image will appear where a CAD-related component 
typically displays a representation of the CAD model, such as the Component Viewer or 
Search dialog in the main aPriori GUI. To associate an image with a virtual component 
part in the Bulk Loader, use the folder icon to specify the full path to the image file under 
the Image File Path column in the File Info section of the Bulk Costing and Analysis UI: 

 
For information about using images in the aPriori UI, see Specifying 2D Images for 
virtual components. Note that in the Bulk Costing & Analysis UI you can right-click and 
select Image File to specify the full path to the 2D image file. You can also specify this 
path in a Bulk Costing Excel user inputs file or BOM input file using the imageFilePath 
property. 

Cost Overrides 
You can override certain computed values in bulk costing the same way you can in the 
main aPriori client. However, bulk costing does not provide any validation or error 
checking of overrides, so you must be careful when implementing these overrides, 
please refer to the override information in the main UI  documentation when determining 
which values you can override. Start with Overriding computed values on page 112. You 
can also find override details in the Cost Model Guide.  
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Reviewing bulk costing and analysis 
results 
After batch costing groups of parts, aPriori automatically executes two analyses:  

 Cost per Mass Analysis. aPriori determines the average cost per mass, shows 
you which parts’ cost per mass are above the average, and computes the 
potential cost reduction opportunity by annualizing the per component savings 
based on production volume. 

 Cost Comparison. aPriori calculates the variance between an existing part cost 
(from a current cost or quote) and an aPriori cost estimate. You can sort to find 
the parts with the greatest variance. These parts are the most likely candidates 
for cost reduction. 

The Bulk Costing and Analysis module uses Rollups to display cost analysis results.  
The Bulk Costing & Analysis Output includes all fields that are typically available in a 
Rollup plus some additional categories of data elements: Quote Info, Quoted Cost Per 
Mass Analysis, Cost Comparison (compares aPriori Cost to Quoted Cost), aPriori Cost 
per Mass, Stock Dimensions and GCD Summary. The full set of fields contained in these 
categories is listed later in this section. 
To identify outliers, navigate to the Headings “Quoted Cost Per Mass” and “Cost 
Comparison.” By looking at the cost per mass based on the price you’re currently paying 
and a comparison of the current cost to the aPriori cost, you can quickly ID outliers and 
rank those with the greatest potential cost savings. Identify the outliers with largest cost-
down potential by sorting on “Est. Annual Savings Based on Avg. Quote Cost Per Mass” 
and “Est. Annual Savings Based on Var. Between aPriori & Quoted Cost.” 
Notes about Quoted Cost Per Mass: 

 Quote Cost Per Finish Mass = Finish Mass / Quoted Total Cost  
 % Var. from Avg. Quote Cost Per Mass = percent difference between the part’s 

cost per mass and the average quoted cost per mass of the group. The average 
cost per mass is automatically calculated for any rollup that you create. 

 Tip: Analyzing the % Variance for the Avg. Cost per Mass is meaningful only if 
you have related parts in the rollup. aPriori recommends that you, at a minimum, 
group parts by process family. Additionally, you may want to segregate parts 
even further considering variables such as product line, supplier, part type etc.  

 Est. Component Savings Based on Avg. Quote Cost Per Mass shows how much 
a part would cost if it had the average cost per mass.  

 Est. Annual Savings Based on Avg. Quote Cost Per Mass equals Estimated 
Component Savings * annual volume. 

The Bulk Costing Analysis fields are displayed in groups in the rollup and are listed 
below:  

 Quote Info: 
Quoted Total Cost  
Quoted Total 
Capital Investment  
Quoted Material Composition  
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Quoted Process Group  
Quoted Annual Volume  
Quoted Routing  
Quoted Date  
Quoted Factory (Source)  

 Quote Cost Per Mass  
Quote Cost Per Finish Mass  
% Var. from Avg. Quote Cost Per Mass  
Est. Component Savings Based On Avg. Quote Cost Per Mass  
Est. Annual Savings Based On Avg. Quote Cost Per Mass  

 aPriori Cost Per Mass  
aPriori Cost Per Finish Mass  
% Var. From Avg. aPriori Cost Per Mass  
Est. Component Savings Based On Avg. aPriori Cost Per Mass  
Est. Annual Savings Based On Avg. aPriori Cost Per Mass  

 Cost Comparison 
aPriori vs. Quoted Cost (Diff)  
aPriori vs. Quoted Cost (% Diff)  
Est. Annual Savings Based on Var. Between aPriori & Quoted Cost  

 Stock Dimensions 
For components costed in process groups utilizing material stock, the following 
stock fields are populated: 

Stock Form   
Stock Width  
Stock Height   
Stock Length  
Stock Thickness   
Stock Wall Thickness  
Stock Inside Diameter 
Stock Outside Diameter  

 GCD Summary 
The number of GCDs of each type below are displayed for each component in 
the rollup: 

Assembly Component GCD   
Blank  
Bulk Removal   
Closed Bend  
Combo Void   
Complex Hole  
Corner Pick   
Cross Section  
Curved Bend   
Curved Surface  
Curved Wall   
Edge  
End   
Form  
Heli Groove   



Bulk Costing and Analysis  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 308 

Keyway  
Lance   
Main Surface  
Multi Step Hole   
Not Supported  
Parting Line   
Planar Face  
Pocket Ring  
Setup Axis   
Sharp Edge  
Simple Hole   
Stock Trim  
Straight Bend   
Turning Axis  
Void   
Weld  

Running from the Command Line 
The Bulk Costing and Analysis module can run from the command line in "batch" mode, 
without starting the aPriori user interface.  
This provides the benefits of: 

 allowing batch cost analysis of many parts at a single time in an automated and 
scheduled fashion  

 using bulk costing for activities like Spend Analytics  
 running bulk costing as an offline process 

 
Costing inputs can be specified through spreadsheets, and cost estimates and related 
data of interest can be output to spreadsheets. This enables you  to interface aPriori with 
other product lifecycle management systems to support fully-automated batch costing. 
For example, an upstream system may prepare a set of CAD files and a corresponding 
set of cost inputs to pass to aPriori and initiate a Bulk Costing session; the outputs of the 
session can then be passed to another downstream system.  

Note: If you set bulkLoader.watchpointXlsFile in the properties file, you must also set  
bulkLoader.rollupName or no report will be generated. 
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bulkLoad.cmd  
To run Bulk Costing from the command line, use the bulkLoad.cmd command, which is 
found in  
apriori_install\version\install\bin 

This command takes three arguments which must be specified in the exact order shown 
below. 

Note: Do not map a network drive to the aPriori installation folder and then use that 
mapped drive when running the bulkLoad command.  Doing so will cause the 
bulkLoad command to fail with a log entry similar to "RuntimeException 
executing:Cannot build ClassLoader from dependencies.txt Msg:Cannot find 

dependencies file:Z:\install-support\antscripts\lib\classpath-win64.txt" 

Syntax 
bulkLoad.cmd props_file [username password] 

Arguments 
props_file -- The path to the properties file, which contains the same inputs that are 
provided via the user interface when running interactively. See bulkLoad.properties file 
below for more information. 
username -- The aPriori log-in account name to use for this session. 

password -- The associated aPriori password. 

Note that if username and password are not specified as arguments on the command 
line, the Bulk Loader looks for them in the properties file. If not found there, and if your 
aPriori administrator has implemented Single Sign On (SSO), the Bulk Loader attempts 
to use the currently logged-in user’s Windows credentials.  

Example 
Create a batch file named bulk.bat with the following contents that makes a call to the 
bulkLoad.cmd command. (username and password are shown as part of the batch file, 
but you should consider providing these at run time, 
call BulkLoad.cmd C:\Files\bulkLoad.properties myUserName myPassword 

Important Note About Forward and Back Slashes 
When using the command line, paths should be specified with Windows backslashes, as 
you would expect. However, paths specified within properties files must be specified with 
UNIX-style forward slashes. The example in the previous section correctly shows the 
command line using Windows-style backslashes to specify the bulkLoad.properties file. 
However, any paths WITHIN the bulkLoad.properties file must use forward slashes, such 
as: bulkLoader.partsDir=C:/BulkLoad_Test/CAD_files 
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bulkLoad.properties file 
The bulkLoad.properties file specifies the predefined bulk costing inputs required by the 
bulkLoad.cmd command.  
aPriori provides a sample file named bulkLoadTemplate.properties  at 
install\ext\analysis-purchasing-module\command-line\ 

Note that paths specified within this file must use UNIX-style forward slashes. In 
addition, you can add entries from the apriori.properties and the bulk loader 
plugin.properties (see below) which will override the values set in those files. Note that 
paths specified within these files must use UNIX-style forward slashes.  
 

Properties file entries Description 

bulkLoader.name= Corresponds to the Name field in the user interface. 

bulkLoader.partsDir=<directory of parts> Corresponds to the Directory field in the user interface. 
Note that this property and any other path properties in 
this file must be specified with UNIX-style forward 
slashes, such as C:/BulkLoad_Test/CAD_files 

bulkLoader.inputsFile=<input excel file> Optional - Corresponds to the Inputs File field in the user 
interface. 

bulkLoader.rollupName=<name of Rollup> Optional - Corresponds to the Rollup Name field in the 
user interface. Note: Must be specified when 
bulkLoader.watchpointXlsFile is set, or no report will be 
generated. 

bulkLoader.processingInputRule = 
<update|skip|create_new_scenario| 
clear_existing> 

Optional – Corresponds to the “Processing rule if scenario 
exists” drop-down box. 

bulkLoader.active=<true|false> Optional – Corresponds to the Active field in the user 
interface, which takes yes|no rather than true|false 
values. 

bulkLoader.official=<true|false> Optional – Corresponds to the Official field in the User 
Interfac, which takes yes|no rather than true|false values 
e. 

bulkLoader.onlyCostSpreadsheetCompone
nts= 
<true/false> 

Corresponds to the “Only cost components in 
spreadsheet” field in the user interface. 

bulkLoader.defaultProcessGroup= 
<default process group name> 

Corresponds to the Default Part Process Group field in 
the user interface. 

bulkLoader.defaultPartVpe= 
<default part vpe> 

Corresponds to the Default Part VPE field in the user 
interface. 

bulkLoader.defaultAssemblyVpe= 
<default assembly vpe> 

Corresponds to the Default Assembly VPE field in the user 
interface. 

bulkLoader.description=<text> Optional - Corresponds to the Description field in the user 
interface. 

bulkLoader.username=<username> Required if not entered on the command line, and if your 
site has not implemented Single Sign On to automatically 
use your logged-in Windows credentials. Otherwise 
specify your aPriori username.   
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bulkLoader.password=<password> This is the aPriori password used to log in to the 
application.  Not required if it has been entered on the 
command line, or if your company has implemented 
Single Sign On (SSO) to automatically use your logged-in 
Windows credentials. In summary, for SSO-enabled 
installations, leave username and password blank to have 
the Bulk Loader job run under the Windows username 
and password. 

bulkLoader.deployment=<deployment> Required. This must specify the name of the deployment 
you wish to connect to. 

bulkLoader.schemaname=<schemaname> Required.  Set this to point to the component schema 
associated with the deployment you specified above.  The 
schema must be configured in the aPriori database. 

bulkLoader.xmlFile= 
<previously exported bulk loader XML 
file> 

Optional - Set this to use an existing bulk loader file.  This 
is the same as Open Loader File functionality in the user 
interface. 

bulkLoader.watchpointXmlFile= 
<watchpoint input file> 

Optional - This is the name and path of the watchpoint 
input file. 

bulkLoader.watchpointXlsFile= 
<watchpoint output spreadsheet> 

Optional - This is the name and path of the watchpoint 
output report file. Note: If you set  this property, you 
must also set bulkLoader.rollupName or no report will be 
generated. 

plugin.properties file 
The Bulk Loader plugin.properties file is found in install\ext\analysis-purchasing-
module and affects both command line and UI-based  Bulk Costing. Although most of 
the settings in this properties file are documented by comments, you should only make 
adjustments to this file with the assistance of aPriori Customer Support.  
Note: As of aPriori Release 2015 R1, bulkload.batch.size has a new default value of 
"50" instead of "0", and is used in the following calculation to ensure that child processes 
cannot cause the parent bulk load process to hang: 
maxBatchSize * launcher.cost.timeout.seconds + 15 mins 
If this value is exceeded, the parent bulk loader process can kill any child process.  If this 
occurs, aPriori notifies you with a message similar to: 
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You can uncomment  bulkload.batch.size and set it to a positive value. "0" is no 
longer supported.  
Also note that as of aPriori 2015 R1 SP1, the Bulk Loader plugin.properties file contains 
a new property named bulkload.rmi.port (default value "1099")  This is a unique port 
number that the Bulk Loader uses to communicate with its children processes.   Don't 
change it unless you are running two instances of Bulk Loader concurrently on the same 
machine,  or the default port (1099) is already in use. You can also control cache 
cleaning behavior from this file. See the note in the table "Summary of aPriori 
Properties" in the System Administration Guide for more info. 

Running as a Scheduled Task 
If you want to run Bulk Costing and Analysis as a Microsoft Windows scheduled task (via 
the Windows Task Scheduler), then the task must be defined using one of the following 
options: 

 Run only when the user is logged on  
 Run whether user is logged on or not – If you choose this option, you must specify 

the domain user’s credentials and uncheck the “Do not store password. The task will 
only have access to local computer resources box.” The Bulk Costing and Analysis 
task will not run if you check the checkbox.  

You can invoke the Bulk Costing module using Windows command scripts to enable 
“lights out” automated costing of a batch of parts. For example, you may want a workflow 
that supports automated costing of all parts that meet specific criteria. Contact aPriori 
Support or Professional Services for more information. 

Bulk Costing Usage Reports (System 
Admins) 
The Bulk Costing and Analysis module provides a script-based Bulk Costing Usage 
Report to help you analyze how Bulk Costing and Analysis is being used within your 
organization.   
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Note: This section is intended primarily for aPriori System Administrators. You must 
have write permission to the aPriori installation to configure and run these 
reports. 

The Bulk Costing Usage Report captures Bulk Cost Events, whether they were  initiated 
through the Bulk Costing & Analysis user interface (via the Tools > Bulk Costing and 
Analysis menu item) or through the command-line script (see Running from the 
Command Line).  The report also includes Cost Events which are the total number of 
cost events generated through the aPriori Windows Client UI and the Bulk Costing & 
Analysis module.   
Bulk Cost Events, Cost Events and the number of Scenarios created are tracked by end-
user license.  

Notes:  
• Your company needs to be licensed to use the Bulk Costing and Analysis 

module.   
• The final count of various events will not be saved until you exit aPriori. For 

example, if you bulk cost 24 parts and immediately run a usage report, you 
might see only 20 bulk cost events recorded. If you exit aPriori and then rerun 
the report, you will see all 24 bulk cost events reported, 

This report is intended for tracking Bulk Costing usage. For general usage tracking to 
guide and monitor a deployment, aPriori recommends that you use the Scenario Activity 
and Usage Report available in aPriori Cost Insight.  These dashboards and reports have 
more detail on costing activity, including costing trends over time, details on specific 
components cost and the materials, VPEs, process groups and processes used in 
costing activity.  For more information, see the chapter on “Scenario Activity and Usage 
Reports” in the Cost Insight Guide. 
The Bulk Costing Usage Report is run as a command line script, not through the aPriori 
user interface. There are actually two versions of this script, which both reside in the 
aPriori installation directory (<aP_install>\bin): 

 createUsageReport.cmd – An editable version intended to be run manually. 

 createUsageReportCmdLineArgs.cmd – A version intended to be run from another 
script or as a scheduled task which passes in arguments at run-time. 

The two scripts are mostly identical except that the following settings are configured to 
accept command line arguments in createUsageReportCmdLineArgs.cmd : 

 set startDate=%1 

 set endDate=%2 

 set onlyRecordsAfterLastReport=%3 

 set usageReportPath=%~f4 

By default, these scripts create reports in <aP_install>\UsageReports. 

The rest of this section assumes that you are working with createUsageReport.cmd. 

Note: This report only includes Bulk Costing events that are generated using aPriori 
2016 R2 or higher.  Prior releases of aPriori tracked Cost Events, but did not 
track Bulk Costing events, so there is no data about them available for reporting 
purposes.   
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To configure and run createUsageReport.cmd 

1 Navigate to <aP_install>\bin  

2 Open createUsageReport.cmd in a text editor. 

3 To run the Usage Report for a specified timeframe --Set startDate and endDate 
values in the form MM/DD/YYYY and make sure onlyRecordsAfterLastReport is set 
to false.   
To run the Usage Report for costing activity since the time the report was 
generated --  Leave startDate and endDate blank and set 
onlyRecordsAfterLastReport to true. 
Save the file when done. 

4 Double-click createUsageReport.cmd  to run the report. 

The resulting report is created and saved by default in  <aP_install>\UsageReports.  
(You can specify a different target by editing usageReportPath in the .cmd file.) 

Understanding cost failures during bulk 
costing 
If any components failed to cost during your Bulk Costing session, aPriori will still create 
an “empty” cost component in the aPriori database that is mapped to that CAD model, 
but it will not contain actual geometric or cost information. Also, aPriori does provide a 
message window at the end of the Bulk Costing session which lists these components 
and a brief description of the costing issues for each. In some cases, these descriptions 
are abbreviated and there are additional ways to get more information about the cause 
of the failure. 
You can use the following approaches for investigating and handling costing failures 
after bulk costing: 

 Look in the resulting rollup. Components that failed to cost will be displayed with 
a red X icon in the Status column.  

 If you open a cost component and all the fields on the Cost Summary or 
Part/Assembly Details tab are null (a dash is displayed instead of numeric 
values), this typically means that no geometry information was extracted, and no 
costing occurred. 

 In some cases, it may help to first Delete the aPriori cost component from the 
aPriori database (using the Tools/Delete Components menu item), and then cost 
that single component individually using the main aPriori application instead of 
the Bulk Costing and Analysis module. For certain situations, better error 
messages are displayed that will help you diagnose geometry issues. The main 
aPriori application can also detect situations in which NX assemblies are 
modeled within a single “part” file and handle it as a part rather than an 
assembly. After individually costing problematic components, you can add them 
to a rollup if needed. 
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Improving performance 
To improve bulk costing performance, you (or your administrator) can experiment with 
different values for "bulkload.concurrent.loader.count=1" in the following properties 
file: 
<apriori_install> ext\analysis-purchasing-module\plugin.properties 

This controls the number of concurrent bulk load threads that aPriori will support. The 
value is limited by the number of CPUs (or CPU cores) that your computer has. If you 
specify more threads than CPUs, then the extra threads will simply wait for the other 
processes to complete, before running, and you won't see any additional performance 
benefit. Each thread by default will consume an additional 2 GB of memory, so carefully 
balance any performance gains against the load on your system. 
 



 

11 Spreadsheet 
Reports 

This section describes the reporting capabilities of aPriori. 

This chapter includes the following topics: 
 Introduction to aPriori Spreadsheet Reports  
 Excel and Google Sheets Compatibility 
 When to Use Spreadsheet Reports  
 System-Defined Spreadsheet Reports  
 Custom Spreadsheet Reports  
 Defining What You Want to Do  
 Elements of Report Files 
 PivotTables  
 Installing and Running Custom Reports  
 Running from the Command Line 
 Troubleshooting FAQ  
  XML Configuration File Reference 

 



 

Introduction to aPriori Spreadsheet 
Reports 
aPriori spreadsheet reports extract data from a scenario (part, assembly or rollup), and 
present it in an Excel spreadsheet.  
You can also generate XML and CSV (comma-separated value) output. aPriori provides 
a number of predefined reports from the Reports>Spreadsheet Reports menu option. An 
example of one of those predefined reports, the Component Sourcing Report, can be 
seen below. 

 
You can also define your own custom reports. 
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Custom reports are available from the same menu as the system-defined reports. 

 
You typically run these reports from the aPriori User Interface (UI), but you can also run 
them from the Command Line Interface (CLI). See "Running from the Command Line" on 
page 336. 

Note: aPriori uses an internal "watchpoint" mechanism to generate spreadsheet reports 
and populate them with variable and attribute values. This is why you will 
occasionally see this term when using report functionality. However, aPriori 
watchpoints have no relation to watchpoints that are used in conjunction with 
some debuggers.  

Excel and Google Sheets Compatibility 
In general, you should use a recent version of Microsoft Excel when working with 
Spreadsheet reports, and when creating custom reports with templates, you should use 
the same version of Excel for both creating and viewing the template. Check the System 
Requirements document for the version of Excel that aPriori has tested Spreadsheet 
Reports against (as of this writing, we have tested against Excel 2010). 
With the exception of the Component Sourcing report, all aPriori report templates are 
.xlsx files, so if you are using Excel 2003, you should upgrade to Excel 2010 when using 
.xlsx-based reports. 
Note that template-based reports work properly when the OS running the report supports 
the same version of Excel on which the spreadsheet report template is based. For 
example, if you build a spreadsheet report and create a template for it with Excel 2010, 
then you should use Excel 2010 to view it. Problems may occur  when the two versions 
are mismatched. You should not use Excel 2007, for instance, to open a template 
created on Excel 2010. 
It is possible to view aPriori Spreadsheet reports in Google Sheets, however you may 
need to unhide tabs that are hidden in the reports. If you open a report in Google Sheets 
and the display looks incomplete or incorrect, try the following workaround: 

1 Open the report in Excel. 

2 Right-click on the tabs and unhide them. 

3 Import into Google Docs 
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When to Use Spreadsheet Reports 

Generating reports as Excel spreadsheets can be convenient when you wish to share 
your data with other programs or organizations. Some aPriori customers use 
spreadsheet reports to combine their aPriori data with a PLM (Product Lifecycle 
Management) system. 
The ability to define your own reports and to change their format makes spreadsheet 
reports a very flexible tool for analyzing and exporting your aPriori data. 
The ability to run spreadsheet reports from the command line also means that you can 
automate report generation by creating scripts that run as Windows scheduled tasks. 

System-Defined Spreadsheet Reports 
When you install aPriori, you automatically have access to several pre-defined 
spreadsheet reports. These can be generated from the aPriori user interface or from the 
command line interface (see Installing and Running Custom Reports and Running from the 
Command Line). 

Note: The older PDF report feature  is deprecated and no longer available as of aPriori 
2015 R1. Also note that spreadsheet reports now support foreign currencies. 

The following reports are available: 
 

Report Description 
Assembly Summary 
Report 

Summarize the current part and process costs associated 
with the active assembly. 

Component Sourcing 
Report 

The Component Sourcing report makes it easy to compare 
aPriori cost estimates with supplier quotes. The report is 
available for parts and assemblies and provides 
manufacturing and cost information for each process in the 
selected manufacturing routing as well as for the whole 
component. 

Copy Welds Analysis 
Report 

Use this report to determine the success of a Copy Welds 
From.. operation (see  Virtual welds). This report is 
automatically generated when you perform the copy, and 
you can also generate it from scratch from this menu.  As 
with other reports, the data of most interest is found on the 
first tab ("Weld Diagnosis"). The other tabs contain raw data 
that is used to compile the diagnosis tab. Imported virtual 
welds retain the same weld IDs that they had in the source 
assembly. Any existing virtual welds in the destination 
assembly are discarded. Any CAD-defined (non-virtual) 
welds have IDs that start after the imported IDs so that they 
appear at the end of the weld list. 

Cost Comparison 
Report 

Compares the current costs for the parts, part scenarios, 
assemblies, and roll-ups included in the active comparison 



Spreadsheet Reports  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 320 

Cost Driver The Cost Driver report applies to parts or assemblies and 
contains several charts that provide insight into which types 
of costs dominate the overall cost and which processes and 
features (GCDs) are the most time-consuming and 
therefore costly. 

Machining Tool Usage 
Summary 

Provides a summary of the tools and their properties used 
to machine a part. 

Part Cost The Part Cost report shows the current cost of the 
processes associated with manufacturing the active part 

Roll-up Summary 
Report 

Compares the current costs for the parts, part scenarios, 
assemblies, and roll-ups included in the active roll-up 

Tooling Report The Tooling report applies to parts and presents tooling 
cost and tooling manufacturing detail breakdowns for the 
following process groups: 

• Injection Molding 

• Progressive Die 

• Tandem Die 

• Transfer Die 

• Stage Tooling 

All available process tooling reports are available as 
separate tabs in the same Tooling Report. 

All Components Cost 
Report 

Generates an Excel file which includes a row of information 
about all the cost components in the aPriori database.  
Note: This report is generated differently than the other 
spreadsheet reports, and has the following unique 
characteristics: 

• You must be an aPriori administrator to run this 
report 

• It has its own Reports menu item. It is not found 
under the Spreadsheet Reports menu item. 

Note: To accommodate components with extensive data, some reports reserve a 
minimum number of pages for the report summary.  For smaller components, 
some of these pages may be marked with "This page intentionally left blank".  
You can delete any such pages after the report has been generated. 

To generate a spreadsheet report from the UI 

1 Open a part, assembly, cost comparison, or roll-up in aPriori.  

2 Click Reports > Spreadsheet Reports. 

3 Select the report type from the drop-down menu. Click OK. 
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Note: You can run any report on any component, even if it is not logical. For 
example, you can run an Assembly Summary Report on an open part, but 
aPriori will flag the error in the summary block at the top of the report with a 
message in red such as "This report is only intended to be run on an 
assembly, this is a part". 

4 If necessary, edit the default values for the folder and file name for saving the report, 
.and click Save. 

5 Click Yes to view the report or No to close the window without viewing the report.  

Custom Spreadsheet Reports 
In addition to using aPriori's system-defined spreadsheet reports, you can define your 
own. It is often desirable to use existing, system-defined reports as your starting point. 
The system-defined report XML files reside in: 
apriori_install\ext\cost-watchpoint-report\watchpoints\ 
       reportname.watchpoints.xml 

The corresponding Excel template files resides in: 
apriori_install\ext\cost-watchpoint-report\watchpoints\templates\ 
       reportname.template.xls 

File types 
The typical spreadsheet report consists of an XML file defining the data to extract, and 
optionally, an Excel spreadsheet template file which determines how the output will be 
formatted. To install a new custom report in aPriori, you can either: 

 Compress these files into a .zip file and install it with 
 Tools>Spreadsheet Reports>Install Spreadsheet Reports 

 Simply copy the files into 
 user\apriori\version\watchpoint-report-defs   

 The output files will be either an Excel spreadsheet, or a comma-separated values 
(CSV) file, or an XML file. 

Report Definition Files 
.xml -- Required. Specifies what data to extract from aPriori. Name MUST end in 
".watchpoints.xml" or the report will be ignored when you try to run it from the UI (the 
restriction is not enforced when running from the command line). 
.xls (or .xlsx or .xlsm) -- Optional. Specifies how to format the data. The convention used 
by Tools>Spreadsheet Reports>Install Spreadsheet Reports is to end the name in 
".template.xls", and to place this file in a "template" sub-folder under the reports (.xml) 
folder. The template file must be specified with the templatePath attribute to the <report> 
tag in the .xml file, or it will be ignored. 
.zip -- The .xml file and the .xls (if defined) must be bundled into a .zip file to be 
recognized by the aPriori Tools>Spreadsheet Reports>Install Spreadsheet Reports 
command. 
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Report Output Files 
.xls (or .xlsx or .xlsm) -- The default spreadsheet output file. 
.csv -- A text output file containing comma-separated values. (Specified with a 
generateCsv="true" attribute to the <reports> tag in the XML definition file. 

.xml -- A text output file containing XML. (Specified with a generateXml="true" attribute 
to the <reports> tag in the XML definition file. 

For more information about the <report> tag and its attributes, See "Elements of Report 
Files" on page 324. 

Note: Custom reports are installed locally and are only available to the user who installs 
them. They are not available to other users even though they may share the 
same aPriori database server. 

Workflow 
The typical workflow for defining and running such custom reports is: 

1 Create an .xml file to return the results you want (see "Creating a Custom 
Spreadsheet Report" below). Optionally define an Excel .xls file to format the data 
the way you want. In the .xml file, make sure to define the <report> tag 
"templatePath" attribute to point to the current .xls file).  

2 Install the new report, either by copying the files to 
 user\apriori\version\watchpoint-report-defs, or by creating a .zip file from 
the modified .xml and .xls files and using 
Tools>Spreadsheet Reports>Install Spreadsheet Reports.  
(Copying a new report for the first time requires restarting aPriori; subsequent update 
copies do not.) 

3 Run the report with Reports>Spreadsheet Reports 
Note that you can also choose to run the custom report (or any system-defined report) 
from the command line. If you will always be running this report from the command line 
and never using it from the UI, you can skip the last two steps and generate the reports 
as described in See "Running from the Command Line" on page 336. 
When you install your custom reports, they reside in your local aPriori user folder, such 
as: 
C:\Users\myUserName\aPriori\14.1\watchpoint-report-defs 

They are NOT added to the aPriori system-defined reports in  
apriori_install\ext\cost-watchpoint-report\watchpoints 

Creating a Custom Spreadsheet Report 
When first starting with aPriori spreadsheet reports, it is best to begin with the simple 
snippets based on the samples shown in this document at the See "Elements of Report 
Files" on page 324 The system-defined spreadsheet report files that are installed as part of 
aPriori may contain advanced features that are not meant to be used for custom reports, and 
which are not documented. 



Spreadsheet Reports  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 323 

Defining What You Want to Do 
As with any coding activity, you should have a clear idea of what you want to accomplish 
with your custom report. If you simply want to re-format data that is presented in the UI, 
then you will probably focus on setting up the template Excel file so that it presents the 
data they way you want it.  
If you simply want to extract a handful of values that are not available in a single 
UI screen, and do not care much about the appearance of the data, you, may not even 
define a spreadsheet format file; just define a simple XML file that extracts the data you 
want and dumps the raw data into a new .xls file. 
If you are looking for an automated status report that runs every night, you will probably 
focus on extracting the data you are most interested in and executing the report 
generation from a command line script that kicks off as a Windows scheduled task. 
If you are looking to generate a common-format quoting report, you might start by 
identifying the quantities and expected costs for various models that can be presented in 
a uniform way, and also spend time with the Excel format to ensure that presents the 
data in a professional and intuitive way. 
Will your report require graphs? Plan to spend some time in the Excel template defining 
that graphics you want to include. 
Regardless of what specific purpose your report will serve, spend some time up front 
defining what you want it to do. 

Editing XML Files 
aPriori suggests that you use a text editor such as Notepad++ that provides contextual 
highlighting for editing XML files.  

Complexity 
Part of this evaluation process should consider the complexity of the report you want to 
create. Here are some factors to consider: 
Spreadsheet: 

 Easy -- Raw formatting 
 Medium -- Basic formatting 
 More difficult -- Charts, PivotTables®, graphics 

Type of data: 
 Easy -- Part level 
 Medium -- Process and Operation Level 
 More difficult -- GCD Level 

Availability of data: 
 Easy -- Already available as output in UI 
 Medium -- Can be calculated from available output 
 More difficult -- Needs to be custom-defined (probably for multiple processes) 
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Note: In general, if you can see it in the UI, you can access it for a spreadsheet report. 
However, you may encounter situations where this is not true. If you do run into 
this situation, please file a support ticket explaining what variable you cannot 
access from XML that you can see in the UI. 

To Generate XML or CSV Files 
If you want to generate XML or CSV (comma-separated values) files rather than a .xls 
spreadsheet, see the attributes for the <reports> tag as described at "<reports>" on 
page 342. 
  

Elements of Report Files 
A typical aPriori spreadsheet report consists of: 

 an XML (.xml) file that defines the data to be extracted from aPriori. 
 an optional Excel template file (.xls or .xlsx or .xlsm) that defines how the data 

should be formatted. 
 an Excel output file containing the extracted data (the actual "report"). 

Note that if no Excel template file exists, then the data will be dumped into the Excel 
output file with no formatting. For small reports, this may be sufficient. But more likely 
you will need to format the data with a template file to make the report usable. 
You can format your spreadsheet report with Excel PivotTables® for advanced 
formatting. And you can choose not to create a spreadsheet at all and instead dump out 
your data into a CSV (comma-separated values) file or an XML file. 
The data that you can extract from aPriori are generally variables that are defined as 
part of the aPriori software, or defined by a VPE creator as a custom output. 

Basic Structure of the XML File 
The following section gives a high-level overview of the contents of a typical aPriori 
spreadsheet report XML file. For more detailed information, see the XML Reference 
section starting at "XML Configuration File Reference" on page 340. 

<?xml version="1.0" encoding="utf-8"?> 
 <reports templatePath="templates/costdriver.report.template.xls" 
         traverseAssemblies="true"> 
   <CostModelWatchpoints sheetName="apOutput"> 
   </CostModelWatchpoints> 
   ... 
   <CostModelWatchpoints>...</CostModelWatchPoints> 
   </reports> 

 A <reports> tag can contain any number of <CostModelWatchPoints> tags, each of which 
represents a logical group of data to be generated. In the case of the data going to Excel, each 
<CostModelWatchpoints> section generates data to a single worksheet (named by the 'sheetName' 
attribute). For example: 

<CostModelWatchpoints sheetName="apOutput"> 
   <Node name="*" isLeaf="true" suppressZeros="false" tag="first"> 
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     <CSL> 
         <Formula>materialCost</Formula> 
         <Formula>laborCost</Formula> 
         <Formula>directOverheadCost</Formula> 
         <Formula>setupCostPerPart</Formula> 
         <Formula>expendableToolingCostPerPart</Formula> 
         <Formula>targetCost</Formula> 
     </CSL> 
   </Node> 
 </CostModelWatchpoints> 

The <reports> Tag 
 ( See "<reports>" on page 342 for a detailed reference.) 

 

The <CostModelWatchPoints> Tag 
(See "<CostModelWatchpoints>" on page 343 for a detailed reference.) 
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The <node> Tag 
(See "<node>" on page 345 for a detailed reference.) 

 

The <CSL> Tag 
(See "<CSL>" on page 345 for a detailed reference.) 
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The <Formula> and <Macro> Tags 
(See "<Formula>" on page 346 and <MACRO> for a detailed reference.) 

 

Commonly Used Variables 
Here are some commonly used variables that can get you started. 
For all components: 

 calculationDate 
 costedByUserFullName 
 selectedRoutingName – removes unnecessary optional-but-unused process 

names 
 displayName – shows process name correctly for User Defined Processes 

For parts 
 materialName 
 materialStockName 
 materialUnitCost – shows actual unit cost used in material calculation 
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For assembly sub-components 
 parentScenario 
 countInParent 
 “aggregates” = (individual value) x countInParent 

Note that this provides only the count for the current BOM depth. If you have the same 
part in multiple depths of the BOM, it will not output the total count in all BOM levels as 
one value, but rather it will be a value for each level. 

Built-in Aggregation, Quoted Cost and other Formulas/Attributes 
The following formulas/attributes are available for components, assemblies and rollups. 
For the aggregation attributes, consider the following example: Assembly1 consists of 3 
parts: 2 instances of Part A and one instance of Part B. Within Assembly1, 
"countInParent" of Part A is 2 and of Part B is 1. 
Now suppose that there is another assembly, Assembly2, that contains 2 instances of 
Assembly1. For Assembly1, in the context of Assembly 2, "countInParent" is still 2. The 
values of "countInParent" for parts A and B are the same as well. 
The following attributes are available at any level. You should use some subset of these 
if you set "generateStandardColumns" to false: 

 gcdType 
 gcdName 
 processName 
 nodeName 
 processGroupName 
 partNumber 
 scenarioType 
 scenarioName 
 vpeName 

Costs and weights work the same way as counts. So "aggregateCostInParent" for a 
given part is (fullyBurdenedCost + costOfChildScenarios)* countInParent. 
Note that"aggregateCost..." (and by extension "aggregateFinishMass") includes the 
(aggregate) cost of child scenarios for rollups and assemblies. Logically, the cost of child 
scenarios for mere parts is 0. 
Below is a list of the aggregated attributes: 

 parentScenario 
 parentScenarioType 
 countInParent 
 aggregateCost (aggregateFullyBurdenedCost) 
 aggregateCostInParent 
 costOfChildScenarios 
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 aggregateFinishMass 
 aggregateFinishMassInParent 
 finishMassOfChildScenarios 
 aggregateFullyBurdenedCost 
 aggregatePiecePartCost 
 aggregateToolingCostPerPart (ammortized tooling) 
 aggregateFixtureCostPerPart 
 aggregateProgrammingCostPerPart 
 aggregateAdditionalDirectCosts 
 aggregateExtraCosts 
 aggregateMaterialCost 
 aggregateOverheadCost 
 aggregateLogisticsCost 
 aggregateLaborCost 
 aggregateLaborTime 

Non ammortized aggregates: 
 aggregateCapitalInvestment 
 aggregateHardToolingcost 
 aggregateFixtureCost 
 aggregateProgrammingCost 

User Defined Attributes 
User-defined attributes are accessible directly. That is, a custom (or user-defined 
attribute) called "owner" would be accessible as "customAttributes.owner" 

Using the <Macro> Tag 
Use the Macro tag to generate formulas that will run in Excel. Only the subset of 
formulas supported by Apache POI is supported (see 
http://poi.apache.org/spreadsheet/formula.html).  
Example: 
<Macro Heading="bob">${fullyBurdenedCost}*${countInParent}</Macro> 

This will generate a column called "bob" that for each generated row contains the Excel 
formula "=$R1$C1 + $R1Rc2", where: 

  R1 is the value of the current row 
 C1 is the column name where fullyBurdened cost landed 
  C2 is the column where countInParent landed.  

http://poi.apache.org/spreadsheet/formula.html
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This assumes that you have specified that the report generator should generate these 
two columns within the same <CSL> tag. Note that the name that you use for a column 
should be the name of the Heading attribute if there is one. 
Other available syntax: 

 ${^<colHeading>} refers to the <colHeading> cell in the previous row (will 
map to 0 if this is the first row) 

 ${.<colHeading>} refers to the <colHeading> cell in the first row 

 ${@<colHeading>} refers to the column (the entire column) 

In addition, the report generator creates a named range that maps to the data values (it 
excludes the header row) for each column with the column header name. You can just 
refer to that name in your formula macro. 

Note: If a non-existent column is referenced in a macro formula, the value "0" is 
substituted. A non-existent column can occur if you have a Macro spec that 
references columns for which the current "Node/CSL" elements have as yet 
generated no rows. For example, assume that your Node spec is looking for all 
leaf nodes, only some of which have the custom output "foo". If you use "foo" in a 
macro formula, there will be no column for "foo" in the output spreadsheet until 
we actually hit a node that causes us to create one. 

Figuring Out What Variables to Use 
aPriori spreadsheet reports provide access to so many formulas and functions that it can 
be difficult to know what variable name to call for a particular value. These also tend to 
change from release to release, so any attempt to maintain a static reference list would 
quickly become obsolete. The most practical way to find the formula value that you want 
to use is to run a report that returns ALL formulas and functions. If necessary to identify 
the variable name for a specific value, you can temporarily set the value to something 
unique, run the report, search the report for that unique value, and identify the column 
under which it appears.  
Here is an example of a report that will return all formulas and functions for a given part.  

Note: This report can take a long time to execute if run against a large, complex part, or 
against many parts. Experiment with small parts first. Also, the report can return 
so many columns that Excel may display an "Unreadable content" error message 
when you open the spreadsheet. This error can be ignored. 

Also note the "templatePath" specifier in the <reports> tag. You easily can create a 
blank template file by saving an empty Excel spreadsheet as an .xlsm file. (For the 
purposes of this exercise, you don't need a real template.) Make sure that you save 
this blank template file in the specified folder, and that the name of the file exactly 
matches the name specified in the templatePath.  

<?xml version="1.0" encoding="utf-8"?> 
<reports traverseAssemblies="true" templatePath="templates\All aPriori 
Variables-template.xlsm"> 
    <CostModelWatchpoints sheetName="ap_output" isLeaf="true"  
hasChildren="false" revisitScenarios="true" 
generateOneRowPerAttribute="false" suppressRollups="false" > 
          <Node name="*" suppressZeros="false"> 
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               <CSL getAllFormulas="true" getAllFunctions="true"> 
               </CSL> 
           </Node> 
      </CostModelWatchpoints> 
 </reports> 

Including part images and nesting diagrams in your report 
You can include thumbnail images of parts, and (if available), nesting diagrams, in your 
reports, by adding the following attribute to the <Reports> tag in the XML file: 
generateThumbnails="true" 

In Excel, this will create: 
 a new tab called "Thumbnails" containing the images 
 a table in the cost summary sheet containing the mapping from the scenario 

name to the name of the image in Excel. 
In XML output, the <Scenario> element will have a "thumbnail" attribute with a reference 
to a .png file, which gets generated in the same directory as the XML. 
In CSV, we generate the .png files in the same directory as the .csv files. There is no 
reference in the CSV output to the .png files. 

Including information about scenario overrides 
As of aPriori Professional Release 2018 R1, you can now include information about 
scenario overrides in your spreadsheet reports. (For information about overrides, see 
Overriding computed values in Chapter 5.)  
To do this, you must: 

 Extend the scope of the data included in the report to include override data. 
 Format the data as desired.   

1 Add the following commands to the report’s XML file to include the user override data 
and specify the worksheet where data will be output.   
generateUserOverrides="true"  

overridesSheetName="<sheet name>" 

2 Modify the report’s Excel template file to format and display the override information 
as desired.  The override outputs will be generated in a standard format that can 
easily be processed using a pivot table (see the next section) to simplify formatting.  

Note: This capability is currently available only for custom spreadsheet reports.The 
standard spreadsheet reports that are included in the out-of-the-box aPriori 
installation have not been updated to include override data.. 

PivotTables 
One way to increase the usability of your aPriori spreadsheet reports is to enhance your 
Excel template files with PivotTables®. This is not an aPriori-specific topic, so this 
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section does not go into depth. You should go to Excel documentation for general Pivot 
Table information. But this section gives you an overview as to how to use PivotTables 
with aPriori data. 

When to use PivotTables 
Consider using PivotTables when you want to create relatively simple tabular or 
graphical views of your aPriori data. You can also use PivotTables to filter out a certain 
data point (or points) from the output data worksheet. 

 

To Define a PivotTable Template 

1 Create and install a spreadsheet report. 

2 Run the spreadsheet report on actual data. 

3 Open the output .xls file and use the Insert>PivotTable>PivotTable and/or PivotChart 
feature to define the range of data you want to use from the output tab. 

4 Refer to Excel on-line help for details about defining your PivotTable and PivotChart. 

5 Click PivotTable Options > Data and ensure that “Refresh data when opening the file is 
checked. 

6 Remove the output tab and ReportSummarySheet tabs. This is now your template. 

7 Update the templatePath of your watchpoints.xml file to reference the new Excel 
template. 

8 Install and run the report. 

To Use a PivotTable to Filter out Data 
To filter the PivotTable to display the information you want, you need to select a path 
that, when used, will only display the information you want. For example: 

1 Follow Steps 1 through 3 above in “To Define a PivotTable Template”. 
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2 In this case, you want to display the labor cost for the casting process in a report. 
Here is the data that is output when the report is run: 

 

3 Once you create the PivotTable with Insert>PivotTable>PivotTable, you can then start 
to create the path to display the information you want. The quickest path to display 
labor cost for casting is to first check off the box next to “Name” in the PivotTable Field 
List and to filter the “Name” column to show only information for Casting: 

 

4 Check off the “Labor (USD)” box to show the labor cost for the Casting process: 



Spreadsheet Reports  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 334 

 

5 The end result of the PivotTable should look like this: 

 
The report template can then read off of this cell for every time the report is run to 
then always show the labor cost for the casting process. 

Using More Filters 
This same method can be used for data outputs that require as many filters as you need 
in order to get only the information that you want to show. Below is an example of using 
more filters. In this case you want to display Labor Rate for the turret press process for 
the part name “AP_BRACKET_HANGER_EL0000.Initial”. 
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The red box above shows the path the PivotTable should take. 

 
After the three boxes above are checked off and the two filters are applied, the 
PivotTable displays only the labor rate for the turret press node for the selected part: 
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Installing and Running Custom Reports 
Once you have defined your XML report file and (optionally) your .xls spreadsheet 
template file, you can install them in one of two ways: 

From the GUI 

1 Compress them into a .zip file (typically via the Windows  
Send to>Compressed (zipped) folder command). 

2 Install the .zip file with Tools>Spreadsheet Reports>Install Spreadsheet Reports. 

3 Run the report with Reports>Spreadsheet Reports.  

By Copying 
Copy the files to  
C:\Users\myUserName\aPriori\version\watchpoint-report-defs 

Caveats 
 The installer recognizes only .zip files. Within the .zip file, only files with the 

following extensions will be installed: .xml, .xls, .xlsx, .xlsm. Any other file will be 
ignored. 

 Even if an XML file is successfully installed, it will not appear in the list of 
available reports unless the name ends in ".watchpoints.xml". A report named 
"report.xml" will not appear. A report named "reports.watchpoints.xml" will. 

 If you try to install a custom report with the same name as an existing system-
defined report, aPriori displays the error "The following reports already exist and 
were not installed" 

 If you install a custom report with the same name as an existing custom report, 
aPriori overwrites the older report. 

Define a shared store (System Admins Only) 
It is possible for a System Administrator to define a property so that custom spreadsheet 
reports are accessible by multiple users via a shared folder. 

1 Choose a shared folder that multiple users can access, and create a subfolder there 
named "templates". For example: 
F:\shared\apriori_reports\templates 
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4 Make sure that aPriori is not running, otherwise you might lose any changes to the 
properties file when you restart aPriori. 

5 Change to the folder C:\Users\<user>\AppData\Local\aPriori\<version>. 

6 In this folder you can make edits to one of two files: 
• apriori.user.properties  -- (This file gets overwritten every time you exit 

aPriori.) 
• apriori.system.properties – (This file does NOT get overwritten when you 

exit aPriori. This file may not already exist in this folder. If not, go ahead and 
create it.) 

Add the following entry to file, pointing to the shared folder that you created in Step 1 
above. For example: 
apriori.watchpoint.report.dir=F\:\\shared\\apriori_reports 

Note that you must preface special characters and spaces with "\", and that you do NOT want to 
include the “template” sub-folder in this line. 

7 Save the file you have just edited. 

8 Start aPriori. 

9 Click Tools > Spreadsheet Reports > Install Spreadsheet Reports. 

10 Navigate to the .zip spreadsheet report file(s) that you wish to share and click Ok to install them. 
When done, these files should exist in the shared folder you specified. 

11 For all users who should have access to shared reports, repeat Steps 2 through 6. 

12 For any of these users who have reports to contribute to the shared folder, ensure that thbye have write 
access to the shared folder, then repeat Steps 7 and 8. 

Running from the Command Line 
You can run spreadsheet reports from the command line. This means that you can 
include report generation in batch scripts and create reports without needing to bring up 
the aPriori user interface. This can be useful for automated status reports, or 
automatically feeding aPriori data into another application or database. 
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Reports run from the command line do not need to be installed in aPriori prior to use. 
You can simply specify the pathname to the .xml input and .xls output files. Note that you 
should specify any .xls template file with the "templatePath" attribute to the "reports" tag 
at the top of the .xml file. For example: 
<reports traverseAssemblies="true" 
templatePath="C:\aPriori_templates\report.template.xls">  

Otherwise the output .xls file will be unformatted; any existing content will be overwritten. 

runAprioriReport.cmd 
To generate spreadsheet reports from the command line, you run the 
runAprioriReport.cmd command, which is found in  
apriori_install\version\install\bin 

This command takes seven arguments which must be provided in the exact order shown 
below. Only the seventh (final) argument is optional. 

Syntax 
runAprioriReport.cmd co_type co_name xml_report_file xls_output_file  
   [ scenario_name ]username password  

Arguments 
co_type -- Cost object type: either part, assembly, rollup, or dynamicRollup . 

co_name -- Cost object name: 

xml_report_file -- The full pathname to the XML spreadsheet report definition file.  

xls_output_file -- The full pathname to the Excel file to be populated.  

scenario_name -- [Optional] If scenario_name is omitted, "initial" is assumed. 

username -- The aPriori log-in account name to use for this report session. 

password -- The associated aPriori password. 

Notes: 
1. The order of arguments has changed as of aPriori Release 2018 R1 for 
compatibility with Single Sign On (SSO): If the optional scenario_name 
argument is used; it must precede any username and password credentials. If 
you have existing scripts from release prior to 2018 R1, you must ensure that 
these arguments follow the new ordering when upgrading. 
2. If username and password are not specified as arguments on the command 
line, the report utility looks for them in the properties file. If not found there, and if 
your aPriori administrator has implemented Single Sign On (SSO), the report 
utility attempts to use the currently logged-in user’s Windows credentials. 

Examples 
To run a custom report named "XYZ" that resides in folder named C:\Files, from the 
command line, and generate an Excel file named "results" in the same folder, for a part 
named "r5": 
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runAprioriReport.cmd part R5 C:\Files\XYZ.watchpoints.xml 
C:\Files\results.xls initial user1 user1passwd  

To run the system-defined Cost Driver report from the command line and generate an 
Excel spreadsheet in a folder named "files", for a part named R6: 
runAprioriReport.cmd part R6 “apriori_install\ext\cost-watchpoint-
report\watchpoints\Cost Driver.watchpoints.xml” c:\files\results.xls 
initial user1 user1passwd  

Troubleshooting FAQ 
This section identifies some common issues you may encounter when running aPriori 
spreadsheet reports. 
Q: I've created an .xml report file, but I cannot install it using  
Tools>Spreadsheet Reports>Install Spreadsheet Reports. Why can't I install it? 
A: You need to compress the XML report file and its associated .xls template file (if any) into a 
.zip file before the Install command will recognize it. 
Q: I successfully installed my new report file, but I cannot see it in the drop-down menu 
when I use Reports>Spreadsheet Reports. Why? 
A: Ensure that the XML file name ends in ".watchpoints.xml". The Reports pulldown menu 
ignores any file that does not follow this convention. 
Q: I want to run a report but the Reports>Spreadsheet Reports menu option is greyed 
out. Why? 
A: You must have a part, assembly, or rollup open in aPriori before this menu option becomes 
active. 
Q: I have defined a spreadsheet template file and included it in my .zip file and 
successfully installed it. But when I run my report, the spreadsheet has no formatting -- 
just raw data. What's wrong? 
A: The XML file needs to explicitly specify the path to its template file with the templatePath 
attribute to the <report> tag. Ensure that this attribute exists and does not contain any typos. Also 
ensure that the extension is correct (.xls or .xlsx or .xlsm). 
Q: Where can I find a comprehensive list of all the variables I can use in these reports? 
A: See "Figuring Out What Variables to Use" on page 330. 

Q: I’m seeing some odd values in my reports, possibly related to formatting issues. Is 
there something that I am overlooking? 
A: If you are using Excel Version 2003, try upgrading to Excel Version 2010. The aPriori-
provided templates for all reports EXCEPT Component Sourcing 
(component.sourcing.report.template.xls) are 2010-compatible .xlsx files.  
Q: I successfully created and ran a custom spreadsheet report, but when I tried to open 
the spreadsheet, Excel displayed the following error: "Excel found unreadable content in 
<filename.xls>..." But I cannot see anything wrong with my XML file. What is causing 
this error? 
A: One subtle cause of this problem can be multiple instances of the same formula within 
different nodes, but with different upper- and lower-case conventions. For example, in the 
example below there is an instance of "aggregateCost", followed by a second instance spelled 
"aggregatecost": 



Spreadsheet Reports  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 340 

 <Node  name=" Progressive Die " isProcess="true" level="process" 
suppressZeros="false"> 
   <CSL> 
     <Formula> targetCost </Formula> 
     <Formula> aggregateCost </Formula> 
     <Formula> targetCostDelta </Formula> 
   </CSL> 
 </Node> 
 <Node  name=" Transfer Die " isProcess="true" level="process" 
suppressZeros="false"> 
   <CSL> 
     <Formula> targetCost </Formula> 
     <Formula> aggregatecost </Formula> 
     <Formula> targetCostDelta </Formula> 
   </CSL> 
 </Node> 
     

In this example, the different cases of the same formula (marked in red) will cause unreadable 
data to be output to the Excel file. This problem can be difficult to find, as the individual formulae 
will work fine without the conflicting formulae. The best way to avoid this is to ensure that the 
case used is consistent. 

XML Configuration File Reference 
Here is an example of an XML configuration file that defines an aPriori spreadsheet 
report.  
<?xml version="1.0" encoding="utf-8"?> 
 <reports templatePath="templates/costdriver.report.template.xls" 
traverseAssemblies="true"> 
   <CostModelWatchpoints sheetName="directCostsData"> 
     <Node name="*" isLeaf="true" suppressZeros="false" tag="first"> 
       <CSL>  
         <Formula>materialCost</Formula> 
         <Formula>laborCost</Formula> 
         <Formula>directOverheadCost</Formula> 
         <Formula>setupCostPerPart</Formula> 
         <Formula>expendableToolingCostPerPart</Formula> 
         <Formula>targetCost</Formula> 
       </CSL> 
     </Node> 
   </CostModelWatchpoints> 
   <CostModelWatchpoints sheetName="cycleTimeData"> 
     <Node name="*" isLeaf="true" suppressZeros="true" tag="2nd"> 
       <CSL> 
         <Formula>cycleTime</Formula> 
       </CSL> 
        <OperationNodes > 
               <Node name="*" isLeaf="true" suppressZeros="true" 
                    tag="3rd"> 
                <CSL> 
                   <Formula>cycleTime</Formula> 
                </CSL> 
                  <GcdTypes> 
                    <Gcd name="*"/> 
                    <Gcd name="CurvedWall"><Attribute>direction 
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                       </Attribute></Gcd> 
                  </GcdTypes> 
               </Node> 
         </OperationNodes> 
      </Node> 
   </CostModelWatchpoints> 
 </reports> 

Column Headings 
If the generateOneRowPerAttribute attribute on the CostModelWatchPoints element is 
set to “true”, each worksheet into which data is output contains the following columns. (If 
set to “false”, then columns for each value that would have appeared under the “formula” 
column are added to the spreadsheet.) 

 bomLineNumber -- This is a number starting from 1 (from 2 in the case of rollups) 
that is unique to each part/assembly for which rows are generated. 

 bomDepth -- begining with "1" this number is incremented by one for each level 
in an assembly/rollup. Thus, immediate children of a top-level assembly will be at 
level 2, their children will be at 3 and so on. 

 Part Number -- Self-explanatory. 
 Cad File Name -- Self-explanatory. 
 Scenario -- Default is “initial”. 
 ScenarioType -- Rollup, part, or assembly. Note: Since aPriori doesn't generate 

any data for rollups other than the parts and/or assemblies that they contain, 
"rollup" never actually appears. 

 ScenarioFullName – When generateStandardColumns=”true”, output format is 
“partNumber.scenarioName”. If generateStandardColumns=”false”, the line  
“<Formula Heading="ScenarioFullName">displayName</Formula>” returns 
“partNumber.scenarioName” for virtual parts, and the Node value of process 
group/routing (e.g., ”Sheet Metal/Machining”) for a costed CAD part.  Consider 
using “<Formula>componentName</Formula>” instead. 

 VPE -- This is blank if the row represents a gcd attribute value. 
 ProcessGroup -- This is blank if the row represents a gcd attribute value. 
 Process -- The process or operation name from which the cost output has been 

generated. This is null if the row represents a gcd attribute/value 
 Level -- One of "component", "process" or "operation". 
 Leaf -- Boolean value. Set to true if the process/operation is a leaf node in a 

template. 
 HasChildren -- Boolean value. Set to true if the process/operation has child 

operations for which data has been output in this report. Note that this is a value 
that is computed while the report is being generated, not from the process model. 
Use this if your output includes, for instance, both "3 Axis Mill" and "Milling" and 
you want to create a pivot that picks up just "milling" or just "3 Axis Mill". 

 Node -- The name of the Node represented by this row in the report (blank for 
gcds). 



Spreadsheet Reports  aPriori User Guide 

aPriori Professional 
2019 R2 aPriori Confidential 342 

 GcdType -- The type of the gcd represented in this row. This could be either the 
gcd type for the operation from which we're grabbing an output or the type of the 
gcd who's attribute we're printing out. 

 Gcd -- The name of the actual gcd 
 Gcd Display Name -- Self-explanatory. 
 CostView -- The costview from which this report was generated ("current", "last 

saved", "previous"). Will generally be "current". 
 Tag -- The value of the tag generated for this row (see below in the xml language 

spec). 
 formula -- The name of the formula (or gcd attribute) represented by this row. 

(not present if generateOneRowPerAttribute is set to false) 
 Value -- The value represented by the row. (not present if 

generateOneRowPerAttribute is set to false) 
Again, if the generateOneRowPerAttribute attribute on the CostModelWatchPoints 
element is set to false, then the formula and Value columns are replaced by a single row 
for each node or GCD, containing columns for each specified attribute. 

<reports> 
Attributes: 

 templatePath - the relative file path to the Excel template to be used as the basis 
for generating data. If this is blank, no template is used.  

 traverseAssemblies -- if true, the data generation will traverse into assemblies 
generating date not only for the assembly itself but for contained subassemblies 
and parts (this is exhaustive and there's no way to specify how many levels down 
to go at this point). 

 generateXml -- if true, the report output will be generated as an XML document 
as opposed to an Excel spreadsheet. 

 generateCsv -- if true, the report output will be generated as a comma-separated 
values (CSV) document as opposed to an Excel spreadsheet. 

 useTabSeparator -- When used with generateCsv, the columns will be separated 
by tabs rather than commas. 

 outputDir -- full path to the directory the output will be saved in, this will be used if 
the directory exists and the user doesn't change the directory through the file 
chooser. 

 outputName -- save name of the file, this will be used if the user doesn't modify it 
in the file chooser. 

 promptSave -- defaults to true; if false, no dialogs are displayed after selecting 
the report to generate. outputDir must be specified if this is set to false. Since the 
file chooser usually handles overwriting but is now suppressed, files sharing 
names will be saved as duplicates (foo(1).xls, foo(2).xls, etc.). WARNING: as 
part of suppressing the "Would you like to view the report?" dialog, error dialogs 
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are also suppressed, so the user needs to be aware of any reports that don't 
generate. 

 fileExtension -- specify .xls, .xlsx, or .xlsm for Excel reports, this will be forced. 
templatePath extensions will always take precedence over this property. 

 appendDateToOutput -- if true, concatenate a date timestamp onto the end of the 
file before the extension. 

 dateFormat -- customize formatting for the date timestamp, such as "yyyy-MM-
dd_hh-mm-ss" 

Notes about generateCsv: If both generateXml and generateCsv are set to true, 
XML takes precedence. 
If you set the generateCsv to true, a .csv file will be generated for each 
<CostModelWatchPoints> element. The name of the file will have the sheetName 
appended to the name that you give to the file in the UI. The contents of the summary 
tab will end up in a file that just contains the root filename. 
For example, if you select "myPartCostTracking.csv" as the filename, then 
myPartCostTracking.csv will contain the summary tab, while 
myPartCostTracking_sheetName.csv will contain the data that would have gone into 
sheetName had this been Excel output. 
Both CSV and XML output is streamed to disk so unlike Excel does not build any in-
memory structures before writing the data to disk. 

Child Elements: 
<CostModelWatchpoint> (one or more) 

<CostModelWatchpoints> 
Attributes: 

 sheetName -- The name of the tab into which to output the data. This is a 
required attribute. aPriori recommends that you use "ap_output" as a default. 

 rangeName -- The name of the "named range" to create in Excel representing 
the data output by this CostModelWatchpoint element. If rangeName is null, a 
range will be created using sheetName. 

 generateOneRowPerAttribute -- If set to "false", the spreadsheet will contain one 
row per node or gcd with the attribute values as separate columns rather than 
one row per attribute/value pair. 

 revisitScenarios -- If set to "true", the system will not filter out duplicate visits to 
scenarios. This could occur while traversing assemblies for example, and if what 
you want to do is aggregate costs or deal with counts of scenarios in an 
assembly or rollup you will have to revisit them. (more about aggregation 
attributes below). 

 suppressRollups -- If set to true, the system will not generate a row for the rollup 
itself in the cost outputs. 
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 generateStandardColumns -- Defaults to true. If set to False, the system will not 
generate the standard set of columns and it is up to the report author to make 
sure that there is enough key information in each generated row to make 
appropriate distinctions. Attributes that get generated as standard outputs can 
now be named explicitly and generate the following columns: 
o  bomLineNumber  
o  bomDepth  
o  Part Number  
o  Scenario  
o  ScenarioType  
o  ScenarioFullName  
o  VPE  
o  ProcessGroup  
o  Process  
o  Level  
o  Leaf  
o  HasChildren  
o  Node  
o  GcdType  
o  Gcd  
o  Gcd Display Name  
o  CostView  
o  Tag  

 generateFailedOperationResults -- Defaults to false. If true, data for failed 
operations is generated. 

 generateSetupAxes -- If you want to generate rows to represent all the setup 
axes in the part, set this to true. You cannot select which attributes to get out of 
setup axes: you get all of them. 

 generateDtcMetrics – Defaults to false. If true, all Design to Cost (DTC) metrics 
appropriate for each scenario will be output on the component row where they 
can be accessed for Cost Insight Report Ad Hoc reports. Has no effect on OOB 
Reports. 

 outputDuplicateProcAndOpData -- If you want to generate duplicate rows for 
process & operation output, revisitScenarios must be set to true for this to have 
any affect. 

Child Elements: 
<Node> (one or more) 
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<node> 
Attributes: 

 name - the name of the process/operation for which this node specification 
applies. "*" means all nodes. 

 processGroup - the name of the process group for which this operation applies. 
Defaults to all. 

 isLeaf - if true, only generate the specified output for leaf nodes 
 level - one of "component", "process", "operation" - not relevant yet (future 

expansion) 
 tag - optionally, the tag to generate for each row within this Node spec. Note that 

if the node spec contains another node spec by virtue of OperationNodes, then 
the embedded node spec will not inherit the tag value of this node. 

 isProcess - if true, only nodes that represent processes will be processed 
 isOperation - if true, only nodes that represent operations will be processed. 

Child Elements: 
<CSL> (only 1 allowed) 

<OperationNodes> (only 1 allowed) 

<GcdTypes> (only 1 allowed) This works whether it is in a <Node> within an 
<OperationNodes> element. If it isn't within <OperationNodes>, the only 
relevant <GcdType> will be Component. 

<OperationNodes> 
Attributes: 
None 

Child Elements: 
<Node> (one or more) 

<CSL> 
Attributes: 

 getAllFormulas - if true then no <Formula> child nodes are needed, and a row will 
be generated for every single cost model output for the current node. 

 suppressZeros - no row will be generated for any <Formula> that has a value of 0. 
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 suppress - if true, no CSL outputs will be generated for the current node. 

Child Elements 
<Formula> 

<Macro> 

<Formula> 
There can be zero or more <Formula> elements as children of the <CSL> element. The 
value of each element must be the name of an output for which a row should be 
generated. 

Note: It is impractical to list all the possible formula values. To extract a list of all valid 
formula values for the current node, run a report that specifies the getAllFormulas 
attribute to the <CSL> tag. See "Figuring Out What Variables to Use" on page 330.  

Attributes: 
Heading -- If supplied, this becomes the column heading if generateOneRowPerAttr is 
TRUE, or it becomes the value of the "attribute" column if generateOneRowPerAttr is 
false. If no heading is supplied, the formula (attribute) name is used as the heading. 

<MACRO> 
 Specify an Excel formula to be output. Can be used within both the <CSL> and <Gcd> 
tags.  

Attributes: 
Heading -- If supplied, this becomes the column heading if generateOneRowPerAttr is 
TRUE, or it becomes the value of the "attribute" column if generateOneRowPerAttr is 
false. If no heading is supplied, the formula (attribute) name is used as the heading. 

<GcdTypes> 
The <GcdTypes> element (which is always a child of a <Node> and potentially a sibling to 
a <CSL> node) serves two roles: it specifies which (or possibly all) the Gcds for which 
CSL outputs are to be generated, but can also specify which Gcd attributes should be 
generated into the current sheet as well. 
One can have a <Node> element with only <GcdTypes> as children. (In fact, one can use 
this approach to create a worksheet with just GCD attribute values and no CSL output 
values). 

Attributes:  
None 
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Child Elements: 
<Gcd> 

<Gcd> 
Attributes: 

 name -- the name of a Gcd type (such as "CurvedWall" or "PlanarFace"), or "*" 
for all. 

 getAllAttributes -- specifies that you want every attribute output for the Gcd. 
Analogous to getAllFormulas in the CSL element. 

 generateRelations -- if true, a row is generated for each relation that this gcd has. 
There is no way to specify which attributes. The code generates them all.  

ChildElements: 
<Attribute> is an exact analog of the <Formula> element inside a <CSL> construct. 

<Attribute> 
This performs the same function for the <Gcd> tag that <Formula> performs for the <CSL> 
tag.  See "<Formula>" on page 346 for more information. 

Note: It is impractical to list all the possible attribute values. To extract a list of all valid 
gcd attribute values for the current node, run a report that specifies 
"getAllAttributes="true"" to the <gcd> tag. 
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Glossary 
Actual Tool A tool that is either available at the machining area being modeled or 

available in a machine tool catalog. Actual tools usually have a make 
(for example, Kennemetal) and a model (for example, Corobore 860). 
A particular model is available in a series of sizes (usually diameters). 

Amortized 
Investment 

The amortized sum of all fixed costs. Fixed costs must be incurred 
before the start of production. In aPriori, all fixed costs are amortized 
to the individual part or assembly by dividing the total, up-front cost 
for the fixed cost (the capital cost) by the Total Product Volume. 

Annual 
Volume 

The total number of parts or assemblies of a specific design produced 
in one year. 

Arc Welding A welding process that uses the concentrated heat of an electric arc 
between an electrode and the base material to melt the metals at the 
welding point. Depending on the material to be welded, either direct 
or alternating current may be used for the arc, and consumable or 
non-consumable electrodes. 

Assembly 
 

An assembly of parts as defined by the MCAD system part/assembly 
tree. Normally, an assembly has more than one part. Technically, 
however, the MCAD system might allow an assembly with only one 
part. Parts in assembly are oriented to one another and secured by 
an assembly process, such as welding or snap-fit. An assembly cost 
object comprises the costs of all the member parts or sub-assemblies 
associated with it, as well as the cost of the orientation and securing 
of the members in the assembly. Costs of assembling the sub-
assembly components are included in the total cost of those 
components. 

Batch Size The number of parts in a Set-up Batch. Typically, batch sizes 
represent one month of sales. 

Bounding Box A prismatic box enclosing the final part shape. The orientation of the 
bounding box determines the minimum stock size and the orientation 
of the part within the stock.  

Bulk Removal 
Factor 

A value used to compute the diameter of the default bulk removal tool 
and the characteristics of the bulk removal skin. 

Cache See "Document Cache". 

Capital 
Investment 

The total amount a company must invest in fixed costs before the first 
part or assembly can be made. This cost is 'fixed' because the 
company incurs the cost whether it makes one part or the total 
number of parts allowable before tooling must be refurbished or 
replaced. 

Casting The process of forming an object by pouring material into a mold, 
where it solidifies. Also, the process of forming a film or sheet by 
pouring a liquid onto a moving belt or by precipitation in a chemical 
bath. 
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Cavity The space inside a mold into which material is injected. 

Computer-
Aided Design 
(CAD) 

Software applications that enable interactive engineering drawing and 
electronic storage of mechanical designs including geometry, physical 
configuration, materials of construction, etc. 

Cost 
Comparison 

A tabular list of each member of the Comparison (rows) and the 
associated cost/time information (columns). 

Cost 
Estimating 

The process of calculating the probable cost of a product or service, 
including labor, material, vendor/supplier costs, and applicable rates 
and factors. 

Cost Object 
 

An entity that has costs associated with it. aPriori has three different 
types of cost objects: parts, assemblies, and Cost Roll-ups. 

Cost of Goods 
Sold (COGS) 

The direct expenses incurred in producing a particular good for sale, 
including the actual cost of materials that comprise the good, and the 
direct labor expense in putting the good in salable condition. COGS 
does not include indirect expenses such as office expenses, 
accounting, shipping department (although it may contain shipping 
costs), advertising, and other expenses that cannot be attributed to a 
particular item for sale. COGS for a manufacturing company will 
include things like basic materials plus the costs of production, 
supplies, and labor. 

Cost per Part Cost of tooling amortized at an individual component (part or 
assembly) level by Total Production Volume. 

Cost Roll-up A list of components (parts and assemblies) and their associated 
costs/times. 

Cost Target The cost target for the component (part or assembly) 

Cost 
Taxonomy 

The structure and linkages within aPriori that describe different Cost 
Categories. The Cost Taxonomy is canonically defined by aPriori. All 
parts of the Cost Taxonomy are linked; however, not all are directly 
additive. The Cost Taxonomy is the “architecture” of cost in aPriori. 

Currency A unit of cost. The default currency is US dollars.  

Cycle Time The actual time that a machine/process is operating on a given 
component (part or assembly). 

Die Casting A metal shaping process in which molten metal is forced into a 
reusable mold and held under pressure until it solidifies. 

Direct 
Overhead 

Costs associated with manufacturing of a specific part on a machine, 
such as, the machine's power costs, depreciation, maintenance, and 
so on, based on time. 

Document 
Cache 

A folder in which VPE information is saved from the database. This 
cache improves the performance of aPriori, especially when the 
clients are not located within the same LAN as the database server. It 
eliminates the need to extract large amounts of data from the 
database each time a part is costed. See the aPriori System 
Administration Guide for information about doc cache cleaning 
options. 
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Exchange 
Rate 

Refers to the factor applied to equate one currency amount to another 
currency amount. For example, 1 USD = 1.1895 Euro. 

Expendable 
Tooling 

Tooling that is consumed during manufacturing, but not tied to a 
specific part. For example, a drill bit, turret press punch, etc. is used 
in the manufacture of many different part designs. 

External 
Groove 

A circular continuous channel cut into an external feature of a part. 

External 
Thread 

A thread that is formed on an external feature of a part. 

Extraction The use of a solvent to remove (extract) one or more components 
from a mixture; generally, the process of removing a desired or 
undesired constituent. 

Extrusion The process of forming rods, tubes, or other continuously formed 
pieces by pushing hot or cold semisoft solid material through a die. 

Facility The selection name for a Virtual Production Environment (VPE). 

Fixtures and 
Jigs 

Devices used to hold a part or an assembly in the correct orientation 
on a machine during manufacture or assembly. Fixtures and jigs 
under the Fixed Cost category are created for a specific design. It is 
assumed that these fixtures will not be re-used on a different design 
in the future. 

Forging A process where the desired shape is accomplished by forming in 
presses, hammers, rolls, upsetters, and related machinery to deform 
the workpiece. 

Forming The process that produces a useful shape by making any change in 
the shape of a metal piece which does not intentionally reduce the 
metal thickness. The term covers all operations required to form a flat 
sheet into a part, including deep drawing, stretching, bending, and 
buckling in the context of sheet metal. 

Geometric 
Cost Driver 
(GCD) 

A geometric attribute in the solid model of a component (part or 
assembly) that drives cost on the manufacturing floor. A GCD may be 
a discrete concept such as the thickness of sheet metal or the 
finished mass of a cast part, or it may be a high level human 
geometrical concept such as a bend, hole, pocket, fillet, draft angle, 
etc. 

Grinding The process that removes material from a workpiece using a grinding 
wheel or coated abrasives. 

Grooving A process in which grooves are cut to a specified depth in one pass 
by a form tool. Grooving does not sever a complete section from the 
workpiece. 

Hard Tooling Capital or hard tooling are tools that are purchased for creating one 
specific design and cannot be used to create other designs. 

Hot Runners Runners that are insulated from the chilled cavities in a mold and are 
kept hot. Hot-runner molds make parts that have no scrap. 
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Injection 
Molding 

A shaping process in which thermoplastic material is fed into a heated 
barrel, mixed, and forced into a mold cavity, where it cools and 
hardens to the configuration of the mold cavity. 

Internal 
Groove 

A circular continuous channel cut into an internal feature of a part. 

Internal 
Thread 

A thread that is formed on an internal feature of a part. 

Labor Cost The amount that labor is paid to manufacture the part or assembly. 
During the building of a VPE, the customer determines which 
components of labor compensation are included in the labor rate that 
is used to calculate labor cost. However, labor cost usually includes 
hourly wages and benefits. 

Labor Time The time that a person is paid to perform an operation/process on one 
component (part or assembly). 

Lifter A mechanism for raising a part in a die or mold to a height for 
advancing it to another station, or for ejecting it from the die or mold. 

Machine The aPriori representation of a physical machine in a manufacturing 
facility. 

Machining The process in which a shape is generated by removing unwanted 
material. Shape restrictions exist for some machining processes. For 
example, turning can only produce axisymmetric shapes. 

Machining 
Operation 

An action performed as part of a machining technique. Typically, an 
operation is performed with a single tool. 

Machining 
Technique 

A description of the method used to manufacture a GCD. Some 
GCDs, such as holes, may be manufactured with a variety of 
techniques, each technique having its own scope of use and 
advantages. A machining technique typically requires one or more 
manufacturing operations to be performed. 

Manual Arc 
Cost 

The cost associated for a person to perform only the arcing to MIG 
weld one assembly. 

Manual Arc 
Time 

The time for a person to perform only the arcing to MIG weld one 
assembly. 

Manual Cycle 
Time 

The time for a person to perform all the tasks to weld one assembly 
(for example, loading, clamping, arcing, etc.). 

Manual Spot 
Cost 

The cost associated for a person to perform only the arcing to spot 
weld one assembly. 

Manual Spot 
Time 

The time for a person to perform only the arcing to spot weld one 
assembly. 

Material The chemical composition/alloy/name of the material of which a part 
is made. 

Material 
Composition 

The specific chemical composition of the material in industry standard 
terms (for example, ANSI spec, such as 1020 Hot Rolled Q1). 
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Material Cost The cost of the physical material used in the manufacture of the part. 
Material Cost includes both the material in the physical part and an 
allocation of scrap material that is wasted during the manufacturing 
process. Material cost does not include consumable material (for 
example, weld wire, adhesives, etc.), only primary material. 

Material Stock The physical size of the piece from which a part is made (for example, 
sheet size for sheet metal, rod diameter and length for a shaft). For 
net form processes such as injection molding and casting, sizing is 
not applicable. 

Material Type The general class of metal (for example, Steel, Nylon, Brass, 
Aluminum, etc.). Although type is really a parent class, it functions as 
an attribute of composition in aPriori, rather than its parent. 

Material 
Utilization 

A measure of waste in manufacturing defined as: 
Gross Mass of a Part \ Rough Mass  

Mechanical 
Computer-
Aided Design 
(MCAD) 

Refer to Computer-Aided Design (CAD). 

MIG Gun 
Manipulation 
Cost 

The cost associated with manipulating the MIG gun. 

MIG Gun 
Manipulation 
Time 

The time allowance for a person to move between welds, clean, and 
manipulate the MIG gun. 

MIG Welding Metal Inert Gas (MIG) welding is often referred to as wire-feed 
welding. It is a commonly used high deposition rate welding process. 
During the welding process, wire is continuously fed from a spool. 
MIG welding is sometimes referred to as a semi-automatic welding 
process. 

Milling A cutting process in which material is removed from a workpiece by a 
rotating tool. 

New Product 
Introduction 
(NPI) Process 

The process of introducing new products to market. It spans the entire 
product life cycle from initial identification of market/technology 
opportunity, conception, design and development through to 
production, market launch, support, enhancement and retirement. 

Non-
Geometric 
Cost Driver  

A driver of part or assembly cost not directly tied to geometry. 
Examples include the factory of the supplier at which the part is 
made, selected routings, selected machines, production volume, and 
so forth. 

Number of 
Years 

The number of years that the component (part or assembly) will be 
produced. 

Other Direct 
Cost 

Other costs that can be specifically associated with the manufacture 
of a given design. In contrast, indirect cost or period overheads (not 
covered in aPriori) are expenses such as rent or lighting that are not 
easily allocated to a specific design. In an accounting system, direct 
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costs typically become part of Cost of Goods Sold, whereas indirect 
costs are expensed every financial period as part of Sales, General, 
and Administrative (SG&A) expense. Other direct costs could be 
preventative maintenance expenses tied to a given machine, a 
material handling additive, and so forth. 

Part A single component that cannot be further subdivided into other cost 
object, as opposed to an assembly. 

Part Number The unique component (part or assembly) identifier, typically specified 
as the CAD file name.  Note that this may or may not actually include 
a part number. 

Parting Line The location where two mold halves meet when they are closed. 

Piece Part 
Cost 

The marginal cost associated with making “one more” part of a given 
design. Piece part cost includes all Variable Costs associated with a 
parts creation but does not include depreciation of capital tooling. It 
does include expandable tooling. 

Pocket 
Removal 
Factor 

Used to compute the pocket roughing tool diameter and the 
characteristics of the pocket's removal skin. 

Process The type of manufacturing process that a machine performs (for 
example, Laser Cut, Standard Press, Plasma Cut, and so forth). Each 
machine has a process type and there may be many machines of the 
same process in a given Virtual Production Environment (VPE). 
aPriori uses three letter codes to denote processes (for example, Cut-
to-Length = CTL, Laser Cut = LAS, and Bend Brake = BND). 

Process Cost The cost associated with a particular type of manufacturing process 
that a machine performs. 

Process 
Formula 

The aPriori logic and formulas that read Geometric Cost Drivers 
(GCDs) and non-geometric cost drivers as input in order to calculate 
time and cost. 

Process Group A group of processes of the same manufacturing type. For example, 
the Sheet Metal process group includes such processes as Laser 
Cut, Bend Brake, Shear, and so forth. Parts may often be completely 
manufactured using processes in one process group only. Other 
times a part or an assembly will require multiple process groups (for 
example, Casting, Machining, and Surface Treatment). 

Process 
Routing 

A sequence of processes that are used in sequence to add a group of 
manufacturing features to a part, and often, to complete the 
manufacture of a given part or sub-assembly (for example, 
CTL/LAS/BND). 

Procurement The body of activities and processes associated with acquiring 
materials, goods, and services to support the operation of the 
enterprise. 

Programming 
Time 

Many modern machines are Computer Numerical Control (CNC) 
machines that follow a computer program to make or assemble parts. 
A program needs to be created once (therefore, it is part of Fixed 
Cost). 
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Robot Arc 
Cost 

The cost associated for a robot to perform only the arcing to MIG weld 
one assembly. 

Robot Arc 
Time 

The time for a robot to perform only the arcing to MIG weld one 
assembly. 

Robot Cycle 
Time 

The time for a robot and its operator to perform all the tasks to weld 
one assembly (for example, loading, clamping, arcing, etc.). 

Robot Spot 
Cost 

The cost associated for a robot to perform only the arcing to spot weld 
one assembly. 

Robot Spot 
Time 

The time for a robot to perform only the arcing to spot weld one 
assembly. 

Rough Mass 
or Weight 

The mass of all the material that was needed to get to the final state 
of the part. The sum of Finished Mass + Gross Part Mass + Mass of 
Stock Scrap. 

Routing 
Entries 

The list of Process Routings associated with a Virtual Production 
Environment (VPE). 

Routing 
Formulas 

Refer to Routing Rules. 

Routing Rules The heuristics (typically Boolean) that help aPriori to determine if a 
Process Routing is capable of manufacturing a given cost object by 
looking at the physical capabilities of a machine. For example, if a 
Sheet Metal Process Routing contains a Turret Press process, aPriori 
verifies that at least one of the turret presses in the Virtual Production 
Environment has the force to punch through the given thickness of 
the sheet metal. If not, this Process Routing is eliminated from the 
analysis. 

Scenario An instance of a Full Cost Driver Record that is dynamic (that is, non-
geometric cost drivers can be modified to regenerate cost completely 
independent of CAD). In addition, it can have new GCDs applied to it 
and be evaluated with the current set of non-geometric cost drivers. 

Scrap Scrap is unused material that is commonly thrown away as useless 
material or sold to a scrap merchant. Scrap may be part scrap 
(considered inherently part of the material needed to produce the 
part) or stock scrap (scrap that is not “part of the part” - for example, 
internal holes, that could possibly be used for other parts). 

Set-up Batch The number of parts run before machines must be set up for new or 
different parts. 

Set-up Cost 
per Part 

The cost to set up a machine for a new batch of parts. 

Set-up Time The time to set up a machine for a new batch of parts. 

Set-ups The cost in machine downtime and labor incurred when a machine is 
configured to run a batch of a given design. This cost is amortized to 
individual parts or assemblies by the number of parts in a batch. 

Side Cores Used when molding parts in cavities not perpendicular to the direction 
in which the part is ejected from the mold. The cores are 
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automatically pulled from the mold prior to the mold opening and 
reinserted when the mold closes again and prior to injection.  

Spot Gun 
Manipulation 
Cost 

The cost associated with manipulating the spot-welding gun. 

Spot Gun 
Manipulation 
Time 

The time allowance for a person to move between welds, clean, and 
manipulate the spot-welding gun. 

Spot Welding The process in which contacting metal surfaces are joined by the heat 
obtained from resistance to electric current flow. Workpieces are held 
together under pressure exerted by electrodes. 

Stock Form The physical form of the stock such as sheet, coil, hex bar, 
rectangular billet, pellet, etc. Note that stock form does not apply to 
net form processes (for example, Injection Molding, Casting, 
Powdered Metals, Extrusions, etc.). 

Stock Size The defining dimensions of the stock form. For example: Sheet — 
Length, Width, Thickness 
Rectangular Billet — Length, Width, Height 
Round Bar — Diameter, Length 
Pellet — N/A (does not apply to net form processes such as Injection 
Molding, Casting, Powdered Metals, Extrusions, etc.). 

Stock 
Utilization 

A measure of the component's bounding box size relative to the 
material stock size. If the size gap is above a certain threshold, which 
indicates excessive material waste, the system may trigger the 
creation of virtual stock rather than choose actual stock. 

Subcomponent A member of an assembly. 

Surface 
Roughness 

The irregularities in the surface texture which result from the 
production process 

Thread Pitch The number of threads per inch in the Imperial System or the distance 
between threads in the metric system. 

Threading A machining process that uses a single-point tool to produce a 
uniform helical thread form on the internal or external surface of a 
cylinder or cone. 

Tool The general type of tool that is being costed (for example, Blanking 
Die, Cam-actuated Die, etc.). 

Tool Material The speed at which a tool can cut material depends on the material 
from which it is made. Two high-level types of tool material are: High 
Speed Steel and Carbide. High Speed Steel tools are often cheaper 
but cut slower than Carbide tools. Each tool series has a tool material 
property. 

Tool Series A tool series is either an actual toolmaker's model milling tool offered 
in a variety of sizes or a virtual tool for a given tool type provided in a 
very wide variety of sizes. A tool series has a tool material property. 

Tool Type 
 

A general category of machining tool, such as Straight Drill, Flat 
Bottom Mill, etc. 
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Turning The process in which the major motion of the single-point cutting tool 
is parallel to the axis of rotation of the rotating workpiece, producing 
cylindrical external surfaces. 

Type The category of tooling under which the tool falls. That is, Hard 
Tooling (Capital Tooling is treated as a fixed cost) or Expendable 
Tooling (treated as a direct variable cost). 

Virtual Part A part with no associated CAD model (created directly in aPriori for 
costing purposes only). A virtual part can be included in roll-ups and 
comparisons. A virtual part must have a unique name among all 
components (including CAD-referenced parts and assemblies, and 
other virtual parts). 

Virtual Stock A placeholder for actual material stock that does not exist for the 
VPE. Virtual stock is used in an analysis when no reasonably-sized 
actual stock is available in the VPE. 

Virtual Tool A placeholder for an actual tool that does not exist for the VPE. Virtual 
tools are used in an analysis when no feasible actual tool can be 
found or when you prefer to perform an analysis with all virtual tools. 

Virtual 
Production 
Environment 
(VPE) 

A virtual group of machines, workcenters, processes, process 
routings, and process groups that represents a production 
environment at a customer or at a supplier. This representation 
includes the physical situation (speeds, feeds, manufacturing times) 
and the cost structure of the VPE (labor rates, overheads, and so 
forth). Often, all the elements of a VPE would be in one physical 
location, analogous to a factory. However, this may vary from 
customer to customer. 

VPE See Virtual Production Environment. 

VPE 
Administrator 

The user of the aPriori VPE Administration Client.  

Workcenter An organizational group of machines. A workcenter often contains 
machines of the same process type which may be closely grouped on 
the manufacturing floor. 
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